Enable debug packages and remove obsolete patch

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2022-08-15 06:41:32 +03:00
parent 4296d0409e
commit 543398841b
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 0 additions and 46 deletions

View File

@ -1,42 +0,0 @@
From 7f4e9eb63a2103abd74c4e577311a0262c86c1f3 Mon Sep 17 00:00:00 2001
From: David Abdurachmanov <davidlt@rivosinc.com>
Date: Wed, 3 Aug 2022 18:56:00 +0300
Subject: [PATCH] Set target_plugin for riscv
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
---
configure | 3 +++
configure.ac | 3 +++
2 files changed, 6 insertions(+)
diff --git a/configure b/configure
index 10dd92e..5f2e351 100755
--- a/configure
+++ b/configure
@@ -17802,6 +17802,9 @@ case ${target} in
powerpc*-*-*)
target_plugin="powerpc.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*86-*-*)
target_plugin="i686.annobin.lo"
;;
diff --git a/configure.ac b/configure.ac
index 49771b4..bbd142e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,9 @@ case ${target} in
powerpc*-*-*)
target_plugin="powerpc.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*86-*-*)
target_plugin="i686.annobin.lo"
;;
--
2.35.1

View File

@ -1,7 +1,4 @@
%ifarch riscv64
# Empty %%files file /builddir/build/BUILD/annobin-10.79/debugsourcefiles.list
%global debug_package %{nil}
# Disable LTO: LLVMgold.so: cannot open shared object file: No such file or directory
%global _lto_cflags %nil
%endif
@ -75,7 +72,6 @@ Source: https://nickc.fedorapeople.org/%{annobin_sources}
# Insert patches here, if needed. Eg:
# Patch01: annobin-foo.patch
Patch10: 0001-Set-target_plugin-for-riscv.patch
Patch11: 0001-Remove-flto-from-Clang-LLVM-plugins.patch
#---------------------------------------------------------------------------------