Set target_plugin for riscv targets

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2022-08-03 18:58:07 +03:00
parent a55206c420
commit 383ed10bca
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 48 additions and 1 deletions

View File

@ -0,0 +1,42 @@
From 7f4e9eb63a2103abd74c4e577311a0262c86c1f3 Mon Sep 17 00:00:00 2001
From: David Abdurachmanov <davidlt@rivosinc.com>
Date: Wed, 3 Aug 2022 18:56:00 +0300
Subject: [PATCH] Set target_plugin for riscv
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
---
configure | 3 +++
configure.ac | 3 +++
2 files changed, 6 insertions(+)
diff --git a/configure b/configure
index 10dd92e..5f2e351 100755
--- a/configure
+++ b/configure
@@ -17802,6 +17802,9 @@ case ${target} in
powerpc*-*-*)
target_plugin="powerpc.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*86-*-*)
target_plugin="i686.annobin.lo"
;;
diff --git a/configure.ac b/configure.ac
index 49771b4..bbd142e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,9 @@ case ${target} in
powerpc*-*-*)
target_plugin="powerpc.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*86-*-*)
target_plugin="i686.annobin.lo"
;;
--
2.35.1

View File

@ -2,7 +2,7 @@
Name: annobin
Summary: Annotate and examine compiled binary files
Version: 10.79
Release: 1%{?dist}
Release: 1.0.riscv64%{?dist}
License: GPLv3+
URL: https://sourceware.org/annobin/
# Maintainer: nickc@redhat.com
@ -68,6 +68,8 @@ Source: https://nickc.fedorapeople.org/%{annobin_sources}
# Insert patches here, if needed. Eg:
# Patch01: annobin-foo.patch
Patch10: 0001-Set-target_plugin-for-riscv.patch
#---------------------------------------------------------------------------------
# Make sure that the necessary sub-packages are built.
@ -483,6 +485,9 @@ fi
#---------------------------------------------------------------------------------
%changelog
* Wed Aug 03 2022 David Abdurachmanov <davidlt@rivosinc.com> - 10.79-1.0.riscv64
- Fix riscv targets
* Mon Jul 25 2022 Nick Clifton <nickc@redhat.com> - 10.79-1
- Annocheck: Fixes for libannocheck.h.