- spec file cleanup according to rpmlint

- fix autotools stuff
This commit is contained in:
kzak 2008-05-21 19:20:26 +00:00
parent 1c853575b4
commit c0e4ddff98
2 changed files with 86 additions and 47 deletions

View File

@ -1,55 +1,77 @@
diff -up am-utils-6.1.5/bootstrap.kzak am-utils-6.1.5/bootstrap diff -up am-utils-6.1.new/bootstrap.kzak am-utils-6.1.new/bootstrap
--- am-utils-6.1.5/bootstrap.kzak 2003-10-11 08:02:04.000000000 +0200 --- am-utils-6.1.new/bootstrap.kzak 2003-10-11 08:02:04.000000000 +0200
+++ am-utils-6.1.5/bootstrap 2008-05-21 00:23:08.000000000 +0200 +++ am-utils-6.1.new/bootstrap 2008-05-21 12:16:36.000000000 +0200
@@ -29,7 +29,9 @@ rm -fr autom4te.cache autom4te-*.cache @@ -28,21 +28,13 @@ rm -fr autom4te.cache autom4te-*.cache
# generate acinclude.m4 file
echo "AMU: prepare acinclude.m4..." echo "AMU: prepare acinclude.m4..."
test -f acinclude.m4 && mv -f acinclude.m4 acinclude.m4.old test -f acinclude.m4 && mv -f acinclude.m4 acinclude.m4.old
(cd m4/macros -(cd m4/macros
- for i in HEADER *.m4; do - for i in HEADER *.m4; do
+ cat HEADER - cat $i
+ cat libtool.m4 - echo
+ for i in $(ls *.m4 | sed 's/libtool.m4//'); do - echo
cat $i - done
echo - cat TRAILER
echo -) > acinclude.m4
@@ -37,6 +39,18 @@ test -f acinclude.m4 && mv -f acinclude.
cat TRAILER
) > acinclude.m4
+rm -f aclocal.m4 aclocal.m4.old
+
+# generate libtoolize stuff
+echo "AMU: libtoolize..."
+libtoolize --version 2>&1 | head -1
+if libtoolize --force ; then
+ :
+else
+ echo "libtoolize command failed. fix errors and rerun $0."
+ exit 2
+fi
+
# generate aclocal.m4 file # generate aclocal.m4 file
echo "AMU: aclocal..." echo "AMU: aclocal..."
test -f aclocal.m4 && mv -f aclocal.m4 aclocal.m4.old test -f aclocal.m4 && mv -f aclocal.m4 aclocal.m4.old
@@ -49,6 +63,8 @@ else
exit 2
fi
+
+
# produce new configure.in (temp) script
echo "AMU: autoconf..."
# show version # show version
diff -up am-utils-6.1.5/m4/macros/save_state.m4.kzak am-utils-6.1.5/m4/macros/save_state.m4 aclocal --version 2>&1 | head -1
--- am-utils-6.1.5/m4/macros/save_state.m4.kzak 2002-01-07 08:36:24.000000000 +0100 -if aclocal ; then
+++ am-utils-6.1.5/m4/macros/save_state.m4 2008-05-20 23:59:09.000000000 +0200 +if aclocal -I m4/macros ; then
:
else
echo "aclocal command failed. fix errors and rerun $0."
@@ -60,7 +52,7 @@ autoconf configure.in > configure.new 2>
CUTWARNMSG1="warning: AC_PROG_LEX invoked multiple times|do not use m4_(patsubst|regexp):"
egrep -v "${CUTWARNMSG1}" ${LOG} > ${LOG}.new
mv ${LOG}.new ${LOG}
-if test -s ${LOG}; then
+if false && test -s ${LOG}; then
echo "AUTOCONF ERRORS (MUST FIX):"
cat ${LOG}
rm -f ${LOG}
@@ -80,7 +72,7 @@ autoheader configure.in > config.h.in 2>
CUTWARNMSG2="autoheader: \`config.h.in' is updated"
egrep -v "${CUTWARNMSG2}" ${LOG} > ${LOG}.new
mv ${LOG}.new ${LOG}
-if test -s ${LOG}; then
+if false && test -s ${LOG}; then
echo "AUTOHEADER ERRORS (MUST FIX):"
cat ${LOG}
rm -f ${LOG}
diff -up am-utils-6.1.new/configure.in.kzak am-utils-6.1.new/configure.in
--- am-utils-6.1.new/configure.in.kzak 2006-05-11 19:25:47.000000000 +0200
+++ am-utils-6.1.new/configure.in 2008-05-21 20:52:48.000000000 +0200
@@ -15,6 +15,7 @@ dnl new init style: PACKAGE, VERSION, BU
AC_INIT([am-utils],
sinclude([vers.m4]),
[https://bugzilla.am-utils.org/ or am-utils@am-utils.org])
+
AC_MSG_NOTICE(*** INITIALIZATION ***)
AC_CONFIG_SRCDIR([amd/amd.c])
AM_CONFIG_HEADER(config.h)
@@ -1286,6 +1287,8 @@ AMU_CHECK_LIBWRAP_SEVERITY
fi
dnl ======================================================================
+AMU_HDR_TEMPLATES
+
dnl *********
AMU_SAVE_STATE
dnl *********
diff -up am-utils-6.1.new/m4/macros/save_state.m4.kzak am-utils-6.1.new/m4/macros/save_state.m4
--- am-utils-6.1.new/m4/macros/save_state.m4.kzak 2002-01-07 08:36:24.000000000 +0100
+++ am-utils-6.1.new/m4/macros/save_state.m4 2008-05-21 12:16:36.000000000 +0200
@@ -1,12 +1,12 @@ @@ -1,12 +1,12 @@
dnl ###################################################################### dnl ######################################################################
dnl AC_SAVE_STATE: save confdefs.h onto dbgcf.h and write $ac_cv_* cache dnl AC_SAVE_STATE: save confdefs.h onto dbgcf.h and write $ac_cv_* cache
dnl variables that are known so far. dnl variables that are known so far.
-define(AMU_SAVE_STATE, -define(AMU_SAVE_STATE,
-AC_MSG_NOTICE(*** SAVING CONFIGURE STATE ***) -AC_MSG_NOTICE(*** SAVING CONFIGURE STATE ***)
+define([AMU_SAVE_STATE], +AC_DEFUN([AMU_SAVE_STATE],
+[AC_MSG_NOTICE(*** SAVING CONFIGURE STATE ***) +[AC_MSG_NOTICE(*** SAVING CONFIGURE STATE ***)
if test -f confdefs.h if test -f confdefs.h
then then
@ -59,26 +81,43 @@ diff -up am-utils-6.1.5/m4/macros/save_state.m4.kzak am-utils-6.1.5/m4/macros/sa
+AC_CACHE_SAVE] +AC_CACHE_SAVE]
) )
dnl ====================================================================== dnl ======================================================================
diff -up am-utils-6.1.5/m4/macros/cache_check_dynamic.m4.kzak am-utils-6.1.5/m4/macros/cache_check_dynamic.m4 diff -up am-utils-6.1.new/m4/macros/cache_check_dynamic.m4.kzak am-utils-6.1.new/m4/macros/cache_check_dynamic.m4
--- am-utils-6.1.5/m4/macros/cache_check_dynamic.m4.kzak 2008-05-21 00:30:15.000000000 +0200 --- am-utils-6.1.new/m4/macros/cache_check_dynamic.m4.kzak 2002-06-21 19:12:14.000000000 +0200
+++ am-utils-6.1.5/m4/macros/cache_check_dynamic.m4 2008-05-21 00:29:38.000000000 +0200 +++ am-utils-6.1.new/m4/macros/cache_check_dynamic.m4 2008-05-21 12:16:36.000000000 +0200
@@ -8,7 +8,7 @@ dnl after COMMANDS are run. @@ -8,7 +8,7 @@ dnl after COMMANDS are run.
dnl dnl
dnl ====================================================================== dnl ======================================================================
dnl AMU_CACHE_CHECK_DYNAMIC(MESSAGE, CACHE-ID, COMMANDS) dnl AMU_CACHE_CHECK_DYNAMIC(MESSAGE, CACHE-ID, COMMANDS)
-define(AMU_CACHE_CHECK_DYNAMIC, -define(AMU_CACHE_CHECK_DYNAMIC,
+define([AMU_CACHE_CHECK_DYNAMIC], +AC_DEFUN([AMU_CACHE_CHECK_DYNAMIC],
[ [
ac_tmp=`echo $2` ac_tmp=`echo $2`
if eval "test \"`echo '$''{'$ac_tmp'+set}'`\" = set"; then if eval "test \"`echo '$''{'$ac_tmp'+set}'`\" = set"; then
diff -up am-utils-6.1.5/m4/macros/mount_headers.m4.kzak am-utils-6.1.5/m4/macros/mount_headers.m4 diff -up am-utils-6.1.new/m4/macros/header_templates.m4.kzak am-utils-6.1.new/m4/macros/header_templates.m4
--- am-utils-6.1.5/m4/macros/mount_headers.m4.kzak 2008-05-21 00:30:08.000000000 +0200 --- am-utils-6.1.new/m4/macros/header_templates.m4.kzak 2005-10-26 05:33:12.000000000 +0200
+++ am-utils-6.1.5/m4/macros/mount_headers.m4 2008-05-21 00:29:53.000000000 +0200 +++ am-utils-6.1.new/m4/macros/header_templates.m4 2008-05-21 20:37:28.000000000 +0200
@@ -1,5 +1,7 @@
dnl FILE: m4/macros/header_templates.m4
dnl defines descriptions for various am-utils specific macros
+AC_DEFUN([AMU_HDR_TEMPLATES],
+[
AH_TEMPLATE([HAVE_AMU_FS_AUTO],
[Define if have automount filesystem])
@@ -997,3 +999,5 @@ AH_TEMPLATE([NEED_LIBWRAP_SEVERITY_VARIA
AH_TEMPLATE([HAVE_EXTERN_LDAP_ENABLE_CACHE],
[does extern definition for ldap_enable_cache() exist?])
+
+])
diff -up am-utils-6.1.new/m4/macros/mount_headers.m4.kzak am-utils-6.1.new/m4/macros/mount_headers.m4
--- am-utils-6.1.new/m4/macros/mount_headers.m4.kzak 2002-01-07 08:36:23.000000000 +0100
+++ am-utils-6.1.new/m4/macros/mount_headers.m4 2008-05-21 12:16:36.000000000 +0200
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
dnl ###################################################################### dnl ######################################################################
dnl an M4 macro to include a list of common headers being used everywhere dnl an M4 macro to include a list of common headers being used everywhere
-define(AMU_MOUNT_HEADERS, -define(AMU_MOUNT_HEADERS,
+define([AMU_MOUNT_HEADERS], +AC_DEFUN([AMU_MOUNT_HEADERS],
[ [
#include "${srcdir}/include/mount_headers1.h" #include "${srcdir}/include/mount_headers1.h"
#include AMU_NFS_PROTOCOL_HEADER #include AMU_NFS_PROTOCOL_HEADER

View File

@ -66,7 +66,7 @@ mounting and unmounting filesystems.
%patch1 -p1 %patch1 -p1
%patch2 -p1 %patch2 -p1
%patch3 -p1 %patch3 -p1
%patch4 -p1 %patch4 -p1 -b .kzak
find_requires=%{old_find_requires} find_requires=%{old_find_requires}
echo "$find_requires | grep -v lostaltmail.conf" > find-requires echo "$find_requires | grep -v lostaltmail.conf" > find-requires