- Update am-utils with latest fedora changes for epel8.

This commit is contained in:
Ian Kent 2019-08-19 18:39:22 +08:00
parent 81d62bb46e
commit 0e893a5657
2 changed files with 40 additions and 46 deletions

View File

@ -10,14 +10,12 @@ Signed-off-by: Ian Kent <raven@themaw.net>
Makefile.am | 3 ++-
configure.ac | 4 ++++
include/am_compat.h | 8 ++++++--
m4/macros/check_linux_libtirpc.m4 | 13 +++++++++++++
4 files changed, 25 insertions(+), 3 deletions(-)
m4/macros/check_linux_libtirpc.m4 | 14 ++++++++++++++
4 files changed, 26 insertions(+), 3 deletions(-)
create mode 100644 m4/macros/check_linux_libtirpc.m4
diff --git a/Makefile.am b/Makefile.am
index bae4615..e094e95 100644
--- a/Makefile.am
+++ b/Makefile.am
--- am-utils-6.2.orig/Makefile.am
+++ am-utils-6.2/Makefile.am
@@ -146,7 +146,8 @@ EXTRA_DIST_M4 = \
m4/macros/type_xdrproc_t.m4 \
m4/macros/type_xfs_args.m4 \
@ -28,11 +26,9 @@ index bae4615..e094e95 100644
EXTRA_DIST_CONF = \
conf/autofs/autofs_default.h \
diff --git a/configure.ac b/configure.ac
index ce61925..98b444d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,6 +222,9 @@ dnl lots of code. So I am forced to use a special purpose macro that sets
--- am-utils-6.2.orig/configure.ac
+++ am-utils-6.2/configure.ac
@@ -222,6 +222,9 @@ dnl lots of code. So I am forced to use
dnl the libraries based on the OS. Sigh. -Erez.
AMU_CHECK_OS_LIBS
@ -50,10 +46,8 @@ index ce61925..98b444d 100644
cdfs/cdfsmount.h \
cdfs/cdfs_mount.h \
fs/udf/udf_mount.h \
diff --git a/include/am_compat.h b/include/am_compat.h
index 3463f3f..d6826fc 100644
--- a/include/am_compat.h
+++ b/include/am_compat.h
--- am-utils-6.2.orig/include/am_compat.h
+++ am-utils-6.2/include/am_compat.h
@@ -454,11 +454,15 @@ struct hsfs_args {
/*
* Define a dummy struct netconfig for non-TLI systems
@ -72,22 +66,20 @@ index 3463f3f..d6826fc 100644
/* some OSs don't define INADDR_NONE and assume it's unsigned -1 */
#ifndef INADDR_NONE
diff --git a/m4/macros/check_linux_libtirpc.m4 b/m4/macros/check_linux_libtirpc.m4
new file mode 100644
index 0000000..918423c
--- /dev/null
+++ b/m4/macros/check_linux_libtirpc.m4
@@ -0,0 +1,13 @@
+++ am-utils-6.2/m4/macros/check_linux_libtirpc.m4
@@ -0,0 +1,14 @@
+dnl ######################################################################
+dnl Check for Linux libtirpc library
+AC_DEFUN([AMU_CHECK_LIBTIRPC],[
+TIRPC_CPPFLAGS=""
+TIRPC_LIBS=""
+
+AC_CHECK_HEADER(tirpc/netconfig.h,[
+ TIRPC_CPPFLAGS="-I/usr/include/tirpc"
+ AC_DEFINE(HAVE_LIBTIRPC, 1, [Define to 1 if you have libtirpc headers installed])
+ AC_CHECK_LIB(tirpc, clnt_tli_create, [TIRPC_LIBS="-ltirpc"], [TIRPC_CPPFLAGS=""])])
+ AMU_CFLAGS="$AMU_CFLAGS $TIRPC_CPPFLAGS"
+ LIBS="$LIBS $TIRPC_LIBS"
+ amu_check_libtirpc_save_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc"
+ AC_CHECK_LIB(tirpc,clnt_tli_create,,amu_check_libtirpc=notfound)])
+ if test "$amu_check_libtirpc" = "notfound"
+ then
+ CPPFLAGS="$amu_check_libtirpc_save_CPPFLAGS"
+ else
+ AC_DEFINE(HAVE_LIBTIRPC, 1, [Define to 1 if you have libtirpc headers installed])
+ fi
+])

View File

@ -2,10 +2,9 @@ Summary: Automount utilities including an updated version of Amd
Name: am-utils
Version: 6.2.0
%define upstream_version 6.2
Release: 27%{?dist}
Release: 38%{?dist}
License: BSD
Epoch: 5
Group: System Environment/Daemons
URL: http://am-utils.org
# Git repository git://git.fsl.cs.sunysb.edu/am-utils-6.2.git
Source: ftp://ftp.am-utils.org/pub/am-utils/am-utils-%{upstream_version}.tar.gz
@ -15,33 +14,33 @@ Source3: am-utils.sysconf
Source4: am-utils.net.map
BuildRequires: gdbm-devel
BuildRequires: hesiod-devel
BuildRequires: openldap-devel
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: bison
BuildRequires: flex
BuildRequires: tcp_wrappers-devel
BuildRequires: systemd-units
BuildRequires: texinfo
BuildRequires: gcc
BuildRequires: m4
BuildRequires: libtirpc-devel
BuildRequires: kernel-headers
BuildRequires: libnsl2-devel
BuildRequires: rpcsvc-proto-devel
Requires: rpcbind
Requires: grep
Requires: gawk
Requires: findutils
Requires: libtirpc
Requires: libnsl2
Requires(pre): /bin/grep
Requires(post): /sbin/install-info
Requires(pre): /usr/bin/grep
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(preun): /sbin/install-info
# Fix problems with possible future libtool rebases (#1181698)
Patch1: am-utils-6.2-dont-include-auto-generated-macros-in-aclinlude_m4.patch
@ -154,7 +153,10 @@ chmod +x find-requires
%configure \
--enable-shared \
--enable-am-cflags="-DHAVE_LINUX_NFS_MOUNT_H" \
--enable-cppflags="-I%{_includedir}/nsl" \
--enable-ldflags="-L%{_libdir}/nsl" \
--enable-libs="-lnsl -lresolv" \
--without-hesiod \
--enable-debug
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@ -210,20 +212,9 @@ fi
/sbin/ldconfig
%systemd_post amd.service
if [ -f %{_infodir}/am-utils.info.gz ]; then
/sbin/install-info %{_infodir}/am-utils.info.gz %{_infodir}/dir || :
fi
%preun
%systemd_preun amd.service
if [ $1 -eq 0 ]; then
# Package removal, not upgrade
if [ -f %{_infodir}/am-utils.info.gz ]; then
/sbin/install-info --delete %{_infodir}/am-utils.info.gz %{_infodir}/dir || :
fi
fi
%postun
%systemd_postun_with_restart amd.service
@ -254,6 +245,17 @@ fi
%{_libdir}/libamu.so*
%changelog
* Mon Aug 19 2019 Ian Kent <ikent@redhat.com> - 5:6.2.0-38
- Update "Requires(pre)" to use /usr/bin/grep instead of /bin/grep.
- Remove "BuildRequires: tcp_wrappers-devel" as tcp_wrappers is depricated.
- Add "BuildRequires: kernel-headers" for linux/version.h requirement.
- add libnsl2 Requires and libnsl2-devel BuildRequires.
- add "BuildRequires: rpcsvc-proto-devel" to pull in missing glibc RPC code.
- disable hesiod support.
- Remove obsolete Group tag.
- Remove obsolete scriptlets.
- Update use linux libtirpc if present patch.
* Tue Aug 29 2017 Ian Kent <ikent@redhat.com> - 5:6.2.0-27
- fix nfsv3 fh length in NFS_FH_DREF().