Resolves: #1873975 - make __acl_create_entry_obj() work with LTO enabled
This commit is contained in:
parent
1a62a26c8d
commit
e0b4e6db20
29
0002-acl-2.2.53-setattr-segv.patch
Normal file
29
0002-acl-2.2.53-setattr-segv.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From c03773259fbe6d3f3355efc8e66990718d5cab54 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 31 Aug 2020 17:16:34 +0200
|
||||
Subject: [PATCH] __acl_create_entry_obj: do not break strict aliasing rules
|
||||
|
||||
... to avoid SIGSEGV with link-time optimisation enabled
|
||||
|
||||
Bug: https://bugzilla.redhat.com/1873975
|
||||
Upstream-report: https://lists.nongnu.org/archive/html/acl-devel/2020-08/msg00000.html
|
||||
---
|
||||
libacl/acl_create_entry.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libacl/acl_create_entry.c b/libacl/acl_create_entry.c
|
||||
index 2214c1a..8ee72a3 100644
|
||||
--- a/libacl/acl_create_entry.c
|
||||
+++ b/libacl/acl_create_entry.c
|
||||
@@ -42,7 +42,7 @@ __acl_create_entry_obj(acl_obj *acl_obj_p)
|
||||
entry_obj_p->eprev = acl_obj_p->aprev;
|
||||
entry_obj_p->enext = (acl_entry_obj *)acl_obj_p;
|
||||
entry_obj_p->eprev->enext = entry_obj_p;
|
||||
- entry_obj_p->enext->eprev = entry_obj_p;
|
||||
+ acl_obj_p->aprev = entry_obj_p;
|
||||
|
||||
entry_obj_p->econtainer = acl_obj_p;
|
||||
init_acl_entry_obj(*entry_obj_p);
|
||||
--
|
||||
2.25.4
|
||||
|
8
acl.spec
8
acl.spec
@ -1,7 +1,7 @@
|
||||
Summary: Access control list utilities
|
||||
Name: acl
|
||||
Version: 2.2.53
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
BuildRequires: gawk
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gettext
|
||||
@ -14,6 +14,9 @@ Source: https://download-mirror.savannah.gnu.org/releases/acl/acl-%{version}.tar
|
||||
# avoid permission denied problem with LD_PRELOAD in the test-suite
|
||||
Patch1: 0001-acl-2.2.53-test-runwrapper.patch
|
||||
|
||||
# make __acl_create_entry_obj() work with LTO enabled (#1873975)
|
||||
Patch2: 0002-acl-2.2.53-setattr-segv.patch
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://savannah.nongnu.org/projects/acl
|
||||
|
||||
@ -119,6 +122,9 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
|
||||
%{_libdir}/libacl.so.*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 31 2020 Kamil Dudka <kdudka@redhat.com> 2.2.53-9
|
||||
- make __acl_create_entry_obj() work with LTO enabled (#1873975)
|
||||
|
||||
* Fri Jul 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.53-8
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user