Fixed segfault when using only "--" as parameter (rhbz#430458)
This commit is contained in:
parent
789e5ea71b
commit
774911caad
11
acl-2.2.39-segfault.patch
Normal file
11
acl-2.2.39-segfault.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- acl-2.2.45/setfacl/setfacl.c.segfault 2008-01-28 13:56:36.000000000 +0100
|
||||||
|
+++ acl-2.2.45/setfacl/setfacl.c 2008-01-28 13:58:08.000000000 +0100
|
||||||
|
@@ -679,6 +679,8 @@ int main(int argc, char *argv[])
|
||||||
|
}
|
||||||
|
}
|
||||||
|
while (optind < argc) {
|
||||||
|
+ if(!seq)
|
||||||
|
+ goto synopsis;
|
||||||
|
if (seq_empty(seq))
|
||||||
|
goto synopsis;
|
||||||
|
saw_files = 1;
|
8
acl.spec
8
acl.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Access control list utilities
|
Summary: Access control list utilities
|
||||||
Name: acl
|
Name: acl
|
||||||
Version: 2.2.39
|
Version: 2.2.39
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libattr-devel >= 2.4.1
|
BuildRequires: libattr-devel >= 2.4.1
|
||||||
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl_%{version}-1.tar.gz
|
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl_%{version}-1.tar.gz
|
||||||
@ -10,6 +10,7 @@ Patch1: acl-2.2.39-build.patch
|
|||||||
Patch2: acl-2.2.39-path_max.patch
|
Patch2: acl-2.2.39-path_max.patch
|
||||||
Patch3: acl-2.2.39-walk.patch
|
Patch3: acl-2.2.39-walk.patch
|
||||||
Patch4: acl-2.2.39-exitcode.patch
|
Patch4: acl-2.2.39-exitcode.patch
|
||||||
|
Patch5: acl-2.2.39-segfault.patch
|
||||||
BuildRequires: autoconf, libtool >= 1.5, gettext
|
BuildRequires: autoconf, libtool >= 1.5, gettext
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -49,6 +50,7 @@ defined in POSIX 1003.1e draft standard 17.
|
|||||||
%patch2 -p1 -b .path_max
|
%patch2 -p1 -b .path_max
|
||||||
%patch3 -p1 -b .walk
|
%patch3 -p1 -b .walk
|
||||||
%patch4 -p1 -b .exitcode
|
%patch4 -p1 -b .exitcode
|
||||||
|
%patch5 -p1 -b .segfault
|
||||||
autoconf
|
autoconf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -104,6 +106,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/%{_lib}/libacl.so.*
|
/%{_lib}/libacl.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-7
|
||||||
|
- Fixed segfault when using only "--" as parameter
|
||||||
|
- Resolves: #430458
|
||||||
|
|
||||||
* Thu Nov 8 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-6
|
* Thu Nov 8 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-6
|
||||||
- Fixed setfacl exitcodes
|
- Fixed setfacl exitcodes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user