auto-import changelog data from acl-2.2.3-1.src.rpm
Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1 - udpate/rebuild Sat Jan 04 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7 - set execute bits on library so that requires are generated. Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5 - Correct patch in previous fix so that shared libraries go in /lib* instead of /usr/lib* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4 - Fix multilibbing Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3 - Added fix to install libs in correct directory on 64bit machine
This commit is contained in:
parent
cae5d51f81
commit
0d74a603de
@ -1 +1 @@
|
|||||||
acl-2.0.11.src.tar.gz
|
acl-2.2.3.src.tar.gz
|
||||||
|
11
acl-2.2.3-multilib.patch
Normal file
11
acl-2.2.3-multilib.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- acl-2.2.3/include/buildmacros.multilib 2003-01-28 19:00:05.000000000 -0500
|
||||||
|
+++ acl-2.2.3/include/buildmacros 2003-01-28 19:04:13.000000000 -0500
|
||||||
|
@@ -103,8 +103,6 @@
|
||||||
|
../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
|
||||||
|
../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
|
||||||
|
../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
|
||||||
|
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
|
||||||
|
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
|
||||||
|
../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so
|
||||||
|
else
|
||||||
|
INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
|
43
acl.spec
43
acl.spec
@ -1,11 +1,13 @@
|
|||||||
Summary: Access control list utilities.
|
Summary: Access control list utilities.
|
||||||
Name: acl
|
Name: acl
|
||||||
Version: 2.0.11
|
Version: 2.2.3
|
||||||
Release: 2
|
Release: 1
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildRequires: libattr-devel
|
BuildRequires: libattr-devel
|
||||||
Source: acl-2.0.11.src.tar.gz
|
Source: http://acl.bestbits.at/current/tar/acl-%{version}.src.tar.gz
|
||||||
Copyright: GPL
|
Patch: acl-2.2.3-multilib.patch
|
||||||
|
BuildRequires: autoconf
|
||||||
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://acl.bestbits.at/
|
URL: http://acl.bestbits.at/
|
||||||
|
|
||||||
@ -36,14 +38,18 @@ programs which make use of the access control list programming interface
|
|||||||
defined in POSIX 1003.1e draft standard 17.
|
defined in POSIX 1003.1e draft standard 17.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup
|
%setup -q
|
||||||
|
%patch -p1 -b .multilib
|
||||||
|
autoconf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
touch .census
|
touch .census
|
||||||
./configure
|
# acl abuses libexecdir
|
||||||
|
%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
DIST_ROOT="$RPM_BUILD_ROOT"
|
DIST_ROOT="$RPM_BUILD_ROOT"
|
||||||
DIST_INSTALL=`pwd`/install.manifest
|
DIST_INSTALL=`pwd`/install.manifest
|
||||||
DIST_INSTALL_DEV=`pwd`/install-dev.manifest
|
DIST_INSTALL_DEV=`pwd`/install-dev.manifest
|
||||||
@ -52,6 +58,9 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
|
|||||||
make install DIST_MANIFEST="$DIST_INSTALL"
|
make install DIST_MANIFEST="$DIST_INSTALL"
|
||||||
make install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
|
make install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
|
||||||
make install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
|
make install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
|
||||||
|
|
||||||
|
chmod +x ${RPM_BUILD_ROOT}/%{_lib}/libacl.so.*
|
||||||
|
|
||||||
files()
|
files()
|
||||||
{
|
{
|
||||||
sort | uniq | awk '
|
sort | uniq | awk '
|
||||||
@ -67,9 +76,9 @@ $1 == "f" { if (match ($6, "/usr/share/man") || match ($6, "/usr/share/doc/acl")
|
|||||||
$1 == "l" { if (match ($3, "/usr/share/man") || match ($3, "/usr/share/doc/acl"))
|
$1 == "l" { if (match ($3, "/usr/share/man") || match ($3, "/usr/share/doc/acl"))
|
||||||
printf ("%%%%doc ");
|
printf ("%%%%doc ");
|
||||||
if (match ($3, "/usr/share/man"))
|
if (match ($3, "/usr/share/man"))
|
||||||
printf ("%attr(0777,root,root) %s*\n", $3);
|
printf ("%%%%attr(0777,root,root) %s*\n", $3);
|
||||||
else
|
else
|
||||||
printf ("%attr(0777,root,root) %s\n", $3); }'
|
printf ("%%%%attr(0777,root,root) %s\n", $3); }'
|
||||||
}
|
}
|
||||||
set +x
|
set +x
|
||||||
files < "$DIST_INSTALL" > files.rpm
|
files < "$DIST_INSTALL" > files.rpm
|
||||||
@ -78,7 +87,7 @@ files < "$DIST_INSTALL_LIB" > fileslib.rpm
|
|||||||
set -x
|
set -x
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%post -n libacl -p /sbin/ldconfig
|
%post -n libacl -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -91,6 +100,22 @@ set -x
|
|||||||
%files -n libacl -f fileslib.rpm
|
%files -n libacl -f fileslib.rpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
|
||||||
|
- udpate/rebuild
|
||||||
|
|
||||||
|
* Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
|
||||||
|
- set execute bits on library so that requires are generated.
|
||||||
|
|
||||||
|
* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
|
||||||
|
- Correct patch in previous fix so that shared libraries go in /lib*
|
||||||
|
instead of /usr/lib*
|
||||||
|
|
||||||
|
* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
|
||||||
|
- Fix multilibbing
|
||||||
|
|
||||||
|
* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
|
||||||
|
- Added fix to install libs in correct directory on 64bit machine
|
||||||
|
|
||||||
* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
|
* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
|
||||||
- Made the package only own the one directory that is unique to it:
|
- Made the package only own the one directory that is unique to it:
|
||||||
/usr/include/acl
|
/usr/include/acl
|
||||||
|
Loading…
Reference in New Issue
Block a user