abrt/0008-abrt-auto-reporting-fix-related-to-conditional-compi.patch
Matej Habrnal b52e1a767a Fix bugs in a-auto-reporting, dbus, a-hook-ccpp and abrt-cli
Correct usage of abrt-gdb-exploitable.

Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
2015-08-17 09:51:23 +02:00

34 lines
974 B
Diff

From 6099fa38833e0679f32488770e59e10b6ac72b6d Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Tue, 28 Jul 2015 13:17:25 +0200
Subject: [PATCH] abrt-auto-reporting: fix related to conditional compilation
We discovered that conditional compilation in abrt-auto-reporting does not
work. We forgot add -DAUTHENTICATED_AUTOREPORTING=1 flag if
AUTHENTICATED_AUTOREPORTING is enabled.
Related to rhbz#1191572
---
src/daemon/Makefile.am | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index a8f3fa2..563923a 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -122,6 +122,11 @@ abrt_auto_reporting_CPPFLAGS = \
-I$(srcdir)/../lib \
$(LIBREPORT_CFLAGS) \
-D_GNU_SOURCE
+
+if AUTHENTICATED_AUTOREPORTING
+abrt_auto_reporting_CPPFLAGS += -DAUTHENTICATED_AUTOREPORTING=1
+endif
+
abrt_auto_reporting_LDADD = \
../lib/libabrt.la \
$(LIBREPORT_LIBS)
--
2.4.3