59 lines
2.0 KiB
Diff
59 lines
2.0 KiB
Diff
diff -ruN abrt-2.1.6/src/configuration-gui/Makefile.am abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.am
|
|
--- abrt-2.1.6/src/configuration-gui/Makefile.am 2013-07-23 10:10:02.000000000 +0200
|
|
+++ abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.am 2013-07-26 18:23:04.000000000 +0200
|
|
@@ -4,9 +4,17 @@
|
|
abrt-config-widget.c \
|
|
abrt-config-widget.h
|
|
|
|
+# G_DEFINE_TYPE(...) macros result in
|
|
+# typedef '_GStaticAssertCompileTimeAssertion_0' locally defined but not used
|
|
+# warnings on some glib versions
|
|
+# (observed on glib2-2.34.2 on F18).
|
|
+# -Wno-error=unused-local-typedefs in CPPFLAGS suppresses this warning.
|
|
+# Newer glib may have it fixed.
|
|
+
|
|
libabrtconfigui_la_CPPFLAGS = \
|
|
-I$(srcdir)/../include \
|
|
-I$(srcdir)/../lib \
|
|
+ -Wno-error=unused-local-typedefs \
|
|
$(LIBREPORT_CFLAGS) \
|
|
$(GTK_CFLAGS) \
|
|
-DABRT_UI_DIR="\"$(uidir)\"" \
|
|
@@ -25,6 +33,7 @@
|
|
system_config_abrt_CPPFLAGS = \
|
|
-I$(srcdir)/../include \
|
|
-I$(srcdir)/../lib \
|
|
+ -Wno-error=unused-local-typedefs \
|
|
$(GTK_CFLAGS) \
|
|
$(LIBREPORT_CFLAGS)
|
|
|
|
diff -ruN abrt-2.1.6/src/configuration-gui/Makefile.in abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.in
|
|
--- abrt-2.1.6/src/configuration-gui/Makefile.in 2013-07-26 07:55:59.000000000 +0200
|
|
+++ abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.in 2013-07-26 18:23:48.000000000 +0200
|
|
@@ -419,9 +419,17 @@
|
|
abrt-config-widget.c \
|
|
abrt-config-widget.h
|
|
|
|
+
|
|
+# G_DEFINE_TYPE(...) macros result in
|
|
+# typedef '_GStaticAssertCompileTimeAssertion_0' locally defined but not used
|
|
+# warnings on some glib versions
|
|
+# (observed on glib2-2.34.2 on F18).
|
|
+# -Wno-error=unused-local-typedefs in CPPFLAGS suppresses this warning.
|
|
+# Newer glib may have it fixed.
|
|
libabrtconfigui_la_CPPFLAGS = \
|
|
-I$(srcdir)/../include \
|
|
-I$(srcdir)/../lib \
|
|
+ -Wno-error=unused-local-typedefs \
|
|
$(LIBREPORT_CFLAGS) \
|
|
$(GTK_CFLAGS) \
|
|
-DABRT_UI_DIR="\"$(uidir)\"" \
|
|
@@ -438,6 +446,7 @@
|
|
system_config_abrt_CPPFLAGS = \
|
|
-I$(srcdir)/../include \
|
|
-I$(srcdir)/../lib \
|
|
+ -Wno-error=unused-local-typedefs \
|
|
$(GTK_CFLAGS) \
|
|
$(LIBREPORT_CFLAGS)
|
|
|