systemd-journal koops, python exceptions without traceback
This commit is contained in:
parent
540b10b023
commit
f4e24995ef
40
0002-python-support-exceptions-without-traceback.patch
Normal file
40
0002-python-support-exceptions-without-traceback.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 6b57ceebb1366e23321b1fe40d15285708e16869 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Wed, 9 Jul 2014 17:55:36 +0200
|
||||
Subject: [PATCH 2/9] python: support exceptions without traceback
|
||||
|
||||
e.g. SyntaxError (python-2.7.5-13.fc20, python-2.7.7-2.fc21)
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/hooks/abrt_exception_handler.py.in | 14 ++++++++------
|
||||
1 file changed, 8 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/hooks/abrt_exception_handler.py.in b/src/hooks/abrt_exception_handler.py.in
|
||||
index cb32e14..fa4f34f 100644
|
||||
--- a/src/hooks/abrt_exception_handler.py.in
|
||||
+++ b/src/hooks/abrt_exception_handler.py.in
|
||||
@@ -55,12 +55,14 @@ def write_dump(tb_text, tb):
|
||||
executable = sys.argv[0]
|
||||
|
||||
dso_list = None
|
||||
- try:
|
||||
- import rpm
|
||||
- dso_list = get_dso_list(tb)
|
||||
- except ImportError as imperr:
|
||||
- syslog("RPM module not available, cannot query RPM db for package "\
|
||||
- "names")
|
||||
+ # Trace back is None in case of SyntaxError exception.
|
||||
+ if tb:
|
||||
+ try:
|
||||
+ import rpm
|
||||
+ dso_list = get_dso_list(tb)
|
||||
+ except ImportError as imperr:
|
||||
+ syslog("RPM module not available, cannot query RPM db for package "\
|
||||
+ "names")
|
||||
|
||||
# Open ABRT daemon's socket and write data to it
|
||||
try:
|
||||
--
|
||||
1.9.3
|
||||
|
1987
0004-koops-dump-oopses-from-systemd-journal.patch
Normal file
1987
0004-koops-dump-oopses-from-systemd-journal.patch
Normal file
File diff suppressed because it is too large
Load Diff
31
0008-abrt-journal-fix-includes.patch
Normal file
31
0008-abrt-journal-fix-includes.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 6581aa9a25334aaa9abd1e40676664602b34ea0b Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Tue, 15 Jul 2014 13:10:04 +0200
|
||||
Subject: [PATCH 8/9] abrt-journal: fix includes
|
||||
|
||||
Related to rhbz#1059724
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-journal.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-journal.c b/src/plugins/abrt-journal.c
|
||||
index 472357d..89c8393 100644
|
||||
--- a/src/plugins/abrt-journal.c
|
||||
+++ b/src/plugins/abrt-journal.c
|
||||
@@ -16,10 +16,10 @@
|
||||
#include <signal.h>
|
||||
#include <poll.h>
|
||||
#include <stdlib.h>
|
||||
-#include <abrt/libabrt.h>
|
||||
#include <stdio.h>
|
||||
|
||||
#include "abrt-journal.h"
|
||||
+#include "libabrt.h"
|
||||
|
||||
#include <systemd/sd-journal.h>
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
23
abrt.spec
23
abrt.spec
@ -40,7 +40,7 @@
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.2.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
@ -48,6 +48,16 @@ Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
|
||||
# don't remove this patch, packages in rawhide are not signed!
|
||||
Patch0: disable-OpenGPGCheck-in-Fedora-Rawhide.patch
|
||||
|
||||
#Patch1: 0001-update-.gitignore.patch
|
||||
Patch2: 0002-python-support-exceptions-without-traceback.patch
|
||||
#Patch3: 0003-use-satyr-with-native-unwider.patch
|
||||
Patch4: 0004-koops-dump-oopses-from-systemd-journal.patch
|
||||
#Patch5: 0005-spec-add-the-journal-oops-stuff.patch
|
||||
#Patch6: 0006-testsuite-add-tests-for-abrt-dump-journal-oops.patch
|
||||
#Patch7: 0007-spec-add-a-build-require-item-for-systemd-journal.patch
|
||||
Patch8: 0008-abrt-journal-fix-includes.patch
|
||||
#Patch9: 0009-spec-don-t-use-native-unwinder-on-arm-arch.patch
|
||||
|
||||
# '%%autosetup -S git' -> git
|
||||
BuildRequires: git
|
||||
|
||||
@ -181,6 +191,7 @@ which is able to analyze C/C++ crashes remotely.
|
||||
%package addon-kerneloops
|
||||
Summary: %{name}'s kerneloops addon
|
||||
Group: System Environment/Libraries
|
||||
BuildRequires: systemd-devel
|
||||
Requires: curl
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
%if 0%{!?rhel:1}
|
||||
@ -459,6 +470,7 @@ mkdir -p $RPM_BUILD_ROOT/var/cache/abrt-di
|
||||
mkdir -p $RPM_BUILD_ROOT/var/run/abrt
|
||||
mkdir -p $RPM_BUILD_ROOT/var/tmp/abrt
|
||||
mkdir -p $RPM_BUILD_ROOT/var/spool/abrt-upload
|
||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/abrt
|
||||
|
||||
desktop-file-install \
|
||||
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
|
||||
@ -798,10 +810,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%else
|
||||
%{_initrddir}/abrt-oops
|
||||
%endif
|
||||
|
||||
%dir %{_localstatedir}/lib/abrt
|
||||
|
||||
%{_bindir}/abrt-dump-oops
|
||||
%{_bindir}/abrt-dump-journal-oops
|
||||
%{_bindir}/abrt-action-analyze-oops
|
||||
%{_bindir}/abrt-action-save-kernel-data
|
||||
%{_mandir}/man1/abrt-dump-oops.1*
|
||||
%{_mandir}/man1/abrt-dump-journal-oops.1*
|
||||
%{_mandir}/man1/abrt-action-analyze-oops.1*
|
||||
%{_mandir}/man1/abrt-action-save-kernel-data.1*
|
||||
|
||||
@ -927,6 +944,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Wed Jul 16 2014 Jakub Filak <jfilak@redhat.com> 2.2.2-4
|
||||
- dump kernel oopses from systemd-journal
|
||||
- support SyntaxError Python exceptions
|
||||
|
||||
* Wed Jul 16 2014 Jakub Filak <jfilak@redhat.com> 2.2.2-3
|
||||
- don't use native unwinder on arm
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user