New version
This commit is contained in:
parent
de16c9bc53
commit
f3025fa350
@ -1 +1 @@
|
||||
abrt-1.0.8.tar.gz
|
||||
abrt-1.0.9.tar.gz
|
||||
|
11
abrt-1.0.9-hideprefs.patch
Normal file
11
abrt-1.0.9-hideprefs.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- abrt-1.0.9/src/Gui/ccgui.glade 2010-03-31 10:34:14.000000000 +0200
|
||||
+++ abrt-1.0.9_hideprefs/src/Gui/ccgui.glade 2010-03-31 21:39:27.653364662 +0200
|
||||
@@ -102,7 +102,7 @@
|
||||
<child>
|
||||
<widget class="GtkImageMenuItem" id="miPreferences">
|
||||
<property name="label">gtk-preferences</property>
|
||||
- <property name="visible">True</property>
|
||||
+ <property name="visible">False</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="always_show_image">True</property>
|
142
abrt.spec
142
abrt.spec
@ -1,15 +1,29 @@
|
||||
%{!?python_site: %define python_site %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0)")}
|
||||
# platform-dependent
|
||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
|
||||
# please modify the "_buildid" define in a way that identifies
|
||||
# that the built package isn't the stock distribution package,
|
||||
# for example, by setting the define to ".local" or ".bz123456"
|
||||
#
|
||||
# % define _buildid .local
|
||||
|
||||
%if 0%{?_buildid}
|
||||
%define pkg_release 0.%{?_buildid}%{?dist}
|
||||
%else
|
||||
%define pkg_release 1%{?dist}
|
||||
%endif
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 1.0.8
|
||||
Release: 1%{?dist}
|
||||
Version: 1.0.9
|
||||
Release: %{?pkg_release}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
Source: http://jmoskovc.fedorapeople.org/%{name}-%{version}.tar.gz
|
||||
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: abrt.init
|
||||
Patch0: abrt-1.0.9-hideprefs.patch
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk2-devel
|
||||
BuildRequires: curl-devel
|
||||
@ -31,7 +45,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires(pre): shadow-utils
|
||||
Obsoletes: abrt-plugin-sqlite3
|
||||
Patch0: abrt_disable_gpgcheck.diff
|
||||
|
||||
%description
|
||||
%{name} is a tool to help users to detect defects in applications and
|
||||
@ -80,17 +93,6 @@ Requires: %{name} = %{version}-%{release}
|
||||
This package contains hook for C/C++ crashed programs and %{name}'s C/C++
|
||||
analyzer plugin.
|
||||
|
||||
#%package plugin-firefox
|
||||
#Summary: %{name}'s Firefox analyzer plugin
|
||||
#Group: System Environment/Libraries
|
||||
#Requires: gdb >= 7.0-3
|
||||
#Requires: elfutils
|
||||
#Requires: yum-utils
|
||||
#Requires: %{name} = %{version}-%{release}
|
||||
|
||||
#%description plugin-firefox
|
||||
#This package contains hook for Firefox
|
||||
|
||||
%package addon-kerneloops
|
||||
Summary: %{name}'s kerneloops addon
|
||||
Group: System Environment/Libraries
|
||||
@ -148,6 +150,22 @@ Requires: %{name} = %{version}-%{release}
|
||||
%description plugin-bugzilla
|
||||
Plugin to report bugs into the bugzilla.
|
||||
|
||||
%package plugin-rhfastcheck
|
||||
Summary: %{name}'s rhfastcheck plugin
|
||||
Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description plugin-rhfastcheck
|
||||
Plugin to quickly check RH support DB for known solution.
|
||||
|
||||
%package plugin-rhticket
|
||||
Summary: %{name}'s rhticket plugin
|
||||
Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description plugin-rhticket
|
||||
Plugin to report bugs into RH support system.
|
||||
|
||||
%package plugin-catcut
|
||||
Summary: %{name}'s catcut plugin
|
||||
Group: System Environment/Libraries
|
||||
@ -217,7 +235,7 @@ Virtual package to make easy default installation on desktop environments.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .disable_gpg
|
||||
%patch0 -p1 -b .hideprefs
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -261,6 +279,13 @@ exit 0
|
||||
%post
|
||||
/sbin/chkconfig --add %{name}d
|
||||
|
||||
%post gui
|
||||
# update icon cache
|
||||
touch --no-create %{_datadir}/icons/hicolor || :
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||
fi
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
%preun
|
||||
@ -271,6 +296,12 @@ fi
|
||||
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%postun gui
|
||||
touch --no-create %{_datadir}/icons/hicolor || :
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||
fi
|
||||
|
||||
%posttrans
|
||||
if [ "$1" -eq "0" ]; then
|
||||
service %{name}d condrestart >/dev/null 2>&1 || :
|
||||
@ -313,10 +344,13 @@ fi
|
||||
%files gui
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/%{name}-gui
|
||||
%{_datadir}/%{name}
|
||||
%dir %{_datadir}/%{name}
|
||||
# all glade, gtkbuilder and py files for gui
|
||||
%{_datadir}/%{name}/*.py*
|
||||
%{_datadir}/%{name}/*.glade
|
||||
%{_datadir}/applications/fedora-%{name}.desktop
|
||||
%{_datadir}/pixmaps/abrt.png
|
||||
%{_datadir}/icons/hicolor/48x48/apps/*.png
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
%{_datadir}/%{name}/icons/hicolor/*/status/*
|
||||
%{_bindir}/%{name}-applet
|
||||
%{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
|
||||
|
||||
@ -327,9 +361,6 @@ fi
|
||||
%{_libdir}/%{name}/libCCpp.so*
|
||||
%{_libexecdir}/abrt-hook-ccpp
|
||||
|
||||
#%files plugin-firefox
|
||||
#%{_libdir}/%{name}/libFirefox.so*
|
||||
|
||||
%files addon-kerneloops
|
||||
%defattr(-,root,root,-)
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
|
||||
@ -373,6 +404,20 @@ fi
|
||||
%{_libdir}/%{name}/Bugzilla.GTKBuilder
|
||||
%{_mandir}/man7/%{name}-Bugzilla.7.gz
|
||||
|
||||
%files plugin-rhfastcheck
|
||||
%defattr(-,root,root,-)
|
||||
#%config(noreplace) %{_sysconfdir}/%{name}/plugins/rhfastcheck.conf
|
||||
%{_libdir}/%{name}/librhfastcheck.so*
|
||||
#%{_libdir}/%{name}/rhfastcheck.GTKBuilder
|
||||
#%{_mandir}/man7/%{name}-rhfastcheck.7.gz
|
||||
|
||||
%files plugin-rhticket
|
||||
%defattr(-,root,root,-)
|
||||
#%config(noreplace) %{_sysconfdir}/%{name}/plugins/rhticket.conf
|
||||
%{_libdir}/%{name}/librhticket.so*
|
||||
#%{_libdir}/%{name}/rhticket.GTKBuilder
|
||||
#%{_mandir}/man7/%{name}-rhticket.7.gz
|
||||
|
||||
%files plugin-catcut
|
||||
%defattr(-,root,root,-)
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Catcut.conf
|
||||
@ -399,6 +444,7 @@ fi
|
||||
%attr(4755, abrt, abrt) %{_libexecdir}/abrt-hook-python
|
||||
%{_libdir}/%{name}/libPython.so*
|
||||
%{python_site}/*.py*
|
||||
%{python_site}/abrt.pth
|
||||
|
||||
|
||||
%files cli
|
||||
@ -411,6 +457,58 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
|
||||
%changelog
|
||||
* Tue Apr 06 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.0.9-1
|
||||
- hooklib: fix excessive rounding down in free space calculation (bz#575644) (vda.linux@googlemail.com)
|
||||
- gui: fix 551989 "crash detected in abrt-gui-1.0.0-1.fc12" and such (vda.linux@googlemail.com)
|
||||
- trivial: fix 566806 "abrt-gui sometimes can't be closed" (vda.linux@googlemail.com)
|
||||
- gui: fix the last case where gnome-keyring's find_items_sync() may throw DeniedError (vda.linux@googlemail.com)
|
||||
- fixed some compilation problems on F13 (jmoskovc@redhat.com)
|
||||
- updated translations (jmoskovc@redhat.com)
|
||||
- minor fix to sosreport to make it work with latest sos rhbz#576861 (jmoskovc@redhat.com)
|
||||
|
||||
* Wed Mar 31 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.0.9-0.201003312045.1
|
||||
- test day build
|
||||
- updated translation
|
||||
- minor fix to sosreport to make it work with latest sos rhbz#576861 (jmoskovc@redhat.com)
|
||||
- GUI: total rewrite based on design from Mairin Duffy (jmoskovc@redhat.com)
|
||||
- trivial: better HTTP/curl error reporting (vda.linux@googlemail.com)
|
||||
- Use backtrace parser from abrtutils, new backtrace rating algorithm, store crash function if it's known (kklic@redhat.com)
|
||||
- abrt-rate-backtrace is replaced by abrt-backtrace --rate (kklic@redhat.com)
|
||||
- Ignore some temp files (kklic@redhat.com)
|
||||
- PYHOOK: don't use sitecustomize.py rhbz#539497 (jmoskovc@redhat.com)
|
||||
- rhfastcheck: a new reporter plugin based on Gavin's work (vda.linux@googlemail.com)
|
||||
- rhticket: new reporter plugin (vda.linux@googlemail.com)
|
||||
- GUI: fixed few window icons (jmoskovc@redhat.com)
|
||||
- Allow user to select which reporter he wants to use to report a crash using CLI.(kklic@redhat.com)
|
||||
- bz reporter: s/uuid/duphash; more understandable message; simplify result str generation; fix indentation (vda.linux@googlemail.com)
|
||||
- GUI: fixed crash count column sorting rhbz#573139 (jmoskovc@redhat.com)
|
||||
- Kerneloops: use 1st line of oops as REASON. Closes rhbz#574196. (vda.linux@googlemail.com)
|
||||
- Kerneloops: fix a case when we file an oops w/o backtrace (vda.linux@googlemail.com)
|
||||
- minor fix in abrt-debuginfo-install to make it work with yum >= 3.2.26 (jmoskovc@redhat.com)
|
||||
- GUI: added action to applet to directly report last crash (jmoskovc@redhat.com)
|
||||
- Never flag backtrace as binary file (fixes problem observed in bz#571411) (vda.linux@googlemail.com)
|
||||
- improve syslog file detection. closes bz#565983 (vda.linux@googlemail.com)
|
||||
- add arch, package and release in comment (npajkovs@redhat.com)
|
||||
- add ProcessUnpackaged option to abrt.conf (vda.linux@googlemail.com)
|
||||
- abrt-debuginfo-install: use -debuginfo repos which match enabled "usual" repos (vda.linux@googlemail.com)
|
||||
- fix format security error (fcrozat@mandriva.com)
|
||||
- icons repackaging (jmoskovc@redhat.com)
|
||||
- partial fix for bz#565983 (vda.linux@googlemail.com)
|
||||
- SPEC: Updated source URL (jmoskovc@redhat.com)
|
||||
- removed unneeded patches
|
||||
- and much more ...
|
||||
|
||||
* Sat Mar 13 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.0.8-3
|
||||
- fixed kerneloops reporting rhbz#570081
|
||||
- fixed Source url
|
||||
- fixed debuginfo-install to work on F13
|
||||
- improved debuginfo-install (vda.linux@googlemail.com)
|
||||
- fix debuginfo-install to work with yum >= 3.2.26 (jmoskovc@redhat.com)
|
||||
|
||||
* Wed Mar 3 2010 Denys Vlasenko <dvlasenk@redhat.com> 1.0.8-2
|
||||
- fix initscript even more (npajkovs@redhat.com)
|
||||
- remove -R2 from yum command line
|
||||
|
||||
* Mon Feb 22 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.0.8-1
|
||||
- fix initscript (npajkovs@redhat.com)
|
||||
- Kerneloops: make hashing more likely to produce same hash on different oopses (vda.linux@googlemail.com)
|
||||
|
Loading…
Reference in New Issue
Block a user