natural implementation of --since, no errors in console
This commit is contained in:
parent
0e36f28ad2
commit
efc3ea225f
29
0006-use-last_occurrence-with-since.patch
Normal file
29
0006-use-last_occurrence-with-since.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From e583b56fd6c3922b149ca55d0f0d1a8cbd1da4a7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
Date: Mon, 6 May 2013 13:00:56 +0200
|
||||||
|
Subject: [ABRT PATCH 6/7] use last_occurrence with --since
|
||||||
|
|
||||||
|
closes #645
|
||||||
|
|
||||||
|
Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
Signed-off-by: Richard Marko <rmarko@redhat.com>
|
||||||
|
---
|
||||||
|
src/lib/problem_api.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib/problem_api.c b/src/lib/problem_api.c
|
||||||
|
index b7dad47..d940767 100644
|
||||||
|
--- a/src/lib/problem_api.c
|
||||||
|
+++ b/src/lib/problem_api.c
|
||||||
|
@@ -174,7 +174,7 @@ GList *get_problem_dirs_for_element_in_time(uid_t uid,
|
||||||
|
};
|
||||||
|
|
||||||
|
const struct problem_condition timec = {
|
||||||
|
- .field_name = FILENAME_TIME,
|
||||||
|
+ .field_name = FILENAME_LAST_OCCURRENCE,
|
||||||
|
.args = &interval,
|
||||||
|
.evaluate = time_interval_problem_condition
|
||||||
|
};
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
@ -0,0 +1,27 @@
|
|||||||
|
From b3cd1e06c6605990ea0a3ed816ff1e95c65d9f2b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
Date: Mon, 6 May 2013 13:00:57 +0200
|
||||||
|
Subject: [ABRT PATCH 7/7] don't show non critical errors in console
|
||||||
|
notification
|
||||||
|
|
||||||
|
closes #646
|
||||||
|
|
||||||
|
Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
Signed-off-by: Richard Marko <rmarko@redhat.com>
|
||||||
|
---
|
||||||
|
src/cli/abrt-console-notification.sh | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/cli/abrt-console-notification.sh b/src/cli/abrt-console-notification.sh
|
||||||
|
index df02d05..cd4a779 100755
|
||||||
|
--- a/src/cli/abrt-console-notification.sh
|
||||||
|
+++ b/src/cli/abrt-console-notification.sh
|
||||||
|
@@ -11,4 +11,4 @@ fi
|
||||||
|
date +%s > "$TMPPATH"
|
||||||
|
mv "$TMPPATH" "$SINCEFILE"
|
||||||
|
|
||||||
|
-abrt-cli status --since="$SINCE"
|
||||||
|
+abrt-cli status --since="$SINCE" 2> /dev/null
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
10
abrt.spec
10
abrt.spec
@ -25,7 +25,7 @@
|
|||||||
Summary: Automatic bug detection and reporting tool
|
Summary: Automatic bug detection and reporting tool
|
||||||
Name: abrt
|
Name: abrt
|
||||||
Version: 2.1.4
|
Version: 2.1.4
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: https://fedorahosted.org/abrt/
|
URL: https://fedorahosted.org/abrt/
|
||||||
@ -42,6 +42,8 @@ Patch5: 0001-updated-translation.patch
|
|||||||
Patch6: 0002-abrt-uefioops-new-service.patch
|
Patch6: 0002-abrt-uefioops-new-service.patch
|
||||||
Patch7: 0005-abrtd.service-start-after-livesys.service.patch
|
Patch7: 0005-abrtd.service-start-after-livesys.service.patch
|
||||||
Patch8: install_uefi.patch
|
Patch8: install_uefi.patch
|
||||||
|
Patch9: 0006-use-last_occurrence-with-since.patch
|
||||||
|
Patch10:0007-don-t-show-non-critical-errors-in-console-notificati.patch
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
@ -318,6 +320,8 @@ to the shell
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
|
%patch9 -p1
|
||||||
|
%patch10 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -834,6 +838,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 06 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-3
|
||||||
|
- don't show non critical errors in console notification
|
||||||
|
- use last_occurrence with --since
|
||||||
|
|
||||||
* Fri May 03 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-2
|
* Fri May 03 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-2
|
||||||
- start abrtd.service after livecd
|
- start abrtd.service after livecd
|
||||||
- udpate translation
|
- udpate translation
|
||||||
|
Loading…
Reference in New Issue
Block a user