New version 2.10.7
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
This commit is contained in:
parent
e06dcb57e7
commit
dc422cf7ed
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.10.4.tar.gz
|
||||
/abrt-2.10.5.tar.gz
|
||||
/abrt-2.10.6.tar.gz
|
||||
/abrt-2.10.7.tar.gz
|
||||
|
@ -1,76 +0,0 @@
|
||||
From 578317a67c0f30469c28752ea2f40ae87a1a356c Mon Sep 17 00:00:00 2001
|
||||
From: Matej Habrnal <mhabrnal@redhat.com>
|
||||
Date: Wed, 21 Feb 2018 16:14:36 +0100
|
||||
Subject: [PATCH] a-container-logger: workaround permission issue in minishift
|
||||
|
||||
This workarounds the following issue:
|
||||
https://github.com/minishift/minishift/issues/2058
|
||||
|
||||
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-container-logger.c | 27 +++++++++++++++++++++++----
|
||||
1 file changed, 23 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-container-logger.c b/src/plugins/abrt-container-logger.c
|
||||
index 2f9488a3..df40f562 100644
|
||||
--- a/src/plugins/abrt-container-logger.c
|
||||
+++ b/src/plugins/abrt-container-logger.c
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#define INIT_PROC_STDERR_FD_PATH "/proc/1/fd/2"
|
||||
|
||||
@@ -25,7 +26,6 @@ int main(int argc, char *argv[])
|
||||
"\n"
|
||||
"\nThe tool reads from standard input and writes to '"INIT_PROC_STDERR_FD_PATH"'";
|
||||
|
||||
- /* the tool expects one parameter STR */
|
||||
if (argc > 1)
|
||||
{
|
||||
fprintf(stderr, "%s\n", program_usage_string);
|
||||
@@ -35,9 +35,27 @@ int main(int argc, char *argv[])
|
||||
FILE *f = fopen(INIT_PROC_STDERR_FD_PATH, "w");
|
||||
if (f == NULL)
|
||||
{
|
||||
- perror("Failed to open '"INIT_PROC_STDERR_FD_PATH"'");
|
||||
- return 2;
|
||||
+ perror("Failed to open '"INIT_PROC_STDERR_FD_PATH"' as root");
|
||||
+
|
||||
+ /* Try to open the 'INIT_PROC_STDERR_FD_PATH' as normal user because of
|
||||
+ https://github.com/minishift/minishift/issues/2058
|
||||
+ */
|
||||
+ if (seteuid(getuid()) == 0)
|
||||
+ {
|
||||
+ f = fopen(INIT_PROC_STDERR_FD_PATH, "w");
|
||||
+ if (f == NULL)
|
||||
+ {
|
||||
+ perror("Failed to open '"INIT_PROC_STDERR_FD_PATH"' as user");
|
||||
+ return 2;
|
||||
+ }
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ perror("Failed to setuid");
|
||||
+ return 3;
|
||||
+ }
|
||||
}
|
||||
+
|
||||
setvbuf (f, NULL, _IONBF, 0);
|
||||
|
||||
char buffer[BUFSIZ];
|
||||
@@ -52,7 +70,8 @@ int main(int argc, char *argv[])
|
||||
if (fwrite(buffer, bytes_read, 1, f) != 1)
|
||||
{
|
||||
perror("Failed to write to '"INIT_PROC_STDERR_FD_PATH"'");
|
||||
- return 3;
|
||||
+ fclose(f);
|
||||
+ return 4;
|
||||
}
|
||||
}
|
||||
fclose(f);
|
||||
--
|
||||
2.14.3
|
||||
|
24
abrt.spec
24
abrt.spec
@ -28,8 +28,8 @@
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.10.6
|
||||
Release: 2%{?dist}
|
||||
Version: 2.10.7
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://abrt.readthedocs.org/
|
||||
@ -37,7 +37,6 @@ Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.ta
|
||||
|
||||
# git format-patch %%{Version} --topo-order -N -M;
|
||||
# i=1; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
|
||||
Patch0001: 0001-a-container-logger-workaround-permission-issue-in-mi.patch
|
||||
|
||||
# '%%autosetup -S git' -> git
|
||||
BuildRequires: git
|
||||
@ -288,6 +287,14 @@ Obsoletes: abrt-addon-python < %{version}-%{release}
|
||||
This package contains python hook and python analyzer plugin for handling
|
||||
uncaught exception in python programs.
|
||||
|
||||
%package -n python2-abrt-container-addon
|
||||
Summary: %{name}'s container addon for catching Python 2 exceptions
|
||||
Conflicts: python2-abrt-addon
|
||||
|
||||
%description -n python2-abrt-container-addon
|
||||
This package contains python 2 hook and handling uncaught exception in python 2
|
||||
programs in container.
|
||||
|
||||
%package -n python3-abrt-addon
|
||||
Summary: %{name}'s addon for catching and analyzing Python 3 exceptions
|
||||
Group: System Environment/Libraries
|
||||
@ -1018,8 +1025,13 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%{_journalcatalogdir}/abrt_python.catalog
|
||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/catalog_python_format.conf
|
||||
%{_mandir}/man5/python_event.conf.5*
|
||||
%{python_sitearch}/abrt*.py*
|
||||
%{python_sitearch}/abrt.pth
|
||||
%{python_sitearch}/abrt_exception_handler.*
|
||||
|
||||
%files -n python2-abrt-container-addon
|
||||
%{python_sitearch}/abrt_container.pth
|
||||
%{python_sitearch}/abrt_exception_handler_container.*
|
||||
%attr(6755, root, root) %{_libexecdir}/abrt-container-logger-python2
|
||||
|
||||
%files -n python3-abrt-addon
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/plugins/python3.conf
|
||||
@ -1127,6 +1139,10 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Mon Feb 26 2018 Matej Habrnal <mhabrnal@redhat.com> 2.10.7-1
|
||||
- Translation updates
|
||||
- hooks: introduce docker hook for Python2
|
||||
|
||||
* Mon Feb 19 2018 Matej Habrnal <mhabrnal@redhat.com> 2.10.6-2
|
||||
- Translation updates
|
||||
- hooks: introduce docker hook for Python3
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (abrt-2.10.6.tar.gz) = 4c47aec3ace8033be954cc75f500d7394a77a3dd2511cabbe1706615907d4d6a4f89da1aec6d4ebc9519e47058ae139fbac40eab47048572a34ea52da528f700
|
||||
SHA512 (abrt-2.10.7.tar.gz) = 3db4ee8554906137c8ecbdf9c64e310fbfb2673a4c5df6211750616ba65156c3c133fc04c4b93c277f80e3cee0078de3773884273d4a80b5b64de9d599e3c780
|
||||
|
Loading…
Reference in New Issue
Block a user