New version 2.10.4
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
This commit is contained in:
parent
49b1bc1549
commit
d2918af2e6
1
.gitignore
vendored
1
.gitignore
vendored
@ -55,3 +55,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.10.1.tar.gz
|
||||
/abrt-2.10.2.tar.gz
|
||||
/abrt-2.10.3.tar.gz
|
||||
/abrt-2.10.4.tar.gz
|
||||
|
@ -1,54 +0,0 @@
|
||||
From c01551e6e9fd293a3f40e481afe8c28e786fe632 Mon Sep 17 00:00:00 2001
|
||||
From: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Fri, 11 Aug 2017 13:24:26 +0300
|
||||
Subject: [PATCH] Quick hack to fix build with rpm >= 4.14
|
||||
|
||||
1) rpm >= 4.14 no longer has rpmCheckTerminate() call, it cleans up
|
||||
automatically on exit(). Note that "needing" rpmCheckTerminate()
|
||||
means the code is buggy: it does not properly track and free
|
||||
rpmdb iterators and/or rpmts handles.
|
||||
2) pgpPubkeyFingerprint() now returns the actual fingerprint, the
|
||||
key ID which it previously returned is now retrieved by
|
||||
pgpPubkeyKeyID()
|
||||
|
||||
If compatibility to older versions is needed, these will need
|
||||
configure checks, left as an excercise for someone more familiar
|
||||
with the abrt codebase.
|
||||
---
|
||||
src/daemon/rpm.c | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/daemon/rpm.c b/src/daemon/rpm.c
|
||||
index 36b36a91..011e44ca 100644
|
||||
--- a/src/daemon/rpm.c
|
||||
+++ b/src/daemon/rpm.c
|
||||
@@ -76,11 +76,14 @@ void rpm_destroy()
|
||||
rpmFreeMacros(NULL);
|
||||
rpmFreeRpmrc();
|
||||
|
||||
+/* rpm >= 4.14 handles this automatically on exit */
|
||||
+#if 0
|
||||
/* RPM doc says "clean up any open iterators and databases".
|
||||
* Observed to eliminate these Berkeley DB warnings:
|
||||
* "BDB2053 Freeing read locks for locker 0x1e0: 28718/139661746636736"
|
||||
*/
|
||||
rpmdbCheckTerminate(1);
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
list_free_with_free(list_fingerprints);
|
||||
@@ -100,7 +103,11 @@ void rpm_load_gpgkey(const char* filename)
|
||||
}
|
||||
|
||||
uint8_t keyID[8];
|
||||
+#if 0
|
||||
if (pgpPubkeyFingerprint(pkt, pklen, keyID) == 0)
|
||||
+#else
|
||||
+ if (pgpPubkeyKeyID(pkt, pklen, keyID) == 0)
|
||||
+#endif
|
||||
{
|
||||
char *fingerprint = pgpHexStr(keyID, sizeof(keyID));
|
||||
if (fingerprint != NULL)
|
||||
--
|
||||
2.14.0
|
||||
|
23
abrt.spec
23
abrt.spec
@ -54,13 +54,13 @@
|
||||
%define docdirversion -%{version}
|
||||
%endif
|
||||
|
||||
%define libreport_ver 2.9.1
|
||||
%define libreport_ver 2.9.2
|
||||
%define satyr_ver 0.22
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.10.3
|
||||
Release: 7%{?dist}
|
||||
Version: 2.10.4
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://abrt.readthedocs.org/
|
||||
@ -72,9 +72,6 @@ Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.ta
|
||||
# don't remove this patch, packages in rawhide are not signed!
|
||||
Patch0: disable-OpenGPGCheck-in-Fedora-Rawhide.patch
|
||||
|
||||
# Hacks for RPM 4.14 support
|
||||
Patch1: 0001-Quick-hack-to-fix-build-with-rpm-4.14.patch
|
||||
|
||||
# '%%autosetup -S git' -> git
|
||||
BuildRequires: git
|
||||
|
||||
@ -85,7 +82,7 @@ BuildRequires: rpm-devel >= 4.6
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libnotify-devel
|
||||
#why? BuildRequires: file-devel
|
||||
BuildRequires: python-devel
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libxml2-devel
|
||||
@ -469,6 +466,7 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-dbus = %{version}-%{release}
|
||||
Requires: dbus-python
|
||||
Requires: libreport-python
|
||||
Requires: python-gobject
|
||||
%{?python_provide:%python_provide python2-abrt}
|
||||
# Remove before F30
|
||||
Provides: %{name}-python = %{version}-%{release}
|
||||
@ -504,6 +502,7 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-dbus = %{version}-%{release}
|
||||
Requires: python3-dbus
|
||||
Requires: libreport-python3
|
||||
Requires: python3-gobject
|
||||
%{?python_provide:%python_provide python3-abrt}
|
||||
# Remove before F30
|
||||
Provides: %{name}-python3 = %{version}-%{release}
|
||||
@ -1170,6 +1169,16 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Mon Aug 28 2017 Matej Habrnal <mhabrnal@redhat.com> 2.10.4-1
|
||||
- Translation updates
|
||||
- logging: rename log() to log_warning()
|
||||
- Quick hack to fix build with rpm >= 4.14
|
||||
- cli,dbus: Allow polkit to be optional at build time
|
||||
- spec: add dependency for python{3}-gobject
|
||||
- a-d-journal-core: fix bad condition in creating reason msg
|
||||
- a-d-journal-core: use pid of crashed process in dumpdir name
|
||||
- changelog: update CHANGELOG.md
|
||||
|
||||
* Wed Aug 16 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 2.10.3-7
|
||||
- Python 2 binary package renamed to python2-abrt
|
||||
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (abrt-2.10.3.tar.gz) = dac86703c60f1b56b8cfa7b2e400f5165a0ee9bd457667dec71981f9475b35552c80d5c5864de22414d83f4ce8ea29300d299f36e7fe4eb77a80112d6a1852ab
|
||||
SHA512 (abrt-2.10.4.tar.gz) = f87fa0592867ef9c8543f066ffd9a0595941c14b4b0420746ebd7ca9e1335d45f0323d2e299778171031f0537e0e8da3dcfd33e3e6adae1cd76e33af7b131504
|
||||
|
Loading…
Reference in New Issue
Block a user