disable shortened and auto reporting in RHEL
Resolves: #918040, #918041
This commit is contained in:
parent
d39e70cd90
commit
d1f93ad6cc
30
abrt-2.1.1-disable_autoreporting_dialog.patch
Normal file
30
abrt-2.1.1-disable_autoreporting_dialog.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -ur abrt-2.1.1/src/applet/applet.c abrt-2.1.1.new/src/applet/applet.c
|
||||
--- abrt-2.1.1/src/applet/applet.c 2013-02-01 17:05:40.000000000 +0100
|
||||
+++ abrt-2.1.1.new/src/applet/applet.c 2013-03-05 12:16:42.463747490 +0100
|
||||
@@ -89,25 +89,7 @@
|
||||
|
||||
static void ask_start_autoreporting()
|
||||
{
|
||||
- /* The "Yes" response will be saved even if user don't check the
|
||||
- * "Don't ask me again" box.
|
||||
- */
|
||||
- const int ret = run_ask_yes_no_save_result_dialog("AutoreportingEnabled",
|
||||
- _("The report which will be sent does not contain any security sensitive data. "
|
||||
- "Therefore it is not necessary to bother you next time and require any further action by you. "
|
||||
- "\nDo you want to enable automatically submitted anonymous crash reports?"),
|
||||
- /*parent wnd */ NULL);
|
||||
-
|
||||
- /* Don't forget:
|
||||
- *
|
||||
- * The "Yes" response will be saved even if user don't check the
|
||||
- * "Don't ask me again" box.
|
||||
- */
|
||||
- if (ret != 0)
|
||||
- set_user_setting("AutoreportingEnabled", "yes");
|
||||
-
|
||||
- /* must be called immediately, otherwise the data could be lost in case of crash */
|
||||
- save_user_settings();
|
||||
+ return;
|
||||
}
|
||||
|
||||
static bool is_shortened_reporting_enabled()
|
14
abrt-2.1.1-dont_enable_shortened_reporting_in_gnome.patch
Normal file
14
abrt-2.1.1-dont_enable_shortened_reporting_in_gnome.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -ur abrt-2.1.1/src/applet/applet.c abrt-2.1.1.new/src/applet/applet.c
|
||||
--- abrt-2.1.1/src/applet/applet.c 2013-02-01 17:05:40.000000000 +0100
|
||||
+++ abrt-2.1.1.new/src/applet/applet.c 2013-03-05 12:04:38.840227170 +0100
|
||||
@@ -117,9 +117,7 @@
|
||||
if (configured)
|
||||
return string_to_bool(configured);
|
||||
|
||||
- /* Default: enabled for GNOME desktop, else disabled */
|
||||
- const char *desktop_env = getenv("DESKTOP_SESSION");
|
||||
- return (desktop_env && strcasestr(desktop_env, "gnome") != NULL);
|
||||
+ return false;
|
||||
}
|
||||
|
||||
/*
|
12
abrt.spec
12
abrt.spec
@ -25,7 +25,7 @@
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.1.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
@ -34,6 +34,8 @@ Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
|
||||
Patch0: abrt-rhelkeys.patch
|
||||
Patch1: disable_gpg_check.patch
|
||||
Patch2: abrt-2.1.1-hide_all_ureport_stuff.patch
|
||||
Patch3: abrt-2.1.1-dont_enable_shortened_reporting_in_gnome.patch
|
||||
Patch4: abrt-2.1.1-disable_autoreporting_dialog.patch
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: rpm-devel >= 4.6
|
||||
@ -259,6 +261,8 @@ problems handled by ABRT in Python.
|
||||
%if 0%{?rhel} >= 7
|
||||
%patch0 -p1 -b .rhel_gpg
|
||||
%patch2 -p1 -b .ureport
|
||||
%patch3 -p1 -b .shoretened
|
||||
%patch4 -p1 -b .autoreporting
|
||||
%endif
|
||||
#Fedora
|
||||
%patch1 -p1 -b .gpgcheck
|
||||
@ -730,7 +734,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_defaultdocdir}/%{name}-python-%{version}/examples/
|
||||
|
||||
%changelog
|
||||
* Fri Feb 04 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-2
|
||||
* Tue Mar 05 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-3
|
||||
- disable shortened and auto reporting in RHEL
|
||||
- Resolves: #918040, #918041
|
||||
|
||||
* Tue Mar 05 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-2
|
||||
- remove ureport events from the reporting workflow in RHEL
|
||||
|
||||
* Fri Feb 04 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-1
|
||||
|
Loading…
Reference in New Issue
Block a user