applet: Update GLib constant name
This fixes FTBFS in F37+ Signed-off-by: Michal Srb <michal@redhat.com>
This commit is contained in:
parent
4f63977e6d
commit
c8a122775e
48
0003-applet-Update-GLib-constant-name.patch
Normal file
48
0003-applet-Update-GLib-constant-name.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
From 8f67ddc99b4a72718290daae323fa5bc3c1d59eb Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Mat=C4=9Bj=20Grabovsk=C3=BD?= <mgrabovs@redhat.com>
|
||||||
|
Date: Thu, 15 Sep 2022 12:59:23 +0200
|
||||||
|
Subject: [PATCH] applet: Update GLib constant name
|
||||||
|
|
||||||
|
The `G_APPLICATION_FLAGS_NONE` constant has apparently been deprecated
|
||||||
|
and removed 2.73. Also bump the version constraint in the spec file.
|
||||||
|
---
|
||||||
|
abrt.spec | 3 ++-
|
||||||
|
src/applet/abrt-applet-application.c | 2 +-
|
||||||
|
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/abrt.spec b/abrt.spec
|
||||||
|
index 2f2c3027..03beca7d 100644
|
||||||
|
--- a/abrt.spec
|
||||||
|
+++ b/abrt.spec
|
||||||
|
@@ -43,6 +43,7 @@
|
||||||
|
%define docdirversion -%{version}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
+%define glib_ver 2.73.3
|
||||||
|
%define libreport_ver 2.14.0
|
||||||
|
%define satyr_ver 0.24
|
||||||
|
|
||||||
|
@@ -56,7 +57,7 @@ Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.ta
|
||||||
|
BuildRequires: %{dbus_devel}
|
||||||
|
BuildRequires: hostname
|
||||||
|
BuildRequires: gtk3-devel
|
||||||
|
-BuildRequires: glib2-devel >= 2.43.4
|
||||||
|
+BuildRequires: glib2-devel >= %{glib_ver}
|
||||||
|
BuildRequires: rpm-devel >= 4.6
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: libnotify-devel
|
||||||
|
diff --git a/src/applet/abrt-applet-application.c b/src/applet/abrt-applet-application.c
|
||||||
|
index 394d52b7..6faa8cf7 100644
|
||||||
|
--- a/src/applet/abrt-applet-application.c
|
||||||
|
+++ b/src/applet/abrt-applet-application.c
|
||||||
|
@@ -1215,6 +1215,6 @@ abrt_applet_application_new (void)
|
||||||
|
{
|
||||||
|
return g_object_new (ABRT_APPLET_TYPE_APPLICATION,
|
||||||
|
"application-id", ABRT_DBUS_NAME ".applet",
|
||||||
|
- "flags", G_APPLICATION_FLAGS_NONE,
|
||||||
|
+ "flags", G_APPLICATION_DEFAULT_FLAGS,
|
||||||
|
NULL);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.37.3
|
||||||
|
|
@ -55,6 +55,7 @@ URL: https://abrt.readthedocs.org/
|
|||||||
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch0: 0001-Fix-for-rpm-4.18.patch
|
Patch0: 0001-Fix-for-rpm-4.18.patch
|
||||||
Patch1: 0002-abrt-journal-call-sd_journal_get_fd-right-after-sd_j.patch
|
Patch1: 0002-abrt-journal-call-sd_journal_get_fd-right-after-sd_j.patch
|
||||||
|
Patch2: 0003-applet-Update-GLib-constant-name.patch
|
||||||
|
|
||||||
BuildRequires: git-core
|
BuildRequires: git-core
|
||||||
BuildRequires: %{dbus_devel}
|
BuildRequires: %{dbus_devel}
|
||||||
|
Loading…
Reference in New Issue
Block a user