Minor fixes

Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
This commit is contained in:
Martin Kutlak 2017-06-01 16:54:16 +02:00
parent 54d3f87adf
commit bf3d889d82
6 changed files with 512 additions and 30 deletions

View File

@ -0,0 +1,38 @@
From 16bcce2f12eb844602cf78d6c186e6d5c519fd6d Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Mon, 13 Mar 2017 10:07:30 +0100
Subject: [PATCH] build: do not upload tarball to fedorahosted.org
fedorahosted.org was retired on March 1st, 2017.
As we have all previous tarball created from github and all
version tags are in place I choose to use github as our new
tarball source.
We don't need to upload tarball anymore.
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
Makefile.am | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index a127364..8632816 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,7 +78,7 @@ DIST=rawhide
scratch-build: srpm
koji build --scratch $(DIST) `make srpm | grep Wrote | cut -d' ' -f2`
-UPLOAD_URL ?= fedorahosted.org:abrt
+UPLOAD_URL ?= localhost
upload: dist
scp $(distdir).tar.gz $$(test -n "$$UPLOAD_LOGIN" && echo "$$UPLOAD_LOGIN@")$(UPLOAD_URL)
@@ -114,4 +114,3 @@ release:
git tag "$$NEW_VER"; \
echo -n "$$NEW_VER" > abrt-version
autoconf --force
- $(MAKE) upload
--
2.9.4

26
0004-Fix-Typo.patch Normal file
View File

@ -0,0 +1,26 @@
From 98bca432496794889dc748d24bc07759382d1b77 Mon Sep 17 00:00:00 2001
From: kprkpr <kevin01010@gmail.com>
Date: Tue, 14 Mar 2017 15:41:11 +0100
Subject: [PATCH] Fix Typo
Daemize -> Daemonize
---
src/daemon/abrt-upload-watch.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/daemon/abrt-upload-watch.c b/src/daemon/abrt-upload-watch.c
index a42b285..137135c 100644
--- a/src/daemon/abrt-upload-watch.c
+++ b/src/daemon/abrt-upload-watch.c
@@ -278,7 +278,7 @@ main(int argc, char **argv)
struct options program_options[] = {
OPT__VERBOSE(&g_verbose),
OPT_BOOL('s', NULL, NULL , _("Log to syslog")),
- OPT_BOOL('d', NULL, NULL , _("Daemize")),
+ OPT_BOOL('d', NULL, NULL , _("Daemonize")),
OPT_INTEGER('w', NULL, &concurrent_workers, _("Number of concurrent workers. Default is "STRINGIZE(DEFAULT_COUNT_OF_WORKERS))),
OPT_INTEGER('c', NULL, &cache_size_mib, _("Maximal cache size in MiB. Default is "STRINGIZE(DEFAULT_CACHE_MIB_SIZE))),
OPT_END()
--
2.9.4

405
0005-Spelling-fixes.patch Normal file
View File

@ -0,0 +1,405 @@
From 3cd13f7b688fe02e221a6d483c9b241643c41a40 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
Date: Sun, 26 Mar 2017 00:03:42 +0200
Subject: [PATCH] Spelling fixes
---
doc/abrt-dump-journal-oops.txt | 2 +-
doc/abrt-dump-journal-xorg.txt | 6 +++---
doc/abrt-server.txt | 2 +-
doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml | 2 +-
doc/doxygen.cfg | 2 +-
doc/project/abrt.tex | 6 +++---
maint/pull-translations | 2 +-
src/configuration-gui/abrt-config-widget.c | 4 ++--
src/daemon/abrt-action-save-package-data.c | 4 ++--
src/daemon/abrt-action-save-package-data.conf | 2 +-
src/daemon/abrt.conf | 2 +-
src/dbus/abrt_problems2_session.c | 10 +++++-----
src/dbus/abrt_problems2_task_new_problem.c | 2 +-
src/lib/hooklib.c | 2 +-
src/lib/ignored_problems.c | 2 +-
src/lib/notify_new_path.c | 4 ++--
src/plugins/abrt-action-analyze-c.c | 2 +-
src/plugins/abrt-action-install-debuginfo.in | 2 +-
src/plugins/abrt-action-list-dsos | 2 +-
src/plugins/abrt-dump-journal-core.c | 2 +-
src/plugins/vimrc_event.conf | 2 +-
src/plugins/xorg.conf | 2 +-
src/python-problem/doc/properties.rst | 4 ++--
23 files changed, 35 insertions(+), 35 deletions(-)
diff --git a/doc/abrt-dump-journal-oops.txt b/doc/abrt-dump-journal-oops.txt
index e0b8d79..ddeb9fe 100644
--- a/doc/abrt-dump-journal-oops.txt
+++ b/doc/abrt-dump-journal-oops.txt
@@ -45,7 +45,7 @@ OPTIONS
Same as -d DumpLocation, DumpLocation is specified in abrt.conf
-s CURSOR::
- Starts scannig systemd-journal from CURSOR
+ Starts scanning systemd-journal from CURSOR
-e::
Starts following systemd-journal from the end
diff --git a/doc/abrt-dump-journal-xorg.txt b/doc/abrt-dump-journal-xorg.txt
index 8f531b9..c860c29 100644
--- a/doc/abrt-dump-journal-xorg.txt
+++ b/doc/abrt-dump-journal-xorg.txt
@@ -32,11 +32,11 @@ Configuration file
~~~~~~~~~~~~~~~~~~
The conf file is located in /etc/abrt/plugins/xorg.conf.
Configuration file lines should have 'PARAM = VALUE' format. The parameters for
-abrt-dump-jounral-xorg are:
+abrt-dump-journal-xorg are:
'JournalFilters'::
Specify list of comma separated filters which are used for searching Xorg
- crashes in jounral (e.g. JournalFilters = _COMM=gdm-x-session, [...])
+ crashes in journal (e.g. JournalFilters = _COMM=gdm-x-session, [...])
OPTIONS
-------
@@ -56,7 +56,7 @@ OPTIONS
Same as -d DumpLocation, DumpLocation is specified in abrt.conf
-s CURSOR::
- Starts scannig systemd-journal from CURSOR
+ Starts scanning systemd-journal from CURSOR
-e::
Starts following systemd-journal from the end
diff --git a/doc/abrt-server.txt b/doc/abrt-server.txt
index bf9b40d..22fb4cb 100644
--- a/doc/abrt-server.txt
+++ b/doc/abrt-server.txt
@@ -35,7 +35,7 @@ Protocol
Initializing new dump:
connect to UNIX domain socket /var/run/abrt.socket
-Providing data (writting data to the socket):
+Providing data (writing data to the socket):
-------------------------------------------------
-> "POST / HTTP/1.1\r\n"
diff --git a/doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml b/doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml
index 0aaffab..9661b95 100644
--- a/doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml
+++ b/doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml
@@ -13,7 +13,7 @@
<para>
For Red Hat Enterprise Linux 6.2, the Automatic Bug Reporting Tool has been upgraded to version 2.0. The <application>ABRT</application> 2-series brings major improvements to automatic bug detection and reporting.
</para>
- <!-- msvoboda: Differencies between ABRT 1-series and ABRT 2-series cannot be added to Release Notes because the amount of changes is too large
+ <!-- msvoboda: Differences between ABRT 1-series and ABRT 2-series cannot be added to Release Notes because the amount of changes is too large
<para>For more information on the major differences between the <application>ABRT</application> 1-series and <application>ABRT</application> 2-series, refer to the <citetitle>Red Hat Enterprise Linux 6.2 Release Notes</citetitle>.</para>-->
<!--msvoboda: The ABRT Migration section will be added on RHEL 6.2 GA
<para>For more information on the major differences between the <application>ABRT</application> 1-series and <application>ABRT</application> 2-series, as well as easy migration instructions, refer to <xref linkend="sect-migration_to_abrt2"/>
diff --git a/doc/doxygen.cfg b/doc/doxygen.cfg
index 7b71bc0..c646933 100644
--- a/doc/doxygen.cfg
+++ b/doc/doxygen.cfg
@@ -1730,7 +1730,7 @@ UML_LOOK = NO
# the class node. If there are many fields or methods and many nodes the
# graph may become too big to be useful. The UML_LIMIT_NUM_FIELDS
# threshold limits the number of items for each type to make the size more
-# managable. Set this to 0 for no limit. Note that the threshold may be
+# manageable. Set this to 0 for no limit. Note that the threshold may be
# exceeded by 50% before the limit is enforced.
UML_LIMIT_NUM_FIELDS = 10
diff --git a/doc/project/abrt.tex b/doc/project/abrt.tex
index 03b5705..b0bd827 100644
--- a/doc/project/abrt.tex
+++ b/doc/project/abrt.tex
@@ -588,12 +588,12 @@ last occurrence : TIMESTAMP NOT NULL \\
\umlclass[x=4,y=-2]{problem report}{
problem id : FOREIGN KEY NOT NULL \\
-report id : FOREGIN KEY NOT NULL
+report id : FOREIGN KEY NOT NULL
}{}
\umlclass[x=4,y=2]{problem component}{
problem id : FOREIGN KEY NOT NULL \\
-component id : FOREGIN KEY NOT NULL \\
+component id : FOREIGN KEY NOT NULL \\
order : INT NOT NULL
}{}
@@ -1910,7 +1910,7 @@ phase:
%\section{Project Quality Management}
%- Plan Quality
%-- Quality management plan
-%-- Quality metrices
+%-- Quality metrics
%-- Quality checklists
%-- Process improvement plan
diff --git a/maint/pull-translations b/maint/pull-translations
index 42db4dc..322a6e8 100755
--- a/maint/pull-translations
+++ b/maint/pull-translations
@@ -6,7 +6,7 @@ fi
git update-index -q --refresh >/dev/null 2>&1
if [ -n "$(git diff-index --name-only HEAD --)" ]; then
- echo "Run this script only without uncommited changes"
+ echo "Run this script only without uncommitted changes"
exit 1
fi
diff --git a/src/configuration-gui/abrt-config-widget.c b/src/configuration-gui/abrt-config-widget.c
index e7457b3..72d592c 100644
--- a/src/configuration-gui/abrt-config-widget.c
+++ b/src/configuration-gui/abrt-config-widget.c
@@ -510,7 +510,7 @@ abrt_config_widget_init(AbrtConfigWidget *self)
* from GObject which offers a functionality for attaching an
* arbitrary data to its instances. The last argument is a function
* called to destroy the arbirarty data when the instance is being
- * destoryed. */
+ * destroyed. */
g_object_set_data_full(G_OBJECT(launcher), "launched-app", app, g_object_unref);
g_signal_connect(launcher, "clicked", G_CALLBACK(pp_launcher_clicked), NULL);
@@ -519,7 +519,7 @@ abrt_config_widget_init(AbrtConfigWidget *self)
gtk_widget_set_hexpand(launcher, FALSE);
gtk_widget_set_vexpand(launcher, FALSE);
- /* Make the launcher button alligned on center of the warning. */
+ /* Make the launcher button aligned on center of the warning. */
gtk_widget_set_halign(launcher, GTK_ALIGN_CENTER);
gtk_widget_set_valign(launcher, GTK_ALIGN_CENTER);
diff --git a/src/daemon/abrt-action-save-package-data.c b/src/daemon/abrt-action-save-package-data.c
index ccd1175..36d84b6 100644
--- a/src/daemon/abrt-action-save-package-data.c
+++ b/src/daemon/abrt-action-save-package-data.c
@@ -292,7 +292,7 @@ static int SavePackageDescriptionToDebugDump(const char *dump_dir_name, const ch
}
if (kernel_oops)
- goto skip_interperter;
+ goto skip_interpreter;
/* Check well-known interpreter names */
const char *basename = strrchr(executable, '/');
@@ -336,7 +336,7 @@ static int SavePackageDescriptionToDebugDump(const char *dump_dir_name, const ch
pkg_name = script_pkg;
}
-skip_interperter:
+skip_interpreter:
package_short_name = xasprintf("%s", pkg_name->p_name);
log_info("Package:'%s' short:'%s'", pkg_name->p_nvr, package_short_name);
diff --git a/src/daemon/abrt-action-save-package-data.conf b/src/daemon/abrt-action-save-package-data.conf
index 493841b..eedcb3d 100644
--- a/src/daemon/abrt-action-save-package-data.conf
+++ b/src/daemon/abrt-action-save-package-data.conf
@@ -3,7 +3,7 @@
# the list of public keys used to check the signature is
# in the file gpg_keys
#
-# How can I check the GPG key used to sign an installed pacakge on
+# How can I check the GPG key used to sign an installed package on
# Red hat Enterprise Linux:
# https://access.redhat.com/solutions/1120013
#
diff --git a/src/daemon/abrt.conf b/src/daemon/abrt.conf
index 6d1660e..2454fa1 100644
--- a/src/daemon/abrt.conf
+++ b/src/daemon/abrt.conf
@@ -46,7 +46,7 @@ AutoreportingEnabled = no
# ShortenedReporting = yes
# Enables various features exploring process's root directories if they differ
-# from the default root directory. The folowing list includes examples of
+# from the default root directory. The following list includes examples of
# enabled features:
# * query the rpm database in the process's root directory
# * save files like /etc/os-release from the process's root directory
diff --git a/src/dbus/abrt_problems2_session.c b/src/dbus/abrt_problems2_session.c
index 3119774..f13e341 100644
--- a/src/dbus/abrt_problems2_session.c
+++ b/src/dbus/abrt_problems2_session.c
@@ -320,7 +320,7 @@ const char *abrt_p2_session_generate_token(AbrtP2Session *session,
return NULL;
}
-#define SESSION_TOKEN_LENGHT 16
+#define SESSION_TOKEN_LENGTH 16
static const char *const alphabet = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
if (duration == 0)
@@ -348,11 +348,11 @@ const char *abrt_p2_session_generate_token(AbrtP2Session *session,
return NULL;
}
- char *token = xmalloc((SESSION_TOKEN_LENGHT + 1) * sizeof(char));
- for (char *iter = token; iter < token + SESSION_TOKEN_LENGHT; ++iter)
+ char *token = xmalloc((SESSION_TOKEN_LENGTH + 1) * sizeof(char));
+ for (char *iter = token; iter < token + SESSION_TOKEN_LENGTH; ++iter)
*iter = alphabet[(int)(strlen(alphabet) * (rand_r(&seed) / (double)RAND_MAX))];
- token[SESSION_TOKEN_LENGHT] = '\0';
+ token[SESSION_TOKEN_LENGTH] = '\0';
const time_t curtime = time(NULL);
if (curtime == ((time_t) -1))
@@ -368,7 +368,7 @@ const char *abrt_p2_session_generate_token(AbrtP2Session *session,
GINT_TO_POINTER(curtime + duration));
return token;
-#undef SESSION_TOKEN_LENGHT
+#undef SESSION_TOKEN_LENGTH
}
int abrt_p2_session_revoke_token(AbrtP2Session *session,
diff --git a/src/dbus/abrt_problems2_task_new_problem.c b/src/dbus/abrt_problems2_task_new_problem.c
index 231cb30..42f4c44 100644
--- a/src/dbus/abrt_problems2_task_new_problem.c
+++ b/src/dbus/abrt_problems2_task_new_problem.c
@@ -167,7 +167,7 @@ static int abrt_p2_task_new_problem_notify_directory_task(AbrtP2TaskNewProblem *
char *message = NULL;
const char *problem_id = abrt_p2_entry_problem_id(entry);
- int r = notify_new_path_with_reponse(problem_id, &message);
+ int r = notify_new_path_with_response(problem_id, &message);
if (r < 0)
{
log_debug("Task '%p': Failed to communicate with the problems daemon",
diff --git a/src/lib/hooklib.c b/src/lib/hooklib.c
index ccb1936..f9337b7 100644
--- a/src/lib/hooklib.c
+++ b/src/lib/hooklib.c
@@ -600,7 +600,7 @@ bool dir_has_correct_permissions(const char *dir_name, int flags)
* 1. Chowning of dump directories switches the ownership to 'user':'abrt'
* 2. We want to allow users to delete their problems
* 3. We want to allow users to modify their data
- * 4. The daemons are hardened agains hard link and symbolic link issues.
+ * 4. The daemons are hardened against hard link and symbolic link issues.
*/
return correct_group;
}
diff --git a/src/lib/ignored_problems.c b/src/lib/ignored_problems.c
index 7779c4c..7afc80a 100644
--- a/src/lib/ignored_problems.c
+++ b/src/lib/ignored_problems.c
@@ -204,7 +204,7 @@ void ignored_problems_remove_row(ignored_problems_t *set, const char *problem_id
{
log_notice("Won't remove problem '%s' from ignored problems:"
" it is already removed", problem_id);
- /* Close orig_fp here becuase it looks like much simpler than
+ /* Close orig_fp here because it looks like much simpler than
* exetendig the set of goto labels at the end of this function */
fclose(orig_fp);
}
diff --git a/src/lib/notify_new_path.c b/src/lib/notify_new_path.c
index bfd0258..4789a3d 100644
--- a/src/lib/notify_new_path.c
+++ b/src/lib/notify_new_path.c
@@ -21,10 +21,10 @@
void notify_new_path(const char *path)
{
/* Ignore results and don't wait for response -> NULL */
- notify_new_path_with_reponse(path, NULL);
+ notify_new_path_with_response(path, NULL);
}
-int notify_new_path_with_reponse(const char *path, char **message)
+int notify_new_path_with_response(const char *path, char **message)
{
int retval;
int fd = socket(AF_UNIX, SOCK_STREAM, 0);
diff --git a/src/plugins/abrt-action-analyze-c.c b/src/plugins/abrt-action-analyze-c.c
index b7213d7..df2561d 100644
--- a/src/plugins/abrt-action-analyze-c.c
+++ b/src/plugins/abrt-action-analyze-c.c
@@ -221,7 +221,7 @@ int main(int argc, char **argv)
if (last_dot != first_dot)
{
/* There are more than one dot: "1.2.3"
- * Strip last part, we don't want to distinquish crashes
+ * Strip last part, we don't want to distinguish crashes
* in packages which differ only by minor release number.
*/
*last_dot = '\0';
diff --git a/src/plugins/abrt-action-install-debuginfo.in b/src/plugins/abrt-action-install-debuginfo.in
index 8be8e8f..f2abf43 100644
--- a/src/plugins/abrt-action-install-debuginfo.in
+++ b/src/plugins/abrt-action-install-debuginfo.in
@@ -144,7 +144,7 @@ if __name__ == "__main__":
TMPDIR = arg
elif opt == "--keeprpms":
keeprpms = True
- # --exact takes precendece over --ids
+ # --exact takes precedence over --ids
elif opt in ("-e", "--exact"):
missing = arg.split(':')
exact_fls = True
diff --git a/src/plugins/abrt-action-list-dsos b/src/plugins/abrt-action-list-dsos
index 384f031..4ffa184 100644
--- a/src/plugins/abrt-action-list-dsos
+++ b/src/plugins/abrt-action-list-dsos
@@ -33,7 +33,7 @@ def parse_maps(maps_path):
# and Xorg backtrace format:
# [ 86985.880] 9: /usr/lib64/libdrm.so.2 (drmHandleEvent+0xa3) [0x376b407513]
# To do that, we take only lines which have a / character,
- # then for each line we start at first /, then remove everyting after first whitespace
+ # then for each line we start at first /, then remove everything after first whitespace
files = [x[x.find('/'):].split()[0] for x in f.readlines() if x.find('/') > -1]
# set() uniqifies the list of filenames
return set(files)
diff --git a/src/plugins/abrt-dump-journal-core.c b/src/plugins/abrt-dump-journal-core.c
index 8822956..971211e 100644
--- a/src/plugins/abrt-dump-journal-core.c
+++ b/src/plugins/abrt-dump-journal-core.c
@@ -99,7 +99,7 @@ struct occurrence_queue
int oq_head; ///< the first empty index
unsigned oq_size; ///< size of the queue
- struct last_occurence
+ struct last_occurrence
{
unsigned oqlc_stamp;
char *oqlc_executable;
diff --git a/src/plugins/vimrc_event.conf b/src/plugins/vimrc_event.conf
index edebe59..cef991a 100644
--- a/src/plugins/vimrc_event.conf
+++ b/src/plugins/vimrc_event.conf
@@ -1,4 +1,4 @@
-# Exemple events that allow the reporter to attach vim configuration files
+# Example events that allow the reporter to attach vim configuration files
# whenever vim crash is reported.
EVENT=collect_vimrc_user component=vim
diff --git a/src/plugins/xorg.conf b/src/plugins/xorg.conf
index 8834e23..7cb144b 100644
--- a/src/plugins/xorg.conf
+++ b/src/plugins/xorg.conf
@@ -3,5 +3,5 @@
# Names should be without "_drv.so" suffix:
BlacklistedXorgModules = nvidia, fglrx, vboxvideo
-# List of filters which is used for searching Xorg crashes in jounral
+# List of filters which is used for searching Xorg crashes in journal
JournalFilters = _COMM=gdm-x-session, _COMM=gnome-shell
diff --git a/src/python-problem/doc/properties.rst b/src/python-problem/doc/properties.rst
index 84fc8d8..ee181ec 100644
--- a/src/python-problem/doc/properties.rst
+++ b/src/python-problem/doc/properties.rst
@@ -32,8 +32,8 @@ Property Meaning E
``architecture`` Machine architecture string ``'x86_64'``
``kernel`` Kernel version string ``'3.6.6-1.fc17.x86_64'``
``package`` Package string ``'time-1.7-40.fc17.x86_64'``
-``time`` Time of the occurence (unixtime) ``datetime.datetime(2012, 12, 2, 16, 18, 41)``
-``count`` Number of times this problem occured ``1``
+``time`` Time of the occurrence (unixtime) ``datetime.datetime(2012, 12, 2, 16, 18, 41)``
+``count`` Number of times this problem occurred ``1``
===================== ======================================================== ====================
Parsed package data is also available:
--
2.9.4

View File

@ -0,0 +1,30 @@
From 7a0e2947ad9372bcee0929cb0b22e10826b61cd9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miroslav=20Such=C3=BD?= <msuchy@redhat.com>
Date: Thu, 30 Mar 2017 09:21:44 +0200
Subject: [PATCH] lib: typo in header
See commit 41740b0d9954a1b9c44755ba61f1d5e7a4c42512
Signed-off-by: Jakub Filak <jakub@thefilaks.net>
---
src/include/libabrt.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/include/libabrt.h b/src/include/libabrt.h
index f71bbd3..ffc0da8 100644
--- a/src/include/libabrt.h
+++ b/src/include/libabrt.h
@@ -127,8 +127,8 @@ wait for the reply
@param message The abrtd reply
@return -errno on error otherwise return value of abrtd
*/
-#define notify_new_path_with_reponse abrt_notify_new_path_with_response
-int notify_new_path_with_reponse(const char *path, char **message);
+#define notify_new_path_with_response abrt_notify_new_path_with_response
+int notify_new_path_with_response(const char *path, char **message);
/* Note: should be public since unit tests need to call it */
#define koops_extract_version abrt_koops_extract_version
--
2.9.4

View File

@ -49,17 +49,22 @@
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 2.9.0
Release: 1%{?dist}
Release: 2%{?dist}
License: GPLv2+
Group: Applications/System
URL: https://abrt.readthedocs.org/
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
# git format-patch %%{Version} --topo-order -N -M;
# i=1; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
# don't remove this patch, packages in rawhide are not signed!
Patch0: disable-OpenGPGCheck-in-Fedora-Rawhide.patch
#Patch0001: 0001-build-fix-generating-list-of-dependences-in-autogen..patch
#Patch0002: 0002-spec-do-not-use-fedorahosted.org-as-source.patch
#Patch0003: 0003-build-do-not-upload-tarball-to-fedorahosted.org.patch
Patch0004: 0004-Fix-Typo.patch
Patch0005: 0005-Spelling-fixes.patch
Patch0006: 0006-lib-typo-in-header.patch
# '%%autosetup -S git' -> git
BuildRequires: git
@ -495,7 +500,8 @@ to the shell
# doesn't allow us to create a new file within a patch, so we have to use
# 'git am' (see /usr/lib/rpm/macros for more details)
#%%define __scm_apply_git(qp:m:) %%{__git} am
%define __scm_apply_git(qp:m:) %{__git} am --exclude doc/design --exclude doc/project/abrt.tex
%define __scm_apply_git(qp:m:) %{__git} am --exclude doc/design --exclude doc/project/abrt.tex --exclude maint/pull-translations --exclude doc/deployment/en-US/Automatic_Bug_Reporting_Tool_ABRT.xml --exclude doc/doxygen.cfg
%autosetup -S git
%build
@ -1089,6 +1095,9 @@ killall abrt-dbus >/dev/null 2>&1 || :
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
%changelog
* Thu Jun 1 2017 Martin Kutlak <mkutlak@redhat.com> 2.9.0-2
- minor fixes
* Fri Sep 09 2016 Jakub Filak <jfilak@redhat.com> 2.9.0-1
- dbus: Problems2 API implementation
- abrtd: change HTTP response code for duplicate problems to 303

View File

@ -1,26 +0,0 @@
From 1ef034096efe367af85f568bc982af969124003b Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Mon, 10 Feb 2014 09:39:07 +0100
Subject: [PATCH] disable OpenGPGCheck in Fedora Rawhide
Packages in Fedora Rawhide are not signed.
---
src/daemon/abrt-action-save-package-data.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/daemon/abrt-action-save-package-data.conf b/src/daemon/abrt-action-save-package-data.conf
index 3d35bb6..e3f724a 100644
--- a/src/daemon/abrt-action-save-package-data.conf
+++ b/src/daemon/abrt-action-save-package-data.conf
@@ -3,7 +3,7 @@
# Product Signing (GPG) Keys:
# https://access.redhat.com/security/team/key
#
-OpenGPGCheck = yes
+OpenGPGCheck = no
# Blacklisted packages
#
--
1.8.3.1