don't allow sending unusable backtrace, versioned libreport deps
This commit is contained in:
parent
97a2ff6878
commit
a4fa2d6195
10
abrt.spec
10
abrt.spec
@ -16,7 +16,7 @@
|
||||
%if "0%{?_buildid}" != "0"
|
||||
%define pkg_release 0.%{?_buildid}%{?dist}
|
||||
%else
|
||||
%define pkg_release 1%{?dist}
|
||||
%define pkg_release 2%{?dist}
|
||||
%endif
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
@ -32,6 +32,7 @@ Source2: abrt-ccpp.init
|
||||
Patch0: remove_libreport_python.patch
|
||||
Patch1: blacklist.patch
|
||||
Patch2: allow_bz_for_koops.patch
|
||||
Patch3: low_bt_rating.patch
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk2-devel
|
||||
BuildRequires: curl-devel
|
||||
@ -61,7 +62,7 @@ Requires: systemd-units
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: libreport
|
||||
Requires: libreport = %{version}-%{release}
|
||||
Requires(pre): shadow-utils
|
||||
Obsoletes: abrt-plugin-sqlite3 > 0.0.1
|
||||
# required for transition from 1.1.13, can be removed after some time
|
||||
@ -268,6 +269,7 @@ generation service over a network using HTTP protocol.
|
||||
%patch0 -p1 -b .libreport_py
|
||||
%patch1 -p1 -b .blacklist
|
||||
%patch2 -p1 -b bz_for_oops
|
||||
%patch3 -p1 -b low_rating
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -592,6 +594,10 @@ fi
|
||||
%{_infodir}/abrt-retrace-server*
|
||||
|
||||
%changelog
|
||||
* Thu Apr 21 2011 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.1-2
|
||||
- don't allow reporting of backtrace with rating = 0 rhbz#672023
|
||||
- use versioned deps on libreport
|
||||
|
||||
* Wed Apr 20 2011 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.1-1
|
||||
- updated to 2.0.1
|
||||
- updated translation
|
||||
|
20
low_bt_rating.patch
Normal file
20
low_bt_rating.patch
Normal file
@ -0,0 +1,20 @@
|
||||
commit 884c0aed054302cb1cbb71c2b21c12df92a7e6e4
|
||||
Author: Karel Klic <kklic@redhat.com>
|
||||
Date: Thu Apr 21 08:59:38 2011 +0200
|
||||
|
||||
Do not allow to submit backtraces with rating 0 (or some other unexpected rating).
|
||||
|
||||
diff --git a/src/gui-wizard-gtk/wizard.c b/src/gui-wizard-gtk/wizard.c
|
||||
index 44dc11b..0a57f04 100644
|
||||
--- a/src/gui-wizard-gtk/wizard.c
|
||||
+++ b/src/gui-wizard-gtk/wizard.c
|
||||
@@ -1005,8 +1005,7 @@ static void check_backtrace_and_allow_send(void) //TODO: rename, this checks rat
|
||||
add_warning(_("The backtrace is incomplete, please make sure you provide the steps to reproduce."));
|
||||
warn = true;
|
||||
break;
|
||||
- case '2':
|
||||
- case '1':
|
||||
+ default:
|
||||
//FIXME: see CreporterAssistant: 394 for ideas
|
||||
add_warning(_("Reporting disabled because the backtrace is unusable."));
|
||||
send = false;
|
Loading…
Reference in New Issue
Block a user