New upstream release 2.1.11
Signed-off-by: Jakub Filak <jfilak@redhat.com>
This commit is contained in:
parent
826fd374c3
commit
995b9a8c20
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.1.8.tar.gz
|
||||
/abrt-2.1.9.tar.gz
|
||||
/abrt-2.1.10.tar.gz
|
||||
/abrt-2.1.11.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff -ur abrt-2.1.1/src/applet/applet.c abrt-2.1.1.new/src/applet/applet.c
|
||||
--- abrt-2.1.1/src/applet/applet.c 2013-02-01 17:05:40.000000000 +0100
|
||||
+++ abrt-2.1.1.new/src/applet/applet.c 2013-03-05 12:16:42.463747490 +0100
|
||||
@@ -89,25 +89,7 @@
|
||||
|
||||
static void ask_start_autoreporting()
|
||||
{
|
||||
- /* The "Yes" response will be saved even if user don't check the
|
||||
- * "Don't ask me again" box.
|
||||
- */
|
||||
- const int ret = run_ask_yes_no_save_result_dialog("AutoreportingEnabled",
|
||||
- _("The report which will be sent does not contain any security sensitive data. "
|
||||
- "Therefore it is not necessary to bother you next time and require any further action by you. "
|
||||
- "\nDo you want to enable automatically submitted anonymous crash reports?"),
|
||||
- /*parent wnd */ NULL);
|
||||
-
|
||||
- /* Don't forget:
|
||||
- *
|
||||
- * The "Yes" response will be saved even if user don't check the
|
||||
- * "Don't ask me again" box.
|
||||
- */
|
||||
- if (ret != 0)
|
||||
- set_user_setting("AutoreportingEnabled", "yes");
|
||||
-
|
||||
- /* must be called immediately, otherwise the data could be lost in case of crash */
|
||||
- save_user_settings();
|
||||
+ return;
|
||||
}
|
||||
|
||||
static bool is_shortened_reporting_enabled()
|
@ -1,31 +0,0 @@
|
||||
From 8004afb7100e94efbca60ad4a08e599d7c2112f4 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Wed, 11 Dec 2013 17:04:52 +0100
|
||||
Subject: [ABRT PATCH] configui: do not use deprecated gtk3 API
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/configuration-gui/system-config-abrt.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/configuration-gui/system-config-abrt.c b/src/configuration-gui/system-config-abrt.c
|
||||
index d5afb43..4638dd6 100644
|
||||
--- a/src/configuration-gui/system-config-abrt.c
|
||||
+++ b/src/configuration-gui/system-config-abrt.c
|
||||
@@ -45,8 +45,13 @@ GtkWidget *system_config_abrt_widget_new(void)
|
||||
GtkWidget *buttons = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, /*spacing*/0);
|
||||
gtk_box_pack_start(GTK_BOX(box), buttons, /*expand*/TRUE, /*fill*/FALSE, /*padding*/0);
|
||||
|
||||
+#if ((GTK_MAJOR_VERSION == 3 && GTK_MINOR_VERSION < 11) || (GTK_MAJOR_VERSION == 3 && GTK_MINOR_VERSION == 11 && GTK_MICRO_VERSION < 2))
|
||||
gtk_widget_set_margin_left(buttons, 10);
|
||||
gtk_widget_set_margin_right(buttons, 10);
|
||||
+#else
|
||||
+ gtk_widget_set_margin_start(buttons, 10);
|
||||
+ gtk_widget_set_margin_end(buttons, 10);
|
||||
+#endif
|
||||
gtk_widget_set_margin_top(buttons, 10);
|
||||
gtk_widget_set_margin_bottom(buttons, 10);
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
13
abrt-2.1.11-fix_0CFLAGS_in_configure.patch
Normal file
13
abrt-2.1.11-fix_0CFLAGS_in_configure.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -ruN abrt-2.1.11/configure abrt-2.1.11.fix/configure
|
||||
--- abrt-2.1.11/configure 2014-01-08 18:46:48.057001105 +0100
|
||||
+++ abrt-2.1.11.fix/configure 2014-01-08 18:46:33.880000782 +0100
|
||||
@@ -17432,7 +17432,8 @@
|
||||
AUTOM4TE=${AUTOM4TE-"${am_missing_run}autom4te"}
|
||||
|
||||
# Needed by tests/atlocal.in.
|
||||
-O0CFLAGS=`echo $CFLAGS | sed 's/-O[0-9] *//' | sed 's/-Werror//'`
|
||||
+# CFLAGS may contain '-Werror=format-security'
|
||||
+O0CFLAGS=`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[^ ]*\)\?//g'`
|
||||
|
||||
|
||||
ac_config_headers="$ac_config_headers config.h"
|
@ -1,17 +0,0 @@
|
||||
diff -ruN abrt-2.1.6.new/src/lib/abrt_conf.c abrt-2.1.6.old/src/lib/abrt_conf.c
|
||||
--- abrt-2.1.6.new/src/lib/abrt_conf.c 2013-07-26 11:20:33.803925230 +0200
|
||||
+++ abrt-2.1.6.old/src/lib/abrt_conf.c 2013-07-26 11:57:24.785656742 +0200
|
||||
@@ -99,9 +99,13 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
+#if 0
|
||||
/* Default: enabled for GNOME desktop, else disabled */
|
||||
const char *desktop_env = getenv("DESKTOP_SESSION");
|
||||
g_settings_shortenedreporting = (desktop_env && strcasestr(desktop_env, "gnome") != NULL);
|
||||
+#else
|
||||
+ g_settings_shortenedreporting = 0;
|
||||
+#endif
|
||||
}
|
||||
|
||||
GHashTableIter iter;
|
@ -1,110 +0,0 @@
|
||||
diff -ur abrt-2.1.1/src/daemon/abrt.conf abrt-2.1.1.new/src/daemon/abrt.conf
|
||||
--- abrt-2.1.1/src/daemon/abrt.conf 2013-02-01 12:59:58.000000000 +0100
|
||||
+++ abrt-2.1.1.new/src/daemon/abrt.conf 2013-03-05 10:01:11.347789231 +0100
|
||||
@@ -28,9 +28,7 @@
|
||||
# In order to run this event automatically after detection, the
|
||||
# AutoreportingEnabled option must be configured to 'yes'
|
||||
#
|
||||
-# Default value: report_uReport
|
||||
-#
|
||||
-AutoreportingEvent = report_uReport
|
||||
+AutoreportingEvent = empty
|
||||
|
||||
# Enables automatic running of the event configured in AutoreportingEvent option.
|
||||
#
|
||||
diff -ur abrt-2.1.1/src/daemon/abrt_event.conf abrt-2.1.1.new/src/daemon/abrt_event.conf
|
||||
--- abrt-2.1.1/src/daemon/abrt_event.conf 2013-02-01 17:05:40.000000000 +0100
|
||||
+++ abrt-2.1.1.new/src/daemon/abrt_event.conf 2013-03-05 10:00:58.406693336 +0100
|
||||
@@ -95,3 +95,7 @@
|
||||
|
||||
EVENT=open-gui
|
||||
report-gtk -x -- "$DUMP_DIR"
|
||||
+
|
||||
+# no operation event, used for AutoreportingEvent to override the default value
|
||||
+EVENT=empty
|
||||
+ exit 0
|
||||
diff -ruN abrt-2.1.6.new/src/plugins/ccpp_event.conf abrt-2.1.6.old/src/plugins/ccpp_event.conf
|
||||
--- abrt-2.1.6.new/src/plugins/ccpp_event.conf 2013-07-26 11:20:33.808925269 +0200
|
||||
+++ abrt-2.1.6.old/src/plugins/ccpp_event.conf 2013-07-26 11:21:37.642419583 +0200
|
||||
@@ -77,14 +77,6 @@
|
||||
-F "/etc/libreport/plugins/$format" \
|
||||
-A "/etc/libreport/plugins/$formatdup"
|
||||
|
||||
-# Send micro report
|
||||
-EVENT=report_uReport analyzer=CCpp
|
||||
- /usr/libexec/abrt-action-ureport
|
||||
-
|
||||
-# update ABRT database after successful report to bugzilla
|
||||
-EVENT=post_report analyzer=CCpp
|
||||
- reporter-ureport -r
|
||||
-
|
||||
EVENT=analyze_CCpp analyzer=CCpp
|
||||
abrt-action-perform-ccpp-analysis
|
||||
|
||||
@@ -93,4 +85,4 @@
|
||||
report-gtk -- "$DUMP_DIR"
|
||||
|
||||
EVENT=report-cli analyzer=CCpp
|
||||
- report-cli -e report_uReport -e analyze_CCpp -e report_Bugzilla -e post_report -- "$DUMP_DIR"
|
||||
+ report-cli -e analyze_LocalGDB -e report_Bugzilla -- "$DUMP_DIR"
|
||||
diff -ruN abrt-2.1.6.new/src/plugins/koops_event.conf abrt-2.1.6.old/src/plugins/koops_event.conf
|
||||
--- abrt-2.1.6.new/src/plugins/koops_event.conf 2013-07-26 11:20:33.810925284 +0200
|
||||
+++ abrt-2.1.6.old/src/plugins/koops_event.conf 2013-07-26 11:22:09.051662800 +0200
|
||||
@@ -20,17 +20,9 @@
|
||||
reporter-bugzilla -b \
|
||||
-F /etc/libreport/plugins/bugzilla_format_kernel.conf
|
||||
|
||||
-# Send micro report
|
||||
-EVENT=report_uReport analyzer=Kerneloops
|
||||
- /usr/libexec/abrt-action-ureport
|
||||
-
|
||||
-# Update ABRT database after successful report to bugzilla
|
||||
-EVENT=post_report analyzer=Kerneloops
|
||||
- reporter-ureport -r
|
||||
-
|
||||
# Automatic/simple GUI-based kernel oopses reporting will do this:
|
||||
EVENT=report-gui analyzer=Kerneloops
|
||||
report-gtk -- "$DUMP_DIR"
|
||||
|
||||
EVENT=report-cli analyzer=Kerneloops
|
||||
- report-cli -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
|
||||
+ report-cli -e report_Bugzilla -- "$DUMP_DIR"
|
||||
diff -ruN abrt-2.1.6.new/src/plugins/python_event.conf abrt-2.1.6.old/src/plugins/python_event.conf
|
||||
--- abrt-2.1.6.new/src/plugins/python_event.conf 2013-07-26 11:20:33.809925276 +0200
|
||||
+++ abrt-2.1.6.old/src/plugins/python_event.conf 2013-07-26 11:22:23.992778495 +0200
|
||||
@@ -15,17 +15,9 @@
|
||||
-c /etc/libreport/plugins/bugzilla.conf
|
||||
# TODO? -F /etc/libreport/plugins/bugzilla_format_python.conf
|
||||
|
||||
-# Send micro report
|
||||
-EVENT=report_uReport analyzer=Python
|
||||
- /usr/libexec/abrt-action-ureport
|
||||
-
|
||||
-# update ABRT database after successful report to bugzilla
|
||||
-EVENT=post_report analyzer=Python
|
||||
- reporter-ureport -r
|
||||
-
|
||||
# Reporting of python exceptions
|
||||
EVENT=report-gui analyzer=Python component!=anaconda
|
||||
report-gtk -- "$DUMP_DIR"
|
||||
|
||||
EVENT=report-cli analyzer=Python component!=anaconda
|
||||
- report-cli -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
|
||||
+ report-cli -e report_Bugzilla -- "$DUMP_DIR"
|
||||
diff -ruN abrt-2.1.6.new/src/plugins/vmcore_event.conf abrt-2.1.6.old/src/plugins/vmcore_event.conf
|
||||
--- abrt-2.1.6.new/src/plugins/vmcore_event.conf 2013-07-26 11:20:33.811925292 +0200
|
||||
+++ abrt-2.1.6.old/src/plugins/vmcore_event.conf 2013-07-26 11:23:36.103336857 +0200
|
||||
@@ -19,12 +19,8 @@
|
||||
reporter-bugzilla -b \
|
||||
-F /etc/libreport/plugins/bugzilla_format_kernel.conf
|
||||
|
||||
-# Send micro report
|
||||
-EVENT=report_uReport analyzer=vmcore
|
||||
- /usr/libexec/abrt-action-ureport
|
||||
-
|
||||
EVENT=report-gui analyzer=vmcore
|
||||
report-gtk -- "$DUMP_DIR"
|
||||
|
||||
EVENT=report-cli analyzer=vmcore
|
||||
- report-cli -e analyze_VMcore -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
|
||||
+ report-cli -e analyze_VMcore -e report_Bugzilla -- "$DUMP_DIR"
|
57
abrt.spec
57
abrt.spec
@ -34,24 +34,21 @@
|
||||
%define docdirversion -%{version}
|
||||
%endif
|
||||
|
||||
%define libreport_ver 2.1.10
|
||||
%define libreport_ver 2.1.11
|
||||
%define satyr_ver 0.13
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.1.10
|
||||
Version: 2.1.11
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
|
||||
# don't remove this patch, packages in rawhide are not signed!
|
||||
Patch1: disable_gpg_check.patch
|
||||
Patch2: abrt-2.1.6.rhel-remove_all_ureport_lines_from_config.patch
|
||||
Patch3: abrt-2.1.6.rhel-dont_enable_shortened_reporting_in_gnome.patch
|
||||
Patch4: abrt-2.1.1-disable_autoreporting_dialog.patch
|
||||
Patch0: disable_gpg_check.patch
|
||||
|
||||
# remove with abrt > 2.1.10
|
||||
Patch5: abrt-2.1.10-gtk3_deprecated_API.patch
|
||||
Patch1: abrt-2.1.11-fix_0CFLAGS_in_configure.patch
|
||||
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk3-devel
|
||||
@ -69,12 +66,12 @@ BuildRequires: asciidoc
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: xmlto
|
||||
BuildRequires: libreport-devel >= %{libreport_ver}
|
||||
BuildRequires: satyr-devel >= 0.12
|
||||
BuildRequires: satyr-devel >= %{satyr_ver}
|
||||
BuildRequires: systemd-python
|
||||
BuildRequires: augeas
|
||||
|
||||
Requires: libreport >= %{libreport_ver}
|
||||
Requires: satyr >= 0.12
|
||||
Requires: satyr >= %{satyr_ver}
|
||||
|
||||
%if %{with systemd}
|
||||
Requires: systemd-units
|
||||
@ -209,6 +206,7 @@ Requires: abrt-addon-kerneloops
|
||||
Requires: crash
|
||||
Requires: kexec-tools
|
||||
Requires: abrt-python
|
||||
Requires: python-augeas
|
||||
|
||||
%description addon-vmcore
|
||||
This package contains plugin for collecting kernel crash information from
|
||||
@ -371,18 +369,11 @@ to the shell
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#RHEL
|
||||
%if 0%{?rhel} >= 7
|
||||
%patch2 -p1 -b .ureport
|
||||
%patch3 -p1 -b .shoretened
|
||||
%patch4 -p1 -b .autoreporting
|
||||
%endif
|
||||
#Fedora
|
||||
%patch1 -p1 -b .gpgcheck
|
||||
%patch5 -p1 -b .gtk3
|
||||
%patch0 -p1 -b .gpgcheck
|
||||
%patch1 -p1 -b .unittests
|
||||
|
||||
%build
|
||||
autoconf
|
||||
#autoconf
|
||||
CFLAGS="%{optflags} -Werror" %configure --enable-doxygen-docs --disable-silent-rules
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -562,6 +553,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
%{_sbindir}/abrtd
|
||||
%{_sbindir}/abrt-server
|
||||
%{_sbindir}/abrt-auto-reporting
|
||||
%{_libexecdir}/abrt-handle-event
|
||||
%{_libexecdir}/abrt-action-ureport
|
||||
%{_bindir}/abrt-handle-upload
|
||||
@ -601,6 +593,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_mandir}/man1/abrt-action-save-package-data.1.gz
|
||||
%{_mandir}/man1/abrt-watch-log.1.gz
|
||||
%{_mandir}/man1/abrt-action-analyze-xorg.1.gz
|
||||
%{_mandir}/man1/abrt-auto-reporting.1.gz
|
||||
%{_mandir}/man8/abrtd.8.gz
|
||||
%{_mandir}/man5/abrt.conf.5.gz
|
||||
%{_mandir}/man5/abrt-action-save-package-data.conf.5.gz
|
||||
@ -810,10 +803,19 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%files dbus
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/abrt-dbus
|
||||
%{_sbindir}/abrt-configuration
|
||||
%{_mandir}/man8/abrt-dbus.8.gz
|
||||
%{_mandir}/man8/abrt-configuration.8.gz
|
||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-abrt.conf
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.abrt.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ccpp.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.python.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.vmcore.xml
|
||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.xorg.xml
|
||||
%{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
|
||||
%{_datadir}/dbus-1/system-services/com.redhat.problems.configuration.service
|
||||
%{_datadir}/polkit-1/actions/abrt_polkit.policy
|
||||
%dir %{_defaultdocdir}/%{name}-dbus%{docdirversion}/
|
||||
%dir %{_defaultdocdir}/%{name}-dbus%{docdirversion}/html/
|
||||
@ -831,6 +833,19 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Wed Jan 08 2014 Jakub Filak <jfilak@redhat.com> 2.1.11-1
|
||||
- Update translations
|
||||
- harvest_vmcore: replace regexp config parsing with augeas
|
||||
- introduce D-Bus Configuration Service
|
||||
- mark koopses with unsupporeted HW as not-reportable
|
||||
- bodhi: use the right exit codes
|
||||
- abrt-handle-event: don't use already freed memory
|
||||
- introduce abrt-auto-reporting utility
|
||||
- abrt-action-notify: fix couple of flaws
|
||||
- Use satyr to compute koops duphash
|
||||
- koops: tweak koops parser for s390 Call Traces
|
||||
- configui: do not use deprecated gtk3 API
|
||||
|
||||
* Wed Dec 11 2013 Jakub Filak <jfilak@redhat.com> 2.1.10-1
|
||||
- abrt-cli: display URL to reports in the details
|
||||
- abrt-cli list: list all problems by default
|
||||
@ -1147,7 +1162,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
* Tue Mar 05 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-2
|
||||
- remove ureport events from the reporting workflow in RHEL
|
||||
|
||||
* Fri Feb 04 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-1
|
||||
* Fri Feb 08 2013 Jakub Filak <jfilak@redhat.com> 2.1.1-1
|
||||
- add SETGID bit to abrt-action-install-debuginfo-to-abrt-cache
|
||||
- add abrt-desktop depency on libreport-fedora
|
||||
- abrt-dump-{oops,xorg}: limit amount of created dirs, add cooldown sleep if exceeded
|
||||
|
Loading…
Reference in New Issue
Block a user