new version 2.0.6

This commit is contained in:
Jiri Moskovcak 2011-11-05 11:23:46 +01:00
parent 95a610dee1
commit 95a6bec8cd
5 changed files with 78 additions and 66 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@ abrt-1.1.13.tar.gz
/abrt-2.0.2.tar.gz
/abrt-2.0.3.tar.gz
/abrt-2.0.4.tar.gz
/abrt-2.0.6.tar.gz

119
abrt.spec
View File

@ -15,20 +15,16 @@
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 2.0.4.981
Release: 3%{?dist}
Version: 2.0.6
Release: 1%{?dist}
License: GPLv2+
Group: Applications/System
URL: https://fedorahosted.org/abrt/
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
Source1: abrt.init
Source2: abrt-ccpp.init
Source3: abrt-oops.init
Source4: abrt-vmcore.init
Source5: abrt1_to_abrt2
Source1: abrt1_to_abrt2
Patch0: blacklist.patch
Patch1: 0001-rhbz-724838-don-t-file-kernel-bugs-if-tainted-B-is-s.patch
Patch2: 0002-rhbz-718097-don-t-file-bugs-about-BIOS-bugs.patch
Patch1: abrt_disable_gpgcheck.diff
Patch2: 0002-gtk3-build-fixes.patch
BuildRequires: dbus-devel
BuildRequires: gtk2-devel
BuildRequires: rpm-devel >= 4.6
@ -43,16 +39,9 @@ BuildRequires: libtool
BuildRequires: nss-devel
BuildRequires: asciidoc
BuildRequires: xmlto
BuildRequires: libreport-devel >= 2.0.5-2
BuildRequires: libreport-devel > 2.0.6
BuildRequires: btparser-devel
# for rhel6
%if 0%{?rhel} >= 6
BuildRequires: gnome-keyring-devel
%else
BuildRequires: libgnome-keyring-devel
%endif
%if %{with systemd}
Requires: systemd-units
%endif
@ -112,12 +101,12 @@ analyzer plugin.
Summary: %{name}'s retrace client
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: xz
%description retrace-client
This package contains the client application for Retrace server
which is able to analyze C/C++ crashes remotely.
%package addon-kerneloops
Summary: %{name}'s kerneloops addon
Group: System Environment/Libraries
@ -128,19 +117,18 @@ Obsoletes: kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloopsreporter > 0.0.1
%description addon-kerneloops
This package contains plugin for collecting kernel crash information.
%package addon-vmcore
Summary: %{name}'s vmcore addon
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: abrt-addon-kerneloops
%description addon-kerneloops
This package contains plugin for collecting kernel crash information from system log.
%description addon-vmcore
This package contains plugin for collecting kernel crash information from vmcore files.
%package addon-python
Summary: %{name}'s addon for catching and analyzing Python exceptions
Group: System Environment/Libraries
@ -195,12 +183,15 @@ Virtual package to make easy default installation on desktop environments.
%setup -q
# Fedora specific
%patch0 -p1 -b .blacklist
# general fixes
%patch1 -p1
%patch2 -p1
# general
%patch1 -p1 -b .gpg
%patch2 -p1 -b .gtk3
%build
mkdir -p m4
test -r m4/aclocal.m4 || touch m4/aclocal.m4
autoconf
automake
%configure
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
@ -214,14 +205,8 @@ make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
# remove all .la and .a files
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
install -m 755 %SOURCE1 ${RPM_BUILD_ROOT}/%{_libexecdir}/abrt1-to-abrt2
mkdir -p ${RPM_BUILD_ROOT}/%{_initrddir}
%if ! %{with systemd}
install -m 755 %SOURCE1 ${RPM_BUILD_ROOT}/%{_initrddir}/abrtd
install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}/%{_initrddir}/abrt-ccpp
install -m 755 %SOURCE3 ${RPM_BUILD_ROOT}/%{_initrddir}/abrt-oops
install -m 755 %SOURCE4 ${RPM_BUILD_ROOT}/%{_initrddir}/abrt-vmcore
%endif
install -m 755 %SOURCE5 ${RPM_BUILD_ROOT}/%{_libexecdir}/abrt1-to-abrt2
mkdir -p $RPM_BUILD_ROOT/var/cache/abrt-di
mkdir -p $RPM_BUILD_ROOT/var/run/abrt
mkdir -p $RPM_BUILD_ROOT/var/spool/abrt
@ -254,9 +239,11 @@ getent passwd abrt >/dev/null || useradd --system -g abrt -u %{abrt_gid_uid} -d
exit 0
%post
## [ $1 -eq 1 ] install section
if [ $1 -eq 1 ]; then
%if %{with systemd}
# Enable (but don't start) the units by default
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl enable abrtd.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrtd
@ -269,9 +256,11 @@ fi
# because /cache/abrt-di/* was created under root with root:root
# so 2.x fails when it tries to extract debuginfo there..
chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
## [ $1 -eq 1 ] install section
if [ $1 -eq 1 ]; then
%if %{with systemd}
# Enable (but don't start) the units by default
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl enable abrt-ccpp.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrt-ccpp
@ -282,18 +271,26 @@ fi
# that abrtd service is enabled and thus enable the new abrt-ccpp
# service. If abrtd is running on the system, run abrt-ccpp service
# as well, because what was a part of abrtd became a separate service.
if [ $1 -gt 1 ]; then # Is this an upgrade?
/sbin/chkconfig --add abrt-ccpp
/sbin/pidof abrtd >/dev/null 2>&1
if [ $? -eq 0 ]; then # Is abrtd running?
service abrt-ccpp restart >/dev/null 2>&1 || :
fi
## [ $1 -gt 1 ] upgrade section
if [ $1 -gt 1 ]; then
%if %{with systemd}
/bin/systemctl restart abrt-ccpp.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrt-ccpp > /dev/null 2>&1 || :
/sbin/pidof abrtd >/dev/null 2>&1
if [ $? -eq 0 ]; then # Is abrtd running?
service abrt-ccpp restart >/dev/null 2>&1 || :
fi
%endif
fi
%post addon-kerneloops
## [ $1 -eq 1 ] install section
if [ $1 -eq 1 ]; then
%if %{with systemd}
# Enable (but don't start) the units by default
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl enable abrt-oops.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrt-oops
@ -304,25 +301,31 @@ fi
# that abrtd service is enabled and thus enable the new abrt-oops
# service. If abrtd is running on the system, run abrt-ccpp service
# as well, because what was a part of abrtd became a separate service.
if [ $1 -gt 1 ]; then # Is this an upgrade?
/sbin/chkconfig --add abrt-oops
/sbin/pidof abrtd >/dev/null 2>&1
if [ $? -eq 0 ]; then # Is abrtd running?
service abrt-oops restart >/dev/null 2>&1 || :
fi
## [ $1 -gt 1 ] upgrade section
if [ $1 -gt 1 ]; then
%if %{with systemd}
/bin/systemctl try-restart abrt-oops.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrt-oops > /dev/null 2>&1 || :
/sbin/pidof abrtd >/dev/null 2>&1
if [ $? -eq 0 ]; then # Is abrtd running?
service abrt-oops restart >/dev/null 2>&1 || :
fi
%endif
fi
%post addon-vmcore
if [ $1 -eq 1 ]; then
%if %{with systemd}
# Enable (but don't start) the units by default
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl enable abrt-vmcore.service >/dev/null 2>&1 || :
%else
/sbin/chkconfig --add abrt-vmcore
%endif
fi
%preun
if [ "$1" -eq "0" ] ; then
%if %{with systemd}
@ -369,16 +372,16 @@ fi
%if %{with systemd}
%postun
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl try-reload abrtd.service >/dev/null 2>&1 || :
%postun addon-kerneloops
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl try-reload abrt-oops.service >/dev/null 2>&1 || :
%postun addon-vmcore
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl try-reload abrt-vmcore.service >/dev/null 2>&1 || :
%postun addon-ccpp
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
/bin/systemctl try-reload abrt-ccpp.service >/dev/null 2>&1 || :
%endif
@ -433,6 +436,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%config(noreplace) %{_sysconfdir}/libreport/events.d/smolt_event.conf
%dir %attr(0755, abrt, abrt) %{_localstatedir}/spool/%{name}
%dir %attr(0700, abrt, abrt) %{_localstatedir}/spool/%{name}-upload
# abrtd runs as root
%dir %attr(0755, root, root) %{_localstatedir}/run/%{name}
%ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
%ghost %attr(0644, -, -) %{_localstatedir}/run/abrtd.pid
@ -447,7 +451,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man5/abrt.conf.5.gz
%{_mandir}/man5/abrt-action-save-package-data.conf.5.gz
# {_mandir}/man5/pyhook.conf.5.gz
%{_mandir}/man1/abrt-retrace-client.1.gz
%{_datadir}/dbus-1/system-services/com.redhat.abrt.service
%{_libexecdir}/abrt1-to-abrt2
@ -503,12 +506,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_sysconfdir}/libreport/events/collect_GConf.xml
%{_sysconfdir}/libreport/events/collect_vimrc_user.xml
%{_sysconfdir}/libreport/events/collect_vimrc_system.xml
%{_mandir}/man*/abrt-action-analyze-c.*
%{_mandir}/man*/abrt-action-trim-files.*
%{_mandir}/man*/abrt-action-generate-backtrace.*
%{_mandir}/man*/abrt-action-analyze-backtrace.*
%{_mandir}/man*/abrt-action-list-dsos.*
%{_mandir}/man1/abrt-install-ccpp-hook.1.gz
%{_mandir}/man1/abrt-action-analyze-c.1.gz
%files retrace-client
%{_bindir}/abrt-retrace-client
@ -540,10 +543,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_sbindir}/abrt-harvest-vmcore
%{_bindir}/abrt-action-analyze-vmcore
%files addon-python
%defattr(-,root,root,-)
#%config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
%config(noreplace) %{_sysconfdir}/%{name}/plugins/python.conf
%{_sysconfdir}/libreport/events.d/python_event.conf
%{_bindir}/abrt-action-analyze-python
%{_mandir}/man1/abrt-action-analyze-python.1*
@ -560,6 +562,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%defattr(-,root,root,-)
%changelog
* Fri Nov 04 2011 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.6-1
- new version
- moved to gtk3
- Resolves: #701171 #712508 #726033 #728194 #728314 #730107 #733389 #738602
- Resolves: #741242 #749365 #700252 #734298 #736016 #738324 #748457 #692274
- Resolves: #711986 #723219 #749891 #712602 #744887 #749603 #625445 #665210
- Resolves: #737991 #639068 #578969 #636000 #631856
* Fri Oct 07 2011 Nikola Pajkovsky <npajkovs@redhat.com> - 2.0.4.981-3
- don't file kernel bugs if "tainted: B" is set.
- don't file bugs about BIOS bugs.
@ -583,9 +593,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- [RFE] abrt should have an easy way to include smolt-profile
- Resolves: #694828 #694833 #704958 #735071 #731189 #739182 #704452 #734037 #606123 #631822
* Thu Sep 22 2011 Jiri Moskovcak <jmoskovc@redhat.com> - 2.0.4.980-1
- new upstream release
* Tue Sep 13 2011 Jiri Moskovcak <jmoskovc@redhat.com> - 2.0.4-5
- minor spec file fix

View File

@ -1,6 +1,6 @@
--- abrt-1.1.10/src/Daemon/abrt.conf 2010-06-30 15:08:48.000000000 +0200
+++ abrt-1.1.10_/src/Daemon/abrt.conf 2010-07-26 13:59:27.484253074 +0200
@@ -4,7 +4,7 @@
--- abrt-2.0.6/src/daemon/abrt-action-save-package-data.conf 2011-11-04 13:03:43.271953835 +0100
+++ abrt-2.0.6_/src/daemon/abrt-action-save-package-data.conf 2011-11-04 13:03:36.661746556 +0100
@@ -3,7 +3,7 @@
# the list of public keys used to check the signature is
# in the file gpg_keys
#

View File

@ -1,7 +1,11 @@
--- abrt-2.0.1/src/plugins/koops_events.conf 2011-03-30 21:10:14.000000000 +0200
+++ abrt-2.0.1_/src/plugins/koops_events.conf 2011-04-20 14:43:46.460859863 +0200
@@ -9,3 +9,4 @@
--- abrt-2.0.6/src/daemon/abrt-action-save-package-data.conf 2011-11-04 13:03:43.271953835 +0100
+++ abrt-2.0.6_/src/daemon/abrt-action-save-package-data.conf 2011-11-04 13:03:36.661746556 +0100
@@ -3,7 +3,7 @@
# the list of public keys used to check the signature is
# in the file gpg_keys
#
-OpenGPGCheck = yes
+OpenGPGCheck = no
# report
EVENT=report_Kerneloops analyzer=Kerneloops abrt-action-kerneloops
+EVENT=report_Bugzilla analyzer=Kerneloops abrt-action-bugzilla
# Blacklisted packages
#

View File

@ -1 +1 @@
64fea3ba4fc382a73a387e0d31a9bc15 abrt-2.0.4.981.tar.gz
a44d60efdf2173417e334b5547a2441f abrt-2.0.6.tar.gz