New version 2.10.5
Signed-off-by: Julius Milan <jmilan@redhat.com>
This commit is contained in:
parent
a074333d28
commit
85802ca9d7
1
.gitignore
vendored
1
.gitignore
vendored
@ -56,3 +56,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.10.2.tar.gz
|
||||
/abrt-2.10.3.tar.gz
|
||||
/abrt-2.10.4.tar.gz
|
||||
/abrt-2.10.5.tar.gz
|
||||
|
@ -1,70 +0,0 @@
|
||||
From c9915e40c85d91d7434557419a5f9fde160e1e07 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 30 Aug 2017 11:16:15 +0200
|
||||
Subject: [PATCH] logging: rename omitted log() to log_warning()
|
||||
|
||||
Some of the log() functions were omitted in commit f33b8731efedd7382e4f11d83e618a06d92a23ab.
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/daemon/abrt-handle-upload.in | 2 +-
|
||||
src/plugins/abrt-action-find-bodhi-update | 2 +-
|
||||
src/plugins/abrt-action-install-debuginfo.in | 2 +-
|
||||
src/plugins/abrt-action-ureport | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/daemon/abrt-handle-upload.in b/src/daemon/abrt-handle-upload.in
|
||||
index f31d3a1..469c2ae 100755
|
||||
--- a/src/daemon/abrt-handle-upload.in
|
||||
+++ b/src/daemon/abrt-handle-upload.in
|
||||
@@ -12,7 +12,7 @@ import shutil
|
||||
import datetime
|
||||
import grp
|
||||
|
||||
-from reportclient import set_verbosity, error_msg_and_die, error_msg, log
|
||||
+from reportclient import set_verbosity, error_msg_and_die, error_msg, log_warning
|
||||
|
||||
GETTEXT_PROGNAME = "abrt"
|
||||
import locale
|
||||
diff --git a/src/plugins/abrt-action-find-bodhi-update b/src/plugins/abrt-action-find-bodhi-update
|
||||
index 3bb96fc..0cae6cc 100755
|
||||
--- a/src/plugins/abrt-action-find-bodhi-update
|
||||
+++ b/src/plugins/abrt-action-find-bodhi-update
|
||||
@@ -40,7 +40,7 @@ import sys
|
||||
from argparse import ArgumentParser
|
||||
from subprocess import Popen, PIPE
|
||||
|
||||
-from reportclient import (_, log, log1, set_verbosity, verbose, RETURN_OK,
|
||||
+from reportclient import (_, log_warning, log1, set_verbosity, verbose, RETURN_OK,
|
||||
RETURN_FAILURE, error_msg)
|
||||
import report
|
||||
|
||||
diff --git a/src/plugins/abrt-action-install-debuginfo.in b/src/plugins/abrt-action-install-debuginfo.in
|
||||
index f2abf43..6269c22 100644
|
||||
--- a/src/plugins/abrt-action-install-debuginfo.in
|
||||
+++ b/src/plugins/abrt-action-install-debuginfo.in
|
||||
@@ -11,7 +11,7 @@ import errno
|
||||
import getopt
|
||||
import reportclient
|
||||
from subprocess import Popen, PIPE
|
||||
-from reportclient import verbose, log, log1, log2, set_verbosity, error_msg_and_die, error_msg
|
||||
+from reportclient import verbose, log_warning, log1, log2, set_verbosity, error_msg_and_die, error_msg
|
||||
import time
|
||||
from reportclient.debuginfo import DebugInfoDownload, filter_installed_debuginfos, build_ids_to_path, clean_up
|
||||
import problem
|
||||
diff --git a/src/plugins/abrt-action-ureport b/src/plugins/abrt-action-ureport
|
||||
index a7484c8..089eeb0 100755
|
||||
--- a/src/plugins/abrt-action-ureport
|
||||
+++ b/src/plugins/abrt-action-ureport
|
||||
@@ -11,7 +11,7 @@ import getopt
|
||||
import augeas
|
||||
|
||||
from report import dd_opendir, DD_FAIL_QUIETLY_ENOENT, run_event_on_problem_dir
|
||||
-from reportclient import set_verbosity, error_msg_and_die, error_msg, log1, log
|
||||
+from reportclient import set_verbosity, error_msg_and_die, error_msg, log1, log_warning
|
||||
|
||||
GETTEXT_PROGNAME = "abrt"
|
||||
import locale
|
||||
--
|
||||
2.9.5
|
||||
|
27
abrt.spec
27
abrt.spec
@ -54,13 +54,13 @@
|
||||
%define docdirversion -%{version}
|
||||
%endif
|
||||
|
||||
%define libreport_ver 2.9.2
|
||||
%define satyr_ver 0.22
|
||||
%define libreport_ver 2.9.3
|
||||
%define satyr_ver 0.24
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.10.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.10.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://abrt.readthedocs.org/
|
||||
@ -69,8 +69,6 @@ Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.ta
|
||||
# git format-patch %%{Version} --topo-order -N -M;
|
||||
# i=1; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
|
||||
|
||||
Patch1: 0001-logging-rename-omitted-log-to-log_warning.patch
|
||||
|
||||
# '%%autosetup -S git' -> git
|
||||
BuildRequires: git
|
||||
|
||||
@ -465,7 +463,7 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-dbus = %{version}-%{release}
|
||||
Requires: dbus-python
|
||||
Requires: libreport-python
|
||||
Requires: python-gobject
|
||||
Requires: python2-gobject-base
|
||||
%{?python_provide:%python_provide python2-abrt}
|
||||
# Remove before F30
|
||||
Provides: %{name}-python = %{version}-%{release}
|
||||
@ -501,12 +499,12 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-dbus = %{version}-%{release}
|
||||
Requires: python3-dbus
|
||||
Requires: libreport-python3
|
||||
Requires: python3-gobject
|
||||
%{?python_provide:%python_provide python3-abrt}
|
||||
# Remove before F30
|
||||
Provides: %{name}-python3 = %{version}-%{release}
|
||||
Provides: %{name}-python3%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: %{name}-python3 < %{version}-%{release}
|
||||
Requires: python3-gobject-base
|
||||
BuildRequires: python3-nose
|
||||
BuildRequires: python3-sphinx
|
||||
BuildRequires: libreport-python3
|
||||
@ -1168,6 +1166,19 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Thu Nov 02 2017 Julius Milan <jmilan@redhat.com> 2.10.5-1
|
||||
- Translation updates
|
||||
- a-action-ureport: add option 'ProcessUnpackaged'
|
||||
- spec: change dependency on python{2,3}-gobject
|
||||
- applet: Additional changes to allow optional polkit
|
||||
- doc: remove obsolete doxygen tags
|
||||
- dbus: Additional changes to allow optional polkit
|
||||
- cli-ng: Explicitly state python version in shebangs
|
||||
- spec: rename python binary packages
|
||||
- a-d-journal-core: Save mountinfo from journal
|
||||
- a-d-journal-core: Save container cmdline
|
||||
- logging: rename omitted log() to log_warning()
|
||||
|
||||
* Wed Sep 27 2017 Martin Kutlak <mkutlak@redhat.com> 2.10.4-3
|
||||
- Drop GPG check patch for unsigned packages
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (abrt-2.10.4.tar.gz) = f87fa0592867ef9c8543f066ffd9a0595941c14b4b0420746ebd7ca9e1335d45f0323d2e299778171031f0537e0e8da3dcfd33e3e6adae1cd76e33af7b131504
|
||||
SHA512 (abrt-2.10.5.tar.gz) = 6e334b045efa18f8200447eb142f54d4f68b39d5a470c30b7272778a3ab22c1b55c222fae8657d86e6c78dfd3070f3ddb68f25ee6ca5ca0be4c5463239cbf0ef
|
||||
|
Loading…
Reference in New Issue
Block a user