New upstream release 2.1.6

This commit is contained in:
Jakub Filak 2013-07-26 11:06:00 +02:00
parent 9797cde4eb
commit 7352dcc0f8
7 changed files with 174 additions and 187 deletions

1
.gitignore vendored
View File

@ -27,3 +27,4 @@ abrt-1.1.13.tar.gz
/abrt-2.1.3.tar.gz
/abrt-2.1.4.tar.gz
/abrt-2.1.5.tar.gz
/abrt-2.1.6.tar.gz

View File

@ -1,82 +0,0 @@
From f07ea08ac4fc96162f7b583dc9a14183f1dcec69 Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Tue, 16 Jul 2013 11:35:35 +0200
Subject: [ABRT PATCH 35/36] retrace-client: build correct release for Fedora
Rawhide
Related to rhbz#958933
Signed-off-by: Jakub Filak <jfilak@redhat.com>
Signed-off-by: Michal Toman <mtoman@redhat.com>
---
src/plugins/abrt-retrace-client.c | 51 ++++++++++++++++++++++++++-------------
1 file changed, 34 insertions(+), 17 deletions(-)
diff --git a/src/plugins/abrt-retrace-client.c b/src/plugins/abrt-retrace-client.c
index e5f95a9..9c2c551 100644
--- a/src/plugins/abrt-retrace-client.c
+++ b/src/plugins/abrt-retrace-client.c
@@ -324,26 +324,43 @@ static char *get_release_id(map_string_t *osinfo, const char *architecture)
}
char *result = NULL;
- const char *release = get_map_string_item_or_NULL(osinfo, OSINFO_ID);
- const char *version = get_map_string_item_or_NULL(osinfo, OSINFO_VERSION_ID);
- if (release != NULL && version != NULL)
- result = xasprintf("%s-%s-%s", release, version, arch);
- else
+ char *release = NULL;
+ char *version = NULL;
+ parse_osinfo_for_rhts(osinfo, (char **)&release, (char **)&version);
+
+ if (release == NULL || version == NULL)
+ error_msg_and_die("Can't parse OS release name or version");
+
+ char *space = strchr(version, ' ');
+ if (space)
+ *space = '\0';
+
+ if (strcmp("Fedora", release) == 0)
{
- parse_osinfo_for_rhts(osinfo, (char **)&release, (char **)&version);
- char *space = strchr(version, ' ');
- if (space)
- *space = '\0';
-
- if (strcmp("Fedora", release) == 0)
- result = xasprintf("fedora-%s-%s", version, arch);
- else if (strcmp("Red Hat Enterprise Linux", release) == 0)
- result = xasprintf("rhel-%s-%s", version, arch);
-
- free((void *)release);
- free((void *)version);
+ /* Because of inconsistency between Fedora's os-release and retrace
+ * server.
+ *
+ * Adding the reporting fields to Fedora's os-release was a bit
+ * frustrating for all participants and fixing it on the retrace server
+ * side is neither feasible nor acceptable.
+ *
+ * Therefore, we have decided to add the following hack.
+ */
+ if (strcmp("Rawhide", version) == 0)
+ {
+ /* Rawhide -> rawhide */
+ version[0] = 'r';
+ }
+ /* Fedora -> fedora */
+ release[0] = 'f';
}
+ else if (strcmp("Red Hat Enterprise Linux", release) == 0)
+ strcpy(release, "rhel");
+
+ result = xasprintf("%s-%s-%s", release, version, arch);
+ free(release);
+ free(version);
free(arch);
return result;
}
--
1.8.3.1

View File

@ -1,14 +0,0 @@
diff -ur abrt-2.1.1/src/applet/applet.c abrt-2.1.1.new/src/applet/applet.c
--- abrt-2.1.1/src/applet/applet.c 2013-02-01 17:05:40.000000000 +0100
+++ abrt-2.1.1.new/src/applet/applet.c 2013-03-05 12:04:38.840227170 +0100
@@ -117,9 +117,7 @@
if (configured)
return string_to_bool(configured);
- /* Default: enabled for GNOME desktop, else disabled */
- const char *desktop_env = getenv("DESKTOP_SESSION");
- return (desktop_env && strcasestr(desktop_env, "gnome") != NULL);
+ return false;
}
/*

View File

@ -0,0 +1,17 @@
diff -ruN abrt-2.1.6.new/src/lib/abrt_conf.c abrt-2.1.6.old/src/lib/abrt_conf.c
--- abrt-2.1.6.new/src/lib/abrt_conf.c 2013-07-26 11:20:33.803925230 +0200
+++ abrt-2.1.6.old/src/lib/abrt_conf.c 2013-07-26 11:57:24.785656742 +0200
@@ -99,9 +99,13 @@
}
else
{
+#if 0
/* Default: enabled for GNOME desktop, else disabled */
const char *desktop_env = getenv("DESKTOP_SESSION");
g_settings_shortenedreporting = (desktop_env && strcasestr(desktop_env, "gnome") != NULL);
+#else
+ g_settings_shortenedreporting = 0;
+#endif
}
GHashTableIter iter;

View File

@ -1,6 +1,6 @@
diff -ur abrt-2.1.1/src/daemon/abrt.conf abrt-2.1.1.new/src/daemon/abrt.conf
--- abrt-2.1.1/src/daemon/abrt.conf 2013-02-01 12:59:58.000000000 +0100
+++ abrt-2.1.1.new/src/daemon/abrt.conf 2013-03-05 10:01:11.347789231 +0100
--- abrt-2.1.1/src/daemon/abrt.conf 2013-02-01 12:59:58.000000000 +0100
+++ abrt-2.1.1.new/src/daemon/abrt.conf 2013-03-05 10:01:11.347789231 +0100
@@ -28,9 +28,7 @@
# In order to run this event automatically after detection, the
# AutoreportingEnabled option must be configured to 'yes'
@ -13,8 +13,8 @@ diff -ur abrt-2.1.1/src/daemon/abrt.conf abrt-2.1.1.new/src/daemon/abrt.conf
# Enables automatic running of the event configured in AutoreportingEvent option.
#
diff -ur abrt-2.1.1/src/daemon/abrt_event.conf abrt-2.1.1.new/src/daemon/abrt_event.conf
--- abrt-2.1.1/src/daemon/abrt_event.conf 2013-02-01 17:05:40.000000000 +0100
+++ abrt-2.1.1.new/src/daemon/abrt_event.conf 2013-03-05 10:00:58.406693336 +0100
--- abrt-2.1.1/src/daemon/abrt_event.conf 2013-02-01 17:05:40.000000000 +0100
+++ abrt-2.1.1.new/src/daemon/abrt_event.conf 2013-03-05 10:00:58.406693336 +0100
@@ -95,3 +95,7 @@
EVENT=open-gui
@ -23,10 +23,10 @@ diff -ur abrt-2.1.1/src/daemon/abrt_event.conf abrt-2.1.1.new/src/daemon/abrt_ev
+# no operation event, used for AutoreportingEvent to override the default value
+EVENT=empty
+ exit 0
diff -ur abrt-2.1.1/src/plugins/ccpp_event.conf abrt-2.1.1.new/src/plugins/ccpp_event.conf
--- abrt-2.1.1/src/plugins/ccpp_event.conf 2013-02-07 08:42:58.000000000 +0100
+++ abrt-2.1.1.new/src/plugins/ccpp_event.conf 2013-03-05 09:56:40.607779146 +0100
@@ -80,20 +80,12 @@
diff -ruN abrt-2.1.6.new/src/plugins/ccpp_event.conf abrt-2.1.6.old/src/plugins/ccpp_event.conf
--- abrt-2.1.6.new/src/plugins/ccpp_event.conf 2013-07-26 11:20:33.808925269 +0200
+++ abrt-2.1.6.old/src/plugins/ccpp_event.conf 2013-07-26 11:21:37.642419583 +0200
@@ -77,14 +77,6 @@
-F "/etc/libreport/plugins/$format" \
-A "/etc/libreport/plugins/$formatdup"
@ -41,18 +41,16 @@ diff -ur abrt-2.1.1/src/plugins/ccpp_event.conf abrt-2.1.1.new/src/plugins/ccpp_
EVENT=analyze_CCpp analyzer=CCpp
abrt-action-perform-ccpp-analysis
# Reporting of C/Cpp problems
EVENT=report-gui analyzer=CCpp
- report-gtk -e report_uReport -e analyze_CCpp -e "collect_*" -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-gtk -e analyze_CCpp -e "collect_*" -e report_Bugzilla -- "$DUMP_DIR"
@@ -93,4 +85,4 @@
report-gtk -- "$DUMP_DIR"
EVENT=report-cli analyzer=CCpp
- report-cli -e report_uReport -e analyze_CCpp -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-cli -e analyze_CCpp -e report_Bugzilla -- "$DUMP_DIR"
diff -ur abrt-2.1.1/src/plugins/koops_event.conf abrt-2.1.1.new/src/plugins/koops_event.conf
--- abrt-2.1.1/src/plugins/koops_event.conf 2013-02-01 17:05:40.000000000 +0100
+++ abrt-2.1.1.new/src/plugins/koops_event.conf 2013-03-05 09:57:50.824301289 +0100
@@ -21,17 +21,9 @@
+ report-cli -e analyze_LocalGDB -e report_Bugzilla -- "$DUMP_DIR"
diff -ruN abrt-2.1.6.new/src/plugins/koops_event.conf abrt-2.1.6.old/src/plugins/koops_event.conf
--- abrt-2.1.6.new/src/plugins/koops_event.conf 2013-07-26 11:20:33.810925284 +0200
+++ abrt-2.1.6.old/src/plugins/koops_event.conf 2013-07-26 11:22:09.051662800 +0200
@@ -20,17 +20,9 @@
reporter-bugzilla -b \
-F /etc/libreport/plugins/bugzilla_format_kernel.conf
@ -66,16 +64,15 @@ diff -ur abrt-2.1.1/src/plugins/koops_event.conf abrt-2.1.1.new/src/plugins/koop
-
# Automatic/simple GUI-based kernel oopses reporting will do this:
EVENT=report-gui analyzer=Kerneloops
- report-gtk -e report_uReport -e "collect_*" -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-gtk -e "collect_*" -e report_Bugzilla -- "$DUMP_DIR"
report-gtk -- "$DUMP_DIR"
EVENT=report-cli analyzer=Kerneloops
- report-cli -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-cli -e report_Bugzilla -- "$DUMP_DIR"
diff -ur abrt-2.1.1/src/plugins/python_event.conf abrt-2.1.1.new/src/plugins/python_event.conf
--- abrt-2.1.1/src/plugins/python_event.conf 2013-02-01 17:05:40.000000000 +0100
+++ abrt-2.1.1.new/src/plugins/python_event.conf 2013-03-05 10:04:37.763247228 +0100
@@ -16,17 +16,9 @@
diff -ruN abrt-2.1.6.new/src/plugins/python_event.conf abrt-2.1.6.old/src/plugins/python_event.conf
--- abrt-2.1.6.new/src/plugins/python_event.conf 2013-07-26 11:20:33.809925276 +0200
+++ abrt-2.1.6.old/src/plugins/python_event.conf 2013-07-26 11:22:23.992778495 +0200
@@ -15,17 +15,9 @@
-c /etc/libreport/plugins/bugzilla.conf
# TODO? -F /etc/libreport/plugins/bugzilla_format_python.conf
@ -88,10 +85,26 @@ diff -ur abrt-2.1.1/src/plugins/python_event.conf abrt-2.1.1.new/src/plugins/pyt
- reporter-ureport -r
-
# Reporting of python exceptions
EVENT=report-gui analyzer=Python
- report-gtk -e report_uReport -e "collect_*" -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-gtk -e "collect_*" -e report_Bugzilla -- "$DUMP_DIR"
EVENT=report-gui analyzer=Python component!=anaconda
report-gtk -- "$DUMP_DIR"
EVENT=report-cli analyzer=Python
EVENT=report-cli analyzer=Python component!=anaconda
- report-cli -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-cli -e report_Bugzilla -- "$DUMP_DIR"
diff -ruN abrt-2.1.6.new/src/plugins/vmcore_event.conf abrt-2.1.6.old/src/plugins/vmcore_event.conf
--- abrt-2.1.6.new/src/plugins/vmcore_event.conf 2013-07-26 11:20:33.811925292 +0200
+++ abrt-2.1.6.old/src/plugins/vmcore_event.conf 2013-07-26 11:23:36.103336857 +0200
@@ -19,12 +19,8 @@
reporter-bugzilla -b \
-F /etc/libreport/plugins/bugzilla_format_kernel.conf
-# Send micro report
-EVENT=report_uReport analyzer=vmcore
- /usr/libexec/abrt-action-ureport
-
EVENT=report-gui analyzer=vmcore
report-gtk -- "$DUMP_DIR"
EVENT=report-cli analyzer=vmcore
- report-cli -e analyze_VMcore -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+ report-cli -e analyze_VMcore -e report_Bugzilla -- "$DUMP_DIR"

178
abrt.spec
View File

@ -1,6 +1,11 @@
%{!?python_site: %global python_site %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0)")}
# platform-dependent
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
# http://fedoraproject.org/wiki/Packaging:Guidelines#PIE
# http://fedoraproject.org/wiki/Hardened_Packages
%global _hardened_build 1
%if 0%{?fedora} >= 14
%bcond_without systemd
%else
@ -22,10 +27,12 @@
%define desktopvendor fedora
%endif
%define libreport_ver 2.1.6
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 2.1.5
Release: 2%{?dist}
Version: 2.1.6
Release: 1%{?dist}
License: GPLv2+
Group: Applications/System
URL: https://fedorahosted.org/abrt/
@ -33,13 +40,10 @@ Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
# don't remove this patch, packages in rawhide are not signed!
Patch0: abrt-rhelkeys.patch
Patch1: disable_gpg_check.patch
Patch2: abrt-2.1.1-hide_all_ureport_stuff.patch
Patch3: abrt-2.1.1-dont_enable_shortened_reporting_in_gnome.patch
Patch2: abrt-2.1.6.rhel-remove_all_ureport_lines_from_config.patch
Patch3: abrt-2.1.6.rhel-dont_enable_shortened_reporting_in_gnome.patch
Patch4: abrt-2.1.1-disable_autoreporting_dialog.patch
# Remove it with abrt > 2.1.5
Patch35: 0035-retrace-client-build-correct-release-for-Fedora-Rawh.patch
BuildRequires: dbus-devel
BuildRequires: gtk3-devel
BuildRequires: rpm-devel >= 4.6
@ -55,9 +59,10 @@ BuildRequires: nss-devel
BuildRequires: asciidoc
BuildRequires: doxygen
BuildRequires: xmlto
BuildRequires: libreport-devel >= 2.1.5
BuildRequires: btparser-devel >= 0.2.5
Requires: libreport >= 2.1.5
BuildRequires: libreport-devel >= %{libreport_ver}
BuildRequires: satyr-devel >= 0.5
Requires: libreport >= %{libreport_ver}
Requires: satyr >= 0.5
%if %{with systemd}
Requires: systemd-units
@ -65,11 +70,6 @@ Requires: systemd-units
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: %{name}-libs = %{version}-%{release}
Requires(pre): shadow-utils
Obsoletes: abrt-plugin-sqlite3 > 0.0.1
# required for transition from 1.1.13, can be removed after some time
Obsoletes: abrt-plugin-runapp > 0.0.1
Obsoletes: abrt-plugin-filetransfer > 0.0.1
Obsoletes: abrt-plugin-sosreport > 0.0.1
%description
%{name} is a tool to help users to detect defects in applications and
@ -97,7 +97,7 @@ Group: User Interface/Desktops
Requires: %{name} = %{version}-%{release}
Requires: %{name}-dbus = %{version}-%{release}
Requires: gnome-abrt
BuildRequires: libreport-gtk-devel
BuildRequires: libreport-gtk-devel >= %{libreport_ver}
# we used to have abrt-applet, now abrt-gui includes it:
Provides: abrt-applet = %{version}-%{release}
Obsoletes: abrt-applet < 0.0.5
@ -111,7 +111,6 @@ GTK+ wizard for convenient bug reporting.
Summary: %{name}'s C/C++ addon
Group: System Environment/Libraries
Requires: cpio
Requires: btparser >= 0.2.5
Requires: gdb >= 7.0-3
Requires: elfutils
# abrt-action-perform-ccpp-analysis wants to run analyze_RetraceServer:
@ -140,13 +139,11 @@ Group: System Environment/Libraries
Requires: curl
Requires: %{name} = %{version}-%{release}
Requires: abrt-libs = %{version}-%{release}
Requires: libreport-plugin-kerneloops
Obsoletes: kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloopsreporter > 0.0.1
Requires: libreport-plugin-kerneloops >= %{libreport_ver}
%description addon-kerneloops
This package contains plugin for collecting kernel crash information from system log.
This package contains plugin for collecting kernel crash information from
system log.
%package addon-xorg
Summary: %{name}'s Xorg addon
@ -155,7 +152,8 @@ Requires: curl
Requires: %{name} = %{version}-%{release}
%description addon-xorg
This package contains plugin for collecting Xorg crash information from Xorg log.
This package contains plugin for collecting Xorg crash information from Xorg
log.
%package addon-vmcore
Summary: %{name}'s vmcore addon
@ -165,12 +163,14 @@ Requires: abrt-addon-kerneloops
Requires: crash
%description addon-vmcore
This package contains plugin for collecting kernel crash information from vmcore files.
This package contains plugin for collecting kernel crash information from
vmcore files.
%package addon-uefioops
Summary: %{name}'s UEFI oops addon
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: abrt-libs = %{version}-%{release}
Requires: abrt-addon-kerneloops
%description addon-uefioops
@ -181,7 +181,7 @@ Summary: %{name}'s bodhi plugin
BuildRequires: json-c-devel
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
BuildRequires: libreport-web-devel >= 2.0.10
BuildRequires: libreport-web-devel >= %{libreport_ver}
Obsoletes: libreport-plugin-bodhi > 0.0.1
Provides: libreport-plugin-bodhi
@ -193,8 +193,6 @@ Summary: %{name}'s addon for catching and analyzing Python exceptions
Group: System Environment/Libraries
Requires: python
Requires: %{name} = %{version}-%{release}
Obsoletes: gnome-python2-bugbuddy > 0.0.1
Provides: gnome-python2-bugbuddy
%description addon-python
This package contains python hook and python analyzer plugin for handling
@ -204,15 +202,15 @@ uncaught exception in python programs.
Summary: %{name}'s command line interface
Group: User Interface/Desktops
Requires: %{name} = %{version}-%{release}
Requires: libreport-cli
Requires: libreport-cli >= %{libreport_ver}
Requires: abrt-libs = %{version}-%{release}
%description tui
This package contains a simple command line client for processing abrt reports in
command line environment.
This package contains a simple command line client for processing abrt reports
in command line environment.
%package cli
Summary: Virtual package to install all necessary packages for usage from command line environment
Summary: Virtual package to make easy default installation on non-graphical environments
Group: Applications/System
Requires: %{name} = %{version}-%{release}
Requires: abrt-tui
@ -224,14 +222,16 @@ Requires: abrt-addon-python
Requires: abrt-addon-xorg
Requires: abrt-retrace-client
Requires: abrt-plugin-bodhi
Requires: libreport-plugin-bugzilla, libreport-plugin-logger
Requires: libreport-plugin-ureport
Requires: libreport-plugin-bugzilla >= %{libreport_ver}
Requires: libreport-plugin-logger >= %{libreport_ver}
Requires: libreport-plugin-ureport >= %{libreport_ver}
%description cli
Virtual package to make easy default installation on non-graphical environments.
Virtual package to install all necessary packages for usage from command line
environment.
%package desktop
Summary: Virtual package to install all necessary packages for usage from desktop environment
Summary: Virtual package to make easy default installation on desktop environments
Group: User Interface/Desktops
# This package gets installed when anything requests bug-buddy -
# happens when users upgrade Fn to Fn+1;
@ -252,26 +252,26 @@ Requires: elfutils
Requires: abrt-gui
Requires: gnome-abrt
Requires: abrt-plugin-bodhi
Requires: libreport-plugin-logger, libreport-plugin-bugzilla
Requires: libreport-plugin-ureport
Requires: libreport-plugin-bugzilla >= %{libreport_ver}
Requires: libreport-plugin-logger >= %{libreport_ver}
Requires: libreport-plugin-ureport >= %{libreport_ver}
%if 0%{?fedora}
Requires: libreport-fedora
Requires: libreport-fedora >= %{libreport_ver}
%endif
%if 0%{?rhel}
Requires: libreport-rhel
Requires: libreport-rhel >= %{libreport_ver}
%endif
#Requires: abrt-plugin-firefox
Obsoletes: bug-buddy > 0.0.1
Provides: bug-buddy
%description desktop
Virtual package to make easy default installation on desktop environments.
Virtual package to install all necessary packages for usage from desktop
environment.
%package dbus
Summary: ABRT DBus service
Group: Application/System
Group: Applications/System
Requires: %{name} = %{version}-%{release}
Requires: libreport
BuildRequires: polkit-devel
Requires: abrt-libs = %{version}-%{release}
@ -315,8 +315,6 @@ to the shell
#Fedora
%patch1 -p1 -b .gpgcheck
%patch35 -p1
%build
autoconf
# Removed -Werror until abrt/abrt#673 is fixed
@ -343,6 +341,11 @@ desktop-file-install \
--dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart \
src/applet/abrt-applet.desktop
desktop-file-install \
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
--delete-original \
${RPM_BUILD_ROOT}%{_datadir}/applications/*.desktop
# After everything is installed, remove info dir
rm -f %{buildroot}%{_infodir}/dir
@ -665,12 +668,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man1/abrt-handle-upload.1.gz
%{_mandir}/man1/abrt-server.1.gz
%{_mandir}/man1/abrt-action-save-package-data.1.gz
%{_mandir}/man1/abrt-watch-log.1.gz
%{_mandir}/man1/abrt-action-analyze-xorg.1.gz
%{_mandir}/man8/abrtd.8.gz
%{_mandir}/man8/abrt-dbus.8.gz
%{_mandir}/man5/abrt.conf.5.gz
%{_mandir}/man5/abrt-action-save-package-data.conf.5.gz
# {_mandir}/man5/pyhook.conf.5.gz
%{_mandir}/man1/abrt-action-analyze-ccpp-local.*
%files libs
%defattr(-,root,root,-)
@ -691,9 +694,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/icons/hicolor/*/apps/*
%{_datadir}/icons/hicolor/*/status/*
%{_datadir}/%{name}/icons/hicolor/*/status/*
%{_datadir}/%{name}/ui/*
%{_bindir}/abrt-applet
%{_bindir}/system-config-abrt
#%%{_bindir}/test-report
%{_sysconfdir}/xdg/autostart/abrt-applet.desktop
%config(noreplace) %{_sysconfdir}/xdg/autostart/abrt-applet.desktop
/usr/share/applications/system-config-abrt.desktop
%{_mandir}/man1/abrt-applet.1*
%{_mandir}/man1/system-config-abrt.1*
%files addon-ccpp
%defattr(-,root,root,-)
@ -705,10 +713,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_initrddir}/abrt-ccpp
%endif
%{_libexecdir}/abrt-hook-ccpp
%{_libexecdir}/abrt-gdb-exploitable
%attr(6755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
%{_bindir}/abrt-action-analyze-c
%{_bindir}/abrt-action-trim-files
%{_bindir}/abrt-action-analyze-core
%{_bindir}/abrt-action-analyze-vulnerability
%{_bindir}/abrt-action-install-debuginfo
%{_bindir}/abrt-action-generate-backtrace
%{_bindir}/abrt-action-generate-core-backtrace
@ -718,29 +728,35 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_bindir}/abrt-dedup-client
%{_bindir}/abrt-action-analyze-ccpp-local
%{_sbindir}/abrt-install-ccpp-hook
%{_sysconfdir}/libreport/events.d/ccpp_event.conf
%{_sysconfdir}/libreport/events.d/gconf_event.conf
%{_sysconfdir}/libreport/events.d/vimrc_event.conf
%{_sysconfdir}/libreport/events/analyze_CCpp.xml
%{_sysconfdir}/libreport/events/analyze_LocalGDB.xml
%{_sysconfdir}/libreport/events/collect_xsession_errors.xml
%{_sysconfdir}/libreport/events/collect_GConf.xml
%{_sysconfdir}/libreport/events/collect_vimrc_user.xml
%{_sysconfdir}/libreport/events/collect_vimrc_system.xml
%{_sysconfdir}/libreport/events/post_report.xml
%config(noreplace) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/gconf_event.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
%{_datadir}/libreport/events/analyze_CCpp.xml
%{_datadir}/libreport/events/analyze_LocalGDB.xml
%{_datadir}/libreport/events/collect_xsession_errors.xml
%{_datadir}/libreport/events/collect_GConf.xml
%{_datadir}/libreport/events/collect_vimrc_user.xml
%{_datadir}/libreport/events/collect_vimrc_system.xml
%{_datadir}/libreport/events/post_report.xml
%{_mandir}/man*/abrt-action-analyze-c.*
%{_mandir}/man*/abrt-action-trim-files.*
%{_mandir}/man*/abrt-action-generate-backtrace.*
%{_mandir}/man*/abrt-action-generate-core-backtrace.*
%{_mandir}/man*/abrt-action-analyze-backtrace.*
%{_mandir}/man*/abrt-action-list-dsos.*
%{_mandir}/man1/abrt-install-ccpp-hook.1.gz
%{_mandir}/man*/abrt-install-ccpp-hook.*
%{_mandir}/man*/abrt-action-install-debuginfo.*
%{_mandir}/man*/abrt-action-analyze-ccpp-local.*
%{_mandir}/man*/abrt-action-analyze-core.*
%{_mandir}/man*/abrt-action-analyze-vulnerability.*
%{_mandir}/man*/abrt-action-perform-ccpp-analysis.*
%{_mandir}/man*/abrt-dedup-client.*
%files retrace-client
%{_bindir}/abrt-retrace-client
%{_mandir}/man1/abrt-retrace-client.1.gz
%{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
%{_sysconfdir}/libreport/events/analyze_RetraceServer.xml
%config(noreplace) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
%{_datadir}/libreport/events/analyze_RetraceServer.xml
%files addon-kerneloops
%defattr(-,root,root,-)
@ -753,7 +769,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_bindir}/abrt-dump-oops
%{_bindir}/abrt-action-analyze-oops
%{_bindir}/abrt-action-save-kernel-data
%{_mandir}/man1/abrt-dump-oops.1*
%{_mandir}/man1/abrt-action-analyze-oops.1*
%{_mandir}/man1/abrt-action-save-kernel-data.1*
%files addon-xorg
%defattr(-,root,root,-)
@ -764,12 +782,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_initrddir}/abrt-xorg
%endif
%{_bindir}/abrt-dump-xorg
%{_mandir}/man1/abrt-dump-xorg.1*
%files addon-vmcore
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
%config(noreplace) %{_sysconfdir}/%{name}/abrt-harvest-vmcore.conf
%{_sysconfdir}/libreport/events/analyze_VMcore.xml
%{_datadir}/libreport/events/analyze_VMcore.xml
%if %{with systemd}
%{_unitdir}/abrt-vmcore.service
%else
@ -777,6 +796,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%{_sbindir}/abrt-harvest-vmcore
%{_bindir}/abrt-action-analyze-vmcore
%{_mandir}/man1/abrt-harvest-vmcore.1*
%{_mandir}/man1/abrt-action-analyze-vmcore.1*
%files addon-uefioops
@ -788,12 +808,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%{_sbindir}/abrt-harvest-uefioops
%{_bindir}/abrt-merge-uefioops
%{_mandir}/man1/abrt-harvest-uefioops.1*
%{_mandir}/man1/abrt-merge-uefioops.1*
%files addon-python
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/python.conf
# TODO? Do we need %config(noreplace) in the below line too?
%{_sysconfdir}/libreport/events.d/python_event.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/python_event.conf
%{_bindir}/abrt-action-analyze-python
%{_mandir}/man1/abrt-action-analyze-python.1*
%{python_sitearch}/abrt*.py*
@ -818,6 +840,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files dbus
%defattr(-,root,root,-)
%{_sbindir}/abrt-dbus
%{_mandir}/man8/abrt-dbus.8.gz
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-abrt.conf
%{_datadir}/dbus-1/interfaces/org.freedesktop.Problems.xml
%{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
@ -838,6 +861,35 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
%changelog
* Fri Jul 26 2013 Jakub Filak <jfilak@redhat.com> 2.1.6-1
- replace functions deprecated in Gtk-3.10 with their substitutes
- integrate with satyr, drop btparser
- use absolute path in python shebang rhzb#987010
- abrt-action-save-package-data: properly close rpm database. Closes #674.
- abrt-action-save-package-data: fix handling of ProcessUnpackaged on scripts
- abrt-action-save-package-data manpage: typo fix
- change /var/spool/abrt/ to /var/tmp/abrt in doc rhbz#912750
- Fix RPMdiff warnings about abrtd and abrt-action-install-debuginfo-to-abrt-cache
- specfile: add dependency on abrt-libs to abrt-addon-uefioops
- stop using the hardcoded event list, use workflows instead rhbz#866027
- retrace-client: build correct release for Fedora Rawhide
- spec: drop unnecessary Obsoletes and Provides
- correct FSF address in python exception hook
- add missing manual pages for binaries and scripts
- fix rpmlint issues in the spec file
- move event option XML files to /usr/share/libreport/
- abrt-hook-ccpp: always fall back to creating user core.
- dbus: add GetForeignProblems method
- the system tray icon opens recently detected problem
- add gdb python plugin which analyzes coredump for vulnerability
- applet: stop saving configuration at exit
- introduce system-config-abrt
- abrt-cli status: make the output more natural
- Fix wrong path in shell include
- abrt-dump-xorg: save "type=xorg" along with "analyzer=xorg"
- Update python hook to use fixed socket interface
- abrt-server: updates/fixes for future rasdaemon needs
* Tue Jul 16 2013 Jakub Filak <jfilak@redhat.com> 2.1.5-2
- fix reporting from Rawhide
- Resolves: #958933

View File

@ -1 +1 @@
45e3dbbcb4c66aefda8bf5b5315bfdc6 abrt-2.1.5.tar.gz
7a8d16a6f316528a767e6be93164e688 abrt-2.1.6.tar.gz