New upstream release 2.1.12
This commit is contained in:
parent
995b9a8c20
commit
694a48b58e
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.1.9.tar.gz
|
||||
/abrt-2.1.10.tar.gz
|
||||
/abrt-2.1.11.tar.gz
|
||||
/abrt-2.1.12.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -ruN abrt-2.1.11/configure abrt-2.1.11.fix/configure
|
||||
--- abrt-2.1.11/configure 2014-01-08 18:46:48.057001105 +0100
|
||||
+++ abrt-2.1.11.fix/configure 2014-01-08 18:46:33.880000782 +0100
|
||||
@@ -17432,7 +17432,8 @@
|
||||
AUTOM4TE=${AUTOM4TE-"${am_missing_run}autom4te"}
|
||||
|
||||
# Needed by tests/atlocal.in.
|
||||
-O0CFLAGS=`echo $CFLAGS | sed 's/-O[0-9] *//' | sed 's/-Werror//'`
|
||||
+# CFLAGS may contain '-Werror=format-security'
|
||||
+O0CFLAGS=`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[^ ]*\)\?//g'`
|
||||
|
||||
|
||||
ac_config_headers="$ac_config_headers config.h"
|
43
abrt.spec
43
abrt.spec
@ -34,12 +34,12 @@
|
||||
%define docdirversion -%{version}
|
||||
%endif
|
||||
|
||||
%define libreport_ver 2.1.11
|
||||
%define libreport_ver 2.1.12
|
||||
%define satyr_ver 0.13
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.1.11
|
||||
Version: 2.1.12
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
@ -48,8 +48,6 @@ Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
|
||||
# don't remove this patch, packages in rawhide are not signed!
|
||||
Patch0: disable_gpg_check.patch
|
||||
|
||||
Patch1: abrt-2.1.11-fix_0CFLAGS_in_configure.patch
|
||||
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: rpm-devel >= 4.6
|
||||
@ -179,10 +177,10 @@ Summary: %{name}'s kerneloops addon
|
||||
Group: System Environment/Libraries
|
||||
Requires: curl
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: abrt-libs = %{version}-%{release}
|
||||
%if 0%{!?rhel:1}
|
||||
Requires: libreport-plugin-kerneloops >= %{libreport_ver}
|
||||
%endif
|
||||
Requires: abrt-libs = %{version}-%{release}
|
||||
|
||||
%description addon-kerneloops
|
||||
This package contains plugin for collecting kernel crash information from
|
||||
@ -193,6 +191,7 @@ Summary: %{name}'s Xorg addon
|
||||
Group: System Environment/Libraries
|
||||
Requires: curl
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: abrt-libs = %{version}-%{release}
|
||||
|
||||
%description addon-xorg
|
||||
This package contains plugin for collecting Xorg crash information from Xorg
|
||||
@ -270,6 +269,7 @@ Requires: abrt-addon-ccpp
|
||||
Requires: abrt-addon-python
|
||||
Requires: abrt-addon-xorg
|
||||
%if 0%{?rhel}
|
||||
Requires: libreport-rhel >= %{libreport_ver}
|
||||
Requires: libreport-plugin-rhtsupport >= %{libreport_ver}
|
||||
%else
|
||||
Requires: abrt-retrace-client
|
||||
@ -277,6 +277,8 @@ Requires: abrt-plugin-bodhi
|
||||
Requires: libreport-plugin-bugzilla >= %{libreport_ver}
|
||||
Requires: libreport-plugin-logger >= %{libreport_ver}
|
||||
Requires: libreport-plugin-ureport >= %{libreport_ver}
|
||||
|
||||
Requires: libreport-fedora >= %{libreport_ver}
|
||||
%endif
|
||||
|
||||
%description cli
|
||||
@ -370,7 +372,6 @@ to the shell
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gpgcheck
|
||||
%patch1 -p1 -b .unittests
|
||||
|
||||
%build
|
||||
#autoconf
|
||||
@ -379,7 +380,8 @@ make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} \
|
||||
make install DESTDIR=$RPM_BUILD_ROOT \
|
||||
mandir=%{_mandir} \
|
||||
dbusabrtdocdir=%{_defaultdocdir}/%{name}-dbus%{docdirversion}/html/
|
||||
|
||||
%find_lang %{name}
|
||||
@ -598,10 +600,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_mandir}/man5/abrt.conf.5.gz
|
||||
%{_mandir}/man5/abrt-action-save-package-data.conf.5.gz
|
||||
# {_mandir}/man5/pyhook.conf.5.gz
|
||||
|
||||
# filesystem package should own /usr/share/augeas/lenses directory
|
||||
%{_datadir}/augeas/lenses/abrt.aug
|
||||
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libabrt.so.*
|
||||
@ -657,7 +659,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
%{_libexecdir}/abrt-hook-ccpp
|
||||
%{_libexecdir}/abrt-gdb-exploitable
|
||||
|
||||
# attr(6755) ~= SETUID|SETGID
|
||||
%attr(6755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
|
||||
|
||||
%{_bindir}/abrt-action-analyze-c
|
||||
%{_bindir}/abrt-action-trim-files
|
||||
%{_bindir}/abrt-action-analyze-core
|
||||
@ -675,8 +680,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/gconf_event.conf
|
||||
%{_mandir}/man5/gconf_event.conf.5.gz
|
||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
|
||||
%{_datadir}/libreport/events/analyze_CCpp.xml
|
||||
%{_mandir}/man5/vimrc_event.conf.5.gz
|
||||
%{_datadir}/libreport/events/analyze_CCpp.xml
|
||||
%{_datadir}/libreport/events/analyze_LocalGDB.xml
|
||||
%{_datadir}/libreport/events/collect_xsession_errors.xml
|
||||
%{_datadir}/libreport/events/collect_GConf.xml
|
||||
@ -706,6 +711,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
%{_mandir}/man*/abrt-upload-watch.*
|
||||
|
||||
|
||||
%files retrace-client
|
||||
%{_bindir}/abrt-retrace-client
|
||||
%{_mandir}/man1/abrt-retrace-client.1.gz
|
||||
@ -755,9 +761,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
%{_sbindir}/abrt-harvest-vmcore
|
||||
%{_bindir}/abrt-action-analyze-vmcore
|
||||
%{_bindir}/abrt-action-check-oops-for-hw-error
|
||||
%{_mandir}/man1/abrt-harvest-vmcore.1*
|
||||
%{_mandir}/man5/abrt-vmcore.conf.5*
|
||||
%{_mandir}/man1/abrt-action-analyze-vmcore.1*
|
||||
%{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
|
||||
|
||||
%files addon-pstoreoops
|
||||
%defattr(-,root,root,-)
|
||||
@ -776,7 +784,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/plugins/python.conf
|
||||
%{_datadir}/%{name}/conf.d/plugins/python.conf
|
||||
%{_mandir}/man5/abrt-python.conf.5.gz
|
||||
# TODO? Do we need %config(noreplace) in the below line too?
|
||||
# TODO? Do we need %%config(noreplace) in the below line too?
|
||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/python_event.conf
|
||||
%{_mandir}/man5/python_event.conf.5.gz
|
||||
%{_bindir}/abrt-action-analyze-python
|
||||
@ -833,6 +841,19 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Thu Jan 30 2014 Jakub Filak <jfilak@redhat.com> 2.1.12-1
|
||||
- don't break the event run by failures of abrt-action-notify
|
||||
- harvest-vmcore: properly handle inaccessible dir error
|
||||
- spec: abrt-cli requires a pkg providing workflows
|
||||
- applet: do not say the report is anonymous when ureport auth is enabled
|
||||
- abrtd.service: Don't order after syslog.target
|
||||
- vmcore: properly configure Augeas
|
||||
- applet: don't notify missing ignored_problems file
|
||||
- fix a double free error in abrt-applet
|
||||
- configui: show 'Close' button in the dialog
|
||||
- configure: remove all -Werror from O0CFLAGS
|
||||
- fix handling of Machine Check Exceptions.
|
||||
|
||||
* Wed Jan 08 2014 Jakub Filak <jfilak@redhat.com> 2.1.11-1
|
||||
- Update translations
|
||||
- harvest_vmcore: replace regexp config parsing with augeas
|
||||
@ -1553,7 +1574,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
- added mono-core to blacklist
|
||||
|
||||
* Tue Mar 29 2011 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.0-2
|
||||
- use %ghost on files in /var/run and /var/lock rhbz#656542
|
||||
- use %%ghost on files in /var/run and /var/lock rhbz#656542
|
||||
- fixed notification persistence in gnome3
|
||||
- added analyze selector to CLI
|
||||
- refuse reporting to bz without backtrace or hash
|
||||
|
Loading…
Reference in New Issue
Block a user