bodhi: fix a segfault when testing an os-release opt for 'rawhide'
and actualize the abrt-bodhi man page Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
This commit is contained in:
parent
ef5d23d3b1
commit
58ac8d6e9a
41
0042-doc-actualize-the-abrt-bodhi-man-page.patch
Normal file
41
0042-doc-actualize-the-abrt-bodhi-man-page.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From 655a356abb1f0557690fa21a0d008af472c56788 Mon Sep 17 00:00:00 2001
|
||||
From: Matej Habrnal <mhabrnal@redhat.com>
|
||||
Date: Wed, 2 Sep 2015 12:29:31 +0200
|
||||
Subject: [PATCH] doc: actualize the abrt-bodhi man page
|
||||
|
||||
Parameters -d and -u were not in the man page.
|
||||
|
||||
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
|
||||
---
|
||||
doc/abrt-bodhi.txt | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/doc/abrt-bodhi.txt b/doc/abrt-bodhi.txt
|
||||
index 945a4a9..fe790d6 100644
|
||||
--- a/doc/abrt-bodhi.txt
|
||||
+++ b/doc/abrt-bodhi.txt
|
||||
@@ -7,7 +7,7 @@ abrt-bodhi - The ABRT bodhi client.
|
||||
|
||||
SYNOPSIS
|
||||
--------
|
||||
-'abrt-bodhi' [-v] [-r[RELEASE]] (-b ID1[,ID2,...] | PKG-NAME) [PKG-NAME]...
|
||||
+'abrt-bodhi' [-v] [-r[RELEASE]] [-u URL] [-d DIR] (-b ID1[,ID2,...] | PKG-NAME) [PKG-NAME]...
|
||||
|
||||
DESCRIPTION
|
||||
-----------
|
||||
@@ -25,6 +25,12 @@ OPTIONS
|
||||
-b, --bugs ID1,ID2,..
|
||||
Specify any number of Bugzilla IDs (--bugs=1234,5678)
|
||||
|
||||
+-d, --problem-dir DIR::
|
||||
+ Path to problem directory
|
||||
+
|
||||
+-u, --url URL::
|
||||
+ Specify a bodhi server url
|
||||
+
|
||||
AUTHORS
|
||||
-------
|
||||
* ABRT team
|
||||
--
|
||||
2.5.0
|
||||
|
@ -0,0 +1,29 @@
|
||||
From afe242542e3c372a05de51a7259f417c1df058d2 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Mon, 7 Sep 2015 10:23:30 +0200
|
||||
Subject: [PATCH] bodhi: fix a segfault when testing an os-release opt for
|
||||
'rawhide'
|
||||
|
||||
Resolves: rhbz#1260259
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/plugins/bodhi.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/bodhi.c b/src/plugins/bodhi.c
|
||||
index b348a26..bbd88f7 100644
|
||||
--- a/src/plugins/bodhi.c
|
||||
+++ b/src/plugins/bodhi.c
|
||||
@@ -513,7 +513,7 @@ int main(int argc, char **argv)
|
||||
parse_osinfo_for_rhts(osinfo, &product, &version);
|
||||
|
||||
/* There are no bodhi updates for Rawhide */
|
||||
- bool rawhide = strcasecmp(release, "rawhide") == 0;
|
||||
+ bool rawhide = strcasecmp(version, "rawhide") == 0;
|
||||
if (!rawhide)
|
||||
query = strbuf_append_strf(query, "releases=f%s&", version);
|
||||
|
||||
--
|
||||
2.5.0
|
||||
|
17
abrt.spec
17
abrt.spec
@ -49,7 +49,7 @@
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.6.2
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: https://abrt.readthedocs.org/
|
||||
@ -97,6 +97,17 @@ Patch0035: 0035-ccpp-do-not-break-the-reporting-if-a-bodhi-fails.patch
|
||||
Patch0036: 0036-bodhi-add-ignoring-of-Rawhide.patch
|
||||
Patch0037: 0037-bodhi-add-parsing-of-error-responses.patch
|
||||
#Patch0038: 0038-testsuite-d-e-handling-set-PrivateReports-to-no-in-a.patch
|
||||
#Patch0039: 0039-autogen-use-dnf-instead-of-yum-to-install-dependenci.patch
|
||||
#Patch0040: 0040-testsuite-fix-test-oops_processing.patch
|
||||
#Patch0041: 0041-testsuite-improve-logging-in-dont-blame-interpret-te.patch
|
||||
Patch0042: 0042-doc-actualize-the-abrt-bodhi-man-page.patch
|
||||
#Patch0043: 0043-testsuite-improve-logging-in-bz652338-removed-proc-P.patch
|
||||
#Patch0044: 0044-testsuite-fix-console-notification-test.patch
|
||||
#Patch0045: 0045-testsuite-verify-core_backtrace-frames-generated-by-.patch
|
||||
Patch0046: 0046-bodhi-fix-a-segfault-when-testing-an-os-release-opt-.patch
|
||||
#Patch0047: 0047-testsuite-fix-a-bug-in-ccpp-plugin-hook-unwind.patch
|
||||
#Patch0048: 0048-testsuite-run-will_segfault-in-new-PID-NS.patch
|
||||
#Patch0049: 0049-testsuite-ccpp-plugin-test-crash-in-non-init-PID-NS.patch
|
||||
|
||||
# '%%autosetup -S git' -> git
|
||||
BuildRequires: git
|
||||
@ -1085,6 +1096,10 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2015 Matej Habrnal <mhabrnal@redhat.com> 2.6.2-8
|
||||
- doc: actualize the abrt-bodhi man page
|
||||
- bodhi: fix a segfault when testing an os-release opt for 'rawhide'
|
||||
|
||||
* Wed Aug 26 2015 Matej Habrnal <mhabrnal@redhat.com> 2.6.2-7
|
||||
- bodhi: add parsing of error responses
|
||||
- bodhi: add ignoring of Rawhide
|
||||
|
Loading…
Reference in New Issue
Block a user