update to 2.0.0

Conflicts:

	abrt.spec
This commit is contained in:
Jiri Moskovcak 2011-04-21 18:24:33 +02:00
parent 30b8c3bc25
commit 3a42d823cc
6 changed files with 423 additions and 157 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ abrt-1.1.10.tar.gz
abrt-1.1.13.tar.gz
/abrt-1.1.14.tar.gz
/abrt-1.1.17.tar.gz
/abrt-2.0.0.tar.gz

151
abrt-ccpp.init Normal file
View File

@ -0,0 +1,151 @@
#!/bin/bash
# Install abrt coredump hook
#
# chkconfig: 35 82 16
# description: Installs coredump handler which saves segfault data
### BEGIN INIT INFO
# Provides: abrt-ccpp
# Required-Start: $abrtd
# Default-Stop: 0 1 2 6
# Default-Start: 3 5
# Short-Description: Installs coredump handler which saves segfault data
# Description: Installs coredump handler which saves segfault data
### END INIT INFO
# Source function library.
. /etc/rc.d/init.d/functions
# For debugging
dry_run=false
verbose=false
# We don't have pid files, therefore have to use
# a flag file in /var/lock/subsys to enable GUI service tools
# to figure out our status
LOCK="/var/lock/subsys/abrt-ccpp"
PATTERN_FILE="/proc/sys/kernel/core_pattern"
SAVED_PATTERN_FILE="/var/run/abrt/saved_core_pattern"
HOOK_BIN="/usr/libexec/abrt-hook-ccpp"
PATTERN="|$HOOK_BIN /var/spool/abrt %s %c %p %u %g %t %h %e"
# core_pipe_limit specifies how many dump_helpers can run at the same time
# 0 - means unlimited, but it's not guaranteed that /proc/<pid> of crashing
# process will be available for dump_helper.
# 4 - means that 4 dump_helpers can run at the same time (the rest will also
# run, but they will fail to read /proc/<pid>).
#
# This should be enough for ABRT, we can miss some crashes, but what are
# the odds that more processes crash at the same time? And moreover,
# do people want to save EVERY ONE of the crashes when they have
# a crash storm? I don't think so.
# The value of 4 has been recommended by nhorman.
#
CORE_PIPE_LIMIT_FILE="/proc/sys/kernel/core_pipe_limit"
CORE_PIPE_LIMIT="4"
RETVAL=0
check() {
# Check that we're a privileged user
[ "`id -u`" = 0 ] || exit 4
}
start() {
check
cur=`cat "$PATTERN_FILE"`
cur_first=`printf "%s" "$cur" | sed 's/ .*//'`
$verbose && printf "cur:'%s'\n" "$cur"
# Is it already installed?
if test x"$cur_first" != x"|$HOOK_BIN"; then # no
# It is not installed
printf "%s\n" "$cur" >"$SAVED_PATTERN_FILE"
OLD_PATTERN=""
# Does old pattern start with '|'?
if test x"${cur#|}" = x"$cur"; then # no
# Encode it as hex string, NUL terminated
OLD_PATTERN=`printf "%s" "$cur" | od -tx1 | sed 's/000[^ ]*//' | xargs | sed 's/ //g'`
$verbose && printf "OLD_PATTERN:'%s'\n" "$OLD_PATTERN"
OLD_PATTERN=" ${OLD_PATTERN}00"
fi
# Install new handler
$verbose && printf "Installing to %s:'%s'\n" "$PATTERN_FILE" "${PATTERN}${OLD_PATTERN}"
$dry_run || echo "${PATTERN}${OLD_PATTERN}" >"$PATTERN_FILE"
$dry_run || touch -- "$LOCK"
# Check core_pipe_limit and change it if it's 0,
# otherwise the abrt-hook-ccpp won't be able to read /proc/<pid>
# of the crashing process
if test x"`cat "$CORE_PIPE_LIMIT_FILE"`" = x"0"; then
echo "$CORE_PIPE_LIMIT" >"$CORE_PIPE_LIMIT_FILE"
fi
fi
return $RETVAL
}
stop() {
check
if test -f "$SAVED_PATTERN_FILE"; then
$verbose && printf "Restoring to %s:'%s'\n" "$PATTERN_FILE" "`cat "$SAVED_PATTERN_FILE"`"
$dry_run || cat "$SAVED_PATTERN_FILE" >"$PATTERN_FILE"
fi
$dry_run || rm -f -- "$LOCK"
return $RETVAL
}
restart() {
stop
start
}
reload() {
restart
}
case "$1" in
start)
start
;;
stop)
stop
;;
reload)
reload
;;
force-reload)
echo "$0: Unimplemented feature."
RETVAL=3
;;
restart)
restart
;;
condrestart)
cur=`cat "$PATTERN_FILE"`
cur_first=`printf "%s" "$cur" | sed 's/ .*//'`
# Is it already installed?
if test x"$cur_first" = x"|$HOOK_BIN"; then # yes
$verbose && printf "Installed, re-installing\n"
restart
fi
;;
status)
cur=`cat "$PATTERN_FILE"`
cur_first=`printf "%s" "$cur" | sed 's/ .*//'`
# Is it already installed?
if test x"$cur_first" = x"|$HOOK_BIN"; then # yes
$verbose && printf "Installed\n"
RETVAL=0
else
$verbose && printf "Not installed\n"
RETVAL=3 # "stopped normally"
fi
;;
*)
echo $"Usage: $0 {start|stop|status|restart|condrestart|reload|force-reload}"
RETVAL=2
esac
exit $RETVAL

398
abrt.spec
View File

@ -6,60 +6,103 @@
%else
%define with_systemd 0
%endif
# please modify the "_buildid" define in a way that identifies
# that the built package isn't the stock distribution package,
# for example, by setting the define to ".local" or ".bz123456"
# for example, by setting abbreviation sha1 hash "238f49f"
#
# % define _buildid .local
# % define _buildid git238f49f
%if "0%{?_buildid}" != "0"
%define pkg_release 0.%{?_buildid}%{?dist}
%else
%define pkg_release 2%{?dist}
%define pkg_release 1%{?dist}
%endif
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 1.1.17
Version: 2.0.0
Release: %{?pkg_release}
License: GPLv2+
Group: Applications/System
URL: https://fedorahosted.org/abrt/
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.gz
Source1: abrt.init
Patch0: abrt-1.0.9-hideprefs.patch
Patch1: abrt_disable_gpgcheck.diff
Patch2: blacklist.patch
Source2: abrt-ccpp.init
Patch0: remove_libreport_python.patch
Patch1: settings_warning.patch
BuildRequires: dbus-devel
BuildRequires: gtk2-devel
BuildRequires: curl-devel
BuildRequires: rpm-devel >= 4.6
BuildRequires: sqlite-devel > 3.0
BuildRequires: desktop-file-utils
BuildRequires: libnotify-devel
BuildRequires: xmlrpc-c-devel
BuildRequires: xmlrpc-c-client
BuildRequires: file-devel
BuildRequires: python-devel
BuildRequires: gettext
BuildRequires: libxml2-devel
BuildRequires: polkit-devel
BuildRequires: libtar-devel, bzip2-devel, zlib-devel
BuildRequires: libtar-devel
BuildRequires: intltool
BuildRequires: bison
BuildRequires: libtool
BuildRequires: nss-devel
BuildRequires: texinfo
# for rhel6
%if 0%{?rhel} >= 6
BuildRequires: gnome-keyring-devel
%else
BuildRequires: libgnome-keyring-devel
%endif
%if %{?with_systemd}
Requires: systemd-units
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: %{name}-libs = %{version}-%{release}
Requires: libreport
Requires(pre): shadow-utils
Obsoletes: abrt-plugin-sqlite3
Obsoletes: abrt-plugin-sqlite3 > 0.0.1
# required for transition from 1.1.13, can be removed after some time
Obsoletes: abrt-plugin-runapp > 0.0.1
Obsoletes: abrt-plugin-filetransfer > 0.0.1
Obsoletes: abrt-plugin-sosreport > 0.0.1
%description
%{name} is a tool to help users to detect defects in applications and
to create a bug report with all informations needed by maintainer to fix it.
It uses plugin system to extend its functionality.
%package -n libreport
Summary: Libraries for reporting crashes to different targets.
Group: System Environment/Libraries
%description -n libreport
Libraries providing API for reporting different problems in applications
to different bug targets like bugzilla, ftp, trac, etc...
%package -n libreport-devel
Summary: Development libraries and headers for libreport.
Group: Development/Libraries
%description -n libreport-devel
Development libraries and headers for libreport.
#%package -n libreport-python
#Summary: Python bindings for report-libs.
## Is group correct here? -
#Group: System Environment/Libraries
#%description -n libreport-python
#Python bindings for report-libs.
%package -n libreport-gtk
Summary: GTK frontend for libreport
Group: User Interface/Desktops
%description -n libreport-gtk
Applications for reporting bugs using libreport backend.
%package libs
Summary: Libraries for %{name}
Group: System Environment/Libraries
@ -70,7 +113,7 @@ Libraries for %{name}.
%package devel
Summary: Development libraries for %{name}
Group: Development/Libraries
Requires: %{name}-libs = %{version}-%{release}
Requires: abrt-libs = %{version}-%{release}
%description devel
Development libraries and headers for %{name}.
@ -79,10 +122,7 @@ Development libraries and headers for %{name}.
Summary: %{name}'s gui
Group: User Interface/Desktops
Requires: %{name} = %{version}-%{release}
Requires: dbus-python, pygtk2, pygtk2-libglade,
Requires: gnome-python2-gnomekeyring
# only if gtk2 version < 2.17:
#Requires: python-sexy
Requires: libreport-gtk
# we used to have abrt-applet, now abrt-gui includes it:
Provides: abrt-applet = %{version}-%{release}
Obsoletes: abrt-applet < 0.0.5
@ -94,8 +134,7 @@ GTK+ wizard for convenient bug reporting.
%package addon-ccpp
Summary: %{name}'s C/C++ addon
Group: System Environment/Libraries
Requires: elfutils
Requires: yum-utils
Requires: elfutils, cpio
Requires: %{name} = %{version}-%{release}
%description addon-ccpp
@ -107,9 +146,9 @@ Summary: %{name}'s kerneloops addon
Group: System Environment/Libraries
Requires: curl
Requires: %{name} = %{version}-%{release}
Obsoletes: kerneloops
Obsoletes: abrt-plugin-kerneloops
Obsoletes: abrt-plugin-kerneloopsreporter
Obsoletes: kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloops > 0.0.1
Obsoletes: abrt-plugin-kerneloopsreporter > 0.0.1
%description addon-kerneloops
This package contains plugin for collecting kernel crash information
@ -134,23 +173,6 @@ Requires: mailx
The simple reporter plugin which sends a report via mailx to a specified
email address.
%package plugin-runapp
Summary: %{name}'s runapp plugin
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
%description plugin-runapp
Plugin to run external programs.
%package plugin-sosreport
Summary: %{name}'s sosreport plugin
Group: System Environment/Libraries
Requires: sos
Requires: %{name} = %{version}-%{release}
%description plugin-sosreport
Plugin to include an sosreport in an abrt report.
%package plugin-bugzilla
Summary: %{name}'s bugzilla plugin
Group: System Environment/Libraries
@ -163,9 +185,9 @@ Plugin to report bugs into the bugzilla.
Summary: %{name}'s RHTSupport plugin
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Obsoletes: abrt-plugin-catcut
Obsoletes: abrt-plugin-rhfastcheck
Obsoletes: abrt-plugin-rhticket
Obsoletes: abrt-plugin-catcut > 0.0.1
Obsoletes: abrt-plugin-rhfastcheck > 0.0.1
Obsoletes: abrt-plugin-rhticket > 0.0.1
%description plugin-rhtsupport
Plugin to report bugs into RH support system.
@ -174,24 +196,17 @@ Plugin to report bugs into RH support system.
Summary: %{name}'s reportuploader plugin
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Obsoletes: abrt-plugin-ticketuploader
Obsoletes: abrt-plugin-ticketuploader > 0.0.1
%description plugin-reportuploader
Plugin to report bugs into anonymous FTP site associated with ticketing system.
%package plugin-filetransfer
Summary: %{name}'s File Transfer plugin
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
%description plugin-filetransfer
Plugin to uploading files to a server.
%package addon-python
Summary: %{name}'s addon for catching and analyzing Python exceptions
Group: System Environment/Libraries
Requires: python
Requires: %{name} = %{version}-%{release}
Obsoletes: gnome-python2-bugbuddy
Obsoletes: gnome-python2-bugbuddy > 0.0.1
Provides: gnome-python2-bugbuddy
%description addon-python
@ -202,9 +217,9 @@ uncaught exception in python programs.
Summary: %{name}'s command line interface
Group: User Interface/Desktops
Requires: %{name} = %{version}-%{release}
Requires: %{name}-addon-kerneloops
Requires: %{name}-addon-ccpp, %{name}-addon-python
Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger, %{name}-plugin-runapp
Requires: abrt-addon-kerneloops
Requires: abrt-addon-ccpp, abrt-addon-python
Requires: abrt-plugin-bugzilla, abrt-plugin-logger
%description cli
This package contains simple command line client for controlling abrt daemon over
@ -219,28 +234,42 @@ Group: User Interface/Desktops
# Installing abrt-desktop should result in the abrt which works without
# any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
Requires: %{name} = %{version}-%{release}
Requires: %{name}-addon-kerneloops
Requires: %{name}-addon-ccpp, %{name}-addon-python
Requires: abrt-addon-kerneloops
Requires: abrt-addon-ccpp, abrt-addon-python
# Default config of addon-ccpp requires gdb
Requires: gdb >= 7.0-3
Requires: %{name}-gui
Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla, %{name}-plugin-runapp
#Requires: %{name}-plugin-firefox
Obsoletes: bug-buddy
Requires: abrt-gui
Requires: abrt-plugin-logger, abrt-plugin-bugzilla
#Requires: abrt-plugin-firefox
Obsoletes: bug-buddy > 0.0.1
Provides: bug-buddy
%description desktop
Virtual package to make easy default installation on desktop environments.
%package retrace-server
Summary: %{name}'s retrace server using HTTP protocol
Group: System Environment/Daemons
Requires: abrt-addon-ccpp
Requires: gdb >= 7.0-3
Requires: httpd, mod_wsgi, mod_ssl, python-webob
Requires: mock, xz, elfutils, createrepo
%{?el6:Requires: python-argparse}
Requires(preun): /sbin/install-info
Requires(post): /sbin/install-info
%description retrace-server
The retrace server provides a coredump analysis and backtrace
generation service over a network using HTTP protocol.
%prep
%setup -q
%patch0 -p1 -b .hideprefs
# rawhide packages are not signed, so we need to disable the gpg check
%patch1 -p1 -b .disable_gpg_check
# general patches
%patch2 -p1 -b .blacklist_mono
%patch0 -p1 -b .libreport_py
# FIXME remove when settings check is implemented
%patch1 -p1 -b .warning
%build
autoconf
%configure
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
@ -252,18 +281,15 @@ rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
%find_lang %{name}
#rm -rf $RPM_BUILD_ROOT/%{_libdir}/lib*.la
#rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/lib*.la
# remove all .la and .a files
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
mkdir -p ${RPM_BUILD_ROOT}/%{_initrddir}
install -m 755 %SOURCE1 ${RPM_BUILD_ROOT}/%{_initrddir}/abrtd
# /var/cache/%{name} is to be removed in 1.3.x timeframe
mkdir -p $RPM_BUILD_ROOT/var/cache/%{name}
mkdir -p $RPM_BUILD_ROOT/var/cache/%{name}-di
mkdir -p $RPM_BUILD_ROOT/var/run/%{name}
mkdir -p $RPM_BUILD_ROOT/var/spool/%{name}
mkdir -p $RPM_BUILD_ROOT/var/spool/%{name}-upload
install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}/%{_initrddir}/abrt-ccpp
mkdir -p $RPM_BUILD_ROOT/var/cache/abrt-di
mkdir -p $RPM_BUILD_ROOT/var/run/abrt
mkdir -p $RPM_BUILD_ROOT/var/spool/abrt
mkdir -p $RPM_BUILD_ROOT/var/spool/abrt-upload
desktop-file-install \
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
@ -273,7 +299,10 @@ desktop-file-install \
desktop-file-install \
--dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart \
src/Applet/%{name}-applet.desktop
src/applet/abrt-applet.desktop
# After everything is installed, remove info dir
rm -f %{buildroot}%{_infodir}/dir
%clean
rm -rf $RPM_BUILD_ROOT
@ -287,29 +316,50 @@ exit 0
%post
if [ $1 -eq 1 ]; then
/sbin/chkconfig --add %{name}d
/sbin/chkconfig --add abrtd
fi
#systemd
%if %{?with_systemd}
#if [ $1 -eq 1 ]; then
# Enable (but don't start) the units by default
/bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
/bin/systemctl enable abrtd.service >/dev/null 2>&1 || :
#fi
%endif
%post addon-ccpp
#if [ $1 -eq 1 ]; then
/sbin/chkconfig --add abrt-ccpp
#fi
#systemd: TODO
%post retrace-server
/sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
%preun
if [ "$1" -eq "0" ] ; then
service %{name}d stop >/dev/null 2>&1
/sbin/chkconfig --del %{name}d
service abrtd stop >/dev/null 2>&1
/sbin/chkconfig --del abrtd
fi
#systemd
%if %{?with_systemd}
if [ "$1" -eq "0" ] ; then
/bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
/bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
/bin/systemctl stop abrtd.service >/dev/null 2>&1 || :
/bin/systemctl disable abrtd.service >/dev/null 2>&1 || :
fi
%endif
%preun addon-ccpp
if [ "$1" -eq "0" ] ; then
service abrt-ccpp stop >/dev/null 2>&1
/sbin/chkconfig --del abrt-ccpp
fi
#systemd: TODO
%preun retrace-server
if [ "$1" = 0 ]; then
/sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
fi
%postun
#systemd
%if %{?with_systemd}
@ -338,151 +388,172 @@ fi
%posttrans
if [ "$1" -eq "0" ]; then
service %{name}d condrestart >/dev/null 2>&1 || :
service abrtd condrestart >/dev/null 2>&1 || :
fi
#systemd
%if %{?with_systemd}
if [ "$1" -eq "0" ]; then
/bin/systemctl try-restart %{name}d.service >/dev/null 2>&1 || :
/bin/systemctl try-restart abrtd.service >/dev/null 2>&1 || :
fi
%endif
%posttrans addon-ccpp
if [ "$1" -eq "0" ]; then
#service abrt-ccpp condrestart >/dev/null 2>&1 || :
# this is a tmp hack to set-up the ccpp hook when updating
# from 1.x to 2.x without restarting
service abrt-ccpp restart >/dev/null 2>&1 || :
fi
#systemd: TODO
%files -f %{name}.lang
%defattr(-,root,root,-)
%doc README COPYING
#systemd
%if %{?with_systemd}
/lib/systemd/system/%{name}d.service
/lib/systemd/system/abrtd.service
%endif
%{_sbindir}/%{name}d
%{_bindir}/%{name}-debuginfo-install
%{_bindir}/%{name}-handle-upload
%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
%{_sbindir}/abrtd
%{_sbindir}/abrt-server
%{_bindir}/abrt-handle-upload
%{_bindir}/abrt-handle-crashdump
%{_bindir}/abrt-action-save-package-data
%{_bindir}/abrt-retrace-client
%config(noreplace) %{_sysconfdir}/%{name}/abrt.conf
%config(noreplace) %{_sysconfdir}/%{name}/abrt_event.conf
%config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
%{_initrddir}/%{name}d
# /var/cache/%{name} is to be removed in 1.3.x timeframe
%dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/%{name}
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-abrt.conf
%{_initrddir}/abrtd
%dir %attr(0755, abrt, abrt) %{_localstatedir}/spool/%{name}
%dir %attr(0700, abrt, abrt) %{_localstatedir}/spool/%{name}-upload
%dir /var/run/%{name}
%dir %attr(0775, abrt, abrt) %{_localstatedir}/run/%{name}
%dir %{_sysconfdir}/%{name}
%dir %{_sysconfdir}/%{name}/plugins
%dir %{_libdir}/%{name}
%dir %{_sysconfdir}/%{name}/events.d
#%dir %{_libdir}/%{name}
%{_mandir}/man8/abrtd.8.gz
%{_mandir}/man5/%{name}.conf.5.gz
#%{_mandir}/man5/pyhook.conf.5.gz
# {_mandir}/man5/pyhook.conf.5.gz
%{_mandir}/man7/%{name}-plugins.7.gz
%{_datadir}/polkit-1/actions/org.fedoraproject.abrt.policy
%{_datadir}/dbus-1/system-services/com.redhat.abrt.service
%config(noreplace) %{_sysconfdir}/%{name}/plugins/SQLite3.conf
%{_libdir}/%{name}/libSQLite3.so*
%{_mandir}/man7/%{name}-SQLite3.7.gz
%files -n libreport
%defattr(-,root,root,-)
%{_libdir}/libreport.so.*
%files -n libreport-devel
%defattr(-,root,root,-)
%{_includedir}/report/*
%{_libdir}/libreport.so
#%files -n libreport-python
#%defattr(-,root,root,-)
#%{python_sitearch}/report/*
%files -n libreport-gtk
%defattr(-,root,root,-)
%{_bindir}/bug-reporting-wizard
%{_libdir}/libreportgtk.so.*
%files libs
%defattr(-,root,root,-)
%{_libdir}/lib*.so.*
%{_libdir}/libabrt*.so.*
%{_libdir}/libbtparser.so.*
%files devel
%defattr(-,root,root,-)
%{_includedir}/*
%{_libdir}/lib*.so
%{_includedir}/abrt/*
%{_libdir}/libabrt*.so
%{_libdir}/libbtparser.so
#FIXME: this should go to libreportgtk-devel package
%{_libdir}/libreportgtk.so*
%{_libdir}/pkgconfig/*
%doc doc/abrt-plugin doc/howto-write-reporter
%files gui
%defattr(-,root,root,-)
%{_bindir}/%{name}-gui
%{_bindir}/abrt-gui
%dir %{_datadir}/%{name}
# all glade, gtkbuilder and py files for gui
%{_datadir}/%{name}/*.py*
%{_datadir}/%{name}/*.glade
%{_datadir}/applications/fedora-%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/*
%{_datadir}/icons/hicolor/*/status/*
%{_datadir}/%{name}/icons/hicolor/*/status/*
%{_bindir}/%{name}-applet
%{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
%{_bindir}/abrt-applet
#%{_bindir}/test-report
%{_sysconfdir}/xdg/autostart/abrt-applet.desktop
%files addon-ccpp
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
%dir %{_localstatedir}/cache/%{name}-di
%{_libdir}/%{name}/libCCpp.so*
%dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
%{_initrddir}/abrt-ccpp
%{_libexecdir}/abrt-hook-ccpp
%{_bindir}/abrt-action-analyze-c
%{_bindir}/abrt-action-trim-files
%attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
%{_bindir}/abrt-action-install-debuginfo.py*
%{_bindir}/abrt-action-generate-backtrace
%{_bindir}/abrt-action-analyze-backtrace
%{_bindir}/abrt-action-list-dsos.py*
%{_sysconfdir}/%{name}/events.d/ccpp_events.conf
%{_sysconfdir}/%{name}/events/analyze_LocalGDB.xml
%{_sysconfdir}/%{name}/events/reanalyze_LocalGDB.xml
%{_sysconfdir}/%{name}/events/analyze_RetraceServer.xml
%{_sysconfdir}/%{name}/events/reanalyze_RetraceServer.xml
%files addon-kerneloops
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
%{_bindir}/dumpoops
%{_libdir}/%{name}/libKerneloops.so*
%{_libdir}/%{name}/libKerneloopsScanner.so*
%{_mandir}/man7/%{name}-KerneloopsScanner.7.gz
%{_libdir}/%{name}/libKerneloopsReporter.so*
%{_libdir}/%{name}/KerneloopsReporter.glade
%{_mandir}/man7/%{name}-KerneloopsReporter.7.gz
%{_sysconfdir}/%{name}/events/report_Kerneloops.xml
%{_sysconfdir}/%{name}/events.d/koops_events.conf
%{_mandir}/man7/abrt-KerneloopsReporter.7.gz
%{_bindir}/abrt-dump-oops
%{_bindir}/abrt-action-analyze-oops
%{_bindir}/abrt-action-kerneloops
%files plugin-logger
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Logger.conf
%{_libdir}/%{name}/libLogger.so*
%{_libdir}/%{name}/Logger.glade
%{_mandir}/man7/%{name}-Logger.7.gz
%{_sysconfdir}/%{name}/events/report_Logger.conf
%{_mandir}/man7/abrt-Logger.7.gz
%{_bindir}/abrt-action-print
%files plugin-mailx
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Mailx.conf
%{_libdir}/%{name}/libMailx.so*
%{_libdir}/%{name}/Mailx.glade
%{_mandir}/man7/%{name}-Mailx.7.gz
%files plugin-runapp
%defattr(-,root,root,-)
%{_libdir}/%{name}/libRunApp.so*
%{_mandir}/man7/%{name}-RunApp.7.gz
%files plugin-sosreport
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/SOSreport.conf
%{_libdir}/%{name}/libSOSreport.so*
%{_sysconfdir}/%{name}/events/report_Mailx.xml
%{_sysconfdir}/%{name}/events.d/mailx_events.conf
%{_mandir}/man7/abrt-Mailx.7.gz
%{_bindir}/abrt-action-mailx
%files plugin-bugzilla
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Bugzilla.conf
%{_libdir}/%{name}/libBugzilla.so*
%{_libdir}/%{name}/Bugzilla.glade
%{_mandir}/man7/%{name}-Bugzilla.7.gz
%{_sysconfdir}/%{name}/events/report_Bugzilla.xml
%config(noreplace) %{_sysconfdir}/%{name}/events/report_Bugzilla.conf
# FIXME: remove with the old gui
%{_mandir}/man7/abrt-Bugzilla.7.gz
%{_bindir}/abrt-action-bugzilla
%files plugin-rhtsupport
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/RHTSupport.conf
%{_libdir}/%{name}/libRHTSupport.so*
%{_libdir}/%{name}/RHTSupport.glade
#%{_mandir}/man7/%{name}-RHTSupport.7.gz
%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
# {_mandir}/man7/abrt-RHTSupport.7.gz
%{_bindir}/abrt-action-rhtsupport
%files plugin-reportuploader
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/ReportUploader.conf
%{_libdir}/%{name}/libReportUploader.so*
%{_libdir}/%{name}/ReportUploader.glade
%{_mandir}/man7/%{name}-ReportUploader.7.gz
%files plugin-filetransfer
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/FileTransfer.conf
%{_libdir}/%{name}/libFileTransfer.so*
%{_mandir}/man7/%{name}-FileTransfer.7.gz
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Upload.conf
%{_mandir}/man7/abrt-Upload.7.gz
%{_bindir}/abrt-action-upload
%files addon-python
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
%{_libdir}/%{name}/libPython.so*
%{_bindir}/abrt-action-analyze-python
%{python_site}/*.py*
%{python_site}/abrt.pth
%files cli
%defattr(-,root,root,-)
%{_bindir}/abrt-cli
@ -492,7 +563,22 @@ fi
%files desktop
%defattr(-,root,root,-)
%files retrace-server
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
%config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
%config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
%{_bindir}/abrt-retrace-worker
%{_datadir}/abrt-retrace/*.py*
%{_datadir}/abrt-retrace/*.wsgi
%{_infodir}/abrt-retrace-server*
%changelog
* Wed Mar 16 2011 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.0-1
- update to the latest upstream version
- many improvements
- FIXME: add closed bugzillas
* Fri Feb 18 2011 Jiri Moskovcak <jmoskovc@redhat.com> 1.1.17-2
- removed gnome-python2-vfs dependency
@ -647,7 +733,7 @@ fi
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1.1
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
* Thu Jun 10 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.1.5-1
* Wed Jun 09 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.1.5-1
- GUI: polished the reporter assistant (jmoskovc@redhat.com)
- Logger reporter: do not store useless info (vda.linux@googlemail.com)
- ccpp hook: add SaveBinaryImage option which saves of the crashed binary (vda.linux@googlemail.com)

View File

@ -0,0 +1,6 @@
diff -u -r abrt-1.2.0/src/Makefile.am abrt-1.2.0_/src/Makefile.am
--- abrt-1.2.0/src/Makefile.am 2011-03-14 17:51:12.000000000 +0100
+++ abrt-1.2.0_/src/Makefile.am 2011-03-16 15:32:36.989851003 +0100
@@ -1 +1 @@
-SUBDIRS = include lib report-python hooks btparser daemon applet gtk-helpers gui-gtk cli plugins gui-wizard-gtk retrace
+SUBDIRS = include lib hooks btparser daemon applet gtk-helpers gui-gtk cli plugins gui-wizard-gtk retrace

22
settings_warning.patch Normal file
View File

@ -0,0 +1,22 @@
diff --git a/src/gui-wizard-gtk/wizard.c b/src/gui-wizard-gtk/wizard.c
index 31c7bb2..e08dc4e 100644
--- a/src/gui-wizard-gtk/wizard.c
+++ b/src/gui-wizard-gtk/wizard.c
@@ -1268,6 +1268,17 @@ static void add_pages(void)
config_btn = GTK_WIDGET(gtk_builder_get_object(builder, "button_cfg2"));
if (config_btn)
g_signal_connect(G_OBJECT(config_btn), "clicked", G_CALLBACK(on_show_event_list_cb), NULL);
+
+ //hack to warn user about settings - will be removed before F15 GOLD
+ GtkWidget *settings_warning_eb = gtk_event_box_new();
+ GtkWidget *settings_warning_lbl = gtk_label_new(_("Please make sure you configured the reporters."));
+ gtk_container_add(GTK_CONTAINER(settings_warning_eb), settings_warning_lbl);
+ gtk_box_pack_start(GTK_BOX(pages[PAGENO_REPORTER_SELECTOR].page_widget), settings_warning_eb, false, false, 0);
+ GdkColor bg_color;
+ gdk_color_parse("red", &bg_color);
+ gtk_widget_modify_bg(settings_warning_eb, GTK_STATE_NORMAL, &bg_color);
+ gtk_widget_show_all(settings_warning_eb);
+
}
void create_assistant()

View File

@ -1 +1 @@
71e8ff8bc5616a44ac38d07365b68452 abrt-1.1.17.tar.gz
c4b486d64d0d908f56785e51be756ebc abrt-2.0.0.tar.gz