New upstream release 2.1.8
And also remove unused patches Resolves: #812204
This commit is contained in:
parent
348130428e
commit
332ed5e2cc
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ abrt-1.1.13.tar.gz
|
||||
/abrt-2.1.5.tar.gz
|
||||
/abrt-2.1.6.tar.gz
|
||||
/abrt-2.1.7.tar.gz
|
||||
/abrt-2.1.8.tar.gz
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,58 +0,0 @@
|
||||
diff -ruN abrt-2.1.6/src/configuration-gui/Makefile.am abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.am
|
||||
--- abrt-2.1.6/src/configuration-gui/Makefile.am 2013-07-23 10:10:02.000000000 +0200
|
||||
+++ abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.am 2013-07-26 18:23:04.000000000 +0200
|
||||
@@ -4,9 +4,17 @@
|
||||
abrt-config-widget.c \
|
||||
abrt-config-widget.h
|
||||
|
||||
+# G_DEFINE_TYPE(...) macros result in
|
||||
+# typedef '_GStaticAssertCompileTimeAssertion_0' locally defined but not used
|
||||
+# warnings on some glib versions
|
||||
+# (observed on glib2-2.34.2 on F18).
|
||||
+# -Wno-error=unused-local-typedefs in CPPFLAGS suppresses this warning.
|
||||
+# Newer glib may have it fixed.
|
||||
+
|
||||
libabrtconfigui_la_CPPFLAGS = \
|
||||
-I$(srcdir)/../include \
|
||||
-I$(srcdir)/../lib \
|
||||
+ -Wno-error=unused-local-typedefs \
|
||||
$(LIBREPORT_CFLAGS) \
|
||||
$(GTK_CFLAGS) \
|
||||
-DABRT_UI_DIR="\"$(uidir)\"" \
|
||||
@@ -25,6 +33,7 @@
|
||||
system_config_abrt_CPPFLAGS = \
|
||||
-I$(srcdir)/../include \
|
||||
-I$(srcdir)/../lib \
|
||||
+ -Wno-error=unused-local-typedefs \
|
||||
$(GTK_CFLAGS) \
|
||||
$(LIBREPORT_CFLAGS)
|
||||
|
||||
diff -ruN abrt-2.1.6/src/configuration-gui/Makefile.in abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.in
|
||||
--- abrt-2.1.6/src/configuration-gui/Makefile.in 2013-07-26 07:55:59.000000000 +0200
|
||||
+++ abrt-2.1.6.3.g85d7/src/configuration-gui/Makefile.in 2013-07-26 18:23:48.000000000 +0200
|
||||
@@ -419,9 +419,17 @@
|
||||
abrt-config-widget.c \
|
||||
abrt-config-widget.h
|
||||
|
||||
+
|
||||
+# G_DEFINE_TYPE(...) macros result in
|
||||
+# typedef '_GStaticAssertCompileTimeAssertion_0' locally defined but not used
|
||||
+# warnings on some glib versions
|
||||
+# (observed on glib2-2.34.2 on F18).
|
||||
+# -Wno-error=unused-local-typedefs in CPPFLAGS suppresses this warning.
|
||||
+# Newer glib may have it fixed.
|
||||
libabrtconfigui_la_CPPFLAGS = \
|
||||
-I$(srcdir)/../include \
|
||||
-I$(srcdir)/../lib \
|
||||
+ -Wno-error=unused-local-typedefs \
|
||||
$(LIBREPORT_CFLAGS) \
|
||||
$(GTK_CFLAGS) \
|
||||
-DABRT_UI_DIR="\"$(uidir)\"" \
|
||||
@@ -438,6 +446,7 @@
|
||||
system_config_abrt_CPPFLAGS = \
|
||||
-I$(srcdir)/../include \
|
||||
-I$(srcdir)/../lib \
|
||||
+ -Wno-error=unused-local-typedefs \
|
||||
$(GTK_CFLAGS) \
|
||||
$(LIBREPORT_CFLAGS)
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 133940d93193f82c5cc63d627f691291dfd7759a Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Tue, 6 Aug 2013 12:32:45 +0200
|
||||
Subject: [ABRT PATCH] a-a-ureport: generate core_backtrace only for CCpp
|
||||
problems
|
||||
|
||||
Closes rhbz#993630
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
Signed-off-by: Martin Milata <mmilata@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-action-ureport | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-action-ureport b/src/plugins/abrt-action-ureport
|
||||
index 41916bd..44575d8 100755
|
||||
--- a/src/plugins/abrt-action-ureport
|
||||
+++ b/src/plugins/abrt-action-ureport
|
||||
@@ -59,6 +59,13 @@ if __name__ == "__main__":
|
||||
dd = dd_opendir(dirname, 0)
|
||||
if not dd:
|
||||
sys.exit(1)
|
||||
+
|
||||
+ report_type = dd.load_text("type", DD_FAIL_QUIETLY_ENOENT)
|
||||
+
|
||||
+ # because of backward compatibility
|
||||
+ if not report_type:
|
||||
+ report_type = dd.load_text("analyzer", 0)
|
||||
+
|
||||
core_backtrace_exists = dd.exist("core_backtrace")
|
||||
reported_to = dd.load_text("reported_to", DD_FAIL_QUIETLY_ENOENT)
|
||||
ureports_counter = try_parse_number(dd, "ureports_counter")
|
||||
@@ -90,7 +97,7 @@ if __name__ == "__main__":
|
||||
log(_("uReport was already sent, not sending it again"))
|
||||
sys.exit(0)
|
||||
|
||||
- if not core_backtrace_exists:
|
||||
+ if report_type == "CCpp" and not core_backtrace_exists:
|
||||
exitcode = spawn_and_wait("abrt-action-generate-core-backtrace")
|
||||
if exitcode != 0:
|
||||
log1("uReport can't be sent without core_backtrace. Exiting.")
|
||||
--
|
||||
1.8.3.1
|
||||
|
27
abrt.spec
27
abrt.spec
@ -27,11 +27,11 @@
|
||||
%define desktopvendor fedora
|
||||
%endif
|
||||
|
||||
%define libreport_ver 2.1.7
|
||||
%define libreport_ver 2.1.8
|
||||
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.1.7
|
||||
Version: 2.1.8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
@ -59,9 +59,9 @@ BuildRequires: asciidoc
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: xmlto
|
||||
BuildRequires: libreport-devel >= %{libreport_ver}
|
||||
BuildRequires: satyr-devel >= 0.9
|
||||
BuildRequires: satyr-devel >= 0.10
|
||||
Requires: libreport >= %{libreport_ver}
|
||||
Requires: satyr >= 0.9
|
||||
Requires: satyr >= 0.10
|
||||
|
||||
%if %{with systemd}
|
||||
Requires: systemd-units
|
||||
@ -135,6 +135,7 @@ Requires: %{name}-retrace-client
|
||||
%endif
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: abrt-libs = %{version}-%{release}
|
||||
Requires: libreport-python
|
||||
|
||||
%description addon-ccpp
|
||||
This package contains hook for C/C++ crashed programs and %{name}'s C/C++
|
||||
@ -191,6 +192,7 @@ Requires: %{name} = %{version}-%{release}
|
||||
Requires: abrt-addon-kerneloops
|
||||
Requires: crash
|
||||
Requires: kexec-tools
|
||||
Requires: abrt-python
|
||||
|
||||
%description addon-vmcore
|
||||
This package contains plugin for collecting kernel crash information from
|
||||
@ -685,7 +687,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_bindir}/abrt-action-analyze-backtrace
|
||||
%{_bindir}/abrt-action-list-dsos
|
||||
%{_bindir}/abrt-action-perform-ccpp-analysis
|
||||
%{_bindir}/abrt-dedup-client
|
||||
%{_bindir}/abrt-action-analyze-ccpp-local
|
||||
%{_sbindir}/abrt-install-ccpp-hook
|
||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
|
||||
@ -710,7 +711,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_mandir}/man*/abrt-action-analyze-core.*
|
||||
%{_mandir}/man*/abrt-action-analyze-vulnerability.*
|
||||
%{_mandir}/man*/abrt-action-perform-ccpp-analysis.*
|
||||
%{_mandir}/man*/abrt-dedup-client.*
|
||||
|
||||
%files addon-upload-watch
|
||||
%defattr(-,root,root,-)
|
||||
@ -831,6 +831,21 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Fri Oct 04 2013 Jakub Filak <jfilak@redhat.com> 2.1.8-1
|
||||
- Disassemble only instruction rage memory if backtrace is too big
|
||||
- Include floating-point registers in the backtrace
|
||||
- spec: make addon-ccpp dependent on libreport-python
|
||||
- polkit: replace deprecated functions with their subtitues
|
||||
- retrace-client: query CCpp exploitable information from Retrace server; closes #703
|
||||
- GUI config: add support for Private ticket option
|
||||
- a-a-ureport: handle os errors gracefully rhbz#998428 rhbz#998197
|
||||
- add prefix from configure to the path of debuginfo installer - closes #701
|
||||
- spec: added deps on abrt-python - closes rhbz#1008182
|
||||
- spec: remove abrt-dedup-client; closes #702
|
||||
- remove abrt-dedup-client; related to #702
|
||||
- abrt-*-client: simplify formatting of locale-related headers
|
||||
- Resolves: #812204
|
||||
|
||||
* Wed Sep 11 2013 Jakub Filak <jfilak@redhat.com> 2.1.7-1
|
||||
- fix debuginfo installer expecting user input from a pipe - closes #696
|
||||
- add environment variable whitelist to debuginfo install wrapper - closes #692
|
||||
|
Loading…
Reference in New Issue
Block a user