build fixes

This commit is contained in:
Jiří Moskovčák 2010-07-26 14:07:20 +00:00
parent 5486183fd7
commit 247876f55b
2 changed files with 42 additions and 1 deletions

36
abrt-1.1.10-applet.patch Normal file
View File

@ -0,0 +1,36 @@
commit 406c8793bef87fb49333d7196ea23d42be87c21e
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date: Mon Jul 26 15:33:02 2010 +0200
APPLET: minor build fix
diff --git a/src/Applet/CCApplet.cpp b/src/Applet/CCApplet.cpp
index 8596f4c..02d911d 100644
--- a/src/Applet/CCApplet.cpp
+++ b/src/Applet/CCApplet.cpp
@@ -361,7 +361,7 @@ void CApplet::Disable(const char *reason)
if (pixbuf)
{
gray_scaled = gdk_pixbuf_copy(pixbuf);
- gdk_pixbuf_saturate_and_pixelate(pixbuf, gray_scaled, 0.0, NULL);
+ gdk_pixbuf_saturate_and_pixelate(pixbuf, gray_scaled, 0.0, false);
gtk_status_icon_set_from_pixbuf(m_pStatusIcon, gray_scaled);
//do we need to free pixbufs nere?
}
diff --git a/src/Applet/Makefile.am b/src/Applet/Makefile.am
index 6abef3b..77c9fc9 100644
--- a/src/Applet/Makefile.am
+++ b/src/Applet/Makefile.am
@@ -26,10 +26,10 @@ abrt_applet_LDADD = \
-lglib-2.0 \
-lgthread-2.0 \
$(DBUS_LIBS) \
- $(LIBNOTIFY_LIBS)
+ $(LIBNOTIFY_LIBS) \
+ $(GTK_LIBS)
# ../../lib/Utils/libABRTdUtils.la
# $(DL_LIBS)
-# $(GTK_LIBS)
EXTRA_DIST = abrt-applet.desktop

View File

@ -11,7 +11,7 @@
%if 0%{?_buildid}
%define pkg_release 0.%{?_buildid}%{?dist}
%else
%define pkg_release 1%{?dist}
%define pkg_release 2%{?dist}
%endif
Summary: Automatic bug detection and reporting tool
@ -27,6 +27,7 @@ Source1: abrt.init
Patch0: abrt-1.0.9-hideprefs.patch
Patch1: abrt_disable_gpgcheck.diff
Patch2: blacklist_mono.patch
Patch3: abrt-1.1.10-applet.patch
BuildRequires: dbus-devel
BuildRequires: gtk2-devel
BuildRequires: curl-devel
@ -231,6 +232,7 @@ Virtual package to make easy default installation on desktop environments.
%patch1 -p1 -b .disable_gpg_check
# general patches
%patch2 -p1 -b .blacklist_mono
%patch3 -p1 -b .applet_build
%build
%configure
@ -443,6 +445,9 @@ fi
%defattr(-,root,root,-)
%changelog
* Mon Jul 26 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.1.10-2
- minor build fixes
* Mon Jul 26 2010 Jiri Moskovcak <jmoskovc@redhat.com> 1.1.10-1
- blacklisted mono-core package
- die with an error message if the database plugin is not accessible when needed (kklic@redhat.com)