First working 2.7.x spec file

This commit is contained in:
Marc Maurer 2009-06-11 22:14:45 +00:00
parent ba4886782d
commit 89cda7078e
5 changed files with 23 additions and 96 deletions

View File

@ -1,4 +1,2 @@
abiword-2.6.8.tar.gz
abiword-docs-2.6.8.tar.gz
abiword-extras-2.6.8.tar.gz
abiword-plugins-2.6.8.tar.gz
abiword-2.7.4.tar.gz
abiword-docs-2.7.4.tar.gz

View File

@ -1,15 +0,0 @@
diff -u -r abiword-extras-2.6.4.orig/dictionary/Makefile.am abiword-extras-2.6.4/dictionary/Makefile.am
--- abiword-extras-2.6.4.orig/dictionary/Makefile.am 2008-07-13 14:04:48.000000000 +0200
+++ abiword-extras-2.6.4/dictionary/Makefile.am 2008-07-13 21:23:26.000000000 +0200
@@ -4,9 +4,6 @@
dictionary_DATA = \
ca-ES-barbarism.xml \
en-AU-barbarism.xml \
- es-MX-barbarism.xml\
- ispell_dictionary_list.xml
+ es-MX-barbarism.xml
-EXTRA_DIST = $(dictionary_DATA) \
- BigEndian32.american.hash \
- LittleEndian32.american.hash
+EXTRA_DIST = $(dictionary_DATA)

View File

@ -1,12 +0,0 @@
diff -u -r abiword-plugins-2.6.8.orig/tools/abicommand/xp/AbiCommand.cpp abiword-plugins-2.6.8/tools/abicommand/xp/AbiCommand.cpp
--- abiword-plugins-2.6.8.orig/tools/abicommand/xp/AbiCommand.cpp 2007-10-11 22:05:55.000000000 +0200
+++ abiword-plugins-2.6.8/tools/abicommand/xp/AbiCommand.cpp 2009-03-09 16:59:14.000000000 +0100
@@ -551,7 +551,7 @@
UT_UTF8String *pCom1 =
const_cast < UT_UTF8String * >(static_cast < const UT_UTF8String * >(pToks->getNthItem (1)));
printf(" Filename %s \n",pCom1->utf8_str());
- char *suffix = rindex (pCom1->utf8_str (), '.');
+ const char *suffix = static_cast<const char*>(rindex (pCom1->utf8_str (), '.'));
if (suffix != NULL)
{

View File

@ -1,20 +1,18 @@
%define majorversion 2
%define minorversion 6
%define microversion 8
%define minorversion 7
%define microversion 4
%define olpc_build 0
Summary: The AbiWord word processor
Name: abiword
Version: %{majorversion}.%{minorversion}.%{microversion}
Release: 2%{?dist}
Release: 1%{?dist}
Epoch: 1
Group: Applications/Editors
License: GPLv2+
Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
Source11: abiword.mime
BuildRoot: %{_tmppath}/%{name}-%{version}-root
URL: http://www.abisource.com/
@ -30,7 +28,6 @@ Patch0: abiword-2.6.0-windowshelppaths.patch
Patch1: abiword-2.6.4-desktop.patch
Patch2: abiword-2.6.0-boolean.patch
Patch3: abiword-plugins-2.6.0-boolean.patch
Patch4: abiword-plugins-2.6.8-rindex.patch
%if %{olpc_build}
Patch100: abiword-2.6.4-defaultfont.patch
Patch101: abiword-2.6.4-draghandles.patch
@ -60,12 +57,10 @@ BuildRequires: libwmf-devel
BuildRequires: aiksaurus-devel, aiksaurus-gtk-devel
BuildRequires: link-grammar-devel >= 4.2.2
BuildRequires: gtkmathview-devel >= 0.7.5, flex, bison
BuildRequires: goffice04-devel
#BuildRequires: goffice04-devel
BuildRequires: loudmouth-devel
%if 0%{?fedora} >= 9
BuildRequires: asio-devel >= 0.3.8
%endif
%endif
%description -n libabiword
Library for developing applications based on AbiWord's core.
@ -81,6 +76,8 @@ Includes and definitions for developing with libabiword.
%prep
# setup abiword
%setup -q
# patch abiword
%patch1 -p1 -b .desktop
%if 0%{?fedora} >= 9
%patch2 -p1 -b .boolean
@ -91,56 +88,26 @@ Includes and definitions for developing with libabiword.
%patch102 -p1 -b .nohtmloptions
%endif
# setup abiword-plugins
%setup -q -T -b 1 -n abiword-plugins-%{version}
%patch3 -p1 -b .boolean
%patch4 -p1 -b .rindex
# setup abiword extras
%setup -q -T -b 2 -n abiword-extras-%{version}
# patch abiword plugins
#%patch3 -p1 -b .boolean
# setup abiword documentation
%setup -q -T -b 3 -n abiword-docs-%{version}
%setup -q -T -b 1 -n abiword-docs-%{version}
%patch0 -p1 -b .windowshelppaths
%build
# build libabiword and abiword
cd $RPM_BUILD_DIR/abiword-%{version}
%if %{olpc_build}
%configure --enable-libabiword --disable-bonobo --disable-gnomevfs --disable-gnomeui --disable-gucharmap --disable-printing
%configure --disable-static --disable-gnomevfs --disable-gucharmap --disable-printing --enable-plugins="loadbindings collab" --enable-collab-backend-sugar
%else
%configure --enable-libabiword
%configure --disable-static --enable-plugins --enable-clipart --enable-templates
%endif
make %{?_smp_mflags}
# build abiword-plugins
cd $RPM_BUILD_DIR/abiword-plugins-%{version}
export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
%if %{olpc_build}
CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --enable-libabiword --disable-all --enable-abicollab --with-abicollab-sugar-backend --enable-loadbindings --enable-OpenDocument --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
%else
CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
%endif
# Remove libtool predep_objects and postdep_objects wonkiness so that
# building without -nostdlib doesn't include them twice. Because we
# already link with g++, weird stuff happens if you don't let the
# compiler handle this.
sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
make %{?_smp_mflags}
# build the extras
cd $RPM_BUILD_DIR/abiword-extras-%{version}
# abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
# however, that file is not installed yet, so just point to it in the abiword source tree
export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
%configure
make
# build the documentation
cd $RPM_BUILD_DIR/abiword-docs-%{version}
ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
%install
rm -rf $RPM_BUILD_ROOT
@ -148,16 +115,6 @@ rm -rf $RPM_BUILD_ROOT
# install abiword
cd $RPM_BUILD_DIR/abiword-%{version}
make install DESTDIR=$RPM_BUILD_ROOT
# overwrite the static binary with the dynamic one
mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
# install abiword-plugins
cd $RPM_BUILD_DIR/abiword-plugins-%{version}
make install DESTDIR=$RPM_BUILD_ROOT
# install the extras
cd $RPM_BUILD_DIR/abiword-extras-%{version}
make install DESTDIR=$RPM_BUILD_ROOT
# install the documentation
cd $RPM_BUILD_DIR/abiword-docs-%{version}
@ -168,7 +125,7 @@ find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord
# finish up
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
cp $RPM_BUILD_DIR/abiword-%{version}/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
cd $RPM_BUILD_DIR/abiword-%{version}
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
@ -184,9 +141,8 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
# nuke .la files
rm -f $RPM_BUILD_ROOT/%{_libdir}/libabiword-%{majorversion}.%{minorversion}.la
rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{majorversion}.%{minorversion}/plugins/*.la
# nuke custom dictionary files
rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/dictionary/ispell_dictionary_list.xml
%clean
rm -rf $RPM_BUILD_ROOT
@ -203,10 +159,9 @@ update-desktop-database %{_datadir}/applications
%{_datadir}/applications/*
%{_datadir}/mime-info/*
%{_datadir}/pixmaps/*png
%{_datadir}/icons/*png
%files -n libabiword
%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
%doc $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT
%{_libdir}/libabiword-%{majorversion}.%{minorversion}.so
%{_libdir}/%{name}-%{majorversion}.%{minorversion}
%{_datadir}/%{name}-%{majorversion}.%{minorversion}
@ -216,6 +171,9 @@ update-desktop-database %{_datadir}/applications
%{_libdir}/pkgconfig/%{name}-%{majorversion}.%{minorversion}.pc
%changelog
* Thu Jun 11 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.4-1
- New upstream release
* Mon Mar 09 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.8-2
- Make g++ 4.4 and rindex friends again

View File

@ -1,4 +1,2 @@
fab04d8ef999c303f720197adf261310 abiword-2.6.8.tar.gz
5698c79cfa179f4b15c82a699d11a309 abiword-docs-2.6.8.tar.gz
e3cfff6ad4cda3e4200a75fd2665857a abiword-extras-2.6.8.tar.gz
421c49723e209c971ddb0798c1b313a9 abiword-plugins-2.6.8.tar.gz
83210c96f3cb30d1c787c6cf65a2f1ac abiword-2.7.4.tar.gz
150e2e8bdfeffe62ff2783275767f11e abiword-docs-2.7.4.tar.gz