This commit is contained in:
Peter Robinson 2016-11-29 23:48:40 +00:00
parent 35523bd83d
commit 6f5379884d
10 changed files with 10 additions and 521 deletions

View File

@ -1,36 +0,0 @@
From 9734c2cc2638b16cc9b9c33adb2fbe5b793226f5 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 6 Jun 2015 18:43:14 +0200
Subject: [PATCH] fix libwp? detection
---
plugin-configure.m4 | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/plugin-configure.m4 b/plugin-configure.m4
index 54998fb..92e4ec2 100644
--- a/plugin-configure.m4
+++ b/plugin-configure.m4
@@ -1355,7 +1355,7 @@ AC_SUBST([BMP_CFLAGS])
AC_SUBST([BMP_LIBS])
-wpg_pkgs="$gsf_req libwpg-0.2 >= 0.2.0 libwpd-0.9 >= 0.9.0 libwpd-stream-0.9 >= 0.9.0"
+wpg_pkgs="$gsf_req libwpg-0.3 libwpd-0.10 librevenge-0.0 librevenge-stream-0.0"
wpg_deps="no"
if test "$enable_wpg" != ""; then
@@ -1469,8 +1469,8 @@ AC_SUBST([AIKSAURUS_CFLAGS])
AC_SUBST([AIKSAURUS_LIBS])
-wordperfect_pkgs="libwpg-0.2 >= 0.2.0 libwpd-0.9 >= 0.9.0 libwpd-stream-0.9 >= 0.9.0 $gsf_req"
-wordperfect_wps_pkgs='libwps-0.2 >= 0.1.0'
+wordperfect_pkgs="libwpg-0.3 libwpd-0.10 librevenge-0.0 librevenge-stream-0.0 $gsf_req"
+wordperfect_wps_pkgs='libwps-0.3'
wordperfect_deps="no"
WORDPERFECT_CFLAGS=
--
2.4.2

View File

@ -1,35 +0,0 @@
--- abiword-3.0.0/plugins/grammar/linkgrammarwrap/LinkGrammarWrap.cpp.orig 2014-06-30 08:21:30.000000000 -0500
+++ abiword-3.0.0/plugins/grammar/linkgrammarwrap/LinkGrammarWrap.cpp 2014-06-30 08:27:01.000000000 -0500
@@ -220,6 +220,7 @@ bool LinkGrammarWrap::parseSentence(Piec
pErr = NULL;
}
+#ifdef DEAD_DEBUG_CODE
// for(i=0; i< pT->m_vecGrammarErrors.getItemCount(); i++)
// {
// pErr = pT->m_vecGrammarErrors.getNthItem(i);
@@ -227,15 +228,10 @@ bool LinkGrammarWrap::parseSentence(Piec
// }
UT_UTF8String sErr = linkage_get_violation_name(linkage);
// UT_DEBUGMSG(("Top Level error message |%s|\n",sErr.utf8_str()));
- UT_sint32 count = linkage_get_num_sublinkages(linkage);
//
// Find linkages with violations
//
- for(i=0; i<count;i++)
{
- UT_sint32 iok = linkage_set_current_sublinkage(linkage, i);
- if(iok == 0)
- continue;
UT_sint32 j = 0;
UT_sint32 iNum = linkage_get_num_links(linkage);
for(j=0;j< iNum;j++)
@@ -252,6 +248,8 @@ bool LinkGrammarWrap::parseSentence(Piec
}
}
linkage_delete(linkage);
+#endif // DEAD_DEBUG_CODE
+
for(i=0; i< vecMapOfWords.getItemCount(); i++)
{
AbiGrammarError * p = vecMapOfWords.getNthItem(i);

View File

@ -1,45 +0,0 @@
--- abiword-3.0.0/plugins/grammar/linkgrammarwrap/LinkGrammarWrap.cpp.orig 2014-06-29 14:50:30.000000000 -0500
+++ abiword-3.0.0/plugins/grammar/linkgrammarwrap/LinkGrammarWrap.cpp 2014-06-29 14:55:39.000000000 -0500
@@ -145,12 +145,11 @@ bool LinkGrammarWrap::parseSentence(Piec
}
AbiGrammarError * pWordMap = new AbiGrammarError();
pWordMap->m_iErrLow = iLow;
- pWordMap->m_iErrHigh = iLow + strlen(sentence_get_nth_word(sent, i));
+ pWordMap->m_iErrHigh = iLow + strlen(linkage_get_word(linkage, i));
pWordMap->m_iWordNum = i;
vecMapOfWords.addItem(pWordMap);
bool bNew = false;
- if(!sentence_nth_word_has_disjunction(sent, i))
- {
+
//UT_DEBUGMSG(("|%s| NULL LINK\n",sent->word[i].string));
if(pErr == NULL)
{
@@ -167,7 +166,7 @@ bool LinkGrammarWrap::parseSentence(Piec
}
pErr = new AbiGrammarError();
}
- iHigh = iLow + strlen(sentence_get_nth_word(sent, i));
+ iHigh = iLow + strlen(linkage_get_word(linkage, i));
pErr->m_iErrLow = iLow + iOff -1;
pErr->m_iErrHigh = iHigh + iOff -1;
if(pErr->m_iErrLow < 0)
@@ -188,7 +187,7 @@ bool LinkGrammarWrap::parseSentence(Piec
//
// Expand the sqiggle
//
- iHigh = iLow + strlen(sentence_get_nth_word(sent, i)) + iOff;
+ iHigh = iLow + strlen(linkage_get_word(linkage, i)) + iOff;
pErr->m_iErrHigh = iHigh;
if(pErr->m_iErrHigh < totlen-1)
{
@@ -196,8 +195,7 @@ bool LinkGrammarWrap::parseSentence(Piec
}
pErr->m_iWordNum = i;
}
- }
- iLow += strlen(sentence_get_nth_word(sent, i));
+ iLow += strlen(linkage_get_word(linkage, i));
}
//
// No NULL links but still an error , mark the whole sentence bad.

View File

@ -1,31 +0,0 @@
--- abiword-3.0.1/plugin-configure.m4.orig 2016-04-10 14:22:18.271356761 +0100
+++ abiword-3.0.1/plugin-configure.m4 2016-04-10 14:24:22.493303398 +0100
@@ -1355,7 +1355,7 @@
AC_SUBST([BMP_LIBS])
-wpg_pkgs="$gsf_req libwpg-0.3 libwpd-0.10 librevenge-0.0 librevenge-stream-0.0"
+wpg_pkgs="libwpg-0.3 $gsf_req"
wpg_deps="no"
if test "$enable_wpg" != ""; then
@@ -1469,8 +1469,8 @@
AC_SUBST([AIKSAURUS_LIBS])
-wordperfect_pkgs="libwpg-0.3 libwpd-0.10 librevenge-0.0 librevenge-stream-0.0 $gsf_req"
-wordperfect_wps_pkgs='libwps-0.4'
+wordperfect_pkgs="libwpd-0.10 $gsf_req"
+wordperfect_wps_pkgs='libwps-0.3'
wordperfect_deps="no"
WORDPERFECT_CFLAGS=
@@ -1499,7 +1499,7 @@
PKG_CHECK_EXISTS([ $wordperfect_wps_pkgs ],
[
- wp_deps_pkgs="$wp_deps_pkgs $wordperfect_wps_pkgs"
+ wp_deps_pkgs="$wordperfect_wps_pkgs $wp_deps_pkgs"
WPS_DEFINE=" -DHAVE_LIBWPS"
])

View File

@ -1,263 +0,0 @@
Index: src/af/xap/cocoa/xap_CocoaApp.h
===================================================================
--- src/af/xap/cocoa/xap_CocoaApp.h (revision 35181)
+++ src/af/xap/cocoa/xap_CocoaApp.h (working copy)
@@ -65,7 +65,7 @@
virtual void copyToClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard = true) = 0;
virtual void pasteFromClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard, bool bHonorFormatting = true) = 0;
virtual bool canPasteFromClipboard() = 0;
- virtual const char * getUserPrivateDirectory();
+ virtual const char * getUserPrivateDirectory() const;
virtual bool findAbiSuiteBundleFile(std::string & path, const char * filename, const char * subdir = 0); // checks only bundle
virtual bool findAbiSuiteLibFile(std::string & path, const char * filename, const char * subdir = 0);
virtual bool findAbiSuiteAppFile(std::string & path, const char * filename, const char * subdir = 0); // doesn't check user-dir
Index: src/af/xap/cocoa/xap_CocoaApp.cpp
===================================================================
--- src/af/xap/cocoa/xap_CocoaApp.cpp (revision 35181)
+++ src/af/xap/cocoa/xap_CocoaApp.cpp (working copy)
@@ -192,7 +192,7 @@
*flags = m_geometry.flags;
}
-const char * XAP_CocoaApp::getUserPrivateDirectory()
+const char * XAP_CocoaApp::getUserPrivateDirectory() const
{
static const char * szAbiDir = "Library/Application Support/AbiSuite";
Index: src/af/xap/gtk/xap_UnixApp.h
===================================================================
--- src/af/xap/gtk/xap_UnixApp.h (revision 35181)
+++ src/af/xap/gtk/xap_UnixApp.h (working copy)
@@ -73,7 +73,7 @@
virtual void pasteFromClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard, bool bHonorFormatting = true) = 0;
virtual bool canPasteFromClipboard() = 0;
void migrate(const char *oldName, const char *newName, const char *path) const;
- virtual const char * getUserPrivateDirectory();
+ virtual const char * getUserPrivateDirectory() const;
virtual void setSelectionStatus(AV_View * pView) = 0;
virtual void clearSelection() = 0;
Index: src/af/xap/gtk/xap_UnixApp.cpp
===================================================================
--- src/af/xap/gtk/xap_UnixApp.cpp (revision 35181)
+++ src/af/xap/gtk/xap_UnixApp.cpp (working copy)
@@ -207,70 +207,60 @@
}
// This should be removed at some time.
-void XAP_UnixApp::migrate (const char *oldName, const char *newName, const char *path) const
+void XAP_UnixApp::migrate(const char *oldName,
+ const char *newName, const char *path) const
{
- if (path && newName && oldName && (*oldName == '/'))
- {
- char *old = new char[strlen(path) - strlen(newName) + strlen(oldName)];
-
- if (old)
- {
- size_t len = strrchr(path, '/') - path;
- strncpy(old, path, len);
- old[len] = 0;
- strcat(old, oldName);
+ if (path && newName && oldName && (*oldName == '/')) {
- if (g_access(old, F_OK) == 0)
- {
- UT_WARNINGMSG(("Renaming: %s -> %s\n", old, path));
- g_rename(old, path);
- }
-
- delete[] old;
- }
- }
+ const char* end = strrchr(path, '/');
+ if (!end) {
+ UT_WARNINGMSG(("invalid path '%s', '/' not found", path));
+ return;
+ }
+
+ std::string old(path, end);
+ old += oldName;
+
+ if (g_access(old.c_str(), F_OK) == 0) {
+ UT_WARNINGMSG(("Renaming: %s -> %s\n", old.c_str(), path));
+ g_rename(old.c_str(), path);
+ }
+ }
}
-
-const char * XAP_UnixApp::getUserPrivateDirectory()
+
+const char * XAP_UnixApp::getUserPrivateDirectory() const
{
- /* return a pointer to a static buffer */
- static char *buf = NULL;
+ /* return a pointer to a static buffer */
+ static std::string private_dir;
- if (buf == NULL)
- {
- const char * szAbiDir = "abiword";
- const char * szCfgDir = ".config";
+ if (private_dir.empty()) {
+ const char * szAbiDir = "abiword";
+ const char * szCfgDir = ".config";
- const char * szXDG = getenv("XDG_CONFIG_HOME");
- if (!szXDG || !*szXDG) {
- const char * szHome = getenv("HOME");
- if (!szHome || !*szHome)
- szHome = "./";
+ const char * szXDG = getenv("XDG_CONFIG_HOME");
+ if (!szXDG || !*szXDG) {
+ const char * szHome = getenv("HOME");
+ if (!szHome || !*szHome)
+ szHome = "./";
- buf = new char[strlen(szHome)+strlen(szCfgDir)+strlen(szAbiDir)+4];
+ private_dir = szHome;
+ if (szHome[strlen(szHome)-1] != '/') {
+ private_dir.push_back('/');
+ }
+ private_dir += szCfgDir;
+ } else {
+ private_dir = szXDG;
+ }
- strcpy(buf, szHome);
- if (buf[strlen(buf)-1] != '/')
- strcat(buf, "/");
- strcat(buf, szCfgDir);
- } else {
- buf = new char[strlen(szXDG)+strlen(szAbiDir)+4];
- strcpy(buf, szXDG);
- }
+ private_dir += '/';
+ private_dir += szAbiDir;
- strcat(buf, "/");
- strcat(buf, szAbiDir);
-
-#ifdef PATH_MAX
- if (strlen(buf) >= PATH_MAX)
- DELETEPV(buf);
-#endif
-
- // migration / legacy
- migrate("/AbiSuite", szAbiDir, buf);
+ // migration / legacy
+ // XXX shouldn't that be /.AbiSuite ?
+ migrate("/AbiSuite", szAbiDir, private_dir.c_str());
}
- return buf;
+ return private_dir.c_str();
}
Index: src/af/xap/xp/xap_App.h
===================================================================
--- src/af/xap/xp/xap_App.h (revision 35181)
+++ src/af/xap/xp/xap_App.h (working copy)
@@ -178,7 +178,7 @@
virtual const XAP_StringSet * getStringSet() const = 0;
virtual void migrate(const char *oldName, const char *newName, const char *path) const;
- virtual const char * getUserPrivateDirectory() = 0;
+ virtual const char * getUserPrivateDirectory() const = 0;
virtual const char * getAbiSuiteLibDir() const;
virtual const char * getAbiSuiteAppDir() const = 0;
virtual bool findAbiSuiteLibFile(std::string & path, const char * filename, const char * subdir = 0);
Index: src/af/xap/win/xap_Win32App.h
===================================================================
--- src/af/xap/win/xap_Win32App.h (revision 35181)
+++ src/af/xap/win/xap_Win32App.h (working copy)
@@ -65,7 +65,7 @@
virtual void pasteFromClipboard(PD_DocumentRange * pDocRange, bool, bool) = 0;
virtual bool canPasteFromClipboard(void) = 0;
virtual void cacheCurrentSelection(AV_View *) = 0;
- virtual const char * getUserPrivateDirectory(void);
+ virtual const char * getUserPrivateDirectory(void) const;
virtual HICON getIcon(void) = 0;
virtual HICON getSmallIcon(void) = 0;
Index: src/af/xap/win/xap_Win32App.cpp
===================================================================
--- src/af/xap/win/xap_Win32App.cpp (revision 35181)
+++ src/af/xap/win/xap_Win32App.cpp (working copy)
@@ -238,7 +238,7 @@
return result;
}
-const char * XAP_Win32App::getUserPrivateDirectory(void)
+const char * XAP_Win32App::getUserPrivateDirectory(void) const
{
/* return a pointer to a static buffer */
Index: configure.ac
===================================================================
--- configure.ac (revision 35181)
+++ configure.ac (working copy)
@@ -616,7 +616,7 @@
#
# We need libpng
-for l in libpng libpng14 libpng12; do
+for l in libpng libpng16 libpng14 libpng12; do
AC_MSG_CHECKING(for $l)
if $PKG_CONFIG --exists $l ; then
AC_MSG_RESULT(yes)
Index: plugins/xslfo/xp/ie_exp_XSL-FO.cpp
===================================================================
--- plugins/xslfo/xp/ie_exp_XSL-FO.cpp (revision 35181)
+++ plugins/xslfo/xp/ie_exp_XSL-FO.cpp (working copy)
@@ -1451,7 +1451,7 @@
{ \
UT_UTF8String esc = szValue; \
esc.escapeXML(); \
- buf += " "x"=\""; \
+ buf += " " x"=\""; \
buf += esc.utf8_str(); \
buf += "\""; \
}
Index: plugins/latex/xp/ie_exp_LaTeX.cpp
===================================================================
--- plugins/latex/xp/ie_exp_LaTeX.cpp (revision 35181)
+++ plugins/latex/xp/ie_exp_LaTeX.cpp (working copy)
@@ -1330,7 +1330,7 @@
m_pie->write(sBuf.c_str(),sBuf.size());
}
-#define SUB(a,who) case a: subst = "\\(\\"who"\\)"; return true;
+#define SUB(a,who) case a: subst = "\\(\\" who"\\)"; return true;
#define SUBd(a,who) case a: subst = who; return true;
static bool _convertLettersToSymbols(char c, const char *& subst)
{
Index: plugins/collab/backends/service/xp/soa_soup.cpp
===================================================================
--- plugins/collab/backends/service/xp/soa_soup.cpp (revision 35181)
+++ plugins/collab/backends/service/xp/soa_soup.cpp (working copy)
@@ -163,7 +163,7 @@
static bool _invoke(const std::string& /*url*/, const soa::method_invocation& /*mi*/, SoaSoupSession& sess, std::string& result) {
if (!sess.m_session || !sess.m_msg )
- return soa::GenericPtr();
+ return false;
guint status = soup_session_send_message (sess.m_session, sess.m_msg);
if (!(SOUP_STATUS_IS_SUCCESSFUL (status) ||
Index: plugins/collab/backends/service/xp/RealmProtocol.cpp
===================================================================
--- plugins/collab/backends/service/xp/RealmProtocol.cpp (revision 35181)
+++ plugins/collab/backends/service/xp/RealmProtocol.cpp (working copy)
@@ -6,8 +6,8 @@
#define MAX_PACKET_DATA_SIZE 64*1024*1024
-#define RPV1_PACKET_NONEXISTENT -2
-#define RPV1_PACKET_VARIABLE -1
+#define RPV1_PACKET_NONEXISTENT uint32_t(-2)
+#define RPV1_PACKET_VARIABLE uint32_t(-1)
static uint32_t body_size[6] = {
RPV1_PACKET_NONEXISTENT, /* 0: reserved */

View File

@ -1,23 +0,0 @@
Index: plugins/collab/backends/service/xp/tls_tunnel.cpp
===================================================================
--- plugins/collab/backends/service/xp/tls_tunnel.cpp (revision 35191)
+++ plugins/collab/backends/service/xp/tls_tunnel.cpp (working copy)
@@ -306,9 +306,6 @@
disconnect_(transport_ptr, session_ptr, local_socket_ptr, remote_socket_ptr);
}
-static const int PRIORITIES[] = { GNUTLS_KX_ANON_DH, GNUTLS_KX_RSA, GNUTLS_KX_DHE_DSS, GNUTLS_KX_DHE_RSA, 0 };
-static const int CIPHERS[] = { GNUTLS_CIPHER_AES_256_CBC, GNUTLS_CIPHER_AES_128_CBC, GNUTLS_CIPHER_3DES_CBC, GNUTLS_CIPHER_ARCFOUR_128, 0 };
-
// FIXME: this clientproxy can only handle 1 SSL connection at the same time
ClientProxy::ClientProxy(const std::string& connect_address, unsigned short connect_port,
const std::string& ca_file, bool check_hostname)
@@ -400,8 +397,6 @@
// setup session
return_val_if_neg(gnutls_init(session_ptr.get(), GNUTLS_CLIENT), session_ptr_t());
return_val_if_neg(gnutls_set_default_priority(*session_ptr), session_ptr_t());
- return_val_if_neg(gnutls_kx_set_priority(*session_ptr,PRIORITIES), session_ptr_t());
- return_val_if_neg(gnutls_cipher_set_priority(*session_ptr,CIPHERS), session_ptr_t());
return_val_if_neg(gnutls_credentials_set(*session_ptr, GNUTLS_CRD_CERTIFICATE, x509cred), session_ptr_t());
// setup transport

View File

@ -1,54 +0,0 @@
From 6fcb43935bab90d61858eb1bc0f150c843586c54 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 6 Jun 2015 21:48:02 +0200
Subject: [PATCH] adapt to libwps 0.4
---
plugin-configure.m4 | 2 +-
plugins/wordperfect/plugin.m4 | 2 +-
plugins/wordperfect/xp/ie_imp_WordPerfect.cpp | 4 +++-
3 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/plugin-configure.m4 b/plugin-configure.m4
index 2757f4a..093fbcb 100644
--- a/plugin-configure.m4
+++ b/plugin-configure.m4
@@ -1470,7 +1470,7 @@ AC_SUBST([AIKSAURUS_LIBS])
wordperfect_pkgs="libwpg-0.3 libwpd-0.10 librevenge-0.0 librevenge-stream-0.0 $gsf_req"
-wordperfect_wps_pkgs='libwps-0.3'
+wordperfect_wps_pkgs='libwps-0.4'
wordperfect_deps="no"
WORDPERFECT_CFLAGS=
diff --git a/plugins/wordperfect/plugin.m4 b/plugins/wordperfect/plugin.m4
index 0aadbaf..bc32d48 100644
--- a/plugins/wordperfect/plugin.m4
+++ b/plugins/wordperfect/plugin.m4
@@ -1,6 +1,6 @@
wordperfect_pkgs="libwpd-0.10 $gsf_req"
-wordperfect_wps_pkgs='libwps-0.3'
+wordperfect_wps_pkgs='libwps-0.4'
wordperfect_deps="no"
WORDPERFECT_CFLAGS=
diff --git a/plugins/wordperfect/xp/ie_imp_WordPerfect.cpp b/plugins/wordperfect/xp/ie_imp_WordPerfect.cpp
index bd19971..3e69f79 100644
--- a/plugins/wordperfect/xp/ie_imp_WordPerfect.cpp
+++ b/plugins/wordperfect/xp/ie_imp_WordPerfect.cpp
@@ -1389,7 +1389,9 @@ UT_Confidence_t IE_Imp_MSWorks_Sniffer::recognizeContents (GsfInput * input)
AbiWordperfectInputStream gsfInput(input);
libwps::WPSKind kind;
- libwps::WPSConfidence confidence = libwps::WPSDocument::isFileFormatSupported(&gsfInput, kind);
+ libwps::WPSCreator creator;
+ bool needsEncoding = false;
+ libwps::WPSConfidence confidence = libwps::WPSDocument::isFileFormatSupported(&gsfInput, kind, creator, needsEncoding);
if (kind != libwps::WPS_TEXT)
confidence = libwps::WPS_CONFIDENCE_NONE;
--
2.4.2

View File

@ -1,11 +0,0 @@
--- a/src/Makefile.am 2013-02-19 18:39:42.000000000 -0600
+++ b/src/Makefile.am 2015-04-21 21:36:37.504001500 -0500
@@ -168,7 +168,7 @@ if HAVE_INTROSPECTION
INTROSPECTION_GIRS += Abi-@ABIWORD_SERIES@.gir
-Abi_@ABIWORD_SERIES@.gir: $(INTROSPECTION_SCANNER) libabiword-@ABIWORD_SERIES@.la Makefile
+Abi-@ABIWORD_SERIES@.gir: $(INTROSPECTION_SCANNER) libabiword-@ABIWORD_SERIES@.la Makefile
Abi_@ABI_SUB_SERIES@_gir_INCLUDES = GObject-2.0 Gtk-3.0 Gsf-1
Abi_@ABI_SUB_SERIES@_gir_CFLAGS = $(libabiword_@ABIWORD_SERIES@_la_CPPFLAGS)
Abi_@ABI_SUB_SERIES@_gir_LIBS = libabiword-@ABIWORD_SERIES@.la

View File

@ -1,12 +1,12 @@
%define majorversion 3
%define minorversion 0
%define microversion 1
%define microversion 2
%define svnver 0
Summary: Word processing program
Name: abiword
Version: %{majorversion}.%{minorversion}.%{microversion}
Release: 12%{?dist}
Release: 1%{?dist}
Epoch: 1
Group: Applications/Editors
License: GPLv2+
@ -21,14 +21,6 @@ Patch0: abiword-2.6.0-windowshelppaths.patch
Patch1: abiword-2.8.3-desktop.patch
Patch2: abiword-2.6.0-boolean.patch
Patch3: abiword-3.0.0-librevenge.patch
Patch4: abiword-3.0.0-link-grammar-5.patch
Patch5: abiword-3.0.0-link-grammar-5-second.patch
Patch6: abiword-3.0.0-libwp.patch
Patch7: abiword-3.0.1-libwps-0.4.patch
Patch8: abiword-3.0.1-gnutls.patch
Patch9: abiword-3.0.1-gcc6.patch
Patch10: abiword-3.0.1-fixwps.patch
Patch11: abiword-3.0.1-parallel-make.patch
BuildRequires: autoconf
BuildRequires: automake
@ -115,17 +107,9 @@ Python bindings for developing with libabiword
%patch1 -p1 -b .desktop
%patch2 -p1 -b .boolean
%patch3 -p0 -b .librevenge
%patch4 -p1 -b .link-grammar-5
%patch5 -p1 -b .link-grammar-5-second
%patch6 -p1 -b .libwp
%patch7 -p1 -b .libwps-0.4
%patch8 -p0 -b .gnutls
%patch9 -p0 -b .gcc6
%patch10 -p1 -b .wps2
%patch11 -p1 -b .pb
# setup abiword documentation
%setup -q -T -b 1 -n abiword-docs-%{version}
%setup -q -T -b 1 -n abiword-docs-3.0.1
%patch0 -p1 -b .windowshelppaths
%build
@ -139,7 +123,7 @@ autoreconf -vif
make %{?_smp_mflags} V=1
# build the documentation
cd $RPM_BUILD_DIR/abiword-docs-%{version}
cd $RPM_BUILD_DIR/abiword-docs-3.0.1
ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
%install
@ -192,7 +176,7 @@ SentUpstream: 2014-09-17
EOF
# install the documentation
cd $RPM_BUILD_DIR/abiword-docs-%{version}
cd $RPM_BUILD_DIR/abiword-docs-3.0.1
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help
cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help/
# some of the help dirs have bad perms (#109261)
@ -258,6 +242,9 @@ fi
%{python_sitearch}/*
%changelog
* Tue Nov 29 2016 Peter Robinson <pbrobinson@fedoraproject.org> 1:3.0.2-1
- Update to 3.0.2 stable
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.0.1-12
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

View File

@ -1,2 +1,2 @@
f3f8052e7b4979a43b75775a381e6cb8 abiword-3.0.1.tar.gz
c9b78cb5f9c415ed63ce1cf9874fa8a4 abiword-docs-3.0.1.tar.gz
cda6dd58c747c133b421cc7eb18f5796 abiword-3.0.2.tar.gz
c92c0e1e2081db20757231a53d80c338 abiword-docs-3.0.2.tar.gz