Add patch to explicitly use python2 (#1671692)

This commit is contained in:
Björn Esser 2019-02-01 12:56:43 +01:00
parent 452a13f81f
commit 3fd463e8b7
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
2 changed files with 14 additions and 8 deletions

View File

@ -0,0 +1,8 @@
Index: abiword-3.0.2/src/gi-overrides/Makefile.am
===================================================================
--- abiword-3.0.2.orig/src/gi-overrides/Makefile.am
+++ abiword-3.0.2/src/gi-overrides/Makefile.am
@@ -1,2 +1,2 @@
-overridesdir = `python -c "import gi; print gi._overridesdir"`
+overridesdir = `$(PYTHON) -c "import gi; print gi._overridesdir"`
overrides_PYTHON = Abi.py

View File

@ -6,7 +6,7 @@
Summary: Word processing program
Name: abiword
Version: %{majorversion}.%{minorversion}.%{microversion}
Release: 17%{?dist}
Release: 18%{?dist}
Epoch: 1
License: GPLv2+
URL: http://www.abisource.com/
@ -21,6 +21,7 @@ Patch1: abiword-2.8.3-desktop.patch
Patch2: abiword-2.6.0-boolean.patch
Patch3: abiword-3.0.0-librevenge.patch
Patch4: abiword-3.0.2-fix-black-drawing-regression.patch
Patch5: abiword-3.0.2-explicit-python2.patch
BuildRequires: autoconf
BuildRequires: automake
@ -65,10 +66,6 @@ BuildRequires: telepathy-glib-devel
BuildRequires: wv-devel
BuildRequires: zlib-devel
# the python2 module deoesn't build without this
# TODO investigate, get rid of the depndency
BuildRequires: python-unversioned-command
Requires: libabiword = %{epoch}:%{version}-%{release}
%description
@ -111,6 +108,7 @@ Python bindings for developing with libabiword
%patch2 -p1 -b .boolean
%patch3 -p0 -b .librevenge
%patch4 -p1 -b .black
%patch5 -p1 -b .explicit_python2
# setup abiword documentation
cd abiword-docs-3.0.1
@ -120,8 +118,6 @@ cd abiword-docs-3.0.1
# build libabiword and abiword
cd $RPM_BUILD_DIR/abiword-%{version}
export PYTHON=%{__python2}
autoreconf -vif
%configure --enable-plugins --enable-clipart --enable-templates --enable-introspection
@ -134,7 +130,6 @@ ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
%install
cd $RPM_BUILD_DIR/abiword-%{version}
export PYTHON=%{__python2}
make install DESTDIR=%{buildroot}
# Register as an application to be visible in the software center
@ -233,6 +228,9 @@ find %{buildroot} -name '*.a' -delete
%{python2_sitearch}/*
%changelog
* Fri Feb 01 2019 Björn Esser <besser82@fedoraproject.org> - 1:3.0.2-18
- Add patch to explicitly use python2 (#1671692)
* Fri Feb 01 2019 Björn Esser <besser82@fedoraproject.org> - 1:3.0.2-17
- Rebuilt for libwmf soname bump