merge fix
This commit is contained in:
commit
d0887285da
19
.gitignore
vendored
19
.gitignore
vendored
@ -1 +1,20 @@
|
|||||||
R-2.11.1.tar.gz
|
R-2.11.1.tar.gz
|
||||||
|
/R-2.12.0.tar.gz
|
||||||
|
/R-2.12.1.tar.gz
|
||||||
|
/R-2.12.2.tar.gz
|
||||||
|
/R-2.13.0.tar.gz
|
||||||
|
/R-2.13.1.tar.gz
|
||||||
|
/R-2.13.2.tar.gz
|
||||||
|
/R-2.14.0.tar.gz
|
||||||
|
/R-2.14.1.tar.gz
|
||||||
|
/R-2.15.0.tar.gz
|
||||||
|
/R-2.15.1.tar.gz
|
||||||
|
/R-2.15.2.tar.gz
|
||||||
|
/R-3.0.0.tar.gz
|
||||||
|
/R-3.0.1.tar.gz
|
||||||
|
/R-3.0.2.tar.gz
|
||||||
|
/R-3.0.3.tar.gz
|
||||||
|
/R-3.1.1.tar.gz
|
||||||
|
/R-3.1.2.tar.gz
|
||||||
|
/R-3.1.3.tar.gz
|
||||||
|
/R-3.2.0.tar.gz
|
||||||
|
@ -1,64 +0,0 @@
|
|||||||
--- R-2.0.1/src/main/connections.c.BAD 2005-03-24 16:59:46.000000000 -0600
|
|
||||||
+++ R-2.0.1/src/main/connections.c 2005-03-24 16:56:22.000000000 -0600
|
|
||||||
@@ -2194,7 +2194,7 @@
|
|
||||||
va_list(ap);
|
|
||||||
|
|
||||||
va_start(ap, format);
|
|
||||||
- res = con->vfprintf(con, format, ap);
|
|
||||||
+ res = (con->vfprintf)(con, format, ap);
|
|
||||||
va_end(ap);
|
|
||||||
return res;
|
|
||||||
}
|
|
||||||
@@ -2292,7 +2292,7 @@
|
|
||||||
{
|
|
||||||
va_list(ap);
|
|
||||||
va_start(ap, format);
|
|
||||||
- con->vfprintf(con, format, ap);
|
|
||||||
+ (con->vfprintf)(con, format, ap);
|
|
||||||
va_end(ap);
|
|
||||||
}
|
|
||||||
|
|
||||||
--- R-2.0.1/src/main/printutils.c.BAD 2005-03-24 16:58:59.000000000 -0600
|
|
||||||
+++ R-2.0.1/src/main/printutils.c 2005-03-24 16:59:12.000000000 -0600
|
|
||||||
@@ -427,7 +427,7 @@
|
|
||||||
|
|
||||||
do{
|
|
||||||
con = getConnection(con_num);
|
|
||||||
- con->vfprintf(con, format, arg);
|
|
||||||
+ (con->vfprintf)(con, format, arg);
|
|
||||||
con->fflush(con);
|
|
||||||
con_num = getActiveSink(i++);
|
|
||||||
} while(con_num>0);
|
|
||||||
@@ -452,7 +452,7 @@
|
|
||||||
/* should never happen, but in case of corruption... */
|
|
||||||
R_ErrorCon = 2;
|
|
||||||
} else {
|
|
||||||
- con->vfprintf(con, format, arg);
|
|
||||||
+ (con->vfprintf)(con, format, arg);
|
|
||||||
con->fflush(con);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
--- R-2.0.1/src/include/R_ext/RS.h.BAD 2005-03-25 07:59:09.000000000 -0600
|
|
||||||
+++ R-2.0.1/src/include/R_ext/RS.h 2005-03-25 07:59:26.000000000 -0600
|
|
||||||
@@ -34,8 +34,8 @@
|
|
||||||
#ifndef STRICT_R_HEADERS
|
|
||||||
|
|
||||||
#define R_PROBLEM_BUFSIZE 4096
|
|
||||||
-#define PROBLEM {char R_problem_buf[R_PROBLEM_BUFSIZE];sprintf(R_problem_buf,
|
|
||||||
-#define MESSAGE {char R_problem_buf[R_PROBLEM_BUFSIZE];sprintf(R_problem_buf,
|
|
||||||
+#define PROBLEM {char R_problem_buf[R_PROBLEM_BUFSIZE];(sprintf)(R_problem_buf,
|
|
||||||
+#define MESSAGE {char R_problem_buf[R_PROBLEM_BUFSIZE];(sprintf)(R_problem_buf,
|
|
||||||
#define ERROR ),error(R_problem_buf);}
|
|
||||||
#define RECOVER(x) ),error(R_problem_buf);}
|
|
||||||
#define WARNING(x) ),warning(R_problem_buf);}
|
|
||||||
--- R-2.1.0/src/main/scan.c.BAD 2005-04-18 09:00:40.000000000 -0500
|
|
||||||
+++ R-2.1.0/src/main/scan.c 2005-04-18 09:00:56.000000000 -0500
|
|
||||||
@@ -1638,7 +1638,7 @@
|
|
||||||
{
|
|
||||||
va_list(ap);
|
|
||||||
va_start(ap, format);
|
|
||||||
- con->vfprintf(con, format, ap);
|
|
||||||
+ (con->vfprintf)(con, format, ap);
|
|
||||||
va_end(ap);
|
|
||||||
}
|
|
||||||
|
|
10
R-LANG.patch
10
R-LANG.patch
@ -1,10 +0,0 @@
|
|||||||
--- R-1.9.0/src/scripts/R.sh.in 2004-03-07 12:15:11.000000000 +0100
|
|
||||||
+++ R-1.9.0-fixed/src/scripts/R.sh.in 2004-04-01 18:43:49.000000000 +0200
|
|
||||||
@@ -1,6 +1,7 @@
|
|
||||||
#!/bin/sh
|
|
||||||
# Shell wrapper for R executable.
|
|
||||||
|
|
||||||
+LANG=C
|
|
||||||
R_HOME_DIR=
|
|
||||||
if test -n "${R_HOME}" && \
|
|
||||||
test "${R_HOME}" != "${R_HOME_DIR}"; then
|
|
25
R.spec
25
R.spec
@ -50,8 +50,8 @@
|
|||||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||||
|
|
||||||
Name: R
|
Name: R
|
||||||
Version: 3.2.0
|
Version: 3.2.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A language for data analysis and graphics
|
Summary: A language for data analysis and graphics
|
||||||
URL: http://www.r-project.org
|
URL: http://www.r-project.org
|
||||||
Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/R-%{version}.tar.gz
|
Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/R-%{version}.tar.gz
|
||||||
@ -64,7 +64,11 @@ BuildRequires: gcc-gfortran
|
|||||||
BuildRequires: gcc-c++, tex(latex), texinfo-tex
|
BuildRequires: gcc-c++, tex(latex), texinfo-tex
|
||||||
BuildRequires: libpng-devel, libjpeg-devel, readline-devel
|
BuildRequires: libpng-devel, libjpeg-devel, readline-devel
|
||||||
BuildRequires: tcl-devel, tk-devel, ncurses-devel
|
BuildRequires: tcl-devel, tk-devel, ncurses-devel
|
||||||
BuildRequires: pcre-devel, zlib-devel, valgrind-devel
|
BuildRequires: pcre-devel, zlib-devel
|
||||||
|
# valgrind is available only on selected arches
|
||||||
|
%ifarch %{ix86} x86_64 ppc ppc64 ppc64le s390x armv7hl aarch64
|
||||||
|
BuildRequires: valgrind-devel
|
||||||
|
%endif
|
||||||
%if %{with_java_headless}
|
%if %{with_java_headless}
|
||||||
BuildRequires: java-headless
|
BuildRequires: java-headless
|
||||||
%else
|
%else
|
||||||
@ -152,7 +156,7 @@ Provides: R-grid = %{version}
|
|||||||
Provides: R-KernSmooth = 2.23.14
|
Provides: R-KernSmooth = 2.23.14
|
||||||
Provides: R-lattice = 0.20.31
|
Provides: R-lattice = 0.20.31
|
||||||
Provides: R-MASS = 7.3.40
|
Provides: R-MASS = 7.3.40
|
||||||
Provides: R-Matrix = 1.2.0
|
Provides: R-Matrix = 1.2.1
|
||||||
Obsoletes: R-Matrix < 0.999375-7
|
Obsoletes: R-Matrix < 0.999375-7
|
||||||
Provides: R-methods = %{version}
|
Provides: R-methods = %{version}
|
||||||
Provides: R-mgcv = 1.8.6
|
Provides: R-mgcv = 1.8.6
|
||||||
@ -216,7 +220,7 @@ Requires: tex(cm-super-ts1.enc)
|
|||||||
Requires: qpdf
|
Requires: qpdf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Provides: R-Matrix-devel = 1.2.0
|
Provides: R-Matrix-devel = 1.2.1
|
||||||
Obsoletes: R-Matrix-devel < 0.999375-7
|
Obsoletes: R-Matrix-devel < 0.999375-7
|
||||||
|
|
||||||
%if %{modern}
|
%if %{modern}
|
||||||
@ -939,7 +943,16 @@ R CMD javareconf \
|
|||||||
%postun -n libRmath -p /sbin/ldconfig
|
%postun -n libRmath -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Apr 30 2015 Tom Callaway <spot@fedoraproject.org> - 3.2.0-2
|
* Thu Jun 18 2015 Tom Callaway <spot@fedoraproject.org> - 3.2.1-1
|
||||||
|
- update to 3.2.1
|
||||||
|
|
||||||
|
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 04 2015 Jakub Čajka <jcajka@redhat.com> - 3.2.0-2
|
||||||
|
- valgrind is available only on selected arches, fixes build on s390
|
||||||
|
|
||||||
|
* Thu Apr 30 2015 Tom Callaway <spot@fedoraproject.org>
|
||||||
- conditionalize MAKEINFO for ancient things (rhel 6 or older)
|
- conditionalize MAKEINFO for ancient things (rhel 6 or older)
|
||||||
|
|
||||||
* Sun Apr 26 2015 Tom Callaway <spot@fedoraproject.org> - 3.2.0-1
|
* Sun Apr 26 2015 Tom Callaway <spot@fedoraproject.org> - 3.2.0-1
|
||||||
|
Loading…
Reference in New Issue
Block a user