This commit is contained in:
Tom Callaway 2008-10-26 19:59:58 +00:00
parent 98300c8333
commit c6b2c8e7c5
4 changed files with 82 additions and 23 deletions

View File

@ -1 +1 @@
R-2.7.2.tar.gz
R-2.8.0.tar.gz

View File

@ -0,0 +1,26 @@
diff -up R-2.8.0/configure.BAD R-2.8.0/configure
--- R-2.8.0/configure.BAD 2008-10-26 11:51:56.000000000 -0400
+++ R-2.8.0/configure 2008-10-26 11:52:31.000000000 -0400
@@ -44779,6 +44779,11 @@ else
have_bzlib=no
fi
if test "x${have_bzlib}" = xyes; then
+
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_BZLIB_H 1
+_ACEOF
+
{ echo "$as_me:$LINENO: checking if bzip2 version >= 1.0.5" >&5
echo $ECHO_N "checking if bzip2 version >= 1.0.5... $ECHO_C" >&6; }
if test "${r_cv_have_bzlib+set}" = set; then
diff -up R-2.8.0/m4/R.m4.BAD R-2.8.0/m4/R.m4
--- R-2.8.0/m4/R.m4.BAD 2008-09-21 18:05:06.000000000 -0400
+++ R-2.8.0/m4/R.m4 2008-10-26 11:53:05.000000000 -0400
@@ -3055,6 +3055,7 @@ else
have_bzlib=no
fi
if test "x${have_bzlib}" = xyes; then
+AC_DEFINE(HAVE_BZLIB_H, 1, [Define to 1 if you have bzlib.h.])
AC_CACHE_CHECK([if bzip2 version >= 1.0.5], [r_cv_have_bzlib],
[AC_LANG_PUSH(C)
r_save_LIBS="${LIBS}"

75
R.spec
View File

@ -1,15 +1,14 @@
Name: R
Version: 2.7.2
Release: 2%{?dist}
Version: 2.8.0
Release: 1%{?dist}
Summary: A language for data analysis and graphics
URL: http://www.r-project.org
Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/R-%{version}.tar.gz
Source1: macros.R
Source2: R-make-search-index.sh
# Sent upstream:
# http://bugs.r-project.org/cgi-bin/R/incoming?id=12636
Patch0: R-2.7.1-javareconf-tmpfix.patch
Patch1: R-2.7.2-filter_asoption.patch
# fix bzlib2 detection, sent upstream 10-26-2008
Patch2: R-2.8.0-HAVE_BZLIB_H.patch
License: GPLv2+
Group: Applications/Engineering
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -22,11 +21,36 @@ BuildRequires: java-1.5.0-gcj, lapack-devel
BuildRequires: libSM-devel, libX11-devel, libICE-devel, libXt-devel
BuildRequires: bzip2-devel, libXmu-devel, cairo-devel
BuildRequires: gcc-objc
# R-devel will pull in R-core
Requires: R-devel = %{version}-%{release}
# libRmath-devel will pull in libRmath
Requires: libRmath-devel = %{version}-%{release}
%description
This is a metapackage that provides both core R userspace and
all R development components.
R is a language and environment for statistical computing and graphics.
R is similar to the award-winning S system, which was developed at
Bell Laboratories by John Chambers et al. It provides a wide
variety of statistical and graphical techniques (linear and
nonlinear modelling, statistical tests, time series analysis,
classification, clustering, ...).
R is designed as a true computer language with control-flow
constructions for iteration and alternation, and it allows users to
add additional functionality by defining new functions. For
computationally intensive tasks, C, C++ and Fortran code can be linked
and called at run time.
%package core
Summary: The minimal R components necessary for a functional runtime
Group: Applications/Engineering
Requires: xdg-utils, cups
# These are the submodules that R provides. Sometimes R modules say they
# depend on one of these submodules rather than just R. These are
# provided for packager convenience.
# These are the submodules that R-core provides. Sometimes R modules say they
# depend on one of these submodules rather than just R. These are provided for
# packager convenience.
Provides: R-base = %{version}
Provides: R-boot = 1.2
Provides: R-class = 7.2
@ -55,10 +79,10 @@ Provides: R-tools = %{version}
Provides: R-utils = %{version}
Provides: R-VR = 7.2
%description
A language and environment for statistical computing and graphics.
R is similar to the award-winning S system, which was developed at
Bell Laboratories by John Chambers et al. It provides a wide
%description core
A language and environment for statistical computing and graphics.
R is similar to the award-winning S system, which was developed at
Bell Laboratories by John Chambers et al. It provides a wide
variety of statistical and graphical techniques (linear and
nonlinear modelling, statistical tests, time series analysis,
classification, clustering, ...).
@ -72,7 +96,7 @@ and called at run time.
%package devel
Summary: files for development of R packages.
Group: Applications/Engineering
Requires: R = %{version}-%{release}
Requires: R-core = %{version}-%{release}
# You need all the BuildRequires for the development version
Requires: gcc-c++, gcc-gfortran, tetex-latex, texinfo
Requires: libpng-devel, libjpeg-devel, readline-devel, ncurses-devel
@ -103,8 +127,8 @@ and header files.
%prep
%setup -q
%patch0 -p1 -b .javareconf-tmpfix
%patch1 -p1 -b .filter-little-out
%patch2 -p1 -b .BZLIB_H
# Filter false positive provides.
cat <<EOF > %{name}-prov
@ -206,7 +230,10 @@ for i in $RPM_BUILD_ROOT%{_libdir}/R/library/*/html/*.html; do
done
%files
%defattr(-, root, root)
# Metapackage
%files core
%defattr(-, root, root, -)
%{_bindir}/R
%{_bindir}/Rscript
%{_datadir}/R
@ -228,16 +255,16 @@ done
/etc/ld.so.conf.d/*
%files devel
%defattr(-, root, root)
%defattr(-, root, root, -)
%{_libdir}/pkgconfig/libR.pc
%{_includedir}/R
%files -n libRmath
%defattr(-, root, root)
%defattr(-, root, root, -)
%{_libdir}/libRmath.so
%files -n libRmath-devel
%defattr(-, root, root)
%defattr(-, root, root, -)
%{_libdir}/libRmath.a
%{_includedir}/Rmath.h
%{_libdir}/pkgconfig/libRmath.pc
@ -245,7 +272,7 @@ done
%clean
rm -rf ${RPM_BUILD_ROOT};
%post
%post core
# Create directory entries for info files
# (optional doc files, so we must check that they are installed)
for doc in admin exts FAQ intro lang; do
@ -268,7 +295,7 @@ sed -i "s!../../..!%{_libdir}/R!g" %{_docdir}/R-%{version}/html/search/index.txt
sed -i "s!../../..!/usr/share/R!g" %{_docdir}/R-%{version}/html/search/index.txt
%preun
%preun core
if [ $1 = 0 ]; then
# Delete directory entries for info files (if they were installed)
for doc in admin exts FAQ intro lang; do
@ -279,7 +306,7 @@ if [ $1 = 0 ]; then
done
fi
%postun
%postun core
/sbin/ldconfig
%post -n libRmath
@ -289,6 +316,12 @@ fi
/sbin/ldconfig
%changelog
* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.8.0-1
- Update to 2.8.0
- New subpackage layout: R-core is functional userspace, R is metapackage
requiring everything
- Fix system bzip2 detection
* Thu Oct 16 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.2-2
- fix sh compile (bz 464055)

View File

@ -1 +1 @@
6122945e9301825b97a506151b3cefde R-2.7.2.tar.gz
5213c9644aec984278b669df1a63a2ce R-2.8.0.tar.gz