This commit is contained in:
Tom Callaway 2016-05-10 11:49:28 -04:00
parent 1cf6017953
commit 9aa7451008
5 changed files with 48 additions and 30 deletions

1
.gitignore vendored
View File

@ -22,3 +22,4 @@ R-2.11.1.tar.gz
/R-3.2.2.tar.gz
/R-3.2.3.tar.gz
/R-3.2.4-revised.tar.gz
/R-3.3.0.tar.gz

View File

@ -8,19 +8,15 @@ Xorg server will not generate Expose events if backing store is enabled. Since i
src/modules/X11/devX11.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/modules/X11/devX11.c b/src/modules/X11/devX11.c
index b714f1a..143441f 100644
--- a/src/modules/X11/devX11.c
+++ b/src/modules/X11/devX11.c
@@ -1477,7 +1477,7 @@ X11_Open(pDevDesc dd, pX11Desc xd, const char *dsp,
diff -up R-3.3.0/src/modules/X11/devX11.c.disable-backing-store R-3.3.0/src/modules/X11/devX11.c
--- R-3.3.0/src/modules/X11/devX11.c.disable-backing-store 2016-05-10 09:54:12.440997353 -0400
+++ R-3.3.0/src/modules/X11/devX11.c 2016-05-10 09:54:48.560701316 -0400
@@ -1479,7 +1479,7 @@ X11_Open(pDevDesc dd, pX11Desc xd, const
memset(&attributes, 0, sizeof(attributes));
attributes.background_pixel = whitepixel;
attributes.border_pixel = blackpixel;
- attributes.backing_store = Always;
+ attributes.backing_store = NotUseful;
attributes.event_mask = ButtonPressMask
| ButtonMotionMask
| PointerMotionMask
| PointerMotionHintMask
--
1.7.1

View File

@ -0,0 +1,12 @@
diff -up R-3.3.0/src/scripts/javareconf.in.fixpath R-3.3.0/src/scripts/javareconf.in
--- R-3.3.0/src/scripts/javareconf.in.fixpath 2016-05-10 11:13:49.539844250 -0400
+++ R-3.3.0/src/scripts/javareconf.in 2016-05-10 11:15:10.475180907 -0400
@@ -78,7 +78,7 @@ else
JAVA_PATH=${PATH}
else
## try jre/bin first just in case we don't have full JDK
- JAVA_PATH=${JAVA_HOME}:${JAVA_HOME}/jre/bin:${JAVA_HOME}/bin:${JAVA_HOME}/../bin:${PATH}
+ JAVA_PATH=${JAVA_HOME}:${JAVA_HOME}/jre/bin:${PATH}:${JAVA_HOME}/bin:${JAVA_HOME}/../bin
fi
fi
## if 'java' is not on the PATH or JAVA_HOME, add some guesses as of

49
R.spec
View File

@ -55,11 +55,11 @@
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
Name: R
Version: 3.2.4
Release: 2%{?dist}
Version: 3.3.0
Release: 1%{?dist}
Summary: A language for data analysis and graphics
URL: http://www.r-project.org
Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/R-%{version}-revised.tar.gz
Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/R-%{version}.tar.gz
Source1: macros.R
Source2: R-make-search-index.sh
%if %{texi2any}
@ -77,6 +77,8 @@ Source105: https://cran.r-project.org/doc/manuals/r-release/R-ints.html
Source106: https://cran.r-project.org/doc/FAQ/R-FAQ.html
%endif
Patch0: 0001-Disable-backing-store-in-X11-window.patch
# see https://bugzilla.redhat.com/show_bug.cgi?id=1324145
Patch1: R-3.3.0-fix-java_path-in-javareconf.patch
License: GPLv2+
Group: Applications/Engineering
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -111,6 +113,8 @@ BuildRequires: tre-devel
BuildRequires: autoconf, automake, libtool
%endif
# We use the bundled lapack and shim for BLAS now.
%if 0
%if 0%{?fedora} >= 21
BuildRequires: lapack-devel >= 3.5.0-7
BuildRequires: blas-devel >= 3.5.0-7
@ -123,6 +127,7 @@ BuildRequires: lapack-devel
BuildRequires: blas-devel >= 3.0
%endif
%endif
%endif
BuildRequires: libSM-devel, libX11-devel, libICE-devel, libXt-devel
BuildRequires: bzip2-devel, libXmu-devel, cairo-devel, libtiff-devel
@ -182,7 +187,7 @@ Requires: perl, sed, gawk, tex(latex), less, make, unzip
Provides: R-base = %{version}
Provides: R-boot = 1.3.18
Provides: R-class = 7.3.14
Provides: R-cluster = 2.0.3
Provides: R-cluster = 2.0.4
Provides: R-codetools = 0.2.14
Provides: R-datasets = %{version}
Provides: R-foreign = 0.8.66
@ -192,11 +197,11 @@ Provides: R-grid = %{version}
Provides: R-KernSmooth = 2.23.15
Provides: R-lattice = 0.20.33
Provides: R-MASS = 7.3.45
Provides: R-Matrix = 1.2.4
Provides: R-Matrix = 1.2.6
Obsoletes: R-Matrix < 0.999375-7
Provides: R-methods = %{version}
Provides: R-mgcv = 1.8.12
Provides: R-nlme = 3.1.125
Provides: R-nlme = 3.1.127
Provides: R-nnet = 7.3.12
Provides: R-parallel = %{version}
Provides: R-rpart = 4.1.10
@ -204,7 +209,7 @@ Provides: R-spatial = 7.3.11
Provides: R-splines = %{version}
Provides: R-stats = %{version}
Provides: R-stats4 = %{version}
Provides: R-survival = 2.38.3
Provides: R-survival = 2.39.2
Provides: R-tcltk = %{version}
Provides: R-tools = %{version}
Provides: R-utils = %{version}
@ -256,7 +261,7 @@ Requires: tex(cm-super-ts1.enc)
Requires: qpdf
%endif
Provides: R-Matrix-devel = 1.2.4
Provides: R-Matrix-devel = 1.2.6
Obsoletes: R-Matrix-devel < 0.999375-7
%if %{modern}
@ -288,9 +293,9 @@ Summary: R with Fedora provided Java Runtime Environment
Group: Applications/Engineering
Requires(post): R-core = %{version}-%{release}
%if %{with_java_headless}
Requires(post): java-headless
Requires: java-headless
%else
Requires(post): java
Requires: java
%endif
%description java
@ -348,8 +353,9 @@ A standalone library of mathematical and statistical functions derived
from the R project. This package provides the static libRmath library.
%prep
%setup -q -n %{name}-revised
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .disable-backing-store
%patch1 -p1 -b .fixpath
# Filter false positive provides.
cat <<EOF > %{name}-prov
@ -358,8 +364,7 @@ cat <<EOF > %{name}-prov
| grep -v 'File::Copy::Recursive' | grep -v 'Text::DelimMatch'
EOF
# %%global __perl_provides %%{_builddir}/R-%%{version}/%%{name}-prov
%global __perl_provides %{_builddir}/R-revised/%{name}-prov
%global __perl_provides %{_builddir}/R-%{version}/%{name}-prov
chmod +x %{__perl_provides}
# Filter unwanted Requires:
@ -368,8 +373,7 @@ cat << \EOF > %{name}-req
%{__perl_requires} \
| grep -v 'perl(Text::DelimMatch)'
EOF
# %%global __perl_requires %%{_builddir}/R-%%{version}/%%{name}-req
%global __perl_requires %{_builddir}/R-revised/%{name}-req
%global __perl_requires %{_builddir}/R-%{version}/%{name}-req
chmod +x %{__perl_requires}
%build
@ -428,19 +432,18 @@ export FCFLAGS="%{optflags}"
# https://bugzilla.redhat.com/show_bug.cgi?id=1117496
# https://bugzilla.redhat.com/show_bug.cgi?id=1117497
#
# Also, --enable-BLAS-shlib would be nice to enable
# as a shim to the system blas but it unfortunately
# enables the bundled Rlapack (not a shim to the system lapack).
# We use --enable-BLAS-shlib here. It generates a shared library
# of the R bundled blas, that can be replaced by an optimized version.
# It also results in R using the bundled lapack copy.
( %configure \
%if %{system_tre}
--with-system-tre \
%endif
--with-system-zlib --with-system-bzlib --with-system-pcre \
--with-system-valgrind-headers \
%if 0%{?fedora}
--with-lapack \
--with-blas \
--enable-BLAS-shlib \
%endif
--with-tcl-config=%{_libdir}/tclConfig.sh \
--with-tk-config=%{_libdir}/tkConfig.sh \
@ -993,6 +996,12 @@ R CMD javareconf \
%postun -n libRmath -p /sbin/ldconfig
%changelog
* Tue May 10 2016 Tom Callaway <spot@fedoraproject.org> - 3.3.0-1
- update to 3.3.0
- fix R-java Requires (bz1324145)
- fix JAVA_PATH definition in javareconf (bz1324145)
- use bundled BLAS and LAPACK, create shared library for Rblas
* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 3.2.4-2
- rebuild for ICU 57.1

View File

@ -1 +1 @@
552b0c8088bab08ca4188797b919a58f R-3.2.4-revised.tar.gz
5a7506c8813432d1621c9725e86baf7a R-3.3.0.tar.gz