Merge commit '290075c5e94b7dee49d892b4c6c8cc44d66bedbc' into master-riscv64

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-07-26 11:14:55 +03:00
commit 6d96eedf95
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
10 changed files with 10503 additions and 111 deletions

36
.gitignore vendored
View File

@ -1,28 +1,8 @@
R-2.11.1.tar.gz
/R-2.12.0.tar.gz
/R-2.12.1.tar.gz
/R-2.12.2.tar.gz
/R-2.13.0.tar.gz
/R-2.13.1.tar.gz
/R-2.13.2.tar.gz
/R-2.14.0.tar.gz
/R-2.14.1.tar.gz
/R-2.15.0.tar.gz
/R-2.15.1.tar.gz
/R-2.15.2.tar.gz
/R-3.0.0.tar.gz
/R-3.0.1.tar.gz
/R-3.0.2.tar.gz
/R-3.0.3.tar.gz
/R-3.1.1.tar.gz
/R-3.1.2.tar.gz
/R-3.1.3.tar.gz
/R-3.2.0.tar.gz
/R-3.2.1.tar.gz
/R-3.2.2.tar.gz
/R-3.2.3.tar.gz
/R-3.2.4-revised.tar.gz
/R-3.3.0.tar.gz
/xz-5.2.2.tar.bz2
/zlib-1.2.8.tar.gz
/bzip2-1.0.6.tar.gz
/curl-7.48.0.tar.bz2
/pcre-8.38.tar.bz2
/R-3.3.1.tar.gz
/R-3.3.2.tar.gz
/R-3.3.3.tar.gz
@ -42,3 +22,9 @@ R-2.11.1.tar.gz
/curl-7.59.0.tar.bz2
/xz-5.2.4.tar.bz2
/R-3.5.0.tar.gz
/R-3.5.1.tar.gz
/curl-7.61.1.tar.bz2
/curl-7.63.0.tar.bz2
/R-3.5.2.tar.gz
/R-3.5.3.tar.gz
/R-3.6.0.tar.gz

File diff suppressed because it is too large Load Diff

149
R-2.5.0-pkgconfig.patch Normal file
View File

@ -0,0 +1,149 @@
diff -uNr R-2.5.0/src/nmath/standalone/Makefile.in R-2.5.0-patched/src/nmath/standalone/Makefile.in
--- R-2.5.0/src/nmath/standalone/Makefile.in 2007-03-26 18:42:08.000000000 +0200
+++ R-2.5.0-patched/src/nmath/standalone/Makefile.in 2007-04-29 14:50:55.000000000 +0200
@@ -67,7 +67,7 @@
libRmath_la_LDFLAGS =
CLEANFILES = Makedeps *.d *.o *.lo test $(SOURCES)
-DISTCLEANFILES = Makefile $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
+DISTCLEANFILES = Makefile libRmath.pc $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
DEFS = -DHAVE_CONFIG_H -DMATHLIB_STANDALONE
ALL_CPPFLAGS = $(R_XTRA_CPPFLAGS) -I$(srcdir)/.. $(CPPFLAGS) $(DEFS)
@@ -78,7 +78,7 @@
@r_cc_lo_rules_frag@
-all: Makefile inc static shared
+all: Makefile inc static shared build-pc
inc:
(cd ../../include; $(MAKE) Rmath.h)
@@ -100,6 +100,11 @@
shared: Makefile ../../include/Rconfig.h Copy Makedeps
@$(MAKE) $(Rexeclibdir_LTLIBRARIES)
+build-pc:
+ @$(SED) -e "s:@libdir:$(libdir):" -e "s:@includedir:$(includedir):" \
+ -e 's/@VERSION/$(VERSION)/' -e 's/@libm/$(LIBM)/' $(srcdir)/libRmath.pc.in \
+ > "libRmath.pc"
+
../../include/Rconfig.h:
(cd $(@D); $(MAKE) $(@F))
@@ -163,9 +168,7 @@
install-pc:
@$(MKINSTALLDIRS) "$(libdir)/pkgconfig"
- @$(SED) -e "s:@libdir:$(libdir):" -e "s:@includedir:$(includedir):" \
- -e 's/@VERSION/$(VERSION)/' -e 's/@libm/$(LIBM)/' $(srcdir)/libRmath.pc.in \
- > "$(libdir)/pkgconfig/libRmath.pc"
+ @$(INSTALL_DATA) libRmath.pc "$(libdir)/pkgconfig/libRmath.pc"
uninstall:
@rm -f $(includedir)/Rmath.h $(libdir)/$(libRmath_la) $(libdir)/libRmath.a "$(libdir)/pkgconfig/libRmath.pc"
diff -uNr R-2.5.0/src/scripts/Makefile.in R-2.5.0-patched/src/scripts/Makefile.in
--- R-2.5.0/src/scripts/Makefile.in 2007-03-26 18:42:09.000000000 +0200
+++ R-2.5.0-patched/src/scripts/Makefile.in 2007-04-29 14:50:14.000000000 +0200
@@ -23,17 +23,22 @@
DISTFILES = Makefile.in Makefile.win $(SCRIPTS_S) $(SCRIPTS_B_IN) R.sh.in
CLEANFILES =
-DISTCLEANFILES = Makefile R.fe R.sh $(SCRIPTS_B)
+DISTCLEANFILES = Makefile R.fe R.fe2 R.sh $(SCRIPTS_B)
all: Makefile R
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@
-R: $(SCRIPTS_B) R.fe
+R: $(SCRIPTS_B) R.fe R.fe2
@$(MAKE) rhome=$(top_builddir) install-cmds
@$(INSTALL_SCRIPT) R.fe $(top_builddir)/bin/R
+R.fe2:
+ @(d=`echo '$(rhome)' | sed 's,/,\\\/,g';`; \
+ sed -e "s/\\(R_HOME_DIR=\\).*/\\1$${d}/;" -e "s+\\(R_SHARE_DIR=\\).*+\\1$(rsharedir)+;" -e "s+\\(R_INCLUDE_DIR=\\).*+\\1$(rincludedir)+;" -e "s+\\(R_DOC_DIR=\\).*+\\1$(rdocdir)+;"\
+ < R.fe > $@)
+
## <NOTE>
## Seems we need target rules for creating FOO from FOO.in: pattern
## rules ('%:%.in') are not portable, and some versions of Make do not
@@ -95,10 +100,8 @@
install: installdirs install-cmds
@rm -f $(bindir)/R
- @(d=`echo '$(rhome)' | sed 's,/,\\\/,g';`; \
- sed -e "s/\\(R_HOME_DIR=\\).*/\\1$${d}/;" -e "s+\\(R_SHARE_DIR=\\).*+\\1$(rsharedir)+;" -e "s+\\(R_INCLUDE_DIR=\\).*+\\1$(rincludedir)+;" -e "s+\\(R_DOC_DIR=\\).*+\\1$(rdocdir)+;"\
- < R.fe > "$(Rexecbindir)/R")
- @$(INSTALL_SCRIPT) "$(Rexecbindir)/R" "$(bindir)/R"
+ @$(INSTALL_SCRIPT) R.fe2 "$(Rexecbindir)/R"
+ @$(INSTALL_SCRIPT) R.fe2 "$(bindir)/R"
@chmod 755 "$(bindir)/R" "$(Rexecbindir)/R"
## why of all the scriots does this alone chmod just one copy?
installdirs:
diff -uNr R-2.5.0/src/unix/Makefile.in R-2.5.0-patched/src/unix/Makefile.in
--- R-2.5.0/src/unix/Makefile.in 2007-03-26 18:41:33.000000000 +0200
+++ R-2.5.0-patched/src/unix/Makefile.in 2007-04-29 14:51:55.000000000 +0200
@@ -26,7 +26,7 @@
@WANT_R_SHLIB_TRUE@ALL_CFLAGS = $(ALL_CFLAGS_LO)
-all: Makefile Makedeps R
+all: Makefile Makedeps R
Makefile: $(srcdir)/Makefile.in \
$(top_builddir)/config.status \
@@ -38,11 +38,23 @@
@cat $(DEPENDS) >> Makefile
@touch $@
-R: Makefile
+R: Makefile
@$(MAKE) Makedeps
@WANT_R_SHLIB_FALSE@ @$(MAKE) libunix.a
@WANT_R_SHLIB_TRUE@ @$(MAKE) stamp-lo
+ @$(MAKE) rhome=$(abs_top_builddir) build-Rscript
@$(MAKE) rhome=$(abs_top_builddir) install-Rscript
+ @$(MAKE) build-Rscript
+ @$(MAKE) build-pc
+
+build-pc:
+ @$(SED) -e "s:@rhome:$(rhome):" -e "s:@rincludedir:$(rincludedir):" \
+ -e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
+ > "libR.pc"
+
+build-Rscript:
+ $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
+ $(srcdir)/Rscript.c
## is this portable?
../include/Rversion.h:
@@ -60,22 +72,19 @@
clean:
@-rm -rf .libs _libs
@-rm -f Makedeps *.d *.o *.a *.lo *.la stamp-lo
+ @-rm -f Rscript libR.pc
distclean: clean
@-rm -f Makefile
maintainer-clean: distclean
-## we need to build at install time to capture the correct 'rhome'
+## install previously built Rscript
install-Rscript:
- $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
- $(srcdir)/Rscript.c
@$(MKINSTALLDIRS) "$(Rexecbindir)"
@$(INSTALL_PROGRAM) Rscript "$(Rexecbindir)/Rscript"
-## substitute at install time to allow 'prefix' to be overridden
+## install previously built libR.pc
install-pc:
@$(MKINSTALLDIRS) "$(libdir)/pkgconfig"
- @$(SED) -e "s:@rhome:$(rhome):" -e "s:@rincludedir:$(rincludedir):" \
- -e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
- > "$(libdir)/pkgconfig/libR.pc"
+ @$(INSTALL_DATA) libR.pc "$(libdir)/pkgconfig/libR.pc"
install: install-Rscript @WANT_R_SHLIB_TRUE@ install-pc
@$(MKINSTALLDIRS) "$(bindir)"
@$(INSTALL_PROGRAM) Rscript "$(bindir)/Rscript"

18
R-2.7.0-bad-path.patch Normal file
View File

@ -0,0 +1,18 @@
Index: src/unix/Makefile.in
===================================================================
--- src/unix/Makefile.in (revision 45534)
+++ src/unix/Makefile.in (revision 45535)
@@ -78,11 +78,11 @@
-e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
> "$(DESTDIR)$(libdir)/pkgconfig/libR.pc"
-install: install-main install-Rscript
+install: install-main
install: @WANT_R_SHLIB_TRUE@ install-pc
install: @WANT_R_STATIC_TRUE@ install-pc
-install-main:
+install-main: install-Rscript
@$(MKINSTALLDIRS) "$(DESTDIR)$(bindir)"
@$(INSTALL_PROGRAM) Rscript "$(DESTDIR)$(bindir)/Rscript"

View File

@ -0,0 +1,27 @@
diff -up R-2.7.1/src/scripts/javareconf.BAD R-2.7.1/src/scripts/javareconf
--- R-2.7.1/src/scripts/javareconf.BAD 2008-08-29 11:04:21.000000000 -0400
+++ R-2.7.1/src/scripts/javareconf 2008-08-29 11:05:34.000000000 -0400
@@ -125,16 +125,17 @@ fi
javac_works='not present'
if test -n "$JAVAC"; then
javac_works='not functional'
- rm -rf /tmp/A.java /tmp/A.class
- echo "public class A { }" > /tmp/A.java
- if test -e /tmp/A.java; then
- if "${JAVAC}" /tmp/A.java >/dev/null; then
- if test -e /tmp/A.class; then
+ tempdir=`mktemp -d`
+ echo "public class A { }" > ${tempdir}/A.java
+ if test -e ${tempdir}/A.java; then
+ if "${JAVAC}" ${tempdir}/A.java >/dev/null; then
+ if test -e ${tempdir}/A.class; then
javac_works=yes
fi
fi
fi
- rm -rf /tmp/A.java /tmp/A.class
+ rm -rf ${tempdir}
+
fi
if test "${javac_works}" = yes; then
echo "Java compiler : ${JAVAC}"

View File

@ -0,0 +1,11 @@
--- R-2.7.2/configure.org 2008-09-25 15:00:20.000000000 +0900
+++ R-2.7.2/configure 2008-09-25 15:00:35.000000000 +0900
@@ -26995,7 +26995,7 @@
;;
# Ignore these flags.
- -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
+ -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
;;
-lkernel32)
test x"$CYGWIN" != xyes && ac_cv_f77_libs="$ac_cv_f77_libs $ac_arg"

View File

@ -0,0 +1,26 @@
diff -up R-2.8.0/configure.BAD R-2.8.0/configure
--- R-2.8.0/configure.BAD 2008-10-26 11:51:56.000000000 -0400
+++ R-2.8.0/configure 2008-10-26 11:52:31.000000000 -0400
@@ -44779,6 +44779,11 @@ else
have_bzlib=no
fi
if test "x${have_bzlib}" = xyes; then
+
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_BZLIB_H 1
+_ACEOF
+
{ echo "$as_me:$LINENO: checking if bzip2 version >= 1.0.5" >&5
echo $ECHO_N "checking if bzip2 version >= 1.0.5... $ECHO_C" >&6; }
if test "${r_cv_have_bzlib+set}" = set; then
diff -up R-2.8.0/m4/R.m4.BAD R-2.8.0/m4/R.m4
--- R-2.8.0/m4/R.m4.BAD 2008-09-21 18:05:06.000000000 -0400
+++ R-2.8.0/m4/R.m4 2008-10-26 11:53:05.000000000 -0400
@@ -3055,6 +3055,7 @@ else
have_bzlib=no
fi
if test "x${have_bzlib}" = xyes; then
+AC_DEFINE(HAVE_BZLIB_H, 1, [Define to 1 if you have bzlib.h.])
AC_CACHE_CHECK([if bzip2 version >= 1.0.5], [r_cv_have_bzlib],
[AC_LANG_PUSH(C)
r_save_LIBS="${LIBS}"

View File

@ -0,0 +1,32 @@
diff -up R-3.0.1/src/library/tools/R/install.R.armfix R-3.0.1/src/library/tools/R/install.R
--- R-3.0.1/src/library/tools/R/install.R.armfix 2013-08-12 13:57:17.956790673 -0400
+++ R-3.0.1/src/library/tools/R/install.R 2013-08-12 13:59:51.230800752 -0400
@@ -108,7 +108,11 @@
SHLIB_EXT <- if (WINDOWS) ".dll" else {
## can we do better?
mconf <- file.path(R.home(), paste0("etc", rarch), "Makeconf")
- sub(".*= ", "", grep("^SHLIB_EXT", readLines(mconf), value = TRUE))
+ if (substr( Sys.info()["machine"], 1, 3) == "arm") { # arm has broken regexps in libc
+ sub(".*= ", "", grep("^SHLIB_EXT", readLines(mconf), value = TRUE), perl = TRUE)
+ } else {
+ sub(".*= ", "", grep("^SHLIB_EXT", readLines(mconf), value = TRUE))
+ }
}
options(warn = 1)
@@ -1627,8 +1631,13 @@
mconf <- readLines(file.path(R.home(),
paste0("etc", Sys.getenv("R_ARCH")),
"Makeconf"))
- SHLIB_EXT <- sub(".*= ", "", grep("^SHLIB_EXT", mconf, value = TRUE))
- SHLIB_LIBADD <- sub(".*= ", "", grep("^SHLIB_LIBADD", mconf, value = TRUE))
+ if (substr( Sys.info()["machine"], 1, 3) == "arm") { # arm has broken regexps in libc
+ SHLIB_EXT <- sub(".*= ", "", grep("^SHLIB_EXT", mconf, value = TRUE), perl = TRUE)
+ SHLIB_LIBADD <- sub(".*= ", "", grep("^SHLIB_LIBADD", mconf, value = TRUE), perl = TRUE)
+ } else {
+ SHLIB_EXT <- sub(".*= ", "", grep("^SHLIB_EXT", mconf, value = TRUE))
+ SHLIB_LIBADD <- sub(".*= ", "", grep("^SHLIB_LIBADD", mconf, value = TRUE))
+ }
MAKE <- Sys.getenv("MAKE")
rarch <- Sys.getenv("R_ARCH")
} else {

235
R.spec
View File

@ -9,7 +9,6 @@
%endif
%endif
%ifarch x86_64
%global java_arch amd64
%else
@ -32,6 +31,21 @@
%global with_java_headless 1
%endif
# We need this on old EL for C++11 support.
%if 0%{?rhel} && 0%{?rhel} <= 7
%global use_devtoolset 1
%else
%global use_devtoolset 0
%endif
%if 0%{?rhel} == 7
%global dts_version 8
%endif
%if 0%{?rhel} == 6
%global dts_version 7
%endif
# Using lto breaks debuginfo.
# %%if 0%%{?fedora} >= 19
# %%global with_lto 1
@ -107,8 +121,8 @@
%endif
Name: R
Version: 3.5.0
Release: 2.0.riscv64%{?dist}
Version: 3.6.0
Release: 3%{?dist}
Summary: A language for data analysis and graphics
URL: http://www.r-project.org
Source0: https://cran.r-project.org/src/base/R-3/R-%{version}.tar.gz
@ -133,7 +147,7 @@ Source106: https://cran.r-project.org/doc/FAQ/R-FAQ.html
%global bzipv 1.0.6
%global xzv 5.2.4
%global pcrev 8.42
%global curlv 7.59.0
%global curlv 7.63.0
Source1000: http://zlib.net/zlib-%{zlibv}.tar.gz
Source1001: http://www.bzip.org/1.0.6/bzip2-%{bzipv}.tar.gz
Source1002: http://tukaani.org/xz/xz-%{xzv}.tar.bz2
@ -159,12 +173,15 @@ BuildRequires: stunnel
# see https://bugzilla.redhat.com/show_bug.cgi?id=1324145
Patch1: R-3.3.0-fix-java_path-in-javareconf.patch
License: GPLv2+
Group: Applications/Engineering
BuildRequires: gcc-gfortran
BuildRequires: gcc-c++, tex(latex), texinfo-tex
BuildRequires: libpng-devel, libjpeg-devel, readline-devel
BuildRequires: tcl-devel, tk-devel, ncurses-devel
BuildRequires: pcre-devel, zlib-devel
%if 0%{modern}
# Fedora (at least rawhide) pulls this into the buildroot anyways, but lets be explicit for consistency
BuildRequires: pcre2-devel
%endif
%if 0%{?rhel}
# RHEL older than 6
%if 0%{?rhel} < 7
@ -222,6 +239,10 @@ BuildRequires: less
BuildRequires: tex(inconsolata.sty)
BuildRequires: tex(upquote.sty)
%endif
%if %{use_devtoolset}
BuildRequires: devtoolset-%{dts_version}-toolchain
%endif
# R-devel will pull in R-core
Requires: R-devel = %{version}-%{release}
# libRmath-devel will pull in libRmath
@ -250,7 +271,6 @@ and called at run time.
%package core
Summary: The minimal R components necessary for a functional runtime
Group: Applications/Engineering
Requires: xdg-utils, cups
# R inherits the compiler flags it was built with, hence we need this on hardened systems
%if 0%{hardening}
@ -274,38 +294,52 @@ Requires: libRmath%{?_isa} = %{version}-%{release}
Requires: openblas-Rblas
%endif
%if %{use_devtoolset}
# We need it for CXX11 and higher support.
Requires: devtoolset-%{dts_version}-toolchain
%endif
# These are the submodules that R-core provides. Sometimes R modules say they
# depend on one of these submodules rather than just R. These are provided for
# packager convenience.
Provides: R-base = %{version}
Provides: R-boot = 1.3.20
Provides: R-class = 7.3.14
Provides: R-cluster = 2.0.7.1
Provides: R-codetools = 0.2.15
Provides: R-datasets = %{version}
Provides: R-foreign = 0.8.70
Provides: R-graphics = %{version}
Provides: R-grDevices = %{version}
Provides: R-grid = %{version}
Provides: R-KernSmooth = 2.23.15
Provides: R-lattice = 0.20.35
Provides: R-MASS = 7.3.49
Provides: R-Matrix = 1.2.14
%define add_submodule() %{lua:
local name = rpm.expand("%1")
local version = rpm.expand("%2")
local rpm_version = string.gsub(version, "-", ".")
print("Provides: R-" .. name .. " = " .. rpm_version .. "\\n")
print("Provides: R(" .. name .. ") = " .. version)
}
%add_submodule base %{version}
%add_submodule boot 1.3-22
%add_submodule class 7.3-15
%add_submodule cluster 2.0.8
%add_submodule codetools 0.2-16
%add_submodule compiler %{version}
%add_submodule datasets %{version}
%add_submodule foreign 0.8-71
%add_submodule graphics %{version}
%add_submodule grDevices %{version}
%add_submodule grid %{version}
%add_submodule KernSmooth 2.23-15
%add_submodule lattice 0.20-38
%add_submodule MASS 7.3-51.4
%add_submodule Matrix 1.2-17
Obsoletes: R-Matrix < 0.999375-7
Provides: R-methods = %{version}
Provides: R-mgcv = 1.8.23
Provides: R-nlme = 3.1.137
Provides: R-nnet = 7.3.12
Provides: R-parallel = %{version}
Provides: R-rpart = 4.1.13
Provides: R-spatial = 7.3.11
Provides: R-splines = %{version}
Provides: R-stats = %{version}
Provides: R-stats4 = %{version}
Provides: R-survival = 2.41.3
Provides: R-tcltk = %{version}
Provides: R-tools = %{version}
Provides: R-utils = %{version}
%add_submodule methods %{version}
%add_submodule mgcv 1.8-28
%add_submodule nlme 3.1-139
%add_submodule nnet 7.3-12
%add_submodule parallel %{version}
%add_submodule rpart 4.1-15
%add_submodule spatial 7.3-11
%add_submodule splines %{version}
%add_submodule stats %{version}
%add_submodule stats4 %{version}
%add_submodule survival 2.44-1.1
%add_submodule tcltk %{version}
%add_submodule tools %{version}
%add_submodule translations %{version}
%add_submodule utils %{version}
%description core
A language and environment for statistical computing and graphics.
@ -323,12 +357,17 @@ and called at run time.
%package core-devel
Summary: Core files for development of R packages (no Java)
Group: Applications/Engineering
Requires: R-core = %{version}-%{release}
# You need all the BuildRequires for the development version
Requires: gcc-c++, gcc-gfortran, tex(latex), texinfo-tex
Requires: bzip2-devel, libX11-devel, pcre-devel, zlib-devel
Requires: bzip2-devel, libX11-devel, zlib-devel
Requires: tcl-devel, tk-devel, pkgconfig, xz-devel
# This may go away at some point, possibly R 3.6?
Requires: pcre-devel
%if 0%{modern}
# Configure picks this up, but despite linking to it, it does not seem to be used as of R 3.5.2.
Requires: pcre2-devel
%endif
# No longer true.
# Requires: blas-devel >= 3.0, lapack-devel
%if %{modern}
@ -355,7 +394,7 @@ Requires: tex(cm-super-ts1.enc)
Requires: qpdf
%endif
Provides: R-Matrix-devel = 1.2.14
Provides: R-Matrix-devel = 1.2.17
Obsoletes: R-Matrix-devel < 0.999375-7
%if %{modern}
@ -370,11 +409,11 @@ Install R-core-devel if you are going to develop or compile R packages.
%package devel
Summary: Full R development environment metapackage
Requires: R-rpm-macros
Requires: R-core-devel = %{version}-%{release}
%if %{modern}
Requires: R-java-devel = %{version}-%{release}
%else
Group: Development/Libraries
%endif
%description devel
@ -384,7 +423,6 @@ environment.
%if %{modern}
%package java
Summary: R with Fedora provided Java Runtime Environment
Group: Applications/Engineering
Requires(post): R-core = %{version}-%{release}
%if %{with_java_headless}
Requires: java-headless
@ -411,7 +449,6 @@ Fedora's openJDK.
%package java-devel
Summary: Development package for use with Java enabled R components
Group: Applications/Engineering
Requires(post): R-core-devel = %{version}-%{release}
Requires(post): java-devel
@ -422,7 +459,6 @@ that assume java is present and configured on the system.
%package -n libRmath
Summary: Standalone math library from the R project
Group: Development/Libraries
%description -n libRmath
A standalone library of mathematical and statistical functions derived
@ -430,7 +466,6 @@ from the R project. This package provides the shared libRmath library.
%package -n libRmath-devel
Summary: Headers from the R Standalone math library
Group: Development/Libraries
Requires: libRmath = %{version}-%{release}, pkgconfig
%description -n libRmath-devel
@ -439,7 +474,6 @@ from the R project. This package provides the libRmath header files.
%package -n libRmath-static
Summary: Static R Standalone math library
Group: Development/Libraries
Requires: libRmath-devel = %{version}-%{release}
%description -n libRmath-static
@ -510,6 +544,9 @@ make DESTDIR=%{_builddir}/%{name}-%{version}/curl-%{curlv}/target INSTALL="insta
popd
%endif
%if %{use_devtoolset}
. /opt/rh/devtoolset-%{dts_version}/enable
%endif
# Add PATHS to Renviron for R_LIBS_SITE
echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:/usr/local/lib/R/library:%{_libdir}/R/library:%{_datadir}/R/library'"'}' >> etc/Renviron.in
@ -568,6 +605,13 @@ export FCFLAGS="%{optflags} -ffat-lto-objects"
%else
export FCFLAGS="%{optflags}"
%endif
%if 0%{?fedora} >= 30
# gcc9 needs us to pass --no-optimize-sibling-calls to gfortran
export FCFLAGS="%{optflags} --no-optimize-sibling-calls"
export FFLAGS="%{optflags} --no-optimize-sibling-calls"
%endif
# RHEL 5 & 6 & 7 have a broken BLAS, so we need to use the bundled bits in R until
# they are fixed... and it doesn't look like it will ever be fixed in RHEL 5.
# https://bugzilla.redhat.com/show_bug.cgi?id=1117491
@ -594,6 +638,7 @@ export FCFLAGS="%{optflags}"
--enable-BLAS-shlib \
--enable-R-shlib \
--enable-prebuilt-html \
--enable-memory-profiling \
%if %{with_lto}
%ifnarch %{arm}
--enable-lto \
@ -708,7 +753,7 @@ fi
if [ ! -d "$RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/R" ]; then
mkdir -p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex
pushd $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex
ln -s ../../../R/texmf/tex/latex R
ln -s %{_datadir}/R/texmf/tex/latex R
popd
fi
@ -754,14 +799,6 @@ TZ="Europe/Paris" make check
%endif
%post core
# Create directory entries for info files
# (optional doc files, so we must check that they are installed)
for doc in admin exts FAQ intro lang; do
file=%{_infodir}/R-${doc}.info.gz
if [ -e $file ]; then
/sbin/install-info ${file} %{_infodir}/dir 2>/dev/null || :
fi
done
/sbin/ldconfig
%if %{runjavareconf}
R CMD javareconf \
@ -786,18 +823,6 @@ R CMD javareconf \
# Don't use .. based paths, substitute /usr/share/R
# sed -i "s!../../..!/usr/share/R!g" %{_docdir}/R-%{version}/html/search/index.txt
%preun core
if [ $1 = 0 ]; then
# Delete directory entries for info files (if they were installed)
for doc in admin exts FAQ intro lang; do
file=%{_infodir}/R-${doc}.info.gz
if [ -e ${file} ]; then
/sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null || :
fi
done
fi
%postun core
/sbin/ldconfig
if [ $1 -eq 0 ] ; then
@ -809,16 +834,7 @@ fi
%if %{modern}
%post java
R CMD javareconf \
JAVA_HOME=%{_jvmdir}/jre \
JAVA_CPPFLAGS='-I%{_jvmdir}/java/include\ -I%{_jvmdir}/java/include/linux' \
JAVA_LIBS='-L%{_jvmdir}/jre/lib/%{java_arch}/server \
-L%{_jvmdir}/jre/lib/%{java_arch}\ -L%{_jvmdir}/java/lib/%{java_arch} \
-L/usr/java/packages/lib/%{java_arch}\ -L/lib\ -L/usr/lib\ -ljvm' \
JAVA_LD_LIBRARY_PATH=%{_jvmdir}/jre/lib/%{java_arch}/server:%{_jvmdir}/jre/lib/%{java_arch}:%{_jvmdir}/java/lib/%{java_arch}:/usr/java/packages/lib/%{java_arch}:/lib:/usr/lib \
> /dev/null 2>&1 || exit 0
%post java-devel
%if %{runjavareconf}
R CMD javareconf \
JAVA_HOME=%{_jvmdir}/jre \
JAVA_CPPFLAGS='-I%{_jvmdir}/java/include\ -I%{_jvmdir}/java/include/linux' \
@ -829,19 +845,29 @@ R CMD javareconf \
> /dev/null 2>&1 || exit 0
%endif
%post -n libRmath -p /sbin/ldconfig
%post java-devel
%if %{runjavareconf}
R CMD javareconf \
JAVA_HOME=%{_jvmdir}/jre \
JAVA_CPPFLAGS='-I%{_jvmdir}/java/include\ -I%{_jvmdir}/java/include/linux' \
JAVA_LIBS='-L%{_jvmdir}/jre/lib/%{java_arch}/server \
-L%{_jvmdir}/jre/lib/%{java_arch}\ -L%{_jvmdir}/java/lib/%{java_arch} \
-L/usr/java/packages/lib/%{java_arch}\ -L/lib\ -L/usr/lib\ -ljvm' \
JAVA_LD_LIBRARY_PATH=%{_jvmdir}/jre/lib/%{java_arch}/server:%{_jvmdir}/jre/lib/%{java_arch}:%{_jvmdir}/java/lib/%{java_arch}:/usr/java/packages/lib/%{java_arch}:/lib:/usr/lib \
> /dev/null 2>&1 || exit 0
%endif
%endif
%postun -n libRmath -p /sbin/ldconfig
%ldconfig_scriptlets -n libRmath
%files
# Metapackage
%files core
%defattr(-, root, root, -)
%{_bindir}/R
%{_bindir}/Rscript
%{_datadir}/R/
%{_datadir}/texmf/
%{_datadir}/texmf/tex/latex/R
# Have to break this out for the translations
%dir %{_libdir}/R/
%{_libdir}/R/bin/
@ -1162,7 +1188,6 @@ R CMD javareconf \
/etc/ld.so.conf.d/*
%files core-devel
%defattr(-, root, root, -)
%{_libdir}/pkgconfig/libR.pc
%{_includedir}/R
# Symlink to %%{_includedir}/R/
@ -1180,22 +1205,64 @@ R CMD javareconf \
%endif
%files -n libRmath
%defattr(-, root, root, -)
%doc doc/COPYING
%{_libdir}/libRmath.so
%files -n libRmath-devel
%defattr(-, root, root, -)
%{_includedir}/Rmath.h
%{_libdir}/pkgconfig/libRmath.pc
%files -n libRmath-static
%defattr(-, root, root, -)
%{_libdir}/libRmath.a
%changelog
* Tue Jun 05 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3.5.0-2.0.riscv64
- Rebuild for qpdf (SOVERSION bump)
* Sun Jul 21 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 3.6.0-3
- Add automated dependency generator to R-devel
- Add standard Provides for bundled libraries
* Thu Jun 13 2019 Tom Callaway <spot@fedoraproject.org> - 3.6.0-2
- use devtoolset toolchain to compile on el6/el7 for C++11 support
* Wed May 29 2019 Tom Callaway <spot@fedoraproject.org> - 3.6.0-1
- update to 3.6.0
- use --no-optimize-sibling-calls for gfortran to work around issues
* Mon Mar 11 2019 Tom Callaway <spot@fedoraproject.org> - 3.5.3-1
- update to 3.5.3
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.5.2-5
- Rebuild for readline 8.0
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 3.5.2-3
- Rebuild for ICU 63
* Tue Jan 8 2019 Tom Callaway <spot@fedoraproject.org> - 3.5.2-2
- handle pcre2 use/detection
* Mon Jan 7 2019 Tom Callaway <spot@fedoraproject.org> - 3.5.2-1
- update to 3.5.2
* Fri Dec 7 2018 Tom Callaway <spot@fedoraproject.org> - 3.5.1-2
- use absolute path in symlink for latex dir (bz1594102)
* Mon Sep 10 2018 Tom Callaway <spot@fedoraproject.org> - 3.5.1-1
- update to 3.5.1
- update bundled curl to 7.61.1
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 3.5.0-5
- Rebuild for ICU 62
* Tue Jun 5 2018 Tom Callaway <spot@fedoraproject.org> - 3.5.0-4
- only own /usr/share/texmf/tex/latex/R ... not /usr/share/texmf
* Fri May 18 2018 Tom Callaway <spot@fedoraproject.org> - 3.5.0-3
- do not run javareconf on el6/ppc64 EVEN in the java subpackages
* Fri May 18 2018 Tom Callaway <spot@fedoraproject.org> - 3.5.0-2
- do not run javareconf on el6/ppc64

View File

@ -1,6 +1,6 @@
SHA512 (zlib-1.2.11.tar.gz) = 73fd3fff4adeccd4894084c15ddac89890cd10ef105dd5e1835e1e9bbb6a49ff229713bd197d203edfa17c2727700fce65a2a235f07568212d820dca88b528ae
SHA512 (bzip2-1.0.6.tar.gz) = 00ace5438cfa0c577e5f578d8a808613187eff5217c35164ffe044fbafdfec9e98f4192c02a7d67e01e5a5ccced630583ad1003c37697219b0f147343a3fdd12
SHA512 (pcre-8.42.tar.bz2) = b47b923108f6ee0c31409b79d0888314271b482a22590e164d02f21d2112fba22dd0342c24f9ba0f5fcc5b8c65550bad08c476e30a2fc79b34ecf4601ed82f3d
SHA512 (curl-7.59.0.tar.bz2) = 9b5586f443a3c9fed947debce86861a8dea0fbf59bf8838cfd72a0884f13073630cf9d369b5535a059d122decd738c652705567752517f5cb11148cc16f693fb
SHA512 (xz-5.2.4.tar.bz2) = 25a548c34a304ba51cdaa63813df0fa4ac2f3cf0ec6dc2d181ec5b62fe586090cd0f1c866ee7ba19e9b264ecabf9ca9f2f1dda7f95313546da4152f3cfaa7e6e
SHA512 (R-3.5.0.tar.gz) = c2703e892eb6f12ec7b536540b823d4ef011dddcbdca06c12d438bc1f07debae9dbd0f72abb6f0d4c577a3c74b155452ef527489cf023ed892109dd86c23bc37
SHA512 (curl-7.63.0.tar.bz2) = 2873ef57b15cf12e508626f4546f6e06450cb87b239be1d26d9b3a22f7533d76eebabb5fa00e7b8c5d7fc9854356997ce164afb069411d079b2b9f0bdb00db25
SHA512 (R-3.6.0.tar.gz) = b2e17b909b6387abb964492e2e9370f913295ca7ac99bab0e965c43ed3c4635e27468c326fb2bca3c529b03c731b0170d9e777a194ad4d6c5a983c050223d8c8