2.11.0
This commit is contained in:
parent
21eaf582af
commit
36e39e36d0
@ -1 +1 @@
|
||||
R-2.10.1.tar.gz
|
||||
R-2.11.0.tar.gz
|
||||
|
@ -1,64 +0,0 @@
|
||||
--- R-2.0.1/src/main/connections.c.BAD 2005-03-24 16:59:46.000000000 -0600
|
||||
+++ R-2.0.1/src/main/connections.c 2005-03-24 16:56:22.000000000 -0600
|
||||
@@ -2194,7 +2194,7 @@
|
||||
va_list(ap);
|
||||
|
||||
va_start(ap, format);
|
||||
- res = con->vfprintf(con, format, ap);
|
||||
+ res = (con->vfprintf)(con, format, ap);
|
||||
va_end(ap);
|
||||
return res;
|
||||
}
|
||||
@@ -2292,7 +2292,7 @@
|
||||
{
|
||||
va_list(ap);
|
||||
va_start(ap, format);
|
||||
- con->vfprintf(con, format, ap);
|
||||
+ (con->vfprintf)(con, format, ap);
|
||||
va_end(ap);
|
||||
}
|
||||
|
||||
--- R-2.0.1/src/main/printutils.c.BAD 2005-03-24 16:58:59.000000000 -0600
|
||||
+++ R-2.0.1/src/main/printutils.c 2005-03-24 16:59:12.000000000 -0600
|
||||
@@ -427,7 +427,7 @@
|
||||
|
||||
do{
|
||||
con = getConnection(con_num);
|
||||
- con->vfprintf(con, format, arg);
|
||||
+ (con->vfprintf)(con, format, arg);
|
||||
con->fflush(con);
|
||||
con_num = getActiveSink(i++);
|
||||
} while(con_num>0);
|
||||
@@ -452,7 +452,7 @@
|
||||
/* should never happen, but in case of corruption... */
|
||||
R_ErrorCon = 2;
|
||||
} else {
|
||||
- con->vfprintf(con, format, arg);
|
||||
+ (con->vfprintf)(con, format, arg);
|
||||
con->fflush(con);
|
||||
return;
|
||||
}
|
||||
--- R-2.0.1/src/include/R_ext/RS.h.BAD 2005-03-25 07:59:09.000000000 -0600
|
||||
+++ R-2.0.1/src/include/R_ext/RS.h 2005-03-25 07:59:26.000000000 -0600
|
||||
@@ -34,8 +34,8 @@
|
||||
#ifndef STRICT_R_HEADERS
|
||||
|
||||
#define R_PROBLEM_BUFSIZE 4096
|
||||
-#define PROBLEM {char R_problem_buf[R_PROBLEM_BUFSIZE];sprintf(R_problem_buf,
|
||||
-#define MESSAGE {char R_problem_buf[R_PROBLEM_BUFSIZE];sprintf(R_problem_buf,
|
||||
+#define PROBLEM {char R_problem_buf[R_PROBLEM_BUFSIZE];(sprintf)(R_problem_buf,
|
||||
+#define MESSAGE {char R_problem_buf[R_PROBLEM_BUFSIZE];(sprintf)(R_problem_buf,
|
||||
#define ERROR ),error(R_problem_buf);}
|
||||
#define RECOVER(x) ),error(R_problem_buf);}
|
||||
#define WARNING(x) ),warning(R_problem_buf);}
|
||||
--- R-2.1.0/src/main/scan.c.BAD 2005-04-18 09:00:40.000000000 -0500
|
||||
+++ R-2.1.0/src/main/scan.c 2005-04-18 09:00:56.000000000 -0500
|
||||
@@ -1638,7 +1638,7 @@
|
||||
{
|
||||
va_list(ap);
|
||||
va_start(ap, format);
|
||||
- con->vfprintf(con, format, ap);
|
||||
+ (con->vfprintf)(con, format, ap);
|
||||
va_end(ap);
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,149 +0,0 @@
|
||||
diff -uNr R-2.5.0/src/nmath/standalone/Makefile.in R-2.5.0-patched/src/nmath/standalone/Makefile.in
|
||||
--- R-2.5.0/src/nmath/standalone/Makefile.in 2007-03-26 18:42:08.000000000 +0200
|
||||
+++ R-2.5.0-patched/src/nmath/standalone/Makefile.in 2007-04-29 14:50:55.000000000 +0200
|
||||
@@ -67,7 +67,7 @@
|
||||
libRmath_la_LDFLAGS =
|
||||
|
||||
CLEANFILES = Makedeps *.d *.o *.lo test $(SOURCES)
|
||||
-DISTCLEANFILES = Makefile $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
|
||||
+DISTCLEANFILES = Makefile libRmath.pc $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
|
||||
|
||||
DEFS = -DHAVE_CONFIG_H -DMATHLIB_STANDALONE
|
||||
ALL_CPPFLAGS = $(R_XTRA_CPPFLAGS) -I$(srcdir)/.. $(CPPFLAGS) $(DEFS)
|
||||
@@ -78,7 +78,7 @@
|
||||
@r_cc_lo_rules_frag@
|
||||
|
||||
|
||||
-all: Makefile inc static shared
|
||||
+all: Makefile inc static shared build-pc
|
||||
|
||||
inc:
|
||||
(cd ../../include; $(MAKE) Rmath.h)
|
||||
@@ -100,6 +100,11 @@
|
||||
shared: Makefile ../../include/Rconfig.h Copy Makedeps
|
||||
@$(MAKE) $(Rexeclibdir_LTLIBRARIES)
|
||||
|
||||
+build-pc:
|
||||
+ @$(SED) -e "s:@libdir:$(libdir):" -e "s:@includedir:$(includedir):" \
|
||||
+ -e 's/@VERSION/$(VERSION)/' -e 's/@libm/$(LIBM)/' $(srcdir)/libRmath.pc.in \
|
||||
+ > "libRmath.pc"
|
||||
+
|
||||
../../include/Rconfig.h:
|
||||
(cd $(@D); $(MAKE) $(@F))
|
||||
|
||||
@@ -163,9 +168,7 @@
|
||||
|
||||
install-pc:
|
||||
@$(MKINSTALLDIRS) "$(libdir)/pkgconfig"
|
||||
- @$(SED) -e "s:@libdir:$(libdir):" -e "s:@includedir:$(includedir):" \
|
||||
- -e 's/@VERSION/$(VERSION)/' -e 's/@libm/$(LIBM)/' $(srcdir)/libRmath.pc.in \
|
||||
- > "$(libdir)/pkgconfig/libRmath.pc"
|
||||
+ @$(INSTALL_DATA) libRmath.pc "$(libdir)/pkgconfig/libRmath.pc"
|
||||
|
||||
uninstall:
|
||||
@rm -f $(includedir)/Rmath.h $(libdir)/$(libRmath_la) $(libdir)/libRmath.a "$(libdir)/pkgconfig/libRmath.pc"
|
||||
diff -uNr R-2.5.0/src/scripts/Makefile.in R-2.5.0-patched/src/scripts/Makefile.in
|
||||
--- R-2.5.0/src/scripts/Makefile.in 2007-03-26 18:42:09.000000000 +0200
|
||||
+++ R-2.5.0-patched/src/scripts/Makefile.in 2007-04-29 14:50:14.000000000 +0200
|
||||
@@ -23,17 +23,22 @@
|
||||
DISTFILES = Makefile.in Makefile.win $(SCRIPTS_S) $(SCRIPTS_B_IN) R.sh.in
|
||||
|
||||
CLEANFILES =
|
||||
-DISTCLEANFILES = Makefile R.fe R.sh $(SCRIPTS_B)
|
||||
+DISTCLEANFILES = Makefile R.fe R.fe2 R.sh $(SCRIPTS_B)
|
||||
|
||||
all: Makefile R
|
||||
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@
|
||||
|
||||
-R: $(SCRIPTS_B) R.fe
|
||||
+R: $(SCRIPTS_B) R.fe R.fe2
|
||||
@$(MAKE) rhome=$(top_builddir) install-cmds
|
||||
@$(INSTALL_SCRIPT) R.fe $(top_builddir)/bin/R
|
||||
|
||||
+R.fe2:
|
||||
+ @(d=`echo '$(rhome)' | sed 's,/,\\\/,g';`; \
|
||||
+ sed -e "s/\\(R_HOME_DIR=\\).*/\\1$${d}/;" -e "s+\\(R_SHARE_DIR=\\).*+\\1$(rsharedir)+;" -e "s+\\(R_INCLUDE_DIR=\\).*+\\1$(rincludedir)+;" -e "s+\\(R_DOC_DIR=\\).*+\\1$(rdocdir)+;"\
|
||||
+ < R.fe > $@)
|
||||
+
|
||||
## <NOTE>
|
||||
## Seems we need target rules for creating FOO from FOO.in: pattern
|
||||
## rules ('%:%.in') are not portable, and some versions of Make do not
|
||||
@@ -95,10 +100,8 @@
|
||||
|
||||
install: installdirs install-cmds
|
||||
@rm -f $(bindir)/R
|
||||
- @(d=`echo '$(rhome)' | sed 's,/,\\\/,g';`; \
|
||||
- sed -e "s/\\(R_HOME_DIR=\\).*/\\1$${d}/;" -e "s+\\(R_SHARE_DIR=\\).*+\\1$(rsharedir)+;" -e "s+\\(R_INCLUDE_DIR=\\).*+\\1$(rincludedir)+;" -e "s+\\(R_DOC_DIR=\\).*+\\1$(rdocdir)+;"\
|
||||
- < R.fe > "$(Rexecbindir)/R")
|
||||
- @$(INSTALL_SCRIPT) "$(Rexecbindir)/R" "$(bindir)/R"
|
||||
+ @$(INSTALL_SCRIPT) R.fe2 "$(Rexecbindir)/R"
|
||||
+ @$(INSTALL_SCRIPT) R.fe2 "$(bindir)/R"
|
||||
@chmod 755 "$(bindir)/R" "$(Rexecbindir)/R"
|
||||
## why of all the scriots does this alone chmod just one copy?
|
||||
installdirs:
|
||||
diff -uNr R-2.5.0/src/unix/Makefile.in R-2.5.0-patched/src/unix/Makefile.in
|
||||
--- R-2.5.0/src/unix/Makefile.in 2007-03-26 18:41:33.000000000 +0200
|
||||
+++ R-2.5.0-patched/src/unix/Makefile.in 2007-04-29 14:51:55.000000000 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
@WANT_R_SHLIB_TRUE@ALL_CFLAGS = $(ALL_CFLAGS_LO)
|
||||
|
||||
-all: Makefile Makedeps R
|
||||
+all: Makefile Makedeps R
|
||||
|
||||
Makefile: $(srcdir)/Makefile.in \
|
||||
$(top_builddir)/config.status \
|
||||
@@ -38,11 +38,23 @@
|
||||
@cat $(DEPENDS) >> Makefile
|
||||
@touch $@
|
||||
|
||||
-R: Makefile
|
||||
+R: Makefile
|
||||
@$(MAKE) Makedeps
|
||||
@WANT_R_SHLIB_FALSE@ @$(MAKE) libunix.a
|
||||
@WANT_R_SHLIB_TRUE@ @$(MAKE) stamp-lo
|
||||
+ @$(MAKE) rhome=$(abs_top_builddir) build-Rscript
|
||||
@$(MAKE) rhome=$(abs_top_builddir) install-Rscript
|
||||
+ @$(MAKE) build-Rscript
|
||||
+ @$(MAKE) build-pc
|
||||
+
|
||||
+build-pc:
|
||||
+ @$(SED) -e "s:@rhome:$(rhome):" -e "s:@rincludedir:$(rincludedir):" \
|
||||
+ -e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
|
||||
+ > "libR.pc"
|
||||
+
|
||||
+build-Rscript:
|
||||
+ $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
|
||||
+ $(srcdir)/Rscript.c
|
||||
|
||||
## is this portable?
|
||||
../include/Rversion.h:
|
||||
@@ -60,22 +72,19 @@
|
||||
clean:
|
||||
@-rm -rf .libs _libs
|
||||
@-rm -f Makedeps *.d *.o *.a *.lo *.la stamp-lo
|
||||
+ @-rm -f Rscript libR.pc
|
||||
distclean: clean
|
||||
@-rm -f Makefile
|
||||
maintainer-clean: distclean
|
||||
|
||||
-## we need to build at install time to capture the correct 'rhome'
|
||||
+## install previously built Rscript
|
||||
install-Rscript:
|
||||
- $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
|
||||
- $(srcdir)/Rscript.c
|
||||
@$(MKINSTALLDIRS) "$(Rexecbindir)"
|
||||
@$(INSTALL_PROGRAM) Rscript "$(Rexecbindir)/Rscript"
|
||||
-## substitute at install time to allow 'prefix' to be overridden
|
||||
+## install previously built libR.pc
|
||||
install-pc:
|
||||
@$(MKINSTALLDIRS) "$(libdir)/pkgconfig"
|
||||
- @$(SED) -e "s:@rhome:$(rhome):" -e "s:@rincludedir:$(rincludedir):" \
|
||||
- -e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
|
||||
- > "$(libdir)/pkgconfig/libR.pc"
|
||||
+ @$(INSTALL_DATA) libR.pc "$(libdir)/pkgconfig/libR.pc"
|
||||
install: install-Rscript @WANT_R_SHLIB_TRUE@ install-pc
|
||||
@$(MKINSTALLDIRS) "$(bindir)"
|
||||
@$(INSTALL_PROGRAM) Rscript "$(bindir)/Rscript"
|
@ -1,18 +0,0 @@
|
||||
Index: src/unix/Makefile.in
|
||||
===================================================================
|
||||
--- src/unix/Makefile.in (revision 45534)
|
||||
+++ src/unix/Makefile.in (revision 45535)
|
||||
@@ -78,11 +78,11 @@
|
||||
-e 's/@VERSION/$(VERSION)/' $(srcdir)/libR.pc.in \
|
||||
> "$(DESTDIR)$(libdir)/pkgconfig/libR.pc"
|
||||
|
||||
-install: install-main install-Rscript
|
||||
+install: install-main
|
||||
install: @WANT_R_SHLIB_TRUE@ install-pc
|
||||
install: @WANT_R_STATIC_TRUE@ install-pc
|
||||
|
||||
-install-main:
|
||||
+install-main: install-Rscript
|
||||
@$(MKINSTALLDIRS) "$(DESTDIR)$(bindir)"
|
||||
@$(INSTALL_PROGRAM) Rscript "$(DESTDIR)$(bindir)/Rscript"
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up R-2.7.1/src/scripts/javareconf.BAD R-2.7.1/src/scripts/javareconf
|
||||
--- R-2.7.1/src/scripts/javareconf.BAD 2008-08-29 11:04:21.000000000 -0400
|
||||
+++ R-2.7.1/src/scripts/javareconf 2008-08-29 11:05:34.000000000 -0400
|
||||
@@ -125,16 +125,17 @@ fi
|
||||
javac_works='not present'
|
||||
if test -n "$JAVAC"; then
|
||||
javac_works='not functional'
|
||||
- rm -rf /tmp/A.java /tmp/A.class
|
||||
- echo "public class A { }" > /tmp/A.java
|
||||
- if test -e /tmp/A.java; then
|
||||
- if "${JAVAC}" /tmp/A.java >/dev/null; then
|
||||
- if test -e /tmp/A.class; then
|
||||
+ tempdir=`mktemp -d`
|
||||
+ echo "public class A { }" > ${tempdir}/A.java
|
||||
+ if test -e ${tempdir}/A.java; then
|
||||
+ if "${JAVAC}" ${tempdir}/A.java >/dev/null; then
|
||||
+ if test -e ${tempdir}/A.class; then
|
||||
javac_works=yes
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
- rm -rf /tmp/A.java /tmp/A.class
|
||||
+ rm -rf ${tempdir}
|
||||
+
|
||||
fi
|
||||
if test "${javac_works}" = yes; then
|
||||
echo "Java compiler : ${JAVAC}"
|
@ -1,26 +0,0 @@
|
||||
diff -up R-2.8.0/configure.BAD R-2.8.0/configure
|
||||
--- R-2.8.0/configure.BAD 2008-10-26 11:51:56.000000000 -0400
|
||||
+++ R-2.8.0/configure 2008-10-26 11:52:31.000000000 -0400
|
||||
@@ -44779,6 +44779,11 @@ else
|
||||
have_bzlib=no
|
||||
fi
|
||||
if test "x${have_bzlib}" = xyes; then
|
||||
+
|
||||
+cat >>confdefs.h <<\_ACEOF
|
||||
+#define HAVE_BZLIB_H 1
|
||||
+_ACEOF
|
||||
+
|
||||
{ echo "$as_me:$LINENO: checking if bzip2 version >= 1.0.5" >&5
|
||||
echo $ECHO_N "checking if bzip2 version >= 1.0.5... $ECHO_C" >&6; }
|
||||
if test "${r_cv_have_bzlib+set}" = set; then
|
||||
diff -up R-2.8.0/m4/R.m4.BAD R-2.8.0/m4/R.m4
|
||||
--- R-2.8.0/m4/R.m4.BAD 2008-09-21 18:05:06.000000000 -0400
|
||||
+++ R-2.8.0/m4/R.m4 2008-10-26 11:53:05.000000000 -0400
|
||||
@@ -3055,6 +3055,7 @@ else
|
||||
have_bzlib=no
|
||||
fi
|
||||
if test "x${have_bzlib}" = xyes; then
|
||||
+AC_DEFINE(HAVE_BZLIB_H, 1, [Define to 1 if you have bzlib.h.])
|
||||
AC_CACHE_CHECK([if bzip2 version >= 1.0.5], [r_cv_have_bzlib],
|
||||
[AC_LANG_PUSH(C)
|
||||
r_save_LIBS="${LIBS}"
|
10
R-LANG.patch
10
R-LANG.patch
@ -1,10 +0,0 @@
|
||||
--- R-1.9.0/src/scripts/R.sh.in 2004-03-07 12:15:11.000000000 +0100
|
||||
+++ R-1.9.0-fixed/src/scripts/R.sh.in 2004-04-01 18:43:49.000000000 +0200
|
||||
@@ -1,6 +1,7 @@
|
||||
#!/bin/sh
|
||||
# Shell wrapper for R executable.
|
||||
|
||||
+LANG=C
|
||||
R_HOME_DIR=
|
||||
if test -n "${R_HOME}" && \
|
||||
test "${R_HOME}" != "${R_HOME_DIR}"; then
|
33
R.spec
33
R.spec
@ -5,14 +5,13 @@
|
||||
%endif
|
||||
|
||||
Name: R
|
||||
Version: 2.10.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.11.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A language for data analysis and graphics
|
||||
URL: http://www.r-project.org
|
||||
Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/R-%{version}.tar.gz
|
||||
Source1: macros.R
|
||||
Source2: R-make-search-index.sh
|
||||
Patch1: R-2.7.2-filter_asoption.patch
|
||||
License: GPLv2+
|
||||
Group: Applications/Engineering
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -57,34 +56,33 @@ Requires: perl, sed, gawk, texlive-latex, texlive-dvips, less, vi
|
||||
# depend on one of these submodules rather than just R. These are provided for
|
||||
# packager convenience.
|
||||
Provides: R-base = %{version}
|
||||
Provides: R-boot = 1.2.41
|
||||
Provides: R-class = 7.3.1
|
||||
Provides: R-cluster = 1.12.1
|
||||
Provides: R-boot = 1.2.42
|
||||
Provides: R-class = 7.3.2
|
||||
Provides: R-cluster = 1.12.3
|
||||
Provides: R-codetools = 0.2.2
|
||||
Provides: R-datasets = %{version}
|
||||
Provides: R-foreign = 0.8.38
|
||||
Provides: R-foreign = 0.8.40
|
||||
Provides: R-graphics = %{version}
|
||||
Provides: R-grDevices = %{version}
|
||||
Provides: R-grid = %{version}
|
||||
Provides: R-KernSmooth = 2.23.3
|
||||
Provides: R-lattice = 0.17.26
|
||||
Provides: R-MASS = 7.3.4
|
||||
Provides: R-Matrix = 0.999375.33
|
||||
Provides: R-lattice = 0.18.5
|
||||
Provides: R-MASS = 7.3.5
|
||||
Provides: R-Matrix = 0.999375.38
|
||||
Obsoletes: R-Matrix < 0.999375-7
|
||||
Provides: R-methods = %{version}
|
||||
Provides: R-mgcv = 1.6.1
|
||||
Provides: R-nlme = 3.1.96
|
||||
Provides: R-nnet = 7.3.1
|
||||
Provides: R-rpart = 3.1.45
|
||||
Provides: R-spatial = 7.3.1
|
||||
Provides: R-rpart = 3.1.46
|
||||
Provides: R-spatial = 7.3.2
|
||||
Provides: R-splines = %{version}
|
||||
Provides: R-stats = %{version}
|
||||
Provides: R-stats4 = %{version}
|
||||
Provides: R-survival = 2.35.7
|
||||
Provides: R-survival = 2.35.8
|
||||
Provides: R-tcltk = %{version}
|
||||
Provides: R-tools = %{version}
|
||||
Provides: R-utils = %{version}
|
||||
Provides: R-VR = 7.3.1
|
||||
|
||||
%description core
|
||||
A language and environment for statistical computing and graphics.
|
||||
@ -108,7 +106,7 @@ Requires: R-core = %{version}-%{release}
|
||||
Requires: gcc-c++, gcc-gfortran, tetex-latex
|
||||
Requires: bzip2-devel, libX11-devel, pcre-devel, zlib-devel
|
||||
Requires: tcl-devel, tk-devel, pkgconfig
|
||||
Provides: R-Matrix-devel = 0.999375.31
|
||||
Provides: R-Matrix-devel = 0.999375.38
|
||||
Obsoletes: R-Matrix-devel < 0.999375-7
|
||||
|
||||
%description devel
|
||||
@ -167,7 +165,6 @@ and header files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .filter-little-out
|
||||
|
||||
# Filter false positive provides.
|
||||
cat <<EOF > %{name}-prov
|
||||
@ -730,6 +727,7 @@ chmod -x $RPM_BUILD_ROOT%{_libdir}/R/library/mgcv/CITATION ${RPM_BUILD_ROOT}%{_d
|
||||
%{_libdir}/R/library/survival/libs/
|
||||
%{_libdir}/R/library/survival/Meta/
|
||||
%{_libdir}/R/library/survival/NAMESPACE
|
||||
%{_libdir}/R/library/survival/noweb/
|
||||
%{_libdir}/R/library/survival/R/
|
||||
# tcltk
|
||||
%dir %{_libdir}/R/library/tcltk/
|
||||
@ -899,6 +897,9 @@ R CMD javareconf \
|
||||
%postun -n libRmath -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Thu Apr 22 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 2.11.0-1
|
||||
- update to 2.11.0
|
||||
|
||||
* Fri Apr 02 2010 Caolán McNamara <caolanm@redhat.com> - 2.10.1-2
|
||||
- rebuild for icu 4.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user