update everyone to 2.7.2, fix security bug 460658
This commit is contained in:
parent
d6615bafd5
commit
0672b69fcb
@ -1 +1 @@
|
||||
R-2.7.1.tar.gz
|
||||
R-2.7.2.tar.gz
|
||||
|
27
R-2.7.1-javareconf-tmpfix.patch
Normal file
27
R-2.7.1-javareconf-tmpfix.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -up R-2.7.1/src/scripts/javareconf.BAD R-2.7.1/src/scripts/javareconf
|
||||
--- R-2.7.1/src/scripts/javareconf.BAD 2008-08-29 11:04:21.000000000 -0400
|
||||
+++ R-2.7.1/src/scripts/javareconf 2008-08-29 11:05:34.000000000 -0400
|
||||
@@ -125,16 +125,17 @@ fi
|
||||
javac_works='not present'
|
||||
if test -n "$JAVAC"; then
|
||||
javac_works='not functional'
|
||||
- rm -rf /tmp/A.java /tmp/A.class
|
||||
- echo "public class A { }" > /tmp/A.java
|
||||
- if test -e /tmp/A.java; then
|
||||
- if "${JAVAC}" /tmp/A.java >/dev/null; then
|
||||
- if test -e /tmp/A.class; then
|
||||
+ tempdir=`mktemp -d`
|
||||
+ echo "public class A { }" > ${tempdir}/A.java
|
||||
+ if test -e ${tempdir}/A.java; then
|
||||
+ if "${JAVAC}" ${tempdir}/A.java >/dev/null; then
|
||||
+ if test -e ${tempdir}/A.class; then
|
||||
javac_works=yes
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
- rm -rf /tmp/A.java /tmp/A.class
|
||||
+ rm -rf ${tempdir}
|
||||
+
|
||||
fi
|
||||
if test "${javac_works}" = yes; then
|
||||
echo "Java compiler : ${JAVAC}"
|
13
R.spec
13
R.spec
@ -1,11 +1,14 @@
|
||||
Name: R
|
||||
Version: 2.7.1
|
||||
Version: 2.7.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A language for data analysis and graphics
|
||||
URL: http://www.r-project.org
|
||||
Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/R-%{version}.tar.gz
|
||||
Source1: macros.R
|
||||
Source2: R-make-search-index.sh
|
||||
# Sent upstream:
|
||||
# http://bugs.r-project.org/cgi-bin/R/incoming?id=12636
|
||||
Patch0: R-2.7.1-javareconf-tmpfix.patch
|
||||
License: GPLv2+
|
||||
Group: Applications/Engineering
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -99,6 +102,7 @@ and header files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .javareconf-tmpfix
|
||||
|
||||
# Filter false positive provides.
|
||||
cat <<EOF > %{name}-prov
|
||||
@ -133,7 +137,7 @@ case "%{_target_cpu}" in
|
||||
export F77="gfortran -m64"
|
||||
export FC="gfortran -m64"
|
||||
;;
|
||||
ia64)
|
||||
ia64|alpha)
|
||||
export CC="gcc"
|
||||
export CXX="g++"
|
||||
export F77="gfortran"
|
||||
@ -283,6 +287,11 @@ fi
|
||||
/sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.2-1
|
||||
- update to 2.7.2
|
||||
- fix spec for alpha compile (bz 458931)
|
||||
- fix security issue in javareconf script (bz 460658)
|
||||
|
||||
* Mon Jul 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.7.1-1
|
||||
- update to 2.7.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user