Update to latest version.
This commit is contained in:
parent
8becc3fbe1
commit
f084d746a2
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/httpuv_1.4.1.tar.gz
|
||||
/httpuv_1.4.2.tar.gz
|
||||
/httpuv_1.4.3.tar.gz
|
||||
/httpuv_1.4.4.1.tar.gz
|
||||
|
@ -1,11 +1,11 @@
|
||||
From e70bb46111996f2e7b79c6b0694d451374935a65 Mon Sep 17 00:00:00 2001
|
||||
From 305abffcb8a640e8c94af1090c12b2259126d2dd Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Mon, 30 Apr 2018 04:53:42 -0400
|
||||
Subject: [PATCH] Use unbundled libuv.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
src/Makevars | 34 +++-------------------------------
|
||||
src/Makevars | 37 +++----------------------------------
|
||||
src/callbackqueue.cpp | 2 +-
|
||||
src/callbackqueue.h | 2 +-
|
||||
src/http.h | 2 +-
|
||||
@ -17,18 +17,18 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
src/thread.h | 2 +-
|
||||
src/uvutil.h | 2 +-
|
||||
src/webapplication.h | 2 +-
|
||||
12 files changed, 14 insertions(+), 42 deletions(-)
|
||||
12 files changed, 14 insertions(+), 45 deletions(-)
|
||||
|
||||
diff --git a/src/Makevars b/src/Makevars
|
||||
index dfb73ff..5f0d419 100644
|
||||
index 7b22000..46d4ad1 100644
|
||||
--- a/src/Makevars
|
||||
+++ b/src/Makevars
|
||||
@@ -9,7 +9,7 @@ ifeq ($(UNAME), Darwin)
|
||||
FRAMEWORK = -framework CoreServices
|
||||
endif
|
||||
|
||||
-PKG_LIBS = ./libuv/.libs/libuv.a ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o $(FRAMEWORK)
|
||||
+PKG_LIBS = $(shell pkgconf --libs libuv) ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o $(FRAMEWORK)
|
||||
-PKG_LIBS = ./libuv/.libs/libuv.a ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o $(FRAMEWORK) -pthread
|
||||
+PKG_LIBS = $(shell pkgconf --libs libuv) ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o $(FRAMEWORK) -pthread
|
||||
ifeq ($(UNAME), SunOS)
|
||||
PKG_LIBS += -lkstat -lsendfile -lsocket -lxnet
|
||||
endif
|
||||
@ -36,12 +36,12 @@ index dfb73ff..5f0d419 100644
|
||||
PKG_LIBS += -lkvm
|
||||
endif
|
||||
|
||||
-PKG_CPPFLAGS = $(C_VISIBILITY)
|
||||
+PKG_CPPFLAGS = $(C_VISIBILITY) $(shell pkgconf --cflags libuv)
|
||||
-PKG_CPPFLAGS = $(C_VISIBILITY) -pthread
|
||||
+PKG_CPPFLAGS = $(C_VISIBILITY) -pthread $(shell pkgconf --cflags libuv)
|
||||
|
||||
# To avoid spurious warnings from `R CMD check --as-cran`, about compiler
|
||||
# warning flags like -Werror.
|
||||
@@ -40,32 +40,4 @@ CONFIGURE_FLAGS="--quiet"
|
||||
@@ -42,35 +42,4 @@ CONFIGURE_FLAGS="--quiet"
|
||||
# PKG_CPPFLAGS += -D_GLIBCXX_ASSERTIONS
|
||||
|
||||
|
||||
@ -53,7 +53,9 @@ index dfb73ff..5f0d419 100644
|
||||
- cp -p -f libuv/m4/lt_obsolete.m4 libuv/m4/lt~obsolete.m4
|
||||
-
|
||||
-# Run ./configure. We need to touch various autotools-related files to avoid
|
||||
-# it trying to run autotools programs again.
|
||||
-# it trying to run autotools programs again. We also need to make sure
|
||||
-# configure is executable, because on some platforms, calling unzip() in R
|
||||
-# does not preserve the executable bit.
|
||||
-#
|
||||
-# It's VERY IMPORTANT that mtime(aclocal.m4) <= mtime(configure), and also
|
||||
-# mtime(aclocal.m4) <= mtime(Makefile.in). On some platforms, passing multiple
|
||||
@ -66,6 +68,7 @@ index dfb73ff..5f0d419 100644
|
||||
- (cd libuv \
|
||||
- && touch aclocal.m4 \
|
||||
- && touch -r aclocal.m4 configure Makefile.in \
|
||||
- && chmod +x configure \
|
||||
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFIGURE_FLAGS))
|
||||
-
|
||||
-libuv/.libs/libuv.a: libuv/Makefile
|
||||
@ -102,7 +105,7 @@ index 27f8bf5..5d995c9 100644
|
||||
class CallbackQueue {
|
||||
public:
|
||||
diff --git a/src/http.h b/src/http.h
|
||||
index 06b70ff..c410712 100644
|
||||
index 41a1291..0ea3578 100644
|
||||
--- a/src/http.h
|
||||
+++ b/src/http.h
|
||||
@@ -1,7 +1,7 @@
|
||||
@ -115,7 +118,7 @@ index 06b70ff..c410712 100644
|
||||
#include <boost/bind.hpp>
|
||||
#include "webapplication.h"
|
||||
diff --git a/src/httprequest.h b/src/httprequest.h
|
||||
index fd1bf80..1feb750 100644
|
||||
index 66de583..e0c7c71 100644
|
||||
--- a/src/httprequest.h
|
||||
+++ b/src/httprequest.h
|
||||
@@ -8,7 +8,7 @@
|
||||
@ -141,7 +144,7 @@ index e41e9a3..32d9ce9 100644
|
||||
|
||||
void on_response_written(uv_write_t* handle, int status) {
|
||||
diff --git a/src/httpuv.cpp b/src/httpuv.cpp
|
||||
index 93eebba..4880f81 100644
|
||||
index 07053d5..e05cc94 100644
|
||||
--- a/src/httpuv.cpp
|
||||
+++ b/src/httpuv.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
@ -154,7 +157,7 @@ index 93eebba..4880f81 100644
|
||||
#include "uvutil.h"
|
||||
#include "webapplication.h"
|
||||
diff --git a/src/socket.cpp b/src/socket.cpp
|
||||
index 830cb1e..8f621b3 100644
|
||||
index de5d6c1..f1ca52b 100644
|
||||
--- a/src/socket.cpp
|
||||
+++ b/src/socket.cpp
|
||||
@@ -1,7 +1,7 @@
|
||||
@ -167,7 +170,7 @@ index 830cb1e..8f621b3 100644
|
||||
void on_Socket_close(uv_handle_t* pHandle);
|
||||
|
||||
diff --git a/src/socket.h b/src/socket.h
|
||||
index d9cfe15..bcf7e0b 100644
|
||||
index c7770e2..feb2070 100644
|
||||
--- a/src/socket.h
|
||||
+++ b/src/socket.h
|
||||
@@ -3,7 +3,7 @@
|
||||
@ -193,7 +196,7 @@ index e9066cb..80ea8b1 100644
|
||||
// These must be called from the main and background thread, respectively, so
|
||||
// that is_main_thread() and is_background_thread() can be tested later.
|
||||
diff --git a/src/uvutil.h b/src/uvutil.h
|
||||
index 4a7c4c0..d212fbb 100644
|
||||
index 0381bd4..e1089b9 100644
|
||||
--- a/src/uvutil.h
|
||||
+++ b/src/uvutil.h
|
||||
@@ -4,7 +4,7 @@
|
||||
@ -206,7 +209,7 @@ index 4a7c4c0..d212fbb 100644
|
||||
/* Prevent naming conflicts for Free() and Calloc() */
|
||||
#define R_NO_REMAP
|
||||
diff --git a/src/webapplication.h b/src/webapplication.h
|
||||
index 7ec2ed8..8f79a4c 100644
|
||||
index b45b0bc..683870b 100644
|
||||
--- a/src/webapplication.h
|
||||
+++ b/src/webapplication.h
|
||||
@@ -2,7 +2,7 @@
|
||||
@ -219,5 +222,5 @@ index 7ec2ed8..8f79a4c 100644
|
||||
#include "websockets.h"
|
||||
#include "thread.h"
|
||||
--
|
||||
2.14.3
|
||||
2.17.1
|
||||
|
||||
|
@ -2,8 +2,8 @@
|
||||
%global rlibdir %{_libdir}/R/library
|
||||
|
||||
Name: R-%{packname}
|
||||
Version: 1.4.3
|
||||
Release: 2%{?dist}
|
||||
Version: 1.4.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: HTTP and WebSocket Server Library
|
||||
|
||||
# Main: GPLv2+; http-parser: MIT; sha1: Public Domain
|
||||
@ -14,7 +14,7 @@ Patch0001: 0001-Use-unbundled-libuv.patch
|
||||
|
||||
# Here's the R view of the dependencies world:
|
||||
# Depends: R-methods
|
||||
# Imports: R-Rcpp >= 0.11.0, R-utils, R-promises, R-later >= 0.7.2
|
||||
# Imports: R-Rcpp >= 0.11.0, R-utils, R-promises, R-later >= 0.7.3
|
||||
# Suggests: R-testthat, R-callr
|
||||
# LinkingTo:
|
||||
# Enhances:
|
||||
@ -23,14 +23,14 @@ Requires: R-methods
|
||||
Requires: R-Rcpp >= 0.11.0
|
||||
Requires: R-utils
|
||||
Requires: R-promises
|
||||
Requires: R-later >= 0.7.2
|
||||
Requires: R-later >= 0.7.3
|
||||
BuildRequires: R-devel
|
||||
BuildRequires: tex(latex)
|
||||
BuildRequires: R-methods
|
||||
BuildRequires: R-Rcpp-devel >= 0.11.0
|
||||
BuildRequires: R-utils
|
||||
BuildRequires: R-promises
|
||||
BuildRequires: R-later-devel >= 0.7.2
|
||||
BuildRequires: R-later-devel >= 0.7.3
|
||||
BuildRequires: R-testthat
|
||||
BuildRequires: R-callr
|
||||
BuildRequires: R-BH-devel
|
||||
@ -90,6 +90,9 @@ rm -f %{buildroot}%{rlibdir}/R.css
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 22 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.4.4.1-1
|
||||
- Update to latest version
|
||||
|
||||
* Thu May 17 2018 Tom Callaway <spot@fedoraproject.org> - 1.4.3-2
|
||||
- rebuild for R 3.5.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (httpuv_1.4.3.tar.gz) = 14c76dad89a0938e1dff644e7dbfa8f780ec3b4f582f9e75f21cde3ad29f377c75624f6ee99e0c41c593199c75e5b0562e2c67f4ac75e2b5162917528649013b
|
||||
SHA512 (httpuv_1.4.4.1.tar.gz) = 092cb8d17b421d2faa24984cded4c7631b821f6ee444c18d913aebab7f45b0c3c9c3e048c9e85d49d88918a8ad3a6e016f761811d718d32d06cf10d867f2f4ff
|
||||
|
Loading…
Reference in New Issue
Block a user