Update to latest version

This commit is contained in:
Iñaki Úcar 2024-04-26 17:41:58 +02:00
parent 39f3adc4d8
commit 8799c69aa5
5 changed files with 8 additions and 308 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@
/httpuv_1.6.5.tar.gz
/httpuv_1.6.6.tar.gz
/httpuv_1.6.9.tar.gz
/httpuv_1.6.15.tar.gz

View File

@ -1,72 +0,0 @@
diff -up httpuv/src/Makevars.system httpuv/src/Makevars
--- httpuv/src/Makevars.system 2023-02-08 14:27:58.000000000 -0500
+++ httpuv/src/Makevars 2023-02-14 12:35:16.048287129 -0500
@@ -1,6 +1,6 @@
UNAME := $(shell uname)
-PKG_LIBS = ./libuv/.libs/libuv.a ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o -pthread
+PKG_LIBS = $(shell pkgconf --libs libuv) ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o -pthread
ifeq ($(UNAME), Darwin)
PKG_LIBS += -framework CoreServices
@@ -18,7 +18,7 @@ endif
PKG_CFLAGS = $(C_VISIBILITY) -DSTRICT_R_HEADERS
PKG_CXXFLAGS = $(CXX_VISIBILITY) -DSTRICT_R_HEADERS
-PKG_CPPFLAGS = -Ilibuv/include -pthread
+PKG_CPPFLAGS = -pthread $(shell pkgconf --cflags libuv)
# To avoid spurious warnings from `R CMD check --as-cran`, about compiler
# warning flags like -Werror.
@@ -38,50 +38,4 @@ CONFIGURE_FLAGS="--quiet"
# PKG_CPPFLAGS += -D_GLIBCXX_ASSERTIONS
-$(SHLIB): libuv/.libs/libuv.a http-parser/http_parser.o sha1/sha1.o base64/base64.o
-
-# We needed to rename lt~obsolete.m4 because the name causes problems with R
-# CMD check. Here we rename it back.
-libuv/m4/lt~obsolete.m4: libuv/m4/lt_obsolete.m4
- cp -p -f libuv/m4/lt_obsolete.m4 libuv/m4/lt~obsolete.m4
-
-# Run ./configure to create the Makefile.
-#
-# On systems that do _not_ have automake installed, we need to make sure that
-# configure does not try to run automake, because it will fail. To do that, we
-# we need to touch various autotools-related files so it doesn't try to run
-# autotools programs again. We also need to make sure configure is executable,
-# because on some platforms, calling unzip() in R does not preserve the
-# executable bit.
-#
-# If the system does have automake, then we'll run autogen.sh before configure,
-# as per the official build instructions for libuv. autogen.sh will in turn run
-# aclocal, autoconf, and automake.
-#
-# It's VERY IMPORTANT that mtime(aclocal.m4) <= mtime(configure), and also
-# mtime(aclocal.m4) <= mtime(Makefile.in). On some platforms, passing multiple
-# files to a single touch command gives them all the same time, but on others
-# (Solaris and possibly some Fedoras) the timestamps are slightly increasing
-# from one to the next, i.e. the order matters. To remove this fragility, we
-# use "-r aclocal.m4" to ensure that all three files are guaranteed to have
-# precisely the same timestamp value.
-libuv/Makefile: libuv/m4/lt~obsolete.m4
- cd libuv; \
- if ! command -v automake >/dev/null 2>&1 ; then \
- echo "automake not found. Touching files so configure will not try to run automake."; \
- touch aclocal.m4; \
- touch -r aclocal.m4 configure Makefile.in; \
- else \
- echo "automake found. Running autoupdate and autogen.sh."; \
- autoupdate; \
- sh autogen.sh; \
- fi; \
- chmod +x configure; \
- CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFIGURE_FLAGS)
-
-libuv/.libs/libuv.a: libuv/Makefile
- $(MAKE) --directory=libuv \
- HAVE_DTRACE=0
-
-clean:
- $(MAKE) --directory=libuv distclean
+$(SHLIB): http-parser/http_parser.o sha1/sha1.o base64/base64.o

View File

@ -1,226 +0,0 @@
From b666a857f1938d2b80b79ddc84356b5602dccdd5 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Mon, 30 Apr 2018 04:53:42 -0400
Subject: [PATCH] Use unbundled libuv.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
src/Makevars | 37 +++----------------------------------
src/callbackqueue.cpp | 2 +-
src/callbackqueue.h | 2 +-
src/http.h | 2 +-
src/httprequest.h | 2 +-
src/httpresponse.cpp | 2 +-
src/httpuv.cpp | 2 +-
src/socket.cpp | 2 +-
src/socket.h | 2 +-
src/thread.h | 2 +-
src/uvutil.h | 2 +-
src/webapplication.h | 2 +-
12 files changed, 14 insertions(+), 45 deletions(-)
diff --git a/src/Makevars b/src/Makevars
index ae8b833..f31fdf5 100644
--- a/src/Makevars
+++ b/src/Makevars
@@ -5,7 +5,7 @@ CXX_STD=CXX11
UNAME := $(shell uname)
-PKG_LIBS = ./libuv/.libs/libuv.a ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o -pthread
+PKG_LIBS = $(shell pkgconf --libs libuv) ./http-parser/http_parser.o ./sha1/sha1.o ./base64/base64.o -pthread
ifeq ($(UNAME), Darwin)
PKG_LIBS += -framework CoreServices
@@ -23,7 +23,7 @@ endif
PKG_CFLAGS = $(C_VISIBILITY) -DSTRICT_R_HEADERS
PKG_CXXFLAGS = $(CXX_VISIBILITY) -DSTRICT_R_HEADERS
-PKG_CPPFLAGS = -Ilibuv/include -pthread
+PKG_CPPFLAGS = -pthread $(shell pkgconf --cflags libuv)
# To avoid spurious warnings from `R CMD check --as-cran`, about compiler
# warning flags like -Werror.
@@ -43,35 +43,4 @@ CONFIGURE_FLAGS="--quiet"
# PKG_CPPFLAGS += -D_GLIBCXX_ASSERTIONS
-$(SHLIB): libuv/.libs/libuv.a http-parser/http_parser.o sha1/sha1.o base64/base64.o
-
-# We needed to rename lt~obsolete.m4 because the name causes problems with R
-# CMD check. Here we rename it back.
-libuv/m4/lt~obsolete.m4: libuv/m4/lt_obsolete.m4
- cp -p -f libuv/m4/lt_obsolete.m4 libuv/m4/lt~obsolete.m4
-
-# Run ./configure. We need to touch various autotools-related files to avoid
-# it trying to run autotools programs again. We also need to make sure
-# configure is executable, because on some platforms, calling unzip() in R
-# does not preserve the executable bit.
-#
-# It's VERY IMPORTANT that mtime(aclocal.m4) <= mtime(configure), and also
-# mtime(aclocal.m4) <= mtime(Makefile.in). On some platforms, passing multiple
-# files to a single touch command gives them all the same time, but on others
-# (Solaris and possibly some Fedoras) the timestamps are slightly increasing
-# from one to the next, i.e. the order matters. To remove this fragility, we
-# use "-r aclocal.m4" to ensure that all three files are guaranteed to have
-# precisely the same timestamp value.
-libuv/Makefile: libuv/m4/lt~obsolete.m4
- (cd libuv \
- && touch aclocal.m4 \
- && touch -r aclocal.m4 configure Makefile.in \
- && chmod +x configure \
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure $(CONFIGURE_FLAGS))
-
-libuv/.libs/libuv.a: libuv/Makefile
- $(MAKE) --directory=libuv \
- HAVE_DTRACE=0
-
-clean:
- $(MAKE) --directory=libuv distclean
+$(SHLIB): http-parser/http_parser.o sha1/sha1.o base64/base64.o
diff --git a/src/callbackqueue.cpp b/src/callbackqueue.cpp
index ffa1be0..fb976c7 100644
--- a/src/callbackqueue.cpp
+++ b/src/callbackqueue.cpp
@@ -2,7 +2,7 @@
#include "callbackqueue.h"
#include "tqueue.h"
#include "thread.h"
-#include "libuv/include/uv.h"
+#include <uv.h>
// This non-class function is a plain C wrapper for CallbackQueue::flush(), and
diff --git a/src/callbackqueue.h b/src/callbackqueue.h
index cfd2732..9596d92 100644
--- a/src/callbackqueue.h
+++ b/src/callbackqueue.h
@@ -3,7 +3,7 @@
#include "tqueue.h"
#include <functional>
-#include "libuv/include/uv.h"
+#include <uv.h>
class CallbackQueue {
public:
diff --git a/src/http.h b/src/http.h
index 5b8ec73..882bbf2 100644
--- a/src/http.h
+++ b/src/http.h
@@ -1,7 +1,7 @@
#ifndef HTTP_HPP
#define HTTP_HPP
-#include "libuv/include/uv.h"
+#include <uv.h>
#include <memory>
#include <functional>
#include "webapplication.h"
diff --git a/src/httprequest.h b/src/httprequest.h
index f25370b..325f473 100644
--- a/src/httprequest.h
+++ b/src/httprequest.h
@@ -6,7 +6,7 @@
#include <functional>
#include <memory>
-#include "libuv/include/uv.h"
+#include <uv.h>
#include "http-parser/http_parser.h"
#include "socket.h"
#include "webapplication.h"
diff --git a/src/httpresponse.cpp b/src/httpresponse.cpp
index 7dccc2e..9083c76 100644
--- a/src/httpresponse.cpp
+++ b/src/httpresponse.cpp
@@ -3,7 +3,7 @@
#include "constants.h"
#include "thread.h"
#include "utils.h"
-#include "libuv/include/uv.h"
+#include <uv.h>
void on_response_written(uv_write_t* handle, int status) {
diff --git a/src/httpuv.cpp b/src/httpuv.cpp
index c5ecf9f..63646cf 100644
--- a/src/httpuv.cpp
+++ b/src/httpuv.cpp
@@ -7,7 +7,7 @@
#include <errno.h>
#include <functional>
#include <memory>
-#include "libuv/include/uv.h"
+#include <uv.h>
#include "base64/base64.hpp"
#include "uvutil.h"
#include "webapplication.h"
diff --git a/src/socket.cpp b/src/socket.cpp
index 16f3dbf..492388f 100644
--- a/src/socket.cpp
+++ b/src/socket.cpp
@@ -1,7 +1,7 @@
#include "socket.h"
#include "httprequest.h"
#include <later_api.h>
-#include "libuv/include/uv.h"
+#include <uv.h>
void on_Socket_close(uv_handle_t* pHandle);
diff --git a/src/socket.h b/src/socket.h
index 11cc840..472e917 100644
--- a/src/socket.h
+++ b/src/socket.h
@@ -3,7 +3,7 @@
#include "http.h"
#include <memory>
-#include "libuv/include/uv.h"
+#include <uv.h>
class HttpRequest;
class WebApplication;
diff --git a/src/thread.h b/src/thread.h
index e9066cb..80ea8b1 100644
--- a/src/thread.h
+++ b/src/thread.h
@@ -1,7 +1,7 @@
#ifndef THREAD_HPP
#define THREAD_HPP
-#include "libuv/include/uv.h"
+#include <uv.h>
// These must be called from the main and background thread, respectively, so
// that is_main_thread() and is_background_thread() can be tested later.
diff --git a/src/uvutil.h b/src/uvutil.h
index 7f812ce..67311d8 100644
--- a/src/uvutil.h
+++ b/src/uvutil.h
@@ -5,7 +5,7 @@
#include <string>
#include <vector>
#include <memory>
-#include "libuv/include/uv.h"
+#include <uv.h>
#include <Rcpp.h>
diff --git a/src/webapplication.h b/src/webapplication.h
index 16fcbf6..51e4f26 100644
--- a/src/webapplication.h
+++ b/src/webapplication.h
@@ -2,7 +2,7 @@
#define WEBAPPLICATION_HPP
#include <functional>
-#include "libuv/include/uv.h"
+#include <uv.h>
#include <Rcpp.h>
#include "websockets.h"
#include "thread.h"
--
2.29.2

View File

@ -1,19 +1,18 @@
%bcond_with bootstrap
%global packname httpuv
%global packver 1.6.9
%global packver 1.6.15
%global rlibdir %{_libdir}/R/library
Name: R-%{packname}
Version: %{packver}
Release: 6%{?dist}
Release: 1%{?dist}
Summary: HTTP and WebSocket Server Library
# Main: GPLv2+; http-parser: MIT; sha1: Public Domain
License: GPL-2.0-or-later AND MIT AND LicenseRef-Fedora-Public-Domain
URL: https://CRAN.R-project.org/package=%{packname}
Source0: https://cran.r-project.org/src/contrib/%{packname}_%{packver}.tar.gz
Patch0001: 0001-Use-unbundled-libuv-new.patch
# Here's the R view of the dependencies world:
# Depends:
@ -53,12 +52,6 @@ by Joyent, Inc.
%prep
%setup -q -c -n %{packname}
pushd %{packname}
%patch0001 -p1 -b .system
rm -r src/libuv
sed -i '/libuv/d' MD5
popd
%build
@ -89,11 +82,15 @@ export LANG=C.UTF-8
%{rlibdir}/%{packname}/R
%{rlibdir}/%{packname}/help
%{rlibdir}/%{packname}/demo
%{rlibdir}/%{packname}/example-static-site
%dir %{rlibdir}/%{packname}/libs
%{rlibdir}/%{packname}/libs/%{packname}.so
%changelog
* Fri Apr 26 2024 Iñaki Úcar <iucar@fedoraproject.org> - 1.6.15-1
- Update to latest version
* Thu Apr 25 2024 Iñaki Úcar <iucar@fedoraproject.org> - 1.6.9-6
- R-maint-sig mass rebuild

View File

@ -1 +1 @@
SHA512 (httpuv_1.6.9.tar.gz) = 435f637c942d47c42a7f75d2b3d105d9869924e2c17c24355486832eed00f667cb6e38984bc6075cb037f5c9ed06dd119a098943ed38216fd724592e3bbf62f7
SHA512 (httpuv_1.6.15.tar.gz) = 8f674b09f1c8ce26b50612bbe6aed756c9f6ad387a59e9f41f776bd0ec14e5454fd8f38aebec66f9ec48aef45b6f8c053d50ed83ac2b8e8f03eee62c85c78e30