update to 1.6.2

This commit is contained in:
Tom Callaway 2023-04-28 16:26:52 -04:00
parent 802bf9eb2d
commit 25595b76e1
4 changed files with 18 additions and 11 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/fs_1.4.2.tar.gz
/fs_1.5.0.tar.gz
/fs_1.5.2.tar.gz
/fs_1.6.2.tar.gz

View File

@ -105,7 +105,7 @@ index c712bdc1..473d665e 100644
+++ b/src/Makevars
@@ -2,7 +2,7 @@ UNAME := $(shell uname)
LIBUV := libuv-1.38.1
LIBUV := libuv-1.44.2
-PKG_LIBS = ./$(LIBUV)/.libs/libuv.a -pthread
+PKG_LIBS = $(shell pkgconf --libs libuv)
@ -125,7 +125,7 @@ index c712bdc1..473d665e 100644
-
-$(LIBUV)/Makefile:
- (cd $(LIBUV) \
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPPFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure --quiet)
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPPFLAGS) $(CPICFLAGS) $(C_VISIBILITY) -std=c99" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure --quiet)
-
-$(LIBUV)/.libs/libuv.a: $(LIBUV)/Makefile
- $(MAKE) --directory=$(LIBUV) \

View File

@ -1,15 +1,18 @@
%bcond_with check
%global packname fs
%global packver 1.5.2
%global packver 1.6.2
%global rlibdir %{_libdir}/R/library
Name: R-%{packname}
Version: 1.5.2
Release: 3%{?dist}
Version: %{packver}
Release: 1%{?dist}
Summary: Cross-Platform File System Operations Based on 'libuv'
License: GPLv3
# Wasn't this so much nicer when it was just GPLv3?
#
# SPDX is currently missing this one:
# https://scancode-licensedb.aboutcode.org/bsd-credit.html
License: GPL-3.0-only AND libutil-David-Nugent AND BSD-3-Clause AND BSD-2-Clause AND ISC AND MIT AND LicenseRef-Fedora-Public-Domain AND Beerware
URL: https://CRAN.R-project.org/package=%{packname}
Source0: https://cran.r-project.org/src/contrib/%{packname}_%{packver}.tar.gz
# Fedora-specific.
@ -18,7 +21,7 @@ Patch0001: 0001-Use-system-libuv.patch
# Here's the R view of the dependencies world:
# Depends:
# Imports: R-methods
# Suggests: R-testthat, R-covr, R-pillar >= 1.0.0, R-tibble >= 1.1.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling, R-vctrs >= 0.3.0
# Suggests: R-testthat >= 3.0.0, R-covr, R-pillar >= 1.0.0, R-tibble >= 1.1.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling, R-vctrs >= 0.3.0
# LinkingTo:
# Enhances:
@ -27,7 +30,7 @@ BuildRequires: R-devel
BuildRequires: tex(latex)
BuildRequires: R-methods
%if %{with check}
BuildRequires: R-testthat
BuildRequires: R-testthat >= 3.0.0
BuildRequires: R-pillar >= 1.0.0
BuildRequires: R-tibble >= 1.1.0
BuildRequires: R-crayon
@ -50,7 +53,7 @@ A cross-platform interface to file system operations, built on top of the
pushd %{packname}
# Remove bundled libuv.
%patch0001 -p1
%patch -P0001 -p1
rm -rf src/libuv-*
sed -i -e '/libuv/d' MD5
@ -99,6 +102,9 @@ _R_CHECK_FORCE_SUGGESTS_=0 %{_bindir}/R CMD check %{packname}
%changelog
* Fri Apr 28 2023 Tom Callaway <spot@fedoraproject.org> - 1.6.2-1
- update to 1.6.2
* Fri Apr 21 2023 Iñaki Úcar <iucar@fedoraproject.org> - 1.5.2-3
- R-maint-sig mass rebuild

View File

@ -1 +1 @@
SHA512 (fs_1.5.2.tar.gz) = 0d114613946ef03a9fa4a1a07cd30f04f0a677646692f17e9adaa55f8e65eb26575822875dc9054c19817fffae9dc11662c89115d4ea123846bea9bdfb06b305
SHA512 (fs_1.6.2.tar.gz) = aeaf74162f9d4e9b433111def551c34b7b28531ee25e409c8446b35bc7f27aded1726a87d809ca7bbbb337801d233fa4df998df178f625a67f5e3c87ff08a92a