Update to latest version.

This commit is contained in:
Elliott Sales de Andrade 2020-08-01 04:55:08 -04:00
parent 78807b0f15
commit 117e45ef3e
4 changed files with 35 additions and 23 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/fs_1.3.1.tar.gz
/fs_1.4.1.tar.gz
/fs_1.4.2.tar.gz
/fs_1.5.0.tar.gz

View File

@ -1,4 +1,4 @@
From bdf668ceec4ee205cd93e6e74c948ac8f27eeef3 Mon Sep 17 00:00:00 2001
From 526dece09265247edf75808b0d77f9cb397164e0 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 22 Sep 2018 23:50:25 -0400
Subject: [PATCH] Use system libuv.
@ -6,8 +6,8 @@ Subject: [PATCH] Use system libuv.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
inst/COPYRIGHTS | 79 -------------------------------------------------
src/Makevars | 19 ++----------
2 files changed, 3 insertions(+), 95 deletions(-)
src/Makevars | 17 ++---------
2 files changed, 3 insertions(+), 93 deletions(-)
diff --git a/inst/COPYRIGHTS b/inst/COPYRIGHTS
index 912533e3..ed998717 100644
@ -100,43 +100,44 @@ index 912533e3..ed998717 100644
use one of the following licenses:
diff --git a/src/Makevars b/src/Makevars
index 97c8f059..18a71d98 100644
index c712bdc1..473d665e 100644
--- a/src/Makevars
+++ b/src/Makevars
@@ -1,6 +1,6 @@
UNAME := $(shell uname)
@@ -2,7 +2,7 @@ UNAME := $(shell uname)
-PKG_LIBS = ./libuv/.libs/libuv.a -pthread
LIBUV := libuv-1.38.1
-PKG_LIBS = ./$(LIBUV)/.libs/libuv.a -pthread
+PKG_LIBS = $(shell pkgconf --libs libuv)
SOURCES = $(wildcard *.cc unix/*.cc)
OBJECTS = $(SOURCES:.cc=.o)
@@ -19,24 +19,11 @@ ifeq ($(UNAME), Linux)
@@ -21,24 +21,13 @@ ifeq ($(UNAME), Linux)
OBJECTS += bsd/setmode.o bsd/strmode.o bsd/reallocarray.o
endif
-PKG_CPPFLAGS = -I./libuv/include -I. -pthread
-PKG_CPPFLAGS = -I./$(LIBUV)/include -I. -pthread
+PKG_CPPFLAGS = $(shell pkgconf --cflags libuv) -I.
all: $(SHLIB)
-$(SHLIB): libuv/.libs/libuv.a
-$(SHLIB): $(LIBUV)/.libs/libuv.a
-
-libuv/Makefile:
- (cd libuv \
-$(LIBUV)/Makefile:
- (cd $(LIBUV) \
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPPFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure --quiet)
-
-libuv/.libs/libuv.a: libuv/Makefile
- $(MAKE) --directory=libuv \
-$(LIBUV)/.libs/libuv.a: $(LIBUV)/Makefile
- $(MAKE) --directory=$(LIBUV) \
- HAVE_DTRACE=0
-
-.PHONY: shlib-clean clean
-
-# shlib-clean: clean
+.PHONY: clean
# shlib-clean: clean
clean:
- $(MAKE) --directory=libuv distclean
- $(MAKE) --directory=$(LIBUV) distclean
rm -f $(OBJECTS)
--
2.25.4

View File

@ -1,10 +1,10 @@
%global packname fs
%global packver 1.4.2
%global packver 1.5.0
%global rlibdir %{_libdir}/R/library
Name: R-%{packname}
Version: 1.4.2
Release: 2%{?dist}
Version: 1.5.0
Release: 1%{?dist}
Summary: Cross-Platform File System Operations Based on 'libuv'
License: GPLv3
@ -16,7 +16,7 @@ Patch0001: 0001-Use-system-libuv.patch
# Here's the R view of the dependencies world:
# Depends:
# Imports: R-methods
# Suggests: R-testthat, R-covr, R-pillar >= 1.0.0, R-tibble >= 1.1.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling
# Suggests: R-testthat, R-covr, R-pillar >= 1.0.0, R-tibble >= 1.1.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling, R-vctrs >= 0.3.0
# LinkingTo:
# Enhances:
@ -32,6 +32,9 @@ BuildRequires: R-rmarkdown
BuildRequires: R-knitr
BuildRequires: R-withr
BuildRequires: R-spelling
%if %{fedora} > 32
BuildRequires: R-vctrs >= 0.3.0
%endif
%description
A cross-platform interface to file system operations, built on top of the
@ -44,7 +47,7 @@ A cross-platform interface to file system operations, built on top of the
pushd %{packname}
# Remove bundled libuv.
%patch0001 -p1
rm -rf src/libuv
rm -rf src/libuv-*
sed -i -e '/libuv/d' MD5
# Don't need coverage; it's not packaged either.
@ -64,7 +67,11 @@ rm -f %{buildroot}%{rlibdir}/R.css
%check
export LANG=C.UTF-8
%if %{fedora} > 32
%{_bindir}/R CMD check %{packname}
%else
_R_CHECK_FORCE_SUGGESTS_=0 %{_bindir}/R CMD check %{packname}
%endif
%files
@ -85,6 +92,9 @@ export LANG=C.UTF-8
%changelog
* Sat Aug 01 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.5.0-1
- Update to latest version
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (fs_1.4.2.tar.gz) = 4910f73af96a99d024e6a7b5eb2154cd6c1fcde4b51f0980abb8a3a3b74a4ee145ab2757e91a548e0f914684487648ef24e304325dace1a1a099926cc537e4a3
SHA512 (fs_1.5.0.tar.gz) = e8b49b2c4cd65fbfa319719121b00bb66014c4330a3f05f27e800be1b04bc8eba4121e9ef06133db185c1aa23294f5f7ceeccbdfad41e6dc06d12d7a338d342b