update to 1.4.1, rebuild for R 4

This commit is contained in:
Tom Callaway 2020-06-07 10:11:36 -04:00
parent 157cccab0c
commit 002af13c3e
5 changed files with 32 additions and 16 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/fs_1.2.7.tar.gz
/fs_1.3.0.tar.gz
/fs_1.3.1.tar.gz
/fs_1.4.1.tar.gz

View File

@ -110,8 +110,8 @@ index a4c07030..6e08a28f 100644
+PKG_LIBS = $(shell pkgconf --libs libuv)
SOURCES = $(wildcard *.cc unix/*.cc)
OBJECTS = $(SOURCES:.cc=.o) RcppExports.o
@@ -19,29 +19,11 @@ ifeq ($(UNAME), Linux)
OBJECTS = $(SOURCES:.cc=.o)
@@ -19,24 +19,11 @@
OBJECTS += bsd/setmode.o bsd/strmode.o bsd/reallocarray.o
endif
@ -122,14 +122,9 @@ index a4c07030..6e08a28f 100644
-$(SHLIB): libuv/.libs/libuv.a
-
-libuv/m4/lt~obsolete.m4: libuv/m4/lt_obsolete.m4
- cp -p -f libuv/m4/lt_obsolete.m4 libuv/m4/lt~obsolete.m4
-
-libuv/Makefile: libuv/m4/lt~obsolete.m4
-libuv/Makefile:
- (cd libuv \
- && touch aclocal.m4 \
- && touch -r aclocal.m4 configure Makefile.in \
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure --quiet)
- && CC="$(CC)" CFLAGS="$(CFLAGS) $(CPPFLAGS) $(CPICFLAGS) $(C_VISIBILITY)" AR="$(AR)" RANLIB="$(RANLIB)" LDFLAGS="$(LDFLAGS)" ./configure --quiet)
-
-libuv/.libs/libuv.a: libuv/Makefile
- $(MAKE) --directory=libuv \
@ -137,12 +132,11 @@ index a4c07030..6e08a28f 100644
-
-.PHONY: shlib-clean clean
-
-shlib-clean: clean
-# shlib-clean: clean
+.PHONY: clean
clean:
- $(MAKE) --directory=libuv distclean
rm -f $(OBJECTS)
--
--
2.20.1

12
0003-fix-cstring.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up fs/src/file.cc.fix fs/src/file.cc
--- fs/src/file.cc.fix 2020-06-07 10:06:16.061054314 -0400
+++ fs/src/file.cc 2020-06-07 10:06:46.228385680 -0400
@@ -9,7 +9,7 @@
#undef ERROR
-#include <string>
+#include <cstring>
#include <vector>
#include "error.h"

View File

@ -2,8 +2,8 @@
%global rlibdir %{_libdir}/R/library
Name: R-%{packname}
Version: 1.3.1
Release: 4%{?dist}
Version: 1.4.1
Release: 1%{?dist}
Summary: Cross-Platform File System Operations Based on 'libuv'
License: GPLv3
@ -13,11 +13,13 @@ Source0: https://cran.r-project.org/src/contrib/%{packname}_%{version}.
Patch0001: 0001-Use-system-libuv.patch
# Workaround for https://github.com/libuv/libuv/issues/2262
Patch0002: 0002-Initialize-stat-buf-to-be-zero.patch
# Fix issue where file.cc needs cstring.h
Patch0003: 0003-fix-cstring.patch
# Here's the R view of the dependencies world:
# Depends:
# Imports: R-methods, R-Rcpp
# Suggests: R-testthat, R-covr, R-pillar >= 1.0.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling
# Suggests: R-testthat, R-covr, R-pillar >= 1.0.0, R-tibble >= 1.1.0, R-crayon, R-rmarkdown, R-knitr, R-withr, R-spelling
# LinkingTo:
# Enhances:
@ -28,6 +30,7 @@ BuildRequires: R-methods
BuildRequires: R-Rcpp-devel
BuildRequires: R-testthat
BuildRequires: R-pillar >= 1.0.0
BuildRequires: R-tibble >= 1.1.0
BuildRequires: R-crayon
BuildRequires: R-rmarkdown
BuildRequires: R-knitr
@ -50,6 +53,8 @@ sed -i -e '/libuv/d' MD5
%patch0002 -p1
%patch0003 -p1
# Don't need coverage; it's not packaged either.
sed -i 's/, covr//g' DESCRIPTION
popd
@ -88,6 +93,10 @@ export LANG=C.UTF-8
%changelog
* Thu Jun 4 2020 Tom Callaway <spot@fedoraproject.org> - 1.4.1-1
- update to 1.4.1
- rebuild for R 4
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (fs_1.3.1.tar.gz) = a64bab2c15baa630990fc927a0397be6ccb10f8bc97e01b28247b92c6a19ce47b8fc3b049bb75b7ceaadf295f8ed7c8eea3d78f1391f39e813f2bb25f0edceba
SHA512 (fs_1.4.1.tar.gz) = bb5a9459f994c5a56e0cd282e88c0ed8a049723669a18587ba42a688adc81229d84626cdc8208034808e42d19e46ce31544507473481964fef6e352c61a9b640