PDAL/PDAL_unbundle.patch

288 lines
9.5 KiB
Diff

diff -rupN PDAL-2.2.0-src/CMakeLists.txt PDAL-2.2.0-src-new/CMakeLists.txt
--- PDAL-2.2.0-src/CMakeLists.txt 2020-09-09 17:14:18.000000000 +0200
+++ PDAL-2.2.0-src-new/CMakeLists.txt 2020-10-18 20:19:25.725455538 +0200
@@ -67,7 +67,6 @@ else()
endif()
set(PDAL_LIB_NAME pdalcpp)
set(PDAL_UTIL_LIB_NAME pdal_util)
-set(PDAL_BOOST_LIB_NAME pdal_boost)
set(PDAL_KAZHDAN_LIB_NAME pdal_kazhdan)
set(PDAL_TEST_SUPPORT_OBJS pdal_test_support)
@@ -141,6 +140,9 @@ include(${PDAL_CMAKE_DIR}/arbiter.cmake)
include(${PDAL_CMAKE_DIR}/nlohmann.cmake)
include(${PDAL_CMAKE_DIR}/openssl.cmake) # Optional
+find_package(PkgConfig REQUIRED)
+PKG_CHECK_MODULES(EIGEN REQUIRED eigen3)
+
#------------------------------------------------------------------------------
# generate the pdal_features.hpp header
#------------------------------------------------------------------------------
@@ -179,13 +181,10 @@ endif()
add_subdirectory(plugins)
-#include_directories(vendor/pdalboost)
if (WITH_TESTS)
- include (${PDAL_CMAKE_DIR}/gtest.cmake)
add_subdirectory(test)
endif()
add_subdirectory(dimbuilder)
-add_subdirectory(vendor/pdalboost)
add_subdirectory(vendor/arbiter)
add_subdirectory(vendor/kazhdan)
add_subdirectory(pdal/util)
@@ -267,13 +266,12 @@ target_include_directories(${PDAL_BASE_L
${ROOT_DIR}
${PROJECT_BINARY_DIR}/include
${PDAL_VENDOR_DIR}
- ${PDAL_VENDOR_DIR}/eigen
- ${PDAL_VENDOR_DIR}/pdalboost
${LIBXML2_INCLUDE_DIR}
${ZSTD_INCLUDE_DIRS}
${NLOHMANN_INCLUDE_DIR}
${GDAL_INCLUDE_DIR}
${LASZIP_INCLUDE_DIR}
+ ${EIGEN_INCLUDE_DIRS}
)
target_link_libraries(${PDAL_BASE_LIB_NAME}
PRIVATE
diff -rupN PDAL-2.1.0-src/pdal/util/CMakeLists.txt PDAL-2.1.0-src-new/pdal/util/CMakeLists.txt
--- PDAL-2.1.0-src/pdal/util/CMakeLists.txt 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/pdal/util/CMakeLists.txt 2020-05-27 11:10:04.732174032 +0200
@@ -33,7 +33,7 @@ PDAL_ADD_FREE_LIBRARY(${PDAL_UTIL_LIB_NA
target_link_libraries(${PDAL_UTIL_LIB_NAME}
PRIVATE
${BACKTRACE_LIBRARIES}
- ${PDAL_BOOST_LIB_NAME}
+ boost_filesystem
${CMAKE_DL_LIBS}
)
target_include_directories(${PDAL_UTIL_LIB_NAME} PRIVATE
diff -rupN PDAL-2.1.0-src/pdal/util/FileUtils.cpp PDAL-2.1.0-src-new/pdal/util/FileUtils.cpp
--- PDAL-2.1.0-src/pdal/util/FileUtils.cpp 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/pdal/util/FileUtils.cpp 2020-05-27 11:08:56.736043058 +0200
@@ -149,25 +149,25 @@ std::ostream *createFile(std::string con
bool directoryExists(const std::string& dirname)
{
//ABELL - Seems we should be calling is_directory
- return pdalboost::filesystem::exists(toNative(dirname));
+ return boost::filesystem::exists(toNative(dirname));
}
bool createDirectory(const std::string& dirname)
{
- return pdalboost::filesystem::create_directory(toNative(dirname));
+ return boost::filesystem::create_directory(toNative(dirname));
}
bool createDirectories(const std::string& dirname)
{
- return pdalboost::filesystem::create_directories(toNative(dirname));
+ return boost::filesystem::create_directories(toNative(dirname));
}
void deleteDirectory(const std::string& dirname)
{
- pdalboost::filesystem::remove_all(toNative(dirname));
+ boost::filesystem::remove_all(toNative(dirname));
}
@@ -177,15 +177,15 @@ std::vector<std::string> directoryList(c
try
{
- pdalboost::filesystem::directory_iterator it(dir);
- pdalboost::filesystem::directory_iterator end;
+ boost::filesystem::directory_iterator it(dir);
+ boost::filesystem::directory_iterator end;
while (it != end)
{
files.push_back(it->path().string());
it++;
}
}
- catch (pdalboost::filesystem::filesystem_error&)
+ catch (boost::filesystem::filesystem_error&)
{
files.clear();
}
@@ -225,13 +225,13 @@ void closeFile(std::istream* in)
bool deleteFile(const std::string& file)
{
- return pdalboost::filesystem::remove(toNative(file));
+ return boost::filesystem::remove(toNative(file));
}
void renameFile(const std::string& dest, const std::string& src)
{
- pdalboost::filesystem::rename(toNative(src), toNative(dest));
+ boost::filesystem::rename(toNative(src), toNative(dest));
}
@@ -242,9 +242,9 @@ bool fileExists(const std::string& name)
try
{
- return pdalboost::filesystem::exists(toNative(name));
+ return boost::filesystem::exists(toNative(name));
}
- catch (pdalboost::filesystem::filesystem_error&)
+ catch (boost::filesystem::filesystem_error&)
{
}
return false;
@@ -253,7 +253,7 @@ bool fileExists(const std::string& name)
uintmax_t fileSize(const std::string& file)
{
- return pdalboost::filesystem::file_size(toNative(file));
+ return boost::filesystem::file_size(toNative(file));
}
@@ -274,7 +274,7 @@ std::string readFileIntoString(const std
std::string getcwd()
{
- const pdalboost::filesystem::path p = pdalboost::filesystem::current_path();
+ const boost::filesystem::path p = boost::filesystem::current_path();
return addTrailingSlash(p.string());
}
@@ -302,7 +302,7 @@ std::string toAbsolutePath(const std::st
// otherwise, make it absolute (relative to current working dir) and return that
std::string toAbsolutePath(const std::string& filename)
{
- return pdalboost::filesystem::absolute(toNative(filename)).string();
+ return boost::filesystem::absolute(toNative(filename)).string();
}
@@ -314,7 +314,7 @@ std::string toAbsolutePath(const std::st
std::string toAbsolutePath(const std::string& filename, const std::string base)
{
const std::string newbase = toAbsolutePath(base);
- return pdalboost::filesystem::absolute(toNative(filename),
+ return boost::filesystem::absolute(toNative(filename),
toNative(newbase)).string();
}
@@ -337,8 +337,8 @@ std::string getFilename(const std::strin
// Get the directory part of a filename.
std::string getDirectory(const std::string& path)
{
- const pdalboost::filesystem::path dir =
- pdalboost::filesystem::path(toNative(path)).parent_path();
+ const boost::filesystem::path dir =
+ boost::filesystem::path(toNative(path)).parent_path();
return addTrailingSlash(dir.string());
}
@@ -359,13 +359,13 @@ std::string stem(const std::string& path
// Determine if the path represents a directory.
bool isDirectory(const std::string& path)
{
- return pdalboost::filesystem::is_directory(toNative(path));
+ return boost::filesystem::is_directory(toNative(path));
}
// Determine if the path is an absolute path
bool isAbsolutePath(const std::string& path)
{
- return pdalboost::filesystem::path(toNative(path)).is_absolute();
+ return boost::filesystem::path(toNative(path)).is_absolute();
}
diff -rupN PDAL-2.2.0-src/test/unit/CMakeLists.txt PDAL-2.2.0-src-new/test/unit/CMakeLists.txt
--- PDAL-2.2.0-src/test/unit/CMakeLists.txt 2020-09-09 17:14:17.000000000 +0200
+++ PDAL-2.2.0-src-new/test/unit/CMakeLists.txt 2020-10-18 20:31:38.138997875 +0200
@@ -34,7 +34,7 @@ PDAL_ADD_TEST(pdal_eigen_test
${PDAL_SRC_DIR}/private/MathUtils.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_file_utils_test FILES FileUtilsTest.cpp)
PDAL_ADD_TEST(pdal_georeference_test FILES GeoreferenceTest.cpp)
@@ -43,7 +43,7 @@ PDAL_ADD_TEST(pdal_kdindex_test
KDIndexTest.cpp
INCLUDES
${PDAL_VENDOR_DIR}
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_kernel_test FILES KernelTest.cpp)
PDAL_ADD_TEST(pdal_log_test FILES LogTest.cpp)
@@ -70,7 +70,7 @@ PDAL_ADD_TEST(pdal_point_view_test
FILES
PointViewTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_point_table_test FILES PointTableTest.cpp)
@@ -189,13 +189,13 @@ PDAL_ADD_TEST(pdal_io_pcd_reader_test
FILES
io/PcdReaderTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_io_pcd_writer_test
FILES
io/PcdWriterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_io_ply_reader_test
FILES
@@ -231,7 +231,7 @@ PDAL_ADD_TEST(pdal_filters_chipper_test
filters/ChipperTest.cpp
INCLUDES
${NLOHMANN_INCLUDE_DIR}
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_filters_nndistance_test
FILES
@@ -281,7 +281,7 @@ PDAL_ADD_TEST(pdal_filters_icp_test
FILES
filters/IcpFilterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_filters_info_test FILES filters/InfoFilterTest.cpp)
PDAL_ADD_TEST(pdal_filters_neighborclassifier_test FILES filters/NeighborClassifierFilterTest.cpp)
@@ -301,7 +301,7 @@ PDAL_ADD_TEST(pdal_filters_planefit_test
FILES
filters/PlaneFitFilterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen)
+ ${EIGEN_INCLUDE_DIRS})
PDAL_ADD_TEST(pdal_filters_pmf_test FILES filters/PMFFilterTest.cpp)
PDAL_ADD_TEST(pdal_filters_reprojection_test FILES
filters/ReprojectionFilterTest.cpp)
@@ -326,7 +326,7 @@ PDAL_ADD_TEST(pdal_filters_splitter_test
FILES
filters/SplitterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen)
+ ${EIGEN_INCLUDE_DIRS})
PDAL_ADD_TEST(pdal_filters_stats_test FILES filters/StatsFilterTest.cpp)
PDAL_ADD_TEST(pdal_filters_transformation_test FILES
filters/TransformationFilterTest.cpp)