Rebuild (proj, gdal)
This commit is contained in:
parent
a0233634b0
commit
8f0748930f
@ -1,7 +1,7 @@
|
||||
Summary: Point Data Abstraction Library
|
||||
Name: PDAL
|
||||
Version: 2.2.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
# The code is licensed BSD except for:
|
||||
# - filters/private/csf/* and plugins/i3s/lepcc/* are ASL 2.0
|
||||
# - vendor/arbiter/*, plugins/nitf/io/nitflib.h and plugins/oci/io/OciWrapper.* are Expat/MIT
|
||||
@ -233,6 +233,9 @@ sphinx-build -b html . build/html
|
||||
%license LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Fri Nov 6 22:41:05 CET 2020 Sandro Mani <manisandro@gmail.com> - 2.2.0-3
|
||||
- Rebuild (proj, gdal)
|
||||
|
||||
* Sat Oct 24 2020 Markus Neteler <neteler@mundialis.de> 2.2.0-2
|
||||
- add laszip-devel requirement to PDAL-devel (fixes BZ #1891154)
|
||||
- activated bash completion
|
||||
|
@ -1,6 +1,22 @@
|
||||
diff -rupN PDAL-2.2.0-src/test/unit/filters/FerryFilterTest.cpp PDAL-2.2.0-src-new/test/unit/filters/FerryFilterTest.cpp
|
||||
--- PDAL-2.2.0-src/test/unit/filters/FerryFilterTest.cpp 2020-09-09 17:14:17.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/test/unit/filters/FerryFilterTest.cpp 2020-11-11 12:44:40.530553155 +0100
|
||||
@@ -119,10 +119,10 @@ TEST(FerryFilterTest, test_ferry_copy_js
|
||||
double x = view->getFieldAs<double>(state_plane_x, 0);
|
||||
double y = view->getFieldAs<double>(state_plane_y, 0);
|
||||
|
||||
- EXPECT_DOUBLE_EQ(-117.2501328350574, lon);
|
||||
+ EXPECT_DOUBLE_EQ(-117.25014718503355, lon);
|
||||
// proj 5 will consider +ellps=GRS80 +towgs84=0,0,0 to be slighly different
|
||||
// than +datum=WGS84 and return 49.341077823260804.
|
||||
- EXPECT_NEAR(49.341077824192915, lat, 1e-9);
|
||||
+ EXPECT_NEAR(49.341084161118197, lat, 1e-9);
|
||||
EXPECT_DOUBLE_EQ(637012.24, x);
|
||||
EXPECT_DOUBLE_EQ(849028.31, y);
|
||||
}
|
||||
diff -rupN PDAL-2.2.0-src/test/unit/io/FauxReaderTest.cpp PDAL-2.2.0-src-new/test/unit/io/FauxReaderTest.cpp
|
||||
--- PDAL-2.2.0-src/test/unit/io/FauxReaderTest.cpp 2020-09-09 17:14:17.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/test/unit/io/FauxReaderTest.cpp 2020-11-04 14:26:57.817013140 +0100
|
||||
+++ PDAL-2.2.0-src-new/test/unit/io/FauxReaderTest.cpp 2020-11-11 12:44:01.154607262 +0100
|
||||
@@ -241,7 +241,7 @@ TEST(FauxReaderTest, uniform)
|
||||
{
|
||||
Options ops;
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN --no-dereference PDAL-2.2.0-src/cmake/macros.cmake PDAL-2.2.0-src-new/cmake/macros.cmake
|
||||
--- PDAL-2.2.0-src/cmake/macros.cmake 2020-09-09 17:14:16.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/cmake/macros.cmake 2020-10-26 17:50:56.464172911 +0100
|
||||
+++ PDAL-2.2.0-src-new/cmake/macros.cmake 2020-11-11 12:44:00.776607812 +0100
|
||||
@@ -206,6 +206,6 @@ macro(PDAL_ADD_TEST _name)
|
||||
"PDAL_DRIVER_PATH=${PROJECT_BINARY_DIR}/bin")
|
||||
else()
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN --no-dereference PDAL-2.2.0-src/CMakeLists.txt PDAL-2.2.0-src-new/CMakeLists.txt
|
||||
--- PDAL-2.2.0-src/CMakeLists.txt 2020-09-09 17:14:18.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/CMakeLists.txt 2020-10-26 17:50:56.100173211 +0100
|
||||
+++ PDAL-2.2.0-src-new/CMakeLists.txt 2020-11-11 12:44:00.407608350 +0100
|
||||
@@ -67,7 +67,6 @@ else()
|
||||
endif()
|
||||
set(PDAL_LIB_NAME pdalcpp)
|
||||
@ -50,7 +50,7 @@ diff -rupN --no-dereference PDAL-2.2.0-src/CMakeLists.txt PDAL-2.2.0-src-new/CMa
|
||||
PRIVATE
|
||||
diff -rupN --no-dereference PDAL-2.2.0-src/pdal/util/CMakeLists.txt PDAL-2.2.0-src-new/pdal/util/CMakeLists.txt
|
||||
--- PDAL-2.2.0-src/pdal/util/CMakeLists.txt 2020-09-09 17:14:16.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/pdal/util/CMakeLists.txt 2020-10-26 17:50:56.100173211 +0100
|
||||
+++ PDAL-2.2.0-src-new/pdal/util/CMakeLists.txt 2020-11-11 12:44:00.408608349 +0100
|
||||
@@ -34,7 +34,7 @@ PDAL_ADD_FREE_LIBRARY(${PDAL_UTIL_LIB_NA
|
||||
target_link_libraries(${PDAL_UTIL_LIB_NAME}
|
||||
PRIVATE
|
||||
@ -62,7 +62,7 @@ diff -rupN --no-dereference PDAL-2.2.0-src/pdal/util/CMakeLists.txt PDAL-2.2.0-s
|
||||
target_include_directories(${PDAL_UTIL_LIB_NAME} PRIVATE
|
||||
diff -rupN --no-dereference PDAL-2.2.0-src/pdal/util/FileUtils.cpp PDAL-2.2.0-src-new/pdal/util/FileUtils.cpp
|
||||
--- PDAL-2.2.0-src/pdal/util/FileUtils.cpp 2020-09-09 17:14:16.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/pdal/util/FileUtils.cpp 2020-10-26 17:50:56.100173211 +0100
|
||||
+++ PDAL-2.2.0-src-new/pdal/util/FileUtils.cpp 2020-11-11 12:44:00.408608349 +0100
|
||||
@@ -151,25 +151,25 @@ std::ostream *createFile(std::string con
|
||||
bool directoryExists(const std::string& dirname)
|
||||
{
|
||||
@ -205,7 +205,7 @@ diff -rupN --no-dereference PDAL-2.2.0-src/pdal/util/FileUtils.cpp PDAL-2.2.0-sr
|
||||
|
||||
diff -rupN --no-dereference PDAL-2.2.0-src/test/unit/CMakeLists.txt PDAL-2.2.0-src-new/test/unit/CMakeLists.txt
|
||||
--- PDAL-2.2.0-src/test/unit/CMakeLists.txt 2020-09-09 17:14:17.000000000 +0200
|
||||
+++ PDAL-2.2.0-src-new/test/unit/CMakeLists.txt 2020-10-26 17:50:56.100173211 +0100
|
||||
+++ PDAL-2.2.0-src-new/test/unit/CMakeLists.txt 2020-11-11 12:44:00.408608349 +0100
|
||||
@@ -34,7 +34,7 @@ PDAL_ADD_TEST(pdal_eigen_test
|
||||
${PDAL_SRC_DIR}/private/MathUtils.cpp
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user