Initial packaging of PDAL - Point Data Abstraction Library

This commit is contained in:
Markus 2020-05-28 19:31:19 +02:00
parent b5f3eef58f
commit 8c64cff0e1
5 changed files with 608 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/PDAL-2.1.0-src.tar.gz

319
PDAL.spec Normal file
View File

@ -0,0 +1,319 @@
Summary: Point Data Abstraction Library
Name: PDAL
Version: 2.1.0
Release: 5%{?dist}
# The code is licensed BSD except for:
# - filters/private/csf/* and plugins/i3s/lepcc/* are ASL 2.0
# - vendor/arbiter/*, plugins/nitf/io/nitflib.h and plugins/oci/io/OciWrapper.* are Expat/MIT
# - plugins/e57/libE57Format/{src,include}/* is Boost
License: BSD and ASL 2.0 and MIT and Boost
Source: https://github.com/%{name}/%{name}/releases/download/%{version}/%{name}-%{version}-src.tar.gz
URL: https://www.pdal.io
# commented out due to size (320 MB larger)
#Source1: http://download.osgeo.org/proj/vdatum/%%{name}-vdatums.zip
# originals
#Source1: http://download.osgeo.org/proj/vdatum/egm08_25/egm08_25.gtx
#Source2: http://download.osgeo.org/proj/vdatum/egm08_25/egm08_25.txt
#Source3: http://download.osgeo.org/proj/vdatum/egm96_15/egm96_15.gtx
#Source4: http://download.osgeo.org/proj/vdatum/egm96_15/WW15MGH.TXT
#Source5: http://download.osgeo.org/proj/vdatum/vertcon/README.TXT
#Source6: http://download.osgeo.org/proj/vdatum/vertcon/vertconc.gtx
#Source7: http://download.osgeo.org/proj/vdatum/vertcon/vertcone.gtx
#Source8: http://download.osgeo.org/proj/vdatum/vertcon/vertconw.gtx
#Source9: http://download.osgeo.org/proj/vdatum/usa_geoid1999.zip
#Source10: http://download.osgeo.org/proj/vdatum/usa_geoid2003.zip
#Source11: http://download.osgeo.org/proj/vdatum/usa_geoid2009.zip
#Source12: http://download.osgeo.org/proj/vdatum/usa_geoid2012.zip
#Source13: http://download.osgeo.org/proj/vdatum/usa_geoid2012b.zip
# Unbundle some bundled libraries
Patch0: PDAL_unbundle.patch
# Use correct libdir for PDAL_DRIVER_PATH when running tests
Patch1: PDAL_tests.patch
BuildRequires: boost-devel
BuildRequires: cmake
BuildRequires: eigen3-devel
BuildRequires: gcc-c++
BuildRequires: gdal
BuildRequires: gdal-devel
BuildRequires: geos-devel
BuildRequires: gtest-devel
BuildRequires: hdf5-devel
BuildRequires: jsoncpp-devel
BuildRequires: laszip-devel
BuildRequires: libgeotiff-devel
BuildRequires: libpq-devel
BuildRequires: libxml2-devel
BuildRequires: libzstd-devel
BuildRequires: netcdf-cxx-devel
BuildRequires: postgresql-devel
BuildRequires: postgresql-server
BuildRequires: proj-devel
BuildRequires: python3-breathe
BuildRequires: python3-devel
BuildRequires: python3-numpy
BuildRequires: python3-sphinx
BuildRequires: python3-sphinxcontrib-bibtex
BuildRequires: python3-sphinx_rtd_theme
BuildRequires: qhull-devel
BuildRequires: sqlite-devel
BuildRequires: zlib-devel
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
# https://github.com/connormanning/arbiter bundled in vendor/arbiter
Provides: bundled(arbiter)
# https://github.com/mkazhdan/PoissonRecon bundled in vendor/kazhdan
Provides: bundled(PoissonRecon)
# https://github.com/jlblancoc/nanoflann bundled in vendor/nanoflann
Provides: bundled(nanoflann)
# https://github.com/nlohmann/json bundled in vendor/nlohmann
Provides: bundled(nlohmann)
%description
PDAL is a BSD licensed library for translating and manipulating point cloud
data of various formats. It is a library that is analogous to the GDAL raster
library. PDAL is focused on reading, writing, and translating point cloud
data from the ever-growing constellation of data formats. While PDAL is not
explicitly limited to working with LiDAR data formats, its wide format
coverage is in that domain.
PDAL is related to Point Cloud Library (PCL) in the sense that both work with
point data, but PDALs niche is data translation and processing pipelines, and
PCLs is more in the algorithmic exploitation domain. There is cross over of
both niches, however, and PDAL provides a user the ability to exploit data
using PCLs techniques.
%package devel
Summary: PDAL development header files and libraries
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description devel
The pdal-devel package contains the header files and libraries needed to
compile C or C++ applications which will directly interact with PDAL.
%package libs
Summary: The shared libraries required for PDAL
%description libs
The pdal-libs package provides the essential shared libraries for any
PDAL client program or interface. You will need to install this package
to use PDAL
# commented out due to size
#%%package vdatums
#Summary: Vertical datum and geoid files for PDAL
#Requires: %%{name} = %%{version}-%%{release}
#
#%%description vdatums
#This package contains vertical datum and geoid files for PDAL.
%package doc
Summary: Documentation for PDAL
BuildArch: noarch
%description doc
This package contains documentation for PDAL.
# We don't want to provide private PDAL extension libs (to be verified)
%global __provides_exclude_from ^%{_libdir}/libpdal_plugin.*\.so.*$
%prep
%autosetup -p1 -n %{name}-%{version}-src
# Remove some bundled libraries
rm -rf vendor/{eigen,gtest,pdalboost}
%build
%cmake -D PDAL_LIB_INSTALL_DIR:PATH=%{_lib} \
-D CMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
-D CMAKE_VERBOSE_MAKEFILE=ON \
-D GEOTIFF_INCLUDE_DIR=%{_includedir}/libgeotiff \
-D BUILD_PLUGIN_PYTHON=ON \
-D BUILD_PGPOINTCLOUD_TESTS:BOOL=OFF \
-D WITH_LASZIP=ON \
-D WITH_TESTS=ON \
-D PDAL_HAVE_HEXER=ON \
-D PDAL_HAVE_GEOS=ON \
-D PDAL_HAVE_PYTHON=ON \
-D PDAL_HAVE_LIBGEOTIFF=ON \
-D PDAL_HAVE_LIBXML2=ON \
-D PDAL_HAVE_NITRO=OFF \
-D POSTGRESQL_INCLUDE_DIR=%{_includedir}/pgsql \
-D POSTGRESQL_LIBRARIES=%{_libdir}/libpq.so .
%make_build
# Build documentation
(
cd doc
sphinx-build -b html . build/html
)
%install
%make_install
# commented out due to size
## unpack vertical datums
#mkdir -p %%{buildroot}%%{_datadir}/proj
#mkdir vdatum
#pushd vdatum
#unzip -o %%{SOURCE1}
#mv *.gtx %%{buildroot}%%{_datadir}/proj/
#popd
#rm -rf vdatum
%check
## test the compiled code (see doc/project/testing.rst)
# we skip tests for selected architectures which need upstream fixes
%ifarch armv7hl aarch64 ppc64le s390x
ctest || true
%else
## we skip the PG test (BUILD_PGPOINTCLOUD_TESTS:BOOL=OFF):
# PGUSER=pdal PGPASSWORD=password PGHOST=localhost PGPORT=5432 ctest -V
ctest -V
%endif
%files
%{_bindir}/pdal
%files libs
%license LICENSE.txt
%license vendor/arbiter/LICENSE
%license plugins/e57/libE57Format/LICENSE.md
%{_libdir}/libpdal_base.so.10
%{_libdir}/libpdal_base.so.11
%{_libdir}/libpdal_plugin_kernel_fauxplugin.so.10
%{_libdir}/libpdal_plugin_kernel_fauxplugin.so.11
%{_libdir}/libpdal_plugin_reader_pgpointcloud.so.10
%{_libdir}/libpdal_plugin_reader_pgpointcloud.so.11
%{_libdir}/libpdal_plugin_writer_pgpointcloud.so.10
%{_libdir}/libpdal_plugin_writer_pgpointcloud.so.11
%{_libdir}/libpdal_util.so.10
%{_libdir}/libpdal_util.so.11
%files devel
%{_bindir}/pdal-config
%{_includedir}/pdal/
%{_libdir}/libpdal_plugin_kernel_fauxplugin.so
%{_libdir}/libpdal_plugin_reader_pgpointcloud.so
%{_libdir}/libpdal_plugin_writer_pgpointcloud.so
%{_libdir}/libpdal_base.so
%{_libdir}/libpdal_util.so
%{_libdir}/libpdalcpp.so
%{_libdir}/cmake/PDAL/
%{_libdir}/pkgconfig/*.pc
# commented out due to size
#%%files vdatums
#%%attr(0644,root,root) %%{_datadir}/proj/*.gtx
%files doc
%doc doc/build/html
%license LICENSE.txt
%changelog
* Wed May 27 2020 Sandro Mani <manisandro@gmail.com> 2.1.0-5
- license statements updates
* Sat May 23 2020 Sandro Mani <manisandro@gmail.com> 2.1.0-4
- major cleanup, see BZ#1838686
* Fri May 22 2020 Markus Neteler <neteler@mundialis.de> 2.1.0-3
- commented out vertical datums due to size for initial Fedora upload
- cleanup upon review by Sandro Mani, BZ#1838686
* Thu May 14 2020 Markus Neteler <neteler@mundialis.de> 2.1.0-2
- fix qhull package name for EPEL 8
* Wed Apr 01 2020 Markus Neteler <neteler@mundialis.de> 2.1.0-1
- New 2.1.0 upstream release
* Wed Sep 18 2019 Markus Neteler <neteler@mundialis.de> 2.0.1-2
- removed unused points2grid dependency
* Mon Sep 16 2019 Markus Neteler <neteler@mundialis.de> 2.0.1-1
- New 2.0.1 upstream release
- PCL support dropped as per release notes
- added BuildRequires gcc-c++ as per RHBZ #1551327 (removing gcc and gcc-c++ from default buildroot)
- further dependency cleanup
* Mon Apr 01 2019 Markus Neteler <neteler@mundialis.de> 1.8.0-2
- fix for "nothing provides pkgconfig(geos) needed by PDAL-devel..."
* Wed Nov 07 2018 Markus Neteler <neteler@mundialis.de> 1.8.0-1
- New 1.8.0 upstream release
* Mon May 14 2018 Markus Neteler <neteler@mundialis.de> 1.7.2-2
- New 1.7.2 upstream release
- hexer no longer required
* Thu May 10 2018 Markus Neteler <neteler@mundialis.de> 1.7.2-1
- New 1.7.2RC2 upstream release
- enforce python3
- set -DBUILD_PLUGIN_PYTHON:BOOL=FALSE to avoid numpy detection error
* Fri Apr 20 2018 Markus Neteler <neteler@mundialis.de> 1.7.0-1
- New 1.7.0 upstream release
- patch for https://github.com/PDAL/PDAL/issues/1899
- patch using https://github.com/PDAL/PDAL/pull/1900
* Thu Dec 14 2017 Markus Neteler <neteler@mundialis.de> 1.6.0-3
- fix pkgconfig (must be in -devel)
* Sat Oct 28 2017 Markus Neteler <neteler@mundialis.de> 1.6.0
- New 1.6.0 upstream release
* Tue Oct 24 2017 Markus Neteler <neteler@mundialis.de> 1.5.0
- New 1.5.0 upstream release
- vertical datums added
* Sun Jan 8 2017 Markus Neteler <neteler@osgeo.org> 1.4.0
- New upstream release
- configure tweaks
* Sat Jun 20 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.9-4
- Change build type from Debug to Release
* Mon Apr 20 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.9-3
- Various updates:
- Build with hexer support
- Own directories in devel subpackage
- omit deprecated Group: tags and %%clean section
- Use better macros for make and cmake
- use %%{?_isa} macro in subpkg dependencies
- have %%build section envoke 'make'
- Update %%install section
- Improve cmake build parameters
- Use %%license macro
- Add %%doc
- Get rid of BuildRoot definition
- No need to cleanup buildroot during %%install
- Remove %%defattr
- Run ldconfig
- Add PostgreSQL and PointCloud support
- Add Python and PCL plugins
- Build with GEOS and OPENNI2 support
- Update BR and Requires
- Add -libs subpackage, and move related files there
* Fri Apr 10 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.9-2
- Add -devel subpackage, and move related files there.
* Fri Apr 10 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.9-1
- Update to 0.9.9
* Tue Mar 10 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.8-3
- Add support for more stuff.
* Sun Mar 8 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.8-2
- Rebuild with new GDAL and the new build points2grid.
* Tue Jan 13 2015 Devrim GUNDUZ <devrim@gunduz.org> 0.9.8-1
- Initial packaging

11
PDAL_tests.patch Normal file
View File

@ -0,0 +1,11 @@
diff -rupN '--exclude=doc' PDAL-2.1.0-src/cmake/macros.cmake PDAL-2.1.0-src-new/cmake/macros.cmake
--- PDAL-2.1.0-src/cmake/macros.cmake 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/cmake/macros.cmake 2020-05-22 23:55:30.170681129 +0200
@@ -206,6 +206,6 @@ macro(PDAL_ADD_TEST _name)
"PDAL_DRIVER_PATH=${PROJECT_BINARY_DIR}/bin")
else()
set_property(TEST ${_name} PROPERTY ENVIRONMENT
- "PDAL_DRIVER_PATH=${PROJECT_BINARY_DIR}/lib")
+ "PDAL_DRIVER_PATH=${PROJECT_BINARY_DIR}/lib${LIB_SUFFIX}")
endif()
endmacro(PDAL_ADD_TEST)

276
PDAL_unbundle.patch Normal file
View File

@ -0,0 +1,276 @@
diff -rupN PDAL-2.1.0-src/CMakeLists.txt PDAL-2.1.0-src-new/CMakeLists.txt
--- PDAL-2.1.0-src/CMakeLists.txt 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/CMakeLists.txt 2020-05-27 11:09:43.675133404 +0200
@@ -51,7 +51,6 @@ else()
endif()
set(PDAL_LIB_NAME pdalcpp)
set(PDAL_UTIL_LIB_NAME pdal_util)
-set(PDAL_BOOST_LIB_NAME pdal_boost)
set(PDAL_KAZHDAN_LIB_NAME pdal_kazhdan)
set(PDAL_TEST_SUPPORT_OBJS pdal_test_support)
@@ -125,6 +124,9 @@ include(${PDAL_CMAKE_DIR}/arbiter.cmake)
include(${PDAL_CMAKE_DIR}/nlohmann.cmake)
include(${PDAL_CMAKE_DIR}/openssl.cmake) # Optional
+find_package(PkgConfig REQUIRED)
+PKG_CHECK_MODULES(EIGEN REQUIRED eigen3)
+
#------------------------------------------------------------------------------
# generate the pdal_features.hpp header
#------------------------------------------------------------------------------
@@ -163,13 +165,10 @@ endif()
add_subdirectory(plugins)
-#include_directories(vendor/pdalboost)
if (WITH_TESTS)
- include (${PDAL_CMAKE_DIR}/gtest.cmake)
add_subdirectory(test)
endif()
add_subdirectory(dimbuilder)
-add_subdirectory(vendor/pdalboost)
add_subdirectory(vendor/arbiter)
add_subdirectory(vendor/kazhdan)
add_subdirectory(pdal/util)
@@ -251,11 +250,10 @@ target_include_directories(${PDAL_BASE_L
${ROOT_DIR}
${PROJECT_BINARY_DIR}/include
${PDAL_VENDOR_DIR}
- ${PDAL_VENDOR_DIR}/eigen
- ${PDAL_VENDOR_DIR}/pdalboost
${LIBXML2_INCLUDE_DIR}
${ZSTD_INCLUDE_DIRS}
${NLOHMANN_INCLUDE_DIR}
+ ${EIGEN_INCLUDE_DIRS}
PUBLIC
${GDAL_INCLUDE_DIR}
${LASZIP_INCLUDE_DIR}
diff -rupN PDAL-2.1.0-src/pdal/util/CMakeLists.txt PDAL-2.1.0-src-new/pdal/util/CMakeLists.txt
--- PDAL-2.1.0-src/pdal/util/CMakeLists.txt 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/pdal/util/CMakeLists.txt 2020-05-27 11:10:04.732174032 +0200
@@ -33,7 +33,7 @@ PDAL_ADD_FREE_LIBRARY(${PDAL_UTIL_LIB_NA
target_link_libraries(${PDAL_UTIL_LIB_NAME}
PRIVATE
${BACKTRACE_LIBRARIES}
- ${PDAL_BOOST_LIB_NAME}
+ boost_filesystem
${CMAKE_DL_LIBS}
)
target_include_directories(${PDAL_UTIL_LIB_NAME} PRIVATE
diff -rupN PDAL-2.1.0-src/pdal/util/FileUtils.cpp PDAL-2.1.0-src-new/pdal/util/FileUtils.cpp
--- PDAL-2.1.0-src/pdal/util/FileUtils.cpp 2020-03-20 22:18:17.000000000 +0100
+++ PDAL-2.1.0-src-new/pdal/util/FileUtils.cpp 2020-05-27 11:08:56.736043058 +0200
@@ -149,25 +149,25 @@ std::ostream *createFile(std::string con
bool directoryExists(const std::string& dirname)
{
//ABELL - Seems we should be calling is_directory
- return pdalboost::filesystem::exists(toNative(dirname));
+ return boost::filesystem::exists(toNative(dirname));
}
bool createDirectory(const std::string& dirname)
{
- return pdalboost::filesystem::create_directory(toNative(dirname));
+ return boost::filesystem::create_directory(toNative(dirname));
}
bool createDirectories(const std::string& dirname)
{
- return pdalboost::filesystem::create_directories(toNative(dirname));
+ return boost::filesystem::create_directories(toNative(dirname));
}
void deleteDirectory(const std::string& dirname)
{
- pdalboost::filesystem::remove_all(toNative(dirname));
+ boost::filesystem::remove_all(toNative(dirname));
}
@@ -177,15 +177,15 @@ std::vector<std::string> directoryList(c
try
{
- pdalboost::filesystem::directory_iterator it(dir);
- pdalboost::filesystem::directory_iterator end;
+ boost::filesystem::directory_iterator it(dir);
+ boost::filesystem::directory_iterator end;
while (it != end)
{
files.push_back(it->path().string());
it++;
}
}
- catch (pdalboost::filesystem::filesystem_error&)
+ catch (boost::filesystem::filesystem_error&)
{
files.clear();
}
@@ -225,13 +225,13 @@ void closeFile(std::istream* in)
bool deleteFile(const std::string& file)
{
- return pdalboost::filesystem::remove(toNative(file));
+ return boost::filesystem::remove(toNative(file));
}
void renameFile(const std::string& dest, const std::string& src)
{
- pdalboost::filesystem::rename(toNative(src), toNative(dest));
+ boost::filesystem::rename(toNative(src), toNative(dest));
}
@@ -242,9 +242,9 @@ bool fileExists(const std::string& name)
try
{
- return pdalboost::filesystem::exists(toNative(name));
+ return boost::filesystem::exists(toNative(name));
}
- catch (pdalboost::filesystem::filesystem_error&)
+ catch (boost::filesystem::filesystem_error&)
{
}
return false;
@@ -253,7 +253,7 @@ bool fileExists(const std::string& name)
uintmax_t fileSize(const std::string& file)
{
- return pdalboost::filesystem::file_size(toNative(file));
+ return boost::filesystem::file_size(toNative(file));
}
@@ -274,7 +274,7 @@ std::string readFileIntoString(const std
std::string getcwd()
{
- const pdalboost::filesystem::path p = pdalboost::filesystem::current_path();
+ const boost::filesystem::path p = boost::filesystem::current_path();
return addTrailingSlash(p.string());
}
@@ -302,7 +302,7 @@ std::string toAbsolutePath(const std::st
// otherwise, make it absolute (relative to current working dir) and return that
std::string toAbsolutePath(const std::string& filename)
{
- return pdalboost::filesystem::absolute(toNative(filename)).string();
+ return boost::filesystem::absolute(toNative(filename)).string();
}
@@ -314,7 +314,7 @@ std::string toAbsolutePath(const std::st
std::string toAbsolutePath(const std::string& filename, const std::string base)
{
const std::string newbase = toAbsolutePath(base);
- return pdalboost::filesystem::absolute(toNative(filename),
+ return boost::filesystem::absolute(toNative(filename),
toNative(newbase)).string();
}
@@ -337,8 +337,8 @@ std::string getFilename(const std::strin
// Get the directory part of a filename.
std::string getDirectory(const std::string& path)
{
- const pdalboost::filesystem::path dir =
- pdalboost::filesystem::path(toNative(path)).parent_path();
+ const boost::filesystem::path dir =
+ boost::filesystem::path(toNative(path)).parent_path();
return addTrailingSlash(dir.string());
}
@@ -359,13 +359,13 @@ std::string stem(const std::string& path
// Determine if the path represents a directory.
bool isDirectory(const std::string& path)
{
- return pdalboost::filesystem::is_directory(toNative(path));
+ return boost::filesystem::is_directory(toNative(path));
}
// Determine if the path is an absolute path
bool isAbsolutePath(const std::string& path)
{
- return pdalboost::filesystem::path(toNative(path)).is_absolute();
+ return boost::filesystem::path(toNative(path)).is_absolute();
}
diff -rupN PDAL-2.1.0-src/test/unit/CMakeLists.txt PDAL-2.1.0-src-new/test/unit/CMakeLists.txt
--- PDAL-2.1.0-src/test/unit/CMakeLists.txt 2020-03-20 22:18:18.000000000 +0100
+++ PDAL-2.1.0-src-new/test/unit/CMakeLists.txt 2020-05-27 11:03:27.686421679 +0200
@@ -32,7 +32,7 @@ PDAL_ADD_TEST(pdal_eigen_test
FILES
EigenTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_file_utils_test FILES FileUtilsTest.cpp)
PDAL_ADD_TEST(pdal_georeference_test FILES GeoreferenceTest.cpp)
@@ -41,7 +41,7 @@ PDAL_ADD_TEST(pdal_kdindex_test
KDIndexTest.cpp
INCLUDES
${PDAL_VENDOR_DIR}
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_kernel_test FILES KernelTest.cpp)
PDAL_ADD_TEST(pdal_log_test FILES LogTest.cpp)
@@ -68,7 +68,7 @@ PDAL_ADD_TEST(pdal_point_view_test
FILES
PointViewTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_point_table_test FILES PointTableTest.cpp)
@@ -178,13 +178,13 @@ PDAL_ADD_TEST(pdal_io_pcd_reader_test
FILES
io/PcdReaderTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_io_pcd_writer_test
FILES
io/PcdWriterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_io_ply_reader_test
FILES
@@ -219,7 +219,7 @@ PDAL_ADD_TEST(pdal_filters_chipper_test
filters/ChipperTest.cpp
INCLUDES
${NLOHMANN_INCLUDE_DIR}
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_filters_nndistance_test
FILES
@@ -266,7 +266,7 @@ PDAL_ADD_TEST(pdal_filters_icp_test
FILES
filters/IcpFilterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen
+ ${EIGEN_INCLUDE_DIRS}
)
PDAL_ADD_TEST(pdal_filters_info_test FILES filters/InfoFilterTest.cpp)
PDAL_ADD_TEST(pdal_filters_neighborclassifier_test FILES filters/NeighborClassifierFilterTest.cpp)
@@ -305,7 +305,7 @@ PDAL_ADD_TEST(pdal_filters_splitter_test
FILES
filters/SplitterTest.cpp
INCLUDES
- ${PDAL_VENDOR_DIR}/eigen)
+ ${EIGEN_INCLUDE_DIRS})
PDAL_ADD_TEST(pdal_filters_stats_test FILES filters/StatsFilterTest.cpp)
PDAL_ADD_TEST(pdal_filters_transformation_test FILES
filters/TransformationFilterTest.cpp)

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (PDAL-2.1.0-src.tar.gz) = 273e43bc02039ef56e22d6496d74c645c947dec7961024f419232b3f70ad5de030d5ee9fb74f44649016da67ff39179b06fa0d85f17a3b7db5fcce3cd0e35ac5