Update to latest upstream release.
Fixes FTBFS on aarch64 (BZ#1408883).
This commit is contained in:
parent
9295e10bb8
commit
cabde45fd9
1
.gitignore
vendored
1
.gitignore
vendored
@ -46,3 +46,4 @@ clog
|
||||
/OpenImageIO-1.6.16.tar.gz
|
||||
/OpenImageIO-1.7.7.tar.gz
|
||||
/OpenImageIO-1.7.9.tar.gz
|
||||
/OpenImageIO-1.7.10.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/src/libtexture/texturesys.cpp
|
||||
+++ b/src/libtexture/texturesys.cpp
|
||||
@@ -2477,6 +2477,8 @@ TextureSystemImpl::sample_bicubic (int n
|
||||
} else {
|
||||
wx = evalBSplineWeights (float4(sfrac));
|
||||
wy = evalBSplineWeights (float4(tfrac));
|
||||
+ dwx = float4::Zero();
|
||||
+ dwy = float4::Zero();
|
||||
}
|
||||
|
||||
// figure out lerp weights so we can turn the filter into a sequence of lerp's
|
@ -1,12 +0,0 @@
|
||||
--- a/src/doc/CMakeLists.txt
|
||||
+++ b/src/doc/CMakeLists.txt
|
||||
@@ -18,7 +18,8 @@ find_package(PythonInterp)
|
||||
if (UNIX AND TXT2MAN AND PYTHONINTERP_FOUND)
|
||||
message (STATUS "Unix man page documentation will be generated")
|
||||
set (cli_tools oiiotool iinfo maketx idiff igrep iconvert)
|
||||
- if (IV_BUILT)
|
||||
+ find_program(IV_FOUND iv)
|
||||
+ if (IV_FOUND)
|
||||
list (APPEND cli_tools iv)
|
||||
endif()
|
||||
|
@ -2,8 +2,8 @@
|
||||
#global beta beta1
|
||||
|
||||
Name: OpenImageIO
|
||||
Version: 1.7.9
|
||||
Release: 2%{?dist}
|
||||
Version: 1.7.10
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for reading and writing images
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -14,7 +14,7 @@ Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}
|
||||
# Images for test suite
|
||||
#Source1: oiio-images.tar.gz
|
||||
|
||||
Patch0: OpenImageIO-1.7.9-man.patch
|
||||
Patch0: OpenImageIO-man.patch
|
||||
|
||||
BuildRequires: cmake gcc-c++
|
||||
BuildRequires: txt2man
|
||||
@ -163,12 +163,12 @@ cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
|
||||
%files utils
|
||||
%exclude %{_bindir}/iv
|
||||
%{_bindir}/*
|
||||
#%exclude %{_mandir}/man1/iv.1.gz
|
||||
%exclude %{_mandir}/man1/iv.1.gz
|
||||
%{_mandir}/man1/*.1.gz
|
||||
|
||||
%files iv
|
||||
%{_bindir}/iv
|
||||
#%{_mandir}/man1/iv.1.gz
|
||||
%{_mandir}/man1/iv.1.gz
|
||||
|
||||
%files devel
|
||||
%doc src/doc/*.pdf
|
||||
@ -178,6 +178,10 @@ cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 2 2017 Richard Shaw <hobbes1069@gmail.com> - 1.7.10-1
|
||||
- Update to latest upstream release.
|
||||
- Fixes FTBFS on aarch64 (BZ#1408883).
|
||||
|
||||
* Tue Dec 27 2016 Jon Ciesla <limburgher@gmail.com> - 1.7.9-2
|
||||
- Rebuild for new LibRaw.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user