- Update to latest upstream release.

- Separate utilities and library packages.
This commit is contained in:
Richard M. Shaw 2013-01-14 13:05:42 -06:00
parent e022e03a2b
commit 2f57d9fa8c
7 changed files with 1220 additions and 96 deletions

1
.gitignore vendored
View File

@ -12,3 +12,4 @@ clog
/OpenImageIO-oiio-Release-1.0.7-0-g0cae52b.tar.gz
/OpenImageIO-oiio-Release-1.0.8-0-g187bb9b.tar.gz
/OpenImageIO-oiio-Release-1.0.9-0-g0b78dec.tar.gz
/oiio-Release-1.1.3.tar.gz

View File

@ -1,13 +0,0 @@
diff -Naur OpenImageIO-oiio-5b37f1c.orig/src/libutil/tbb_misc.cpp OpenImageIO-oiio-5b37f1c/src/libutil/tbb_misc.cpp
--- OpenImageIO-oiio-5b37f1c.orig/src/libutil/tbb_misc.cpp 2012-02-25 17:17:12.000000000 -0600
+++ OpenImageIO-oiio-5b37f1c/src/libutil/tbb_misc.cpp 2012-03-04 17:00:29.519842011 -0600
@@ -30,8 +30,7 @@
// an executing program.
#include "tbb/tbb_stddef.h"
-// Out-of-line TBB assertion handling routines are instantiated here.
-#include "tbb/tbb_assert_impl.h"
+#include "tbb/tbb_machine.h"
#include "tbb/tbb_misc.h"
#include <cstdio>

File diff suppressed because it is too large Load Diff

View File

@ -1,67 +0,0 @@
diff -Naur OpenImageIO-oiio-5b37f1c.orig/src/libOpenImageIO/CMakeLists.txt OpenImageIO-oiio-5b37f1c/src/libOpenImageIO/CMakeLists.txt
--- OpenImageIO-oiio-5b37f1c.orig/src/libOpenImageIO/CMakeLists.txt 2012-02-28 12:58:45.306847484 -0600
+++ OpenImageIO-oiio-5b37f1c/src/libOpenImageIO/CMakeLists.txt 2012-02-28 13:02:27.438365805 -0600
@@ -61,7 +61,11 @@
endif ()
# Include our own TBB if using it
-if (USE_TBB)
+if (USE_TBB AND USE_EXTERNAL_TBB)
+ message (STATUS "System TBB library will be used.")
+ set (libOpenImageIO_srcs ${libOpenImageIO_srcs})
+elseif (USE_TBB AND NOT USE_EXTERNAL_TBB)
+ message (STATUS "Built-in TBB library will be used.")
set (libOpenImageIO_srcs ${libOpenImageIO_srcs} ../libutil/tbb_misc.cpp)
endif ()
diff -Naur OpenImageIO-oiio-5b37f1c.orig/src/include/CMakeLists.txt OpenImageIO-oiio-5b37f1c/src/include/CMakeLists.txt
--- OpenImageIO-oiio-5b37f1c.orig/src/include/CMakeLists.txt 2012-02-25 17:17:12.000000000 -0600
+++ OpenImageIO-oiio-5b37f1c/src/include/CMakeLists.txt 2012-02-28 13:32:00.961799696 -0600
@@ -22,7 +22,7 @@
install (FILES ${public_headers} DESTINATION ${INCLUDE_INSTALL_DIR}
COMPONENT developer)
-if (USE_TBB)
+if (USE_TBB AND NOT USE_EXTERNAL_TBB)
install (DIRECTORY tbb DESTINATION ${INCLUDE_INSTALL_DIR}
COMPONENT developer)
endif ()
diff -Naur OpenImageIO-oiio-f0a566a.orig/src/CMakeLists.txt OpenImageIO-oiio-f0a566a/src/CMakeLists.txt
--- OpenImageIO-oiio-f0a566a.orig/src/CMakeLists.txt 2012-06-12 13:03:37.000000000 -0500
+++ OpenImageIO-oiio-f0a566a/src/CMakeLists.txt 2012-06-28 15:12:45.831826494 -0500
@@ -34,6 +34,8 @@
set (PYTHON_VERSION 2.6)
set (USE_EXTERNAL_PUGIXML OFF CACHE BOOL
"Use an externally built shared library version of the pugixml library")
+set (USE_EXTERNAL_TBB OFF CACHE BOOL
+ "Use system TBB library instead of bundled.")
set (SOVERSION ${OIIO_VERSION_MAJOR}.${OIIO_VERSION_MINOR}
CACHE STRING "Set the SO version in the SO name of the output library")
diff -Naur OpenImageIO-oiio-f0a566a.orig/src/libOpenImageIO/CMakeLists.txt OpenImageIO-oiio-f0a566a/src/libOpenImageIO/CMakeLists.txt
--- OpenImageIO-oiio-f0a566a.orig/src/libOpenImageIO/CMakeLists.txt 2012-06-28 15:08:38.114834341 -0500
+++ OpenImageIO-oiio-f0a566a/src/libOpenImageIO/CMakeLists.txt 2012-06-28 15:19:34.819584416 -0500
@@ -63,7 +63,9 @@
# Include our own TBB if using it
if (USE_TBB AND USE_EXTERNAL_TBB)
message (STATUS "System TBB library will be used.")
- set (libOpenImageIO_srcs ${libOpenImageIO_srcs})
+ find_package (TBB REQUIRED)
+ include_directories (${TBB_INCLUDE_DIRS})
+ set (libOpenImageIO_srcs ${libOpenImageIO_srcs})
elseif (USE_TBB AND NOT USE_EXTERNAL_TBB)
message (STATUS "Built-in TBB library will be used.")
set (libOpenImageIO_srcs ${libOpenImageIO_srcs} ../libutil/tbb_misc.cpp)
@@ -211,7 +213,11 @@
target_link_libraries (OpenImageIO ${OCIO_LIBRARIES})
endif ()
-
+# Link against system TBB library if specified
+if (USE_TBB AND USE_EXTERNAL_TBB)
+ message (STATUS "Linking TBB: ${TBB_LIBRARIES}")
+ target_link_libraries (OpenImageIO ${TBB_LIBRARIES})
+endif ()
if (WIN32)

View File

@ -0,0 +1,68 @@
diff -Naur oiio-Release-1.1.2.orig/src/CMakeLists.txt oiio-Release-1.1.2/src/CMakeLists.txt
--- oiio-Release-1.1.2.orig/src/CMakeLists.txt 2012-12-05 12:46:56.000000000 -0600
+++ oiio-Release-1.1.2/src/CMakeLists.txt 2013-01-02 15:52:43.941560982 -0600
@@ -83,6 +83,8 @@
set (PYTHON_VERSION 2.6)
set (USE_EXTERNAL_PUGIXML OFF CACHE BOOL
"Use an externally built shared library version of the pugixml library")
+set (USE_EXTERNAL_TBB OFF CACHE BOOL
+ "Use system TBB library instead of bundled.")
set (SOVERSION ${OIIO_VERSION_MAJOR}.${OIIO_VERSION_MINOR}
CACHE STRING "Set the SO version in the SO name of the output library")
diff -Naur oiio-Release-1.1.2.orig/src/include/CMakeLists.txt oiio-Release-1.1.2/src/include/CMakeLists.txt
--- oiio-Release-1.1.2.orig/src/include/CMakeLists.txt 2012-12-05 12:46:56.000000000 -0600
+++ oiio-Release-1.1.2/src/include/CMakeLists.txt 2013-01-02 15:52:43.940561015 -0600
@@ -22,7 +22,7 @@
install (FILES ${public_headers} DESTINATION ${INCLUDE_INSTALL_DIR}
COMPONENT developer)
-if (USE_TBB)
+if (USE_TBB AND NOT USE_EXTERNAL_TBB)
install (DIRECTORY tbb DESTINATION ${INCLUDE_INSTALL_DIR}
COMPONENT developer)
endif ()
diff -Naur oiio-Release-1.1.2.orig/src/libOpenImageIO/CMakeLists.txt oiio-Release-1.1.2/src/libOpenImageIO/CMakeLists.txt
--- oiio-Release-1.1.2.orig/src/libOpenImageIO/CMakeLists.txt 2012-12-05 12:46:56.000000000 -0600
+++ oiio-Release-1.1.2/src/libOpenImageIO/CMakeLists.txt 2013-01-02 15:52:43.941560982 -0600
@@ -62,7 +62,13 @@
endif ()
# Include our own TBB if using it
-if (USE_TBB)
+if (USE_TBB AND USE_EXTERNAL_TBB)
+ message (STATUS "System TBB library will be used.")
+ find_package (TBB REQUIRED)
+ include_directories (${TBB_INCLUDE_DIRS})
+ set (libOpenImageIO_srcs ${libOpenImageIO_srcs})
+elseif (USE_TBB AND NOT USE_EXTERNAL_TBB)
+ message (STATUS "Built-in TBB library will be used.")
set (libOpenImageIO_srcs ${libOpenImageIO_srcs} ../libutil/tbb_misc.cpp)
endif ()
@@ -202,7 +208,11 @@
${VISIBILITY_COMMAND} ${VISIBILITY_MAP_COMMAND}
${Boost_LIBRARIES})
-
+# Link against system TBB library if specified
+if (USE_TBB AND USE_EXTERNAL_TBB)
+ message (STATUS "Linking TBB: ${TBB_LIBRARIES}")
+ target_link_libraries (OpenImageIO ${TBB_LIBRARIES})
+endif ()
# Include OpenColorIO if using it
if (USE_OCIO AND OCIO_FOUND)
diff -Naur oiio-Release-1.1.2.orig/src/libutil/tbb_misc.cpp oiio-Release-1.1.2/src/libutil/tbb_misc.cpp
--- oiio-Release-1.1.2.orig/src/libutil/tbb_misc.cpp 2012-12-05 12:46:56.000000000 -0600
+++ oiio-Release-1.1.2/src/libutil/tbb_misc.cpp 2013-01-02 15:53:10.403678615 -0600
@@ -30,8 +30,7 @@
// an executing program.
#include "tbb/tbb_stddef.h"
-// Out-of-line TBB assertion handling routines are instantiated here.
-#include "tbb/tbb_assert_impl.h"
+#include "tbb/tbb_machine.h"
#include "tbb/tbb_misc.h"
#include <cstdio>

View File

@ -3,29 +3,32 @@
%global githash3 9bf4356
Name: OpenImageIO
Version: 1.0.9
Release: 3%{?dist}
Version: 1.1.3
Release: 1%{?dist}
Summary: Library for reading and writing images
Group: Development/Libraries
License: BSD
URL: https://sites.google.com/site/openimageio/home
Source0: https://download.github.com/%{name}-oiio-Release-%{version}-0-%{githash1}.tar.gz
#Source0: https://download.github.com/%{name}-oiio-Release-%{version}-0-%{githash1}.tar.gz
Source0: https://download.github.com/oiio-Release-%{version}.tar.gz
# Images for test suite
#Source1: %{name}-oiio-images-%{githash3}.tar.gz
Source101: FindTBB.cmake
Patch0: OpenImageIO-1.0.0-use_external_tbb.patch
Patch1: OpenImageIO-1.0.0-tbb_include.patch
Patch0: OpenImageIO-1.1.2-use_external_tbb.patch
Patch2: OpenImageIO-ppc.patch
BuildRequires: cmake
BuildRequires: cmake txt2man
BuildRequires: qt4-devel
BuildRequires: boost-devel glew-devel OpenEXR-devel ilmbase-devel
BuildRequires: python2-devel txt2man
BuildRequires: boost-devel
BuildRequires: glew-devel
BuildRequires: OpenEXR-devel ilmbase-devel
BuildRequires: python2-devel
BuildRequires: libpng-devel libtiff-devel openjpeg-devel libwebp-devel
BuildRequires: zlib-devel jasper-devel
BuildRequires: zlib-devel
BuildRequires: jasper-devel
BuildRequires: pugixml-devel
%ifarch x86_64
BuildRequires: tbb-devel
@ -50,8 +53,24 @@ classes, utilities, and applications. Main features include:
PNM/PPM/PGM/PBM, Field3d.
- An ImageCache class that transparently manages a cache so that it can access
truly vast amounts of image data.
- A really nice image viewer, iv, also based on OpenImageIO classes (and so
will work with any formats for which plugins are available).
%package utils
Summary: Command line utilies for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description utils
Command-line tools to minipulate and get information on images using the
%{name} library.
%package iv
Summary: %{name} based image viewer.
Requires: %{name}%{?_isa} = %{version}-%{release}
%description iv
A really nice image viewer, iv, based on %{name} classes (and so will work with
any formats for which plugins are available).
%package devel
@ -64,10 +83,12 @@ Development files for package %{name}
%prep
%setup -q -n %{name}-oiio-%{githash2}
#setup -q -n %{name}-oiio-%{githash2}
%setup -q -n oiio-Release-%{version}
%patch0 -p1 -b .exttbb
%patch1 -p1 -b .tbbinc
%ifarch ppc ppc64
%patch2 -p1 -b .ppc
%endif
# Install FindTBB.cmake
install %{SOURCE101} src/cmake/modules/
@ -128,10 +149,18 @@ cp -a doc/*.1 %{buildroot}%{_mandir}/man1
%files
%doc CHANGES LICENSE
%{_bindir}/*
%{_libdir}/libOpenImageIO.so.*
%{python_sitearch}/OpenImageIO.so
%{_mandir}/man1/*
%files utils
%exclude %{_bindir}/iv
%{_bindir}/*
%exclude %{_mandir}/man1/iv.1.gz
%{_mandir}/man1/*.1.gz
%files iv
%{_bindir}/iv
%{_mandir}/man1/iv.1.gz
%files devel
%doc src/doc/*.pdf
@ -140,6 +169,10 @@ cp -a doc/*.1 %{buildroot}%{_mandir}/man1
%changelog
* Mon Jan 14 2013 Richard Shaw <hobbes1069@gmail.com> - 1.1.3-1
- Update to latest upstream release.
- Separate utilities and library packages.
* Fri Dec 28 2012 Richard W.M. Jones <rjones@redhat.com> - 1.0.9-3
- Rebuild, see
http://lists.fedoraproject.org/pipermail/devel/2012-December/175685.html

View File

@ -1 +1 @@
4b98a057515cc95fc954743c987f19ba OpenImageIO-oiio-Release-1.0.9-0-g0b78dec.tar.gz
965c2161f8df1415e3ba87e5f94cf633 oiio-Release-1.1.3.tar.gz