40 lines
1.3 KiB
Diff
40 lines
1.3 KiB
Diff
diff -up openexr_viewers-2.0.1/configure.ac.dso openexr_viewers-2.0.1/configure.ac
|
|
--- openexr_viewers-2.0.1/configure.ac.dso 2013-06-18 15:58:29.000000000 -0500
|
|
+++ openexr_viewers-2.0.1/configure.ac 2013-10-11 14:15:38.870351295 -0500
|
|
@@ -75,6 +75,18 @@ AM_PATH_PKGCONFIG(
|
|
[-lIlmImfCtl -lIlmImf -lz -lImath -lHalf -lIex -lIlmThread -lpthread -lIlmCtlSimd -lIlmCtlMath -lIlmCtl],
|
|
[openexrctl-prefix])
|
|
|
|
+dnl
|
|
+dnl check gl
|
|
+dnl
|
|
+AM_PATH_PKGCONFIG(
|
|
+ [GL_CFLAGS],
|
|
+ [GL_LDFLAGS],
|
|
+ [GL_LIBS],
|
|
+ [gl],
|
|
+ ,
|
|
+ [$LIB64_IF_EXISTS -L/usr/local/lib],
|
|
+ [-lGL],
|
|
+ [gl-prefix])
|
|
|
|
dnl --enable-threading
|
|
AC_ARG_ENABLE(threading,
|
|
diff -up openexr_viewers-2.0.1/exrdisplay/Makefile.am.dso openexr_viewers-2.0.1/exrdisplay/Makefile.am
|
|
--- openexr_viewers-2.0.1/exrdisplay/Makefile.am.dso 2013-06-18 14:51:41.000000000 -0500
|
|
+++ openexr_viewers-2.0.1/exrdisplay/Makefile.am 2013-10-11 14:17:07.953771623 -0500
|
|
@@ -5,11 +5,12 @@ if HAVE_FLTK
|
|
bin_PROGRAMS = exrdisplay
|
|
|
|
INCLUDES = @OPENEXR_CXXFLAGS@ \
|
|
- @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
|
|
+ @GL_CFLAGS@ @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
|
|
@OPENEXR_CTL_CXXFLAGS@
|
|
|
|
LDADD = @OPENEXR_LDFLAGS@ @OPENEXR_LIBS@ \
|
|
@OPENEXR_CTL_LDFLAGS@ @OPENEXR_CTL_LIBS@ \
|
|
+ @GL_LDFLAGS@ @GL_LIBS@ \
|
|
@CG_LDFLAGS@ @FLTK_LDFLAGS@
|
|
|
|
all-local:
|