Update to 2.0.1 (wip)
This commit is contained in:
parent
0459a6ed52
commit
f72dac6c76
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
openexr_viewers-1.0.1.tar.gz
|
openexr_viewers-1.0.1.tar.gz
|
||||||
/openexr_viewers-1.0.2.tar.gz
|
/openexr_viewers-1.0.2.tar.gz
|
||||||
|
/openexr_viewers-2.0.1.tar.gz
|
||||||
|
@ -11,18 +11,14 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: %{real_name}
|
Name: %{real_name}
|
||||||
Version: 1.0.2
|
Version: 2.0.1
|
||||||
Release: 13%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Viewers programs for OpenEXR
|
Summary: Viewers programs for OpenEXR
|
||||||
|
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
License: AMPAS BSD
|
License: AMPAS BSD
|
||||||
URL: http://www.openexr.com
|
URL: http://www.openexr.com
|
||||||
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr_viewers-%{version}.tar.gz
|
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr_viewers-%{version}.tar.gz
|
||||||
Patch0: openexr_viewers-1.0.1-gcc43.patch
|
|
||||||
Patch1: openexr_viewers-1.0.2-gcc44.patch
|
|
||||||
# fix dso (missing symbols) by explicitly linking -lGL too
|
|
||||||
Patch2: openexr_viewers-1.0.2-dso.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
@ -68,9 +64,6 @@ This package contains documentation files for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n openexr_viewers-%{version}
|
%setup -q -n openexr_viewers-%{version}
|
||||||
%patch0 -p1 -b .gcc43
|
|
||||||
%patch1 -p1 -b .gcc44
|
|
||||||
%patch2 -p1 -b .dso
|
|
||||||
|
|
||||||
%if %{_lib} == lib64
|
%if %{_lib} == lib64
|
||||||
sed -i -e 's|ACTUAL_PREFIX/lib/CTL|ACTUAL_PREFIX/lib64/CTL|' configure.ac
|
sed -i -e 's|ACTUAL_PREFIX/lib/CTL|ACTUAL_PREFIX/lib64/CTL|' configure.ac
|
||||||
@ -83,6 +76,7 @@ sed -i -e 's|#include <vector>\n using namespace Ctl|#include <vector>\n #
|
|||||||
%build
|
%build
|
||||||
export CXXFLAGS="$RPM_OPT_FLAGS -L%{_libdir}"
|
export CXXFLAGS="$RPM_OPT_FLAGS -L%{_libdir}"
|
||||||
%configure --disable-static \
|
%configure --disable-static \
|
||||||
|
--disable-openexrtest \
|
||||||
--disable-openexrctltest \
|
--disable-openexrctltest \
|
||||||
%if %with_Cg
|
%if %with_Cg
|
||||||
--with-cg-prefix=%{_prefix}
|
--with-cg-prefix=%{_prefix}
|
||||||
@ -137,6 +131,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 05 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.0.1-1
|
||||||
|
- Update to 2.0.1
|
||||||
|
|
||||||
* Sat Sep 14 2013 Bruno Wolff III <bruno@wolff.to> - 1.0.2-13
|
* Sat Sep 14 2013 Bruno Wolff III <bruno@wolff.to> - 1.0.2-13
|
||||||
- Rebuild for ilmbase related soname bumps
|
- Rebuild for ilmbase related soname bumps
|
||||||
|
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
diff -up openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 openexr_viewers-1.0.1/exrdisplay/applyCtl.h
|
|
||||||
--- openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 2006-12-09 01:14:07.000000000 +0100
|
|
||||||
+++ openexr_viewers-1.0.1/exrdisplay/applyCtl.h 2008-01-10 02:07:14.000000000 +0100
|
|
||||||
@@ -49,6 +49,7 @@
|
|
||||||
#include <ImfArray.h>
|
|
||||||
#include <ImfHeader.h>
|
|
||||||
#include <vector>
|
|
||||||
+#include <cstdlib>
|
|
||||||
|
|
||||||
//
|
|
||||||
// Apply a series of CTL transforms to the raw pixel data from an image file
|
|
||||||
diff -up openexr_viewers-1.0.1/configure.ac.gcc43 openexr_viewers-1.0.1/configure.ac
|
|
||||||
--- openexr_viewers-1.0.1/configure.ac.gcc43 2007-10-10 00:20:51.000000000 +0200
|
|
||||||
+++ openexr_viewers-1.0.1/configure.ac 2008-01-10 02:07:14.000000000 +0100
|
|
||||||
@@ -126,6 +126,7 @@ AM_COMPILELINKRUN(
|
|
||||||
#include <ImfFrameBuffer.h>
|
|
||||||
#include <ImathBox.h>
|
|
||||||
#include <vector>
|
|
||||||
+#include <cstdlib>
|
|
||||||
using namespace Ctl;
|
|
||||||
using namespace Imf;
|
|
||||||
using namespace Imath;
|
|
||||||
diff -up openexr_viewers-1.0.1/configure.gcc43 openexr_viewers-1.0.1/configure
|
|
||||||
--- openexr_viewers-1.0.1/configure.gcc43 2007-10-10 00:21:01.000000000 +0200
|
|
||||||
+++ openexr_viewers-1.0.1/configure 2008-01-10 02:07:14.000000000 +0100
|
|
||||||
@@ -20869,6 +20869,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
|
||||||
#include <ImfFrameBuffer.h>
|
|
||||||
#include <ImathBox.h>
|
|
||||||
#include <vector>
|
|
||||||
+#include <cstdlib>
|
|
||||||
using namespace Ctl;
|
|
||||||
using namespace Imf;
|
|
||||||
using namespace Imath;
|
|
||||||
diff -up openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 openexr_viewers-1.0.1/playexr/ctlToLut.h
|
|
||||||
--- openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 2008-01-10 03:09:55.000000000 +0100
|
|
||||||
+++ openexr_viewers-1.0.1/playexr/ctlToLut.h 2008-01-10 03:11:18.000000000 +0100
|
|
||||||
@@ -88,6 +88,7 @@
|
|
||||||
#include <string>
|
|
||||||
#include <vector>
|
|
||||||
#include <half.h>
|
|
||||||
+#include <cstdlib>
|
|
||||||
|
|
||||||
|
|
||||||
void
|
|
||||||
diff -up openexr_viewers-1.0.1/playexr/main.cpp.gcc43 openexr_viewers-1.0.1/playexr/main.cpp
|
|
||||||
--- openexr_viewers-1.0.1/playexr/main.cpp.gcc43 2008-01-10 03:05:03.000000000 +0100
|
|
||||||
+++ openexr_viewers-1.0.1/playexr/main.cpp 2008-01-10 03:05:48.000000000 +0100
|
|
||||||
@@ -48,6 +48,7 @@
|
|
||||||
#include <vector>
|
|
||||||
#include <string>
|
|
||||||
#include <stdlib.h>
|
|
||||||
+#include <cstring>
|
|
||||||
|
|
||||||
using namespace std;
|
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -up openexr_viewers-1.0.2/exrdisplay/Makefile.am.dso openexr_viewers-1.0.2/exrdisplay/Makefile.am
|
|
||||||
--- openexr_viewers-1.0.2/exrdisplay/Makefile.am.dso 2007-03-28 01:06:46.000000000 -0500
|
|
||||||
+++ openexr_viewers-1.0.2/exrdisplay/Makefile.am 2011-06-24 12:48:56.676196480 -0500
|
|
||||||
@@ -7,7 +7,7 @@ bin_PROGRAMS = exrdisplay
|
|
||||||
INCLUDES = @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
|
|
||||||
@OPENEXR_CTL_CXXFLAGS@
|
|
||||||
|
|
||||||
-LDADD = @CG_LDFLAGS@ @FLTK_LDFLAGS@ \
|
|
||||||
+LDADD = @CG_LDFLAGS@ @FLTK_LDFLAGS@ -lGL \
|
|
||||||
@OPENEXR_CTL_LDFLAGS@ \
|
|
||||||
@OPENEXR_CTL_LIBS@
|
|
||||||
|
|
||||||
diff -up openexr_viewers-1.0.2/exrdisplay/Makefile.in.dso openexr_viewers-1.0.2/exrdisplay/Makefile.in
|
|
||||||
--- openexr_viewers-1.0.2/exrdisplay/Makefile.in.dso 2010-07-22 19:46:29.000000000 -0500
|
|
||||||
+++ openexr_viewers-1.0.2/exrdisplay/Makefile.in 2011-06-24 12:49:19.426317303 -0500
|
|
||||||
@@ -214,7 +214,7 @@ target_alias = @target_alias@
|
|
||||||
@HAVE_FLTK_TRUE@INCLUDES = @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
|
|
||||||
@HAVE_FLTK_TRUE@ @OPENEXR_CTL_CXXFLAGS@
|
|
||||||
|
|
||||||
-@HAVE_FLTK_TRUE@LDADD = @CG_LDFLAGS@ @FLTK_LDFLAGS@ \
|
|
||||||
+@HAVE_FLTK_TRUE@LDADD = @CG_LDFLAGS@ @FLTK_LDFLAGS@ -lGL \
|
|
||||||
@HAVE_FLTK_TRUE@ @OPENEXR_CTL_LDFLAGS@ \
|
|
||||||
@HAVE_FLTK_TRUE@ @OPENEXR_CTL_LIBS@
|
|
||||||
|
|
@ -1,38 +0,0 @@
|
|||||||
diff -up openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp.gcc44 openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp
|
|
||||||
--- openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp.gcc44 2007-07-26 04:34:32.000000000 +0200
|
|
||||||
+++ openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp 2011-05-27 19:53:10.400501560 +0200
|
|
||||||
@@ -48,6 +48,7 @@
|
|
||||||
#include <ImfHeader.h>
|
|
||||||
#include <ImfFrameBuffer.h>
|
|
||||||
#include <cassert>
|
|
||||||
+ #include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
using namespace std;
|
|
||||||
@@ -60,6 +61,7 @@
|
|
||||||
#include <ImfStandardAttributes.h>
|
|
||||||
#include <ImfHeader.h>
|
|
||||||
#include <cassert>
|
|
||||||
+ #include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
using namespace std;
|
|
||||||
diff -up openexr_viewers-1.0.2/playexr/ctlToLut.cpp.gcc44 openexr_viewers-1.0.2/playexr/ctlToLut.cpp
|
|
||||||
--- openexr_viewers-1.0.2/playexr/ctlToLut.cpp.gcc44 2007-07-26 04:34:32.000000000 +0200
|
|
||||||
+++ openexr_viewers-1.0.2/playexr/ctlToLut.cpp 2011-05-27 19:57:13.428196868 +0200
|
|
||||||
@@ -48,6 +48,7 @@
|
|
||||||
#include <ImfHeader.h>
|
|
||||||
#include <ImfFrameBuffer.h>
|
|
||||||
#include <cassert>
|
|
||||||
+ #include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
using namespace std;
|
|
||||||
@@ -60,6 +61,7 @@
|
|
||||||
#include <ImfStandardAttributes.h>
|
|
||||||
#include <ImfHeader.h>
|
|
||||||
#include <cassert>
|
|
||||||
+ #include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
|
|
||||||
using namespace std;
|
|
Loading…
Reference in New Issue
Block a user