OpenEXR_Viewers FTBFS: ImplicitDSO Linking issues (#1017880)

This commit is contained in:
Rex Dieter 2013-10-11 14:22:51 -05:00
parent e9c5475be9
commit e3ddd3eccb
2 changed files with 51 additions and 4 deletions

View File

@ -17,7 +17,7 @@
Name: %{real_name}
Version: 2.0.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Viewers programs for OpenEXR
Group: Applications/Multimedia
@ -26,10 +26,12 @@ URL: http://www.openexr.com
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr_viewers-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch1: openexr_viewers-2.0.1-dso.patch
BuildRequires: libtool
BuildRequires: fltk-devel >= 1.1
BuildRequires: pkgconfig(OpenEXR)
BuildRequires: pkgconfig(OpenEXR) >= 2.0
%if %with_Cg
BuildRequires: Cg
BuildRequires: freeglut-devel
@ -73,11 +75,14 @@ This package contains documentation files for %{name}.
%prep
%setup -q -n openexr_viewers-%{version}
%patch1 -p1 -b .dso
%if %{_lib} == lib64
sed -i -e 's|ACTUAL_PREFIX/lib/CTL|ACTUAL_PREFIX/lib64/CTL|' configure.ac
%endif
#Needed to update CTL compiler test
autoconf
#Needed for patch1 and to update CTL compiler test
#autoconf
./bootstrap
sed -i -e 's|#include <vector>\n using namespace Ctl|#include <vector>\n #include <cstdlib>\nusing namespace Ctl|' configure
@ -139,6 +144,9 @@ fi
%endif
%changelog
* Fri Oct 11 2013 Rex Dieter <rdieter@fedoraproject.org> 2.0.1-3
- OpenEXR_Viewers FTBFS: ImplicitDSO Linking issues (#1017880)
* Thu Oct 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.0.1-2
- make OpenEXR_CTL support optional (since it doesn't support openexr-2.x yet)

View File

@ -0,0 +1,39 @@
diff -up openexr_viewers-2.0.1/configure.ac.dso openexr_viewers-2.0.1/configure.ac
--- openexr_viewers-2.0.1/configure.ac.dso 2013-06-18 15:58:29.000000000 -0500
+++ openexr_viewers-2.0.1/configure.ac 2013-10-11 14:15:38.870351295 -0500
@@ -75,6 +75,18 @@ AM_PATH_PKGCONFIG(
[-lIlmImfCtl -lIlmImf -lz -lImath -lHalf -lIex -lIlmThread -lpthread -lIlmCtlSimd -lIlmCtlMath -lIlmCtl],
[openexrctl-prefix])
+dnl
+dnl check gl
+dnl
+AM_PATH_PKGCONFIG(
+ [GL_CFLAGS],
+ [GL_LDFLAGS],
+ [GL_LIBS],
+ [gl],
+ ,
+ [$LIB64_IF_EXISTS -L/usr/local/lib],
+ [-lGL],
+ [gl-prefix])
dnl --enable-threading
AC_ARG_ENABLE(threading,
diff -up openexr_viewers-2.0.1/exrdisplay/Makefile.am.dso openexr_viewers-2.0.1/exrdisplay/Makefile.am
--- openexr_viewers-2.0.1/exrdisplay/Makefile.am.dso 2013-06-18 14:51:41.000000000 -0500
+++ openexr_viewers-2.0.1/exrdisplay/Makefile.am 2013-10-11 14:17:07.953771623 -0500
@@ -5,11 +5,12 @@ if HAVE_FLTK
bin_PROGRAMS = exrdisplay
INCLUDES = @OPENEXR_CXXFLAGS@ \
- @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
+ @GL_CFLAGS@ @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
@OPENEXR_CTL_CXXFLAGS@
LDADD = @OPENEXR_LDFLAGS@ @OPENEXR_LIBS@ \
@OPENEXR_CTL_LDFLAGS@ @OPENEXR_CTL_LIBS@ \
+ @GL_LDFLAGS@ @GL_LIBS@ \
@CG_LDFLAGS@ @FLTK_LDFLAGS@
all-local: