Update gcc44 patch , Workaround fltk

This commit is contained in:
Nicolas Chauvet 2011-05-27 21:41:33 +02:00
parent 8865fc6c0a
commit d66c6b5387
2 changed files with 30 additions and 10 deletions

View File

@ -12,7 +12,7 @@
Name: %{real_name}
Version: 1.0.2
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Viewers programs for OpenEXR
Group: Applications/Multimedia
@ -20,14 +20,14 @@ License: AMPAS BSD
URL: http://www.openexr.com
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr_viewers-%{version}.tar.gz
Patch0: openexr_viewers-1.0.1-gcc43.patch
Patch1: openexr_viewers-1.0.1-gcc44.patch
Patch1: openexr_viewers-1.0.2-gcc44.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool
BuildRequires: OpenEXR_CTL-devel
BuildRequires: OpenEXR_CTL
BuildRequires: fltk-devel
BuildRequires: fltk-devel >= 1.1
%if %with_Cg
BuildRequires: Cg
BuildRequires: freeglut-devel
@ -35,8 +35,6 @@ Provides: OpenEXR_Viewers = %{version}
%else
BuildConflicts: Cg
%endif
# Last version was in F-7 - Can be dropped in F-10
Obsoletes: OpenEXR-utils < 1.6.0
Requires: OpenEXR_CTL
Requires(post): /usr/sbin/alternatives
@ -76,6 +74,7 @@ sed -i -e 's|ACTUAL_PREFIX/lib/CTL|ACTUAL_PREFIX/lib64/CTL|' configure.ac
%endif
#Needed to update CTL compiler test
autoconf
sed -i -e 's|#include <vector>\n using namespace Ctl|#include <vector>\n #include <cstdlib>\nusing namespace Ctl|' configure
%build
@ -88,7 +87,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS -L%{_libdir}"
# Missing libs for playexr
sed -i -e 's|LIBS =|LIBS = -lglut|' playexr/Makefile
make %{?_smp_mflags}
make %{?_smp_mflags} FLTK_LDFLAGS = "-lfltk_gl -lGLU -lGL -lfltk"
%install
@ -134,8 +133,10 @@ fi
%endif
%changelog
* Fri May 27 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.0.2-4
* Fri May 27 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.0.2-5
- Update gcc44 patch
- Rebuild for new fltk
- Drop old Obsoletes OpenEXR-utils < 1.6.0
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

View File

@ -1,6 +1,25 @@
diff -up openexr_viewers-1.0.1/exrdisplay/applyCtl.cpp.gcc44 openexr_viewers-1.0.1/exrdisplay/applyCtl.cpp
--- openexr_viewers-1.0.1/exrdisplay/applyCtl.cpp.gcc44 2009-02-12 23:35:22.000000000 +0100
+++ openexr_viewers-1.0.1/exrdisplay/applyCtl.cpp 2009-02-12 23:35:27.000000000 +0100
diff -up openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp.gcc44 openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp
--- openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp.gcc44 2007-07-26 04:34:32.000000000 +0200
+++ openexr_viewers-1.0.2/exrdisplay/applyCtl.cpp 2011-05-27 19:53:10.400501560 +0200
@@ -48,6 +48,7 @@
#include <ImfHeader.h>
#include <ImfFrameBuffer.h>
#include <cassert>
+ #include <cstdio>
#include <iostream>
using namespace std;
@@ -60,6 +61,7 @@
#include <ImfStandardAttributes.h>
#include <ImfHeader.h>
#include <cassert>
+ #include <cstdio>
#include <iostream>
using namespace std;
diff -up openexr_viewers-1.0.2/playexr/ctlToLut.cpp.gcc44 openexr_viewers-1.0.2/playexr/ctlToLut.cpp
--- openexr_viewers-1.0.2/playexr/ctlToLut.cpp.gcc44 2007-07-26 04:34:32.000000000 +0200
+++ openexr_viewers-1.0.2/playexr/ctlToLut.cpp 2011-05-27 19:57:13.428196868 +0200
@@ -48,6 +48,7 @@
#include <ImfHeader.h>
#include <ImfFrameBuffer.h>